Jump to content

24 posts in this topic

Recommended Posts

Posted (edited)

Hi everyone, this is my first post in the forum.


I have an hackintosh since 2014, built by myself. I installed macOS using ##### two or three times and everything always worked fine.

I'm still with Sierra, and I'd like to move to High Sierra using Vanilla method. I created the USB, installed Clover, made all the setup in three or four different ways according to different guides, but I get always the same errors.

It seems that the installer pen drive can't see itself in the drives scheme. I tried different pen drives, tried to change from 3.0 to 2.0 and so on.

 

Below the links to download the EFI folder and the screenshots of the verbose boot. The configuration of the workstation is in signature.

EFI

Screenshots

 

I hope to have not break any rule in this post, I used the search function but I didn't found anything that help me to fix the installation.

 

Thanks in advance for help.

 

Mitch

 

 

 

Edited by malvibra

Share this post


Link to post
Share on other sites
Advertisement
Just now, Allan said:

Hi @malvibra, welcome to InsanelyMac.

 

This is the guide that you need: [Guide] Sierra / High Sierra / Mojave on Intel 5, 6, 7, 8, 9 and x99 Chipset Series / Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell

 

But, one important thing to you know. We don't give support for any Tonymac tools. ;)

 

Thanks! I'll try tomorrow.

As I said, I used Tonymac tools for some years, but I think that the time to move to clean installations has come :)

 

Keeping you posted about the installation.

Thanks again!

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @Allan,

 

I tried to follow the guide but DiskMakerX doesn't work. It says that it isn't possible to create the usb disks because of my pen drive's filesystem (it says it's APFS but it's HFS, tried with exFat also).

I tried with 4 different pen drives, but nothing worked. I formatted again the pen drives, created the bootable pen drives with createinstallmedia and installed Clover.

Same errors, nothing changed :(

 

EDIT:

DiskMakerX started working after changing system lang to english.

The os is installed but I can't get my 280x working. I don't understand the part about patches in the guide, am I supposed to look for a guide to patch that list?

Thank you!

Edited by malvibra

Share this post


Link to post
Share on other sites
17 hours ago, Allan said:

To patch your DSDT, just run the app RunMe and post the files output here.

@MaLd0n will patch the DSDT for you ;)

 

Thank you! I'd like to learn how to patch DSDT, i have fun doing this kind of things. Is there a guide to start? 

 

Here the download, the Insanelymac downloader doesn't allow me to attach the file.

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Allan said:

Not per hour bro....:(

 

:( Hope for the future.

 

5 hours ago, MaLd0n said:

 

Working, but the pc reboots instead of shut down.
I noticed that the PCIe lane where I installed the video card is 8x. Can I move the card to the 16x slot with this config? Or I have to send you another scan of the system with the card in the right slot?

 

And is it possible to activate thunderbolts on the mobo? 

 

Thank you again!

 

Edited by malvibra

Share this post


Link to post
Share on other sites
1 hour ago, malvibra said:

 

:( Hope for the future.

 

 

Working, but the pc reboots instead of shut down.
I noticed that the PCIe lane where I installed the video card is 8x. Can I move the card to the 16x slot with this config? Or I have to send you another scan of the system with the card in the right slot?

 

And is it possible to activate thunderbolts on the mobo? 

 

Thank you again!

 

check if ERP is enable in bios

yes, TB work

Share this post


Link to post
Share on other sites
Posted (edited)
33 minutes ago, MaLd0n said:

check if ERP is enable in bios

yes, TB work

 

Moved the GPU to the PCIe1 slot (16x), but the system still says 8x.

 

https://ibb.co/e4KZs8

 

This is what it says for TB. I don't have a TB HDD at the moment to check if it doesn't displays the ports because anything is connected.
https://ibb.co/dYgQzo

 

ErP is disabled

Edited by malvibra

Share this post


Link to post
Share on other sites
17 minutes ago, malvibra said:

 

Moved the GPU to the PCIe1 slot (16x), but the system still says 8x.

 

https://ibb.co/e4KZs8

 

This is what it says for TB. I don't have a TB HDD at the moment to check if it doesn't displays the ports because anything is connected.
https://ibb.co/dYgQzo

 

ErP is disabled

ERP need stay enable for avoid restart instead shutdown

send me new dump with new files

RunMe.app

Share this post


Link to post
Share on other sites
55 minutes ago, malvibra said:

 

ErP is ok, macOS shuts down.

 

Here the files:

https://www54.zippyshare.com/v/PBLRyKme/file.html

replace in Clover/Acpi/Patched

https://www73.zippyshare.com/v/cqBWe83y/file.html
test sleep, etc

i put wake only in power button, if u need wake in mouse we can try

Share this post


Link to post
Share on other sites
14 hours ago, MaLd0n said:

replace in Clover/Acpi/Patched

https://www73.zippyshare.com/v/cqBWe83y/file.html
test sleep, etc

i put wake only in power button, if u need wake in mouse we can try

 

Hi MaLd0n,

 

I don't need wake on mouse, the power button is ok. The problem is that after waking up from sleeping the pc is very laggy and slow, and it misses some signals (i.e. keyboard keys).

 

 

Share this post


Link to post
Share on other sites
25 minutes ago, malvibra said:

 

Hi MaLd0n,

 

I don't need wake on mouse, the power button is ok. The problem is that after waking up from sleeping the pc is very laggy and slow, and it misses some signals (i.e. keyboard keys).

 

 

sound like a Power Management problem or some bios config

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, MaLd0n said:

sound like a Power Management problem or some bios config

 

I will try to fix it playing with BIOS.

What about the 8x PCIe? It's still 8x and not 16x.

Is it possible to fix it? Honestly I don't remember how it was before reinstalling.

 

EDIT: Tried all the bios settings related to power mgmt and deep sleep, still not working :(

 

Thank you

Edited by malvibra

Share this post


Link to post
Share on other sites
Posted (edited)

No luck, here's the pmset log if needed. https://pastebin.com/hCHmF4JR

 

I just discovered that my USB hub isn't working. It's a 3.0 hub with 5 ports made by Aukey. I have two 3.0 USB in the front of the case and they're working, but not the hub. Is it possible to fix this? How? 

 

The graphic card is still 8x but I tried to run some benchmarks and the result is almost the same of the previous install.

 

Thanks

 

Edited by malvibra

Share this post


Link to post
Share on other sites

Sorry guys if  I'm annoying you, but I really can't stay without a working sleep/wake.

Is it possible to get some more help please? I tried everything on bios, on SMBIOS in Clover and everywhere, but I can't make it work.

 

@MaLd0n @Allan

 

Thank you again and sorry for disturbing :)

Share this post


Link to post
Share on other sites

u need check if have thirty party USB, some asrock sleep dont work in serie 8/9, need disable 3 party usb in bios for work

Share this post


Link to post
Share on other sites
19 minutes ago, MaLd0n said:

u need check if have thirty party USB, some asrock sleep dont work in serie 8/9, need disable 3 party usb in bios for work


This is my USB configuration, and the second screenshot is the BIOS page to manage USBs. Have I to disable the whole USB 3.0 controller? 

In the specs I found "4 x USB 3.0 Ports (ASMedia Hub)", is this one you was speaking about? Is there a fix? 

 

Screen Shot 2018-07-05 at 22.51.23.png

Screen Shot 2018-07-05 at 22.50.14.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By autantpourmoi
      Hello , I just put a new M2 samsung ssd disk in my hack and a And rx 580 sapphire 8go and installed High Sierra 10.13.6 , everything seems ok except the sleeping mode
      When I go to sleeping mode , the 2 monitors will turn to sleeping mode and after 3 to 5 sec the computer too , but the computer restart in a kind os stand by mode while the monitors still black 
      Is it a normal behaviour which I'm doubting about it , is there any way to keep the computer in sleep and reactivate it by keys?
      any help will be appreciated
       
    • By Mattbatt
      First post, thank you all for any help offered. I am coming from a certain commercialized hackintosh community - after seeing such amazing vanilla installs and reading of the talent here, I decided to have a go at not using such software methods. And I immediately got myself into a predicament 
       
      BACKSTORY
      I successfully upgraded from Mavericks to Mojave 10.14.2 but decided to start over and do a clean install because my Vega Frontier was not playing OOB even with Lilu & whatevergreen - and there was a lot of 'code junk' Clover barfed at boot from this 'commercialized software'.
       
      SUCCESS
      I created Mojave USB installer from scratch using the latest Clover, it worked fine, got me to the Mojave install screen.
       
      PROBLEM
      For reasons unknown to me, I decided for one last ditch effort to see if I could get my already installed Mojave playing nicer - instead of starting over clean. So I installed the latest Clover on my Mojave SSD, (it had a Clover version YEARS ago when I last installed Mavericks) and I replaced the EFI file with the kexts and config of my USB EFI file because I figured, since the USB installer launched, it was all good to go.
       
      Now nothing boots after BIOS. Not my Mavericks drive, Mojave SSD, nor my USB Mojave Installer. They all hang right where Clover usually launches. I look at my USB lights and nothing flashes...
       
      The only drive I can use is Windows 8.1 (my testing environment) and not from Clover. That's just booting windows up without any HD's plugged in.
       
      Is there a way to rescue my predicament? I don't have another Mac computer and CloverConfig only runs on Mac. Is there a way to fix the USB from Windows? Thanks!
       
      Specs: Gigabyte GA-X58A-UD5 rev. 2.0, FC BIOS, i7-980x, Vega64 Frontier Edition, Nvidia GTX480, 24 GB 1333 RAM, SSD + various hardrives
    • By bilbo
      THE GREAT GUIDE
      HIGH SIERRA + Z820

       
      ********
      10/07/2018
       
       
      *********************************************************************************
      ————————————————————————————————————————
      ————————————————————————————————————————
       
      (from El Capitan's guide)
      (from Sierra's guide)
       
      Introduction:
       
      Hi everybody. 
      Again, a new guide version, updated to High Sierra. I hope it will be useful for you all. This time, the update is easy. Basically, the 100% of Sierra’s guide is still valid for High Sierra. The guide has been updated to update links, kexts versions … etc, and some parts try to be more clear. Just there are some important topic to keep in mind:
       
      1. What's new?.
      There is a new and absolute important setting to install High Sierra. We have to activate “legacy ACPI cpu tables” in Advanced Section, in BIOS. Without this option enabled, we will get a KP. 
      This option changes completely the structure of the SSDT needed for PM. We have to get rid old SSDT versions, if you extracted them with this option disabled. And all SSDT generated by ssdtPRGen also.
      And, if your DSDT has the “SSDT-1-CpuDef” code injected, (following my guide, to skip "No ACPI Processor declarations found in the DSDT!" error, (see PM section) ) you will have to delete that part, because the DSDT will cause a KP. A better method is described in this guide. No need of add estrange code into DSDT.

       
      2.Can I use my old files from Sierra´s EFI folder?
      The most important, yes. You can keep your config.plist and your DSDT(see point N.1) … saving tons of time. You have to use the new drivers64Uefi files installed by new clover version, and update the kexts versions of main kexts. The specific kexts for our dear machine, USB3, Astek driver, remains in same version.Of course, I provide of all links and files (into my stuff folder) in this guide.
       
      3. So, do I Need repeat again every step of this guide?.
      If you comes from Sierra´s guide, no. After 1stboot and graphics divers install, you can use your previous files (see point 1.) reboot and jump directly to PM section. 
      For new users, Yes, sure.

      4. Consider any part of this guide open to discuss.
      If you see something wrong, or which could be improved, please, just say it, and I’ll fix it. English is not my native language. If you can’t understand some step, or something could be best written, please, just say it and I’ll fix it too
       

      FOR 26x7 and 26x3 USERS!!!. Finally, there a Fix to this models. It´s under test, but I think it should work. Check out FIRST the last section of this guide.
       
      5. And please, (this is for "anonymous" users) don't PM me with personalquestions. No need for that.Any question can be answered openly.
       
       
      Ok, let’s go.
       
       
       
      PART I
       
      1-BIOS SETUP
       
       
      This guide is for UEFI systems. This is not important to follow this guide except in Clover installation section. Keep in mind it to adapt some settings if you need use legacy-bios mode. 
       
      If you don’t need any special option, and you have been playing with options, reset the bios to default settings.Later, you will be able to change and test, if you need some specific option. The next section describe the essential options. 
       
      6. The main BIOS options are:
       
      In storage: 
      set ACHI mode (IMPORTANT).
       

       
       
      Set boot order. UEFI first, (for me), USB first and HD second. 
       


       
      Security : 
      Device Security: I like disable unused devices (scu controller and serial port). Optional.



       
      Disable Vt-d: Disabled. IMPORTANT. 
       

       

       
      Secure boot. Disabled (...to boot with non signed OS). 
      I use UEFI boot, but I keep legacy support active. This is optional.
       

       
       
      In Power :
      Set Runtimepower management to Enabled. This option will allow Power Management later. About the rest of options, I’m not sure of the impact in performance. Set them by default by the moment. Not important for the guide. Only remeber for further tests that with Pcie Performance Mode enabled, power boost is disabled. Idle Power Savings manage sleep policies.


       
       
      In Advanced:
       
      Set PXE, Storage and Video to EFI. (for me). If you have a graphic card non EFI-compliant, you can set video in Legacy, keeping an UEFI boot.
      Don’t forget set thunderbolt policy in Legacy mode.
       

       

       
      And Now, the essential setting for High Sierra: 
       
      -Enable “Legacy ACPI CPU Tables”
       


       

       

      _________________________________________________________________________________________________________________________________
       
       
       
      PART II:
       
      INSTALLATION
       
      7- MEDIA CREATION
       
      (This guide assume you have a MacOs running. I have no idea how do it on PC)
       
      -Important: Download HighSierra dmg only from Apple.Don´t use suspicious dmgs or Isos. It’s not longer available to search in Apple Store, since Mojave release. Go to this link, and click in “Get macOS high Sierra” (at mid of the page). It will open the apple store download link. The dmg is downloaded in /Applications folder. Let the file in Applications folder. (and keep one compressed copy for future attempts)

       
      -Format one USB stick with common settings:
       


       
      Go to erase tab, select GUID partition table in options, and Mac Os Extended (Journaled) as Filesystem. Name the partition as “USB”. Ok to Apply.   
      On a terminal window, type (copy and paste) :  
      sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction  
      Enter and type your admin password. It will take 10-15 minutes. (When it finish, you’ll see the prompt again)  
      8. INSTALLING CLOVER.
       
      -Download Clover from here. Version used to make this guide: Clover_v2.4k_r4658.
      -Download Clover Configurator from here. It makes easier edit config.plist file and we can use a lot of clover features easily. Now there is a “global edition”
      -Download plisteditor pro demo for edit info.plist files.
      -Download my High Sierra stuff folder. (at the end of the guide)
      -Additional tools: One tool for install kexts, fix permission and rebuild cache. I use Kext helper from rampage’s dmg, although I need always force quit. I don´t like the rest of utilities. This is a personal option. Maybe EFI mounter (from download sections of this site). CloverConfigurator mounts EFI too, but maybe with this utility is easier.
       
      -Install Clover in the USB. On first screen, don’t forget change the install location in order to do not install on your Internal HD. Select your USB stick.
      Click on Customize. Choose “Install for UEFI booting only” and “Install Clover in the ESP” as main options (if your system is UEFI-based) This is optional: choose your favorite Theme. In Drivers64UEFI select: Now is longer section. It´s only because is more exact showing the drivers installed. We have to keep selected the default options and add the same additional drivers. Keep in mind two important things:                   -There is a new driver, APFS driver, for the “new” filesystem. This driver is now essential, in order to allow clover “see” HDs formatted with this FS. It´s activated by default. 
                       -The OSxAptiopnFix2Drv has a new version, v3.
                ... The conclusion of this long explanation, is that we have to add to the default selection of drivers: 
       
                                - EmuVariableUefi-64
                               - OsxAptionFix3Drv
       

      Let the rest of option unselected and Click on Install.
       
       
      9- CONFIGURE CLOVER

      When clover finishes, it will mount EFI partition. Time to modify it. You’ll find all necessary files in my folder. There are three things to modify: config.plist, drivers, and kexts
       
      9.1 Config.plist
       
      The default config.plist is not useful for us. Replace it by mine (folder n.2)
      But take a look to options (with clover configurator) to understand my options in order to be able to adapt them for your specs or your preferences. It’s a basic config.plist. I could add more options or fixes. but is a good idea install with minimum options. 
       
           Acpi section.
          All fixes in ACPI section has been removed except some minor fixes in 2 subsection, smart ups option, etc. SmartUps it’s not important now, but it will be later. So I prefer activate this option. 
          The most important, The rename usb devices patches are included. 
       
          

          Boot section
          Bootflags needed are only -v and npci=0x2000. Of course -v is optional only to see the boot process. You can deactivate it when you finish.
       
          
       
          Any option activated in Boot Graphics/ Cpu/Device/Disable driver
       
          Gui options. These are only personal preferences.
       
          
       
          Graphics. AnyGraphic injection annd any option activated. At least, no needed for my 1080ti card. Check it out for your card video.
       
          
       
          An essential section. Kernels Patches needed.
       
          
       
          RT Variables. BooterConfig, and Csr to deactivate security policy in Sierra. The info values are taken from smbios.
       
          
       
          SMBIOS.  Set it to Mac Pro 6,1. 
       
          
       
                    IMPORTANT—>press “generate new” repeatedly to get one random fresh serial number
       
          System parameter: 
       
          
       
       
      9.2 -Drivers64UEFI folder.
       
      As usual, delete VBoxHfs-64driver and replace it by HFSPlus.efi. (from my folder).

           
       
       
      9.3 Kexts folder:
       
      Add my Kexts from my stuff to /EFI/CLOVER/Kexts/10.13
       
      They are:

           
       
       
      These are the versions Updated since Sierra´s guide.
       
      FakeSMC.kext. If you remember, I have some unexpected KP due to fake smc sensors. Well, I have searched a bit about this, and testing. The main topic is keep the fake smc version and sensors kext of same version or branch. There are several branchs developing              different versions (slice, rehabman, kozleck, etc), after test, and test, I think the most stables and those which gives me best sensor readings is kozeck version. I attach the v1440 from kozleck. In this step I only use FakeSMC kext, withput sensors kexts. Anyway, if you have a better version, use it. Just, don´t forget no use the sensors Kexts.   
      VoodooTSCync.kext, to avoid boot with -x (from rampagdev, dual cpu dmg). You’ll find several versions into my folder.I haven’t noticed any change using the generic or the specific version. I think that is not important for our platform.                  The customize method is:

       

       
               Anyway, I provided the generic version and customized versions for every cpu.

       
      IntelMausiEthernet.kext . Kext for the ethernet card from rehabman. (2018-0424version). It will allow have internet connection on first boot. 
       
      UsbInjectall, for USB2 from rehabman( 2018-0822version)  
      And add to /EFI/CLOVER/Kexts/others
       
           
       
       
      Lilu kext (from here, 1.2.7version)
       
      WhateverGreen.kext (from here, 1.2.2 version) old NvidiaGraphicsFixup proyect has been integrated into this proyect.   
      This couple of kexts avoid black screen booting with 6,1 smbios. Is quite important keep in mind the versions of these kexts keeping the right versions among this kexts. Prior to update some of them, you have to check in info if is compatible with the rest. These versions are ready to work with 10.13.6. 
       
      Thats all. We have our usb installer ready. Copy in a folder all stuff necessary to repeat the process and copy it to the USB stick. You will have it available after first boot.
       
      Reboot from the USB stick and install Sierra. 

       
      10- INSTALLATION

       
      Some advices:
           -Use only USB2 ports, preferablythe front USB2 port.
           -Don’t use USB hubs, or cable extenders… (personal issues)
           -Unplug any other usb device
           -Be sure that you have plugged your internal sata drive to one of the two internal achi sata controller.
       

       
           -The boot process may be slow, (and with terrible and apocalyptic errors). Be patient
           -Maybe, the boot stucks with the error “consideredRebuildKernel …. blabla”. Just reboot again.
           -If you have two monitors, shutdown one can help with graphical errors.
           -Plug your graphic card in PCI Slot 2.
           -For inexperienced users: On first screen, go to disk utility and erase the Volume. (APFS and GPT). Quit the utility and return to first screen. Choose Install.
           -The process is splitted in two steps. The first step promises take only 4 or 5minutes … and now, it’s true!!!. It will take4 or 5 minutes(with a SSD).
           -After this first reboot, you will see more partitions than expected. APFS file system manage more partitions in a more complex way (physical layer, logical layer… bla, bla). Select in clover the new internal HighSierra boot installer partition, not the usb installer. It will finish the  process. This step, takes 10-15min aprox (using a SSD).
       
      Note.I had some unexpected reboot in this step. Only re-trying if you have it also.
       
      -To boot again after installation, keep booting from USB but choose internal HD as boot volume.
       
       
      ---------------------------------------------------------------------------------------------------------------------------------
       
       
       
      PART III:
       
      FIRST BOOT
       
      11. Optional updates.
      The Mac os Version is 17G65. In the date of this guide (oct/2018) is the last version. (there is an optional update only for real macbook laptops). For future security updates, this is the moment to update. Set up the internet options and update the system, but remember check if the Lilu and whatevergreen kexts are compatible or if you need use a new version, or you will geta KP or a black screen on boot.
       
      12- Install Clover.
      On first reboot, install clover again on HDD, repeating same process and same options than with the USB installer, but keep in mind you have to addsome options on clover’s screen install:
       


       

           -Install RC scripts on target volume
           -Optional RC scripts
           -Install Clover Preference Panel.

      …and install clovermanager.app. This is optional but it’s the best way to manage the themes and find a good theme. I provide of one nice High Sierra Theme and the Bootcamp theme. Of course, left this for later. 
       
      Install clover and add same files used on the USB: config.plist , hfsplus driver and kexts. Reboot. You can nowextract the USB installer and reboot from the internalHDD.
      After boot, go to clover preference panel and set it to auto mount EFI partition. It will be useful along this process. Disable this when you finish and you get stable your system.
       
       
    • By FrankWalter
      Bello everyone, when I start the installation of macos high sierra I get the error in the title, I use the distro of niresh in legacy mode. Reading many posts I saw that many advised to set FixHeaders in true, ignoring the fact that it was already so I think it does not make any effect because as I'm in legacy mode use chameleon, however I am attached I leave the error screen and below the specifications of my pc.
       
      HP Proliant DL380 Gen 7
      2 x Intel Xeon E5620
      RAM 24 GB ddr3 1066
      Raid controller hp p410i with 8 SAS 72 gb 10k (I get the error also without this)
      Amd rx 470 (I get the error also with integrated)
      Integrated USB 2.0
      4 x Intel gigabit Ethernet (I get the error also without these)

    • By am_yvr
      Asus Prime B360M-A or Asus Prime H310M-E :

      Which of these two motherboards would give less hassle in a Hackintosh build - requiring fewer after install fixes/updates to get everything working in Mojave or High Sierra?
       
      These are the only two Asus models that I can afford, fit the form factor in my build, and already have had a BIOS upgrade by Asus to 9th-generation - if I want to replace the CPU with an i9 in the future (for now I'll be using i7-8700 or even i3-8350k but I want to future proof a bit)
       
      Thanks guys!
×