Jump to content
PippoX0

macOS Mojave on Legacy PC ? Yes we can

33 posts in this topic

Recommended Posts

Advertisement

Pippox0 .. no, it is not because, have the update 10.14.2 Beta1 on 2 PC and a laptop again downloaded down and installed properly on APFS partition.

 

Only with the tool "macOS_Updater", despite the fact that the developer gingek84 has updated it a day ago, although now the installation works fine,

but just after that, the Apple programs like Mail, Photo, iMessage, Safari and others do not start. In the console, I found referrals that some frameworks

are not found in S / L / Private Framewoks, although they are present when looking.

 

Yes, I'm not surprised, that Apple tries to put stones in the way again to use the damn APFS. I have a large SSD and therefore I have both ready,

an APFS partition for Mojave and just continue to test, a hfs + Mojave partition.

Share this post


Link to post
Share on other sites
On 11/4/2018 at 8:55 AM, pinarek said:

Pippox0 .. no, it is not because, have the update 10.14.2 Beta1 on 2 PC and a laptop again downloaded down and installed properly on APFS partition.

 

Only with the tool "macOS_Updater", despite the fact that the developer gingek84 has updated it a day ago, although now the installation works fine,

but just after that, the Apple programs like Mail, Photo, iMessage, Safari and others do not start. In the console, I found referrals that some frameworks

are not found in S / L / Private Framewoks, although they are present when looking.

 

Yes, I'm not surprised, that Apple tries to put stones in the way again to use the damn APFS. I have a large SSD and therefore I have both ready,

an APFS partition for Mojave and just continue to test, a hfs + Mojave partition.

Good news from gengik84

/System/Library/PrivateFrameworks/AppleMediaServices.framework

Replace it with 10.14.1, all Apple apps work fine with MBR HFS+ on 10.14.2 18C31g here.

 

I wish the final release will fix the beta bug issue:yes:, if it's a bug, not a OOXX.:(

Share this post


Link to post
Share on other sites

Thanks for any tips to solve this problem. Everything is going now again.

But why did Apple change this? just to annoy us with hackintosh or is it something else on it?

 

i have testet Apple.Media.frameworks from a updatet 10.14.2 Beta1 from APFS Partition replace in hfs+ Partition,  many Apple Apps work only NOT Safari works not.

Edited by pinarek

Share this post


Link to post
Share on other sites

@Pinarek Try to replace /System/Library/PrivateFrameworks/SafariShared.framework (copy it from 10.14.1).

It Should work ...

Tell me if you have resolved the issue

 

Cheers

 

 

Share this post


Link to post
Share on other sites

@pippox0 my Friend:

 

yes, if I replace all Apple.Media.frameworks from 10.14.1 in 10.14.2 Beta1 in hfs + partition is ALL (even Safari) only I have tried,

from the updated 10.14.2 Beta1 in the APFS partition Apple.Media. replace framworks in the 10.14.2 Beta1 in hfs + partition and then Safari will not work.

 

It was just a test.

 

Now that I know that the Apple.media.frameworks from the 10.14.1 Final work, then I can then at the next Beta2 then as always "macOS_Updater" for hfs + run

and then again from the 10.14.1 Final these files ( Apple.Media.frameworks) in hfs + partition replace and everything is ok.

Share this post


Link to post
Share on other sites

I successfully updated from 10.14.1 to 10.14.2 on my Mojave HFS partition by creating a full installer USB ---> in place upgrade installation.  This avoided the missing frameworks/app opening problems associated with the updater script discussed above...

 

* Can use either @dosdude1's macOS Mojave patcher tool or @crazybirdy's MBR-EasyInstallerMaker script to make USB installer from full 10.14.2 app
* Boot system to USB installer and target the 10.14.1 partition to perform upgrade install
* After upgrade completes, boot system to Mojave in single user mode to patch/replace com.apple.telemetry.plugin (eg with mojave2core script).  Can also replace legacy kexts from High Sierra if overwritten by update

 

eg in single user mode, type the following commands followed by <Enter> after each line ...

fsck -fy
mount -uw /
/usr/bin/mojave2core
cp -R /Volumes/USB/Kexts/* /System/Library/Extensions  //Assuming you put legacy NVidia/other needed kexts in "Kexts" folder on your USB 
touch /System/Library/Extensions && kextcache -u /
reboot

 

Spoiler

1376621765_Mojave_18C54updateonHFS.thumb.png.b38add9e0457a614f742eae234a01cc6.png1252470128_Mojave_18C54updateonHFS2.thumb.png.c6e9150264ede9019fcbb79e282637b3.png

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×