Jump to content
parrotgeek1

[TECHNICAL] HD3000 10.14 - what's blocking acceleration?

5 posts in this topic

Recommended Posts

Something in 10.14 is intentionally blocking HD3000 acceleration.


Even if you install all of the kexts and bundles, and set useMetal and useIOP to false, there is no acceleration:

sudo defaults write /Library/Preferences/com.apple.CoreDisplay useMetal -boolean no; sudo defaults write /Library/Preferences/com.apple.CoreDisplay useIOP -boolean no


It is **not** a linking problem/missing symbol problem. 
WindowServer loads the GLDriver, and then immediately something decides "nope" and calls gldTerminateLibrary.

 

WE KNOW IT IS POSSIBLE FOR IT TO WORK WITHOUT METAL BECAUSE FERMI GPUS WORK NATIVELY!

 

What does not work:

* replacing OpenGL/OpenCL/GPUSupport frameworks from 10.13 (it boots, but no acceleration still)
* replacing CoreDisplay from 10.13 (boots, glitchy GUI, no acceleration still)
* replacing SkyLight from 10.13 (Missing symbols, impossible to fix/dependency hell).

 

I'm pretty sure something in skylight is blocking it. Anyone want to help?

 

P.S. AppleGVA framework still has Gen6Accelerator code in it even on 10.14.

Edited by parrotgeek1

Share this post


Link to post
Share on other sites
Advertisement

Remember GMA950/GMA X3100 and Mountain Lion back in 2012 ? ...

Some people are still asking about graphics acceleration with these GPUs in Mavericks/Yosemite/El Capitan in 2018 ! :yes:

 

Same battle? :whistle:

 

Edited by Hervé

Share this post


Link to post
Share on other sites

If you open the binaries of Skylight and WindowServer in Hex editor, a list of other mentioned frameworks and libraries stored in /usr/bin can be seen. Maybe replacing all of these frameworks and libraries from High Sierra may permit the acceleration. I didn't try it yet. Anyway, if no boot is possible replacing Skylight, replacing other stuff may not help at all. Another thing to try is exclude Skylight or somehow disable it and substitute CoreGraphics and Quartz frameworks from El Capitan (Seems Skylight was introduced in Sierra). Just replacing kexts, I can boot in safe mode with loading of Framebuffer kext only, otherwise It stucks at a black screen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×