Jump to content
m1g2

Geforce GT610 works under Mojave

15 posts in this topic

Recommended Posts

Advertisement

GTX610 may be Fermi or may be Kepler.

Kepler will work as we see in topic.

Fermi has no chances.

Share this post


Link to post
Share on other sites
Posted (edited)
33 minutes ago, iamprabhuantony said:

Geforce GT610 really?? Hi Bro, is it Metal Supported??


As shown in the screenshot, yes it is.
Edit: Wait, GT 610 has only Fermi, right?! 

Edited by ricoc90

Share this post


Link to post
Share on other sites
1 hour ago, ricoc90 said:


As shown in the screenshot, yes it is.
Edit: Wait, GT 610 has only Fermi, right?! 

We should ask topic starter about more detailed information. For example

$bdmesg >~/Desktop/boot-log.txt

or full AIDA64 report.

Or log with

$ sudo kextutil -v GeforceSensors.kext > geforce-log.txt

Share this post


Link to post
Share on other sites

The question "Is it Fermi or Kepler?" is somewhat answered by the OP, although in another topic:

 

Share this post


Link to post
Share on other sites
Posted (edited)

Is there anything else you did to make it work? I have a GT520, which also uses the GF119 chip, I can get to the Desktop but have no acceleration and my cursor is invisible (which is at least better than 10.13.6 where I get a window server crash loop). I tried with and without Inject Nvidia in Clover and latest Lilu + Whatevergreen.

IMG_0971.JPG

Edited by SPO-Fan

Share this post


Link to post
Share on other sites
On 8/25/2018 at 3:35 AM, SPO-Fan said:

Is there anything else you did to make it work? I have a GT520, which also uses the GF119 chip, I can get to the Desktop but have no acceleration and my cursor is invisible (which is at least better than 10.13.6 where I get a window server crash loop). I tried with and without Inject Nvidia in Clover and latest Lilu + Whatevergreen.

But GT 520M (Fermi GF119M) is QE/CI enabled under 10.14 Beta (with random crash issue).

I documented it on my "EFI-Asus-A43SJ" GitHub Repo.

Share this post


Link to post
Share on other sites
4 minutes ago, Badruzeus said:

But GT 520M (Fermi GF119M) is QE/CI enabled under 10.14 Beta (with random crash issue).

I documented it on my "EFI-Asus-A43SJ" GitHub Repo.

OK

For QE/CI enabled Graphics under macOS Mojave 10.14 Beta 5 ++, install /Extras/GeForce.kext to SLE

This non-native kext allows you to get graphics working with random crash. It is not a solution.

I am not sure how your system will work in different applications, graphics, games, will your system sleep and wake and so on.

Share this post


Link to post
Share on other sites
Posted (edited)
24 minutes ago, Slice said:

OK


For QE/CI enabled Graphics under macOS Mojave 10.14 Beta 5 ++, install /Extras/GeForce.kext to SLE

This non-native kext allows you to get graphics working with random crash. It is not a solution.

I am not sure how your system will work in different applications, graphics, games, will your system sleep and wake and so on.

Yes, here's the main problem.. actually since 10.12, my GF119M would get WindowServer crash immediately if changing non-native display resolutions, even with all native kexts on LE / SLE  and CoreDisplay.framework.

 

Graphics apps are working just fine, video encoding, and so on.. as well as system sleep / wake. But if playing some games that use DisplayScaling; (native mac games app or even wine, vm fullscreen) = crash. The reason why I'm still using 10.11.6 till date for daily use #pity

Edited by Badruzeus

Share this post


Link to post
Share on other sites
Posted (edited)

If GF119 (GT610 etc.) isn't fully compatible with Mojave (Metal or Metal2...),

then the next question doesn't seem to be off-topic:

what are the first nVidia and AMD graphics cards (both the oldest models and the cheapest ones) to fully support Metal...?

If there's already such a thread, I haven't found it.

Edited by AugerJ

Share this post


Link to post
Share on other sites

All Nvidia Kepler will work. For example GTX640.

About AMD I don't know which one is cheapest. It must be at least Southern Island, HD7xxx or R7-2xx. But not 230 which is 6xxx.

May be the chipest is R7 240 which is Oland family but works with some tricks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×