Jump to content
KGP-iMacPro

iMac Pro X99 - live the future now with macOS 10.14 Mojave [Successful Build/Successful Guide]

107 posts in this topic

Recommended Posts

Posted (edited)

Hi there.
After struggling by myself to even get 10.14 past the 'end randomseed' line several times I finally found and used your guide to get 10.14.4 installed and working on my hackintosh workstation. I have 10.13.6 stable but not brilliant, it works ok with FCPX and Resolve as I require but can be temperamental.
Without any Kernal to patch additions I had its power tweaks working and XCPM appeared to work fine. My Radeon Pro WX9100 worked well with the radeon fan speed kext and ran (as per one of the two Luxmark screenshots) at 1442mhz quite successfully.

 

I’m up to the part in your guide where your going through SSDT and device implementations. I tried to get XCPM working in 10.14.4 but have given up for the time being. As per the screenshot with the intel power app, and me testing XCPM in terminal and getting 0 back (so not working) it appears that my Xeon is running locked at full clock speed and is reporting wrong. I tried using just the additions to the kernalToPatch that you had in the section but couldn’t get my machine to start so had to go back to the full set I found in the file you shared to another earlier user to get it booting. I’m not sure what is best to tweak to get my v5 Xeon working fully from there. I have the suggested options turned on in bios (and the power one off as recommended) but no joy. If I try the options I used in 10.13.6 (none) then I can’t get it to boot past ‘end randomseed’

My other primary concern is my Vega card. My Radeon Pro WX9100 is being reported by Luxmark as running currently on 945mhz. And feels slow in games and FCPX.


I've stuck the  VegaTab_9100.kext into the kext folder in clover and also tried adding SSDT-X99-Vega-Fontier.aml (changing the name) but it still feels slow. How might I use the powerplay table to set my WX9100 to 1500mhz and aiming for 55deg Celsius? (I don’t mind a louder card, but I don’t want it too hot as it does long render sessions and long gaming sessions). the Vegatab kext appears to be affecting my fan speed (which is nice) but its not helping the power. If I try running vanilla, I get slow speed 945mhz still. 

 

I would also like to get my thunderbolt 3 port along with bluetooth & wifi working but will try that once I reach the later part of your guide that deals with it. I’ve never managed to any of those three working so far so they are of less immediate desire.

Audio appears to work perfectly right away. So I’m not keen to touch that.
My Hard drives and SSD appear okay. Mac OS itself feels to run beautifully smooth. USB 3 is working on most ports and I’m currently leaving the Clixt-iMacPro-AsusX99E-XHCI-15port.kext in there till I put in the time to remake it to suit my systems different layout.
https://www.dropbox.com/s/qm9tdbb4amwp3v9/EFI.zip?dl=0 is my EFI folder that’s currently in use. Any help toward getting my processor and graphics working properly would be greatly appreciated. I've gone over your guide as best I can, but please let me know if there's something critical I've misunderstood or failed to do. 

 

Screen Shot 2019-03-29 at 1.38.03 PM.pngScreenshot 2019-03-28 11.51.27.png

 

Screen Shot 2019-03-28 at 12.58.19 PM.png

Edit, after a while of gaming it starts to freeze repeatedly so I'm continuing the evenings gaming in 10.13 ...

 

Edited by Setura

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)

Back from Rome and quick update to 10.14.5 Beta on X99 with Radeon VII

 

1.) New macOS 10.14.5 Beta X99 EFI-Folder Source distribution

 

2.) SSDT-X99-Radeon-VII.aml + SSDT-X99-HDEF.aml + SSDT-DTPG.aml

 

3.) Lilu.kext v.1.3.5 + AppleALC.kext v1.3.6 + Whatevergreen.kext v.1.2.7

 

4.) Clover_v2.4k_r4918

 

Perfect Radeon VII implementation, including Hardware Acceleration, Display HotPlug, multi-monitor support, DP/HDMI Audio and system sleep/wake. 

 

1418204539_Screenshot2019-04-04at14_09_36.png.2bd0152acee3a2497d7c0fc79c87eb47.png

 

651837081_Screenshot2019-04-04at14_10_51.thumb.png.4cfb8f8e575821acd9e87a09271ffe5d.png

 

624488481_Screenshot2019-04-04at14_11_21.thumb.png.7adcd762ca6b872710ce4666d860c2fc.png

 

830957145_Screenshot2019-04-04at14_07_08.thumb.png.88b6bdbc6ddbb520bd047c9040e97b2e.png

 

1497698918_Screenshot2019-04-04at13_47_00.png.9f2979eb34bc114b6f4037cad6c9c7ed.png

 

1938380334_Screenshot2019-04-04at13_49_12.thumb.png.a211cc3170d4d703afab26583f8af934.png

 

245099525_Screenshot2019-04-04at13_50_40.thumb.png.3facd36e85f7f942e7700411d813da63.png

 

1773488948_Screenshot2019-04-04at13_54_03.thumb.png.c7ef02e7546d745412909f0de82a9f0b.png

 

937411812_Screenshot2019-04-04at13_59_12.png.7f7fe4cc12ff751206635f88d29140ce.png

 

1739050563_Screenshot2019-04-04at14_03_26.png.ca347cd6ed185e64364c132b7d780e86.png

 

Apart from Luxmark, all other Radeon VII macOS benchmark scores are not optimal at present, mainly due to a yet to be optimised Radeon VII macOS driver implementation or some missing update of respective GPU benchmark programs, although I use a briefly adapted Radeon VII load table in my respective SSDTs. With the current Radeon VII macOS implementation, GPU temps keep low (40-50 deg C) even during Heaven and Valley benchmarks and even in case of the air flow Radeon VII, I am currently employing for testing purposes.

 

Enjoy and have fun,

kgp.png.9d8fa098d81670bd45b048f0abce9f2d.png

Edited by KGP-iMacPro

Share this post


Link to post
Share on other sites
Quote

Important additional comment for all Vega users with 4K monitors though: when connecting a Vega with e.g. the LG 38UC99-W (WUHD, 3840 pix x 1600 pix) via one of the Display Ports (DPs), the screen resolution is fine under both Windows 10 and macOS High Sierra but is totally at odd during boot (VGA like boot screen resolution). The VEGA DP 4K boot screen resolution issue is neither related with the fact that the LG 38UC99-W is an ultra-wide (3840x1600) and not a true UHD (3840x2160) monitor nor related to any likely apparent issue with the ASUS X99-A II firmware. It is definitely a Vega firmware problem in combination with most 4K displays, as the DP 4K boot screen resolution issue is totally absent with my Nvidia GPU and the problem also does not only affect the ASUS Splash Screen but also spreads over the entire boot process until the login screen is reached (Windows and macOS). Splash Screen, Apple logo or verbose boot messages are not stretched but rather have VGA like resolution. Any fix of the AMD vBIOS would be highly appreciated. It is more than disappointing to witness such issues with 600-1000$ GPUs... Fortunately, the 4K boot screen issue is restricted to the Vega DP ports and likely due to the fact that the LG 38UC99-W only supports DP 1.2. Solution: Connect your Vega and your 4K display via the HDMI port. The 30 Hz HDMI monitor frequency issue under 10.13 is successfully removed under Mojave: monitor frequency of 60 Hz with the display connected via HDMI (in contrary to 75 Hz via DP).

 

 

Great benchmarks with Radeon VII :thumbsup_anim:

 

Is the Radeon VII react the same with the boot splash screen as you described here? I mean by the that the screen resolution of the boot screen.

Share this post


Link to post
Share on other sites
3 minutes ago, MMido said:

 

Great benchmarks with Radeon VII :thumbsup_anim:

 

Is the Radeon VII react the same with the boot splash screen as you described here? I mean by the that the screen resolution of the boot screen.

 

I am now using the LG5K2K, which boot resolution works fine with Vegas. With the VII, the boot resolution is ok although not optimal or perfect. 

Share this post


Link to post
Share on other sites
Posted (edited)

New X99 10.14.5 Beta EFI-Folder distribution adding Radeon VII GPU Temp sensor information for iStatMenus. 

EFI-X99-10.14.5-Beta-iMacPro1,1-050419.zip

I just modified Kozlek/Interferenc FakeSMC/HWSensor source code distribution for adding Radeon VII GPU Temp sensor information and subsequently added new FakeSMC.kext and HWSensor.kexts to /EFI/Clover/kexts/Other. The new GPU Sensor kext should now support all Vegas and also the new Radeon VII, when using iStatMenus. 

 

1948412805_Screenshot2019-04-06at00_48_48.png.fbfd7b4d295c42a56fb77110716f2f27.png

 

Enjoy and have fun,

 

kgp.png.3d57346e7032051d0959425805fcbd14.png

Edited by KGP-iMacPro

Share this post


Link to post
Share on other sites

Flawless update to 10.14.5 Beta 2 (18F108f)

 

781517555_Screenshot2019-04-09at01_12_20.png.096d9d3e9f012cc9732a17dd701c0a2e.png

 

No further improvements in Radeon VII performance so far (quite identical overall benchmark scores when compared with Beta 1) but H264 and HEVC support. 

 

1768084373_Screenshot2019-04-09at01_13_24.png.855661f421714a5570e0d44b05a314e2.png

 

Enjoy and have fun,

 

kgp.png.4804906cae583b47a26f810cdcad7b35.png

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
New createInstaller.sh scripts for macOS Mojave 10.14.4 (18E226) and macOS Mojave 10.14.4 (18E2034) - special build

Apple recently changed the index for macOS Mojave 10.14.4 (18E226) on http://swcdn.apple.com/, although resulting Install macOS Mojave.app version remains 14.4.08.
 
347327691_Screenshot2019-04-23at16_12_36.thumb.png.8005338a73baa1ca42fe0be5c3ca8488.png
 
I therefore expect the respective macOS Mojave 10.14.4 build still to be 18E226.

Respective changes for macOS Mojave 10.14.4 (18E226) on http://swcdn.apple.com/ also required minor modifications of createInstall.sh for Mojave 10.14.4 (18E2034), which else also still reveals receptive Install macOS Mojave.app version 14.4.10. 

Corresponding Update of Section D.2) completed. New versions of createInstaller-10.14.4-23042019.sh.zip and  createInstaller-10.14.4-SB-23042019.sh have been linked in the guide in the originating post of this thread. 
 
Enjoy and have fun,
 
kgp.png.f211d88be0a9b8ac816c220a51777795.png
 
Edit: Update of createInstaller-10.14.4-SB-23042019.sh as I accidentally renamed and linked old file before. 
Edited by KGP-iMacPro

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Drovosek
      Unfortunately this is not my PC, I just decided to share the found config successful installation.
      https://vk.com/photo-12954845_457251886
       
      Hardware:
      OS X 10.15.0 Beta 2 
      CPU Intel XEON E5 2650 v3
      MB MSI X99A RAIDER
      AMD Radeon RX VEGA 56 video card
      Kingston HyperX Fury DDR4 2133Mhz 20gb memory
      Crucial 4gb 2400Mhz
      Sound E-MU 0202, Alc892 and AMD DisplayPort Audio
      Intel Gigabit LAN network
      WI-FI Broadcom BCM94360CS2
      BCM20702 BT (trackpad and keyboard work in the BIOS)
      BP Enermax Platimax 1000W
      AirDrop works.
      SSD NVMe Reina 480gb
      Samsung 850 Pro 120gb
      Dell U2713H monitor
      USB 15 ports are registered manually. 3.0 works. 
      Services usual, SpeedStep instituted through kekst. 
      Sleep is unstable.
       
      EFI: https://vk.com/doc207634019_512032268
      New EFI: https://vk.com/doc207634019_516702825
       

      EFI.zip
      new EFI.zip
    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      EFI-Clover-X99.zip
       
       
       
       
       
       
      Anyone else I forgot
       
       
    • By simras
      Hello,

      I am trying to make a new Hackintosh under 10.13 with this specs:
      i7 6800K,
      Asus X99-E
      Asus GTX 970

      But the problem is that I can't pass those errors :
      - couldn't allocate runtime area
      - end randomseed ++++++++++++++ _

      I have always passed this thing on all hackintoshs that I have done, but here, impossible.

      Tried those tests :
      - AptioMemoryFix alone,
      - AptioMemoryFix with EmuVariableUefi and RC Scripts,
      - OsxAptioFix2Drv-free2000 with EmuVariableUefi and RC Scripts,
      - Test2-2016.efi with OsxAptioFixDrv, EmuVariableUefi and RC Scripts,
      - Test2-2016.efi with OsxAptioFix2Drv, EmuVariableUefi and RC Scripts,
      - Test2-2016.efi with OsxAptioFix2Drv, OsxAptioFixDrv, EmuVariableUefi and RC Scripts,
      - Test2.efi with OsxAptioFixDrv, EmuVariableUefi and RC Scripts,
      - Test2.efi with OsxAptioFix2Drv, EmuVariableUefi and RC Scripts,
      - Test2.efi with OsxAptioFix2Drv, OsxAptioFixDrv, EmuVariableUefi and RC Scripts.

      I have tried all this with npci=0x3000 that I have never used before instead of npci=0x2000

      I have done an Hackintosh on Asus X99 Deluxe II and it pass with AptioMemoryFix with EmuVariableUefi and RC Scripts....

      I have tried to reset NVRAM with F11.

      I have tried with 1 RAM stick that I have indicate in the SMBIOS :
      https://hackintosher.com/forums/thread/mapping-ram-and-dimm-slots-on-a-hackintosh-with-clover-smbios.365/
       
      I have follow KGP guide for X99 :
       
      The BIOS settings are exactly the same.

      I link my CLOVER folder.

      Thank you.
      CLOVER.zip
    • By ludufre
      Installing macOS Mojave 10.14.6 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      09/01/2019 15:57h GMT-0
      - Updated to 10.14.6.
       
      06/10/2019 00:44h GMT-0
      - Completely rewritten.
       
      10/17/2018 08:12h GMT-0
      - Fix Kexts permissions commands adjusted.
      - Removed FrameBuffer patch that is not needed.
      - Added audio solution and HDMI.
      - Unfortunately DisplayPort does not work.
      - Replaced Wifi/BT with DW1560 (BCM94352Z)
       
      10/11/2018 04:15h GMT-0
      - Added USB 3.0 patch.
      - Adjusted some steps.
      - Changed text formatting.
       
      10/11/2018 03:42h GMT-0
      - Added missing UEFI configuration.
       
      10/07/2018 00:36h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Not tested yet.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Make audio work.
      - Make HDMI audio work.
      - Test DisplayPort.
      - Make second ethernet work.
      - Replace Wifi/Bluetooth.
      - Test DP.
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover Configurator
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes. / 8 minutes with USB 3.0
       
       

      Install bootloader

      Download the CloverEFI (used 5058, from Automated Clover Builds) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended drivers (check all)
      - UEFI Drivers - Human Interface Devices (check all)
      - UEFI Drivers - FileVault 2 UEFI Drivers (check all, If you are going to use FileVault)
      - UEFI Drivers - Additional drivers - NvmExpressDxe (if you are going to use NVMe)


       
       
      Make things works
       
      We'll make a full working flash drive, so follow these instructions:
       
      Will be mounted the EFI partition of the flash drive.
       
      Open the the /Volumes/EFI/CLOVER/config.plist inside this new partition with Clover Configurator (used 5.5.0.0)
       
      Important modifications
       
      config.plist
       
      ACPI Page
       
      - Check: SSDT - PluginType
       
      BOOT Page
       
      - Add: Arguments - darkwake=2
      - Check: Legacy - XMPDetection=Yes
       
      KERNEL AND KEXT PATCHES Page
       
      - Check: KernelPm
       
      RT VARIABLES Page
       
      - Change: CsrActiveConfig - 0x3E7
       
      SMBIOS Page
       
      - Change: Macmini8,1 - Mac mini (Late 2018) | Intel Core i7-8700B @ 3.20 GHz

       
      - Click: Generate New (few times in the two buttons)

       
       
      Need some Kexts in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the HWSensors 3 from here. I used the FakeSMC.kext, ACPIMonitor.kext, ITEIT87x.kext and IntelCPUMonitor.kext inside of DMG version r240.
      - Download the Lilu.kext from here. I used the version 1.3.8.

       
      Intel UHD 630
       
      ACPI Page
      - Uncheck: Fixes - AddHDMI
      - Uncheck: Fixes - FixDisplay
      - Uncheck: Fixes - FixHDA
       
      GUI Page
      - Change: Screen Resolution - 3840x2160 (My monitor is 4K)

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the WhateverGreen.kext from here. I used the version 1.3.1.

       
      Audio ALC 1220 and HDMI audio

      BOOT Page
      - Add: Arguments - alcid=11

      DEVICES Page
      - Change: Audio - Inject - 11
      - Uncheck: Audio - AFGLowPowerState
      - Uncheck: Audio - ResetHDA

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the AppleALC.kext from here. I used the version 1.4.0.

       
      All USBs (2.0, 3.0, Type-C, internal)
       
      KERNEL AND KEXT PATCHES Page - KextsToPatch
       
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 1 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 2 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 3 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FF0F0F
      - Replace* [HEX]: 83FF3F0F
      - Comment: USB Port Limit Patch 4 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
       
      Need SSDT patch in the folder /EFI/CLOVER/ACPI/patched/
       
      - Download the SSDT-EC.aml, SSDT-UIAC.aml and SSDT-USBX attached bellow.
       
      Wifi and Bluetooth (BCM94360CS)
       
      Works out of box (plug 'n' play).
       
       
      LAN Cards
       
      Need a Kext for feach card in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the IntelMausiEthrenet.kext from here. I used the version 2018-1031.
      - Download the SmallTreeIntel82576.kext attached bellow. I do not remember where I found it.

       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: Periphelrals - Initial Display to IGP
      - Change value: Periphelrals - USB Configuration - XHCI Hand-off to ENABLE
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Change value: Chipset - DVMT Pre-Allocated to 128M
      - Save & Exit Setup
       
      - Now, hold the F12
      - In the list, select your flash drive.
      - It will show twice. One with UEFI prefix and another without.
      - Select with UEFI prefix. Ie.: "UEFI: Sandisk Cruzer"
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "HD".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the EFI folder inside your destination disk EFI parittion, with EFI folder inside flash card EFI partition.

      If the flash drive EFI partition of your destination disk or flash drive is unmounted:
      Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 0 for destination disk and 1 for flash drive.
       
      Then, eject the flash drive.
       
      Last step
       
      Move all Kexts from EFI partition to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/10.14/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      Updates
       
      System update 10.14.6
       
      - Download and open latest CloverConfigurator
      - Open Mount EFI and click in Mount Partition in EFI Partitions list
      - Click in Open Partition that appears
      - Go to EFI -> CLOVER
      - Backup config.plist and ACPI folder to desktop
      - Go back and delete CLOVER folder
      (If you restart now you can't boot in macOS - DON'T RESTART)
      - Download latest Clover and install (link and config above)
      - Replace config.plist and ACPI folder from your desktop
       
      - Update Lilu.kext, AppleALC.kext, WhateverGreen.kext, HWSensors kexts (FakeSMC, ACPIMonitor, IntelCPUMonitor, ITEIT87x) in /Library/Extensions/
      - Run:
       
      sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i /  
       
      - Install macOS Update 10.14.6 and restart
       

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
       
       
      Z370N-WIFI v2.zip
×