Jump to content
  1. v7kF4U2HTd

    v7kF4U2HTd

  2. caH_Pati

    caH_Pati

  3. noname1991

    noname1991

  4. 8car

    8car

  5. nmano

    nmano

  6. crusher

    crusher

  7. ellaosx

    ellaosx

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
    • By arsradu
      Hi guys,
       
      So, this little tutorial is meant to help people fix a new issue with Mojave: opening jpg files (looks like it happens with larger files, not so much with smaller ones) using Quick Look (on spacebar key pressed) or Preview app, using the dedicated GPUs.
      The issue is that, when trying to open jpg files (for some reason, it doesn't occur with pngs), the pop-up window would remain in an endless loop. And from that point forward, any other app trying to open the same file will either become unresponsive (in the case of the Preview app) or just stay in endless loop (in case of Quick Look)
       
      As a workaround, in case the tutorial below doesn't work for you, you can use Grab (built-in app in MacOS) to open said files.
       
      This issue DOES NOT occur using the iGPU. So...if you're comfortable using the iGPU, just switch to that and you should be good to go. You don't need this tutorial.
       
      This tutorial is based on @Cyberdevs' research and testing on this topic (especially useful if you're using an RX series AMD video card), and my own very limited time testing this on my rig. I just thought it would be useful to create a new thread for it so that people can discuss this particular issue here.

       
      With that being said, I'll just move on to the actual tutorial.
       
      New (probably better) method.
       
      Switch your SMBIOS in Clover config in regards to the dedicated GPU you're using, instead of the CPU. Take a look here and choose the corresponding SMBIOS closest to your hardware.
      Yeah, that's it.
       
      In case you lose CPU PM with this method, there are multiple ways to fix that, and they do not make the object of this thread.  It worked perfectly fine for me though and I didn't need to change anything else.
       
      Alternatively, you can also try one of the MacPro SMBIOSes, such as MacPro5,1 or MacPro6,1. It was tested multiple times and it showed good results. 
      Keep in mind that choosing these will most likely not show you an iGPU in System Report, since those machines generally (probably all of them) use Xeon CPUs with no iGPUs either.
       
      /!\NOTE: There have been reports saying that using this method (switching SMBIOS to a MacPro one) with newer versions of MacOS may cause iTunes to crash.
      So...keep that in mind and better try some of the other methods mentioned here.
       
      A simple Lilu plugin
       
      Thanks to vulgo for the plugin and @Matgen84 for sharing and testing it, we now have yet another possible solution to this issue. It's a Lilu plugin (which means that it requires Lilu.kext in order to work) it's called NoVPAJpeg, and it can be downloaded from here.
      You use it as a regular kext, alongside Lilu. I prefer (and recommend) using it within the EFI folder, in Clover/kexts/Other. But if you want to use it in S/L/E, that should work just fine.
       
      More info can be found in this post here.
       
      UPDATE:
       
      According to Vulgo, NoVPAJpeg.kext is now deprecated.
      In case its functionality is needed, use WhateverGreen.kext (alongside Lilu.kext) and add the following boot arguments:
      shikigva=32 shiki-id=Mac-7BA5B2D9E42DDD94 In case you wanna try alternative medicine  ...
       
      The main thing we need to do is actually very simple: we need to enable the iGPU (integrated GPU) by default, in BIOS, while actually being connected to the dedicated GPU.
       
      For ATI GPUs (curtesy of @Cyberdevs' post here).
       
      The discreet GPU should be set as primary in BIOS and your displays should be connected to your discreet GPU
      The iGD/iGPU/iGFX must be enabled in BIOS/UEFI as the secondary GPU.
       
      I removed the DSDT Reconfigured the config.plist to and removed some flags which weren't needed because of the DSDT added the InjectATI + Ornioco Framebuffer (I removed the Orinoco framebuffer because of some weird glitches but it might be useful for other AMD GPUs if you inject the correct framebuffer according to your GPU. No need to inject anything for nVidia GPUs unless your GPU needs it) Added the InjectIntel + ig-platform-id for my intel HD530 (for intel HD 530 I use the 0x19120001 ig-platform-id)  
      Steps 5 to 7 might not be necessary I just did them anyway, if anyone succeeded to get quicklook working without those steps let me know so I can exclude those steps.

           Also confirmed to work with AMD R9 270X on a SandyBridge rig (without an iGPU) using WhateverGreen + Lilu kexts, which also helped to solve the transparency issue along with the Quick Look problem, it also resolved the buggy Screen Capture (Command+Shift+5) issue as well. 
       
          Also, do:
      nvram cleanup kextcache & prelinked kernel rebuild reboot  More info on that here.
       
       
      For NVIDIA GPUs (tested on my old MSi GTX 650)
       
      This is what I needed for my NVIDIA GPU and the MSI motherboard in the signature (*since then, I upgraded my GPU to my current RX 580). Your milage may vary, depending on your hardware. But, the idea should be the same regardless.
       
         For MSi motherboads (check out my motherboard details in the signature)
       
      Set your BIOS to use PEG (dedicated GPU) so you can boot.
      Since you're reading this, chances are that you're already connected to the dedicated GPU and the BIOS is set to PEG. So just go into BIOS and see if you're using the iGPU or the dedicated (PEG) graphics device by default.
      If you're already using this, skip to Step 3 (the part AFTER Reboot). Reboot (I think you don't necessarily need to boot into the OS...but you do need to reboot at least until Clover UI) Reboot back into BIOS and set it from PEG to IGD (integrated graphics) WITHOUT removing the cable. Save Reboot again.  
         The result should be that the OS is tricked into thinking you're booting with the IGPU when in fact you're using the dedicated GPU.
       
         For Gigabyte motherboards
       
         Set:
      Peripherals -> Initial Display Output -> iGFX Chipset -> Internal Graphics -> Enabled
           DVMT Pre-Allocation -> default 64M.
           DVMT Total Gfx Mem -> default 256M Save Reboot  
         You should do this with the cable connected to the dedicated GPU.
       
      You will also need to patch the iGPU from Clover config.
      1. Graphics -> Inject Intel (UNCHECK Inject Nvidia or ATI if it's checked).
      2. ig-platform-id (in my case for Intel HD 4600 Desktop) it was: 0x0d220003
       
      And use IntelGraphicsFixup.kext (now included into WhateverGreen.kext) in Clover/kexts/Other. In my particular case, without the kext, I would get freezes in Safari.
       
      Another way to activate the iGPU while having the dGPU set as primary is by going into BIOS/SAG/Graphics Configuration/iGPU and setting Multi-Monitor to [Enabled], all the rest remains on [Auto], and set Inject/Intel to [True] in Clover config.*.
       
      Thanks to @gjw for the tip.
       
      *Motherboard dependent. But the multi-monitor option might be the same regardless of manufacturer.
       
       
      This might be a bug with Mojave and it could be fixed by Apple in the future. but in the meantime, feel free to use this if it helps you fix the issue.
       
      For HP motherboards (including laptops), so far no solution, unless the BIOS somehow allows to switch from dGPU to iGPU and vice-versa.
       
      Cheers!
    • By Cyberdevs
      Please read me:
      Ever since macOS Mojave came out (I mean the first DP) Apple removed the support for Atheros based WiFi Adapters from the IO80211Family.kext, so to fix it we need to add the AirPortAtheros40.kext to the Extensions manually.
      After each clean install the AirPortAtheros40.kext needs to be installed and after clean installing Mojave DPs after few times I decides to create this app to save some time.
       
      How to use it:
      This application will install the missing AirPortAtheros40.kext into /System/Library/Extensions and after the installation is done and once you reboot your computer the Atheros based WiFi adapters will be enabled.
      The installation is the first step of the process and it is fast but the next steps which are repairing the permission on /System/Library/Extensions and rebuilding the system caches might take a while so please wait until you were asked to reboot your computer.
       
      I'm using a TP-Link WDN4800 with an Atheros chipset and it works on other similar hardware.
       
      If this app helped you please consider donating; any amount is appreciated.
       

       


       
    • By ludufre
      New guide available for macOS Catalina 10.15!
       
       
      Installing macOS Mojave 10.14.6 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      09/01/2019 15:57h GMT-0
      - Updated to 10.14.6.
       
      06/10/2019 00:44h GMT-0
      - Completely rewritten.
       
      10/17/2018 08:12h GMT-0
      - Fix Kexts permissions commands adjusted.
      - Removed FrameBuffer patch that is not needed.
      - Added audio solution and HDMI.
      - Unfortunately DisplayPort does not work.
      - Replaced Wifi/BT with DW1560 (BCM94352Z)
       
      10/11/2018 04:15h GMT-0
      - Added USB 3.0 patch.
      - Adjusted some steps.
      - Changed text formatting.
       
      10/11/2018 03:42h GMT-0
      - Added missing UEFI configuration.
       
      10/07/2018 00:36h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Not tested yet.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Make audio work.
      - Make HDMI audio work.
      - Test DisplayPort.
      - Make second ethernet work.
      - Replace Wifi/Bluetooth.
      - Test DP.
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover Configurator
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes. / 8 minutes with USB 3.0
       
       

      Install bootloader

      Download the CloverEFI (used 5058, from Automated Clover Builds) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended drivers (check all)
      - UEFI Drivers - Human Interface Devices (check all)
      - UEFI Drivers - FileVault 2 UEFI Drivers (check all, If you are going to use FileVault)
      - UEFI Drivers - Additional drivers - NvmExpressDxe (if you are going to use NVMe)


       
       
      Make things works
       
      We'll make a full working flash drive, so follow these instructions:
       
      Will be mounted the EFI partition of the flash drive.
       
      Open the the /Volumes/EFI/CLOVER/config.plist inside this new partition with Clover Configurator (used 5.5.0.0)
       
      Important modifications
       
      config.plist
       
      ACPI Page
       
      - Check: SSDT - PluginType
       
      BOOT Page
       
      - Add: Arguments - darkwake=2
      - Check: Legacy - XMPDetection=Yes
       
      KERNEL AND KEXT PATCHES Page
       
      - Check: KernelPm
       
      RT VARIABLES Page
       
      - Change: CsrActiveConfig - 0x3E7
       
      SMBIOS Page
       
      - Change: Macmini8,1 - Mac mini (Late 2018) | Intel Core i7-8700B @ 3.20 GHz

       
      - Click: Generate New (few times in the two buttons)

       
       
      Need some Kexts in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the HWSensors 3 from here. I used the FakeSMC.kext, ACPIMonitor.kext, ITEIT87x.kext and IntelCPUMonitor.kext inside of DMG version r240.
      - Download the Lilu.kext from here. I used the version 1.3.8.

       
      Intel UHD 630
       
      ACPI Page
      - Uncheck: Fixes - AddHDMI
      - Uncheck: Fixes - FixDisplay
      - Uncheck: Fixes - FixHDA
       
      GUI Page
      - Change: Screen Resolution - 3840x2160 (My monitor is 4K)

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the WhateverGreen.kext from here. I used the version 1.3.1.

       
      Audio ALC 1220 and HDMI audio

      BOOT Page
      - Add: Arguments - alcid=11

      DEVICES Page
      - Change: Audio - Inject - 11
      - Uncheck: Audio - AFGLowPowerState
      - Uncheck: Audio - ResetHDA

      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the AppleALC.kext from here. I used the version 1.4.0.

       
      All USBs (2.0, 3.0, Type-C, internal)
       
      KERNEL AND KEXT PATCHES Page - KextsToPatch
       
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 1 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.iokit.IOUSBHostFamily
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 2 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FB0F0F
      - Replace* [HEX]: 83FB3F0F
      - Comment: USB Port Limit Patch 3 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      - Name*: com.apple.driver.usb.AppleUSBXHCI
      - Find* [HEX]: 83FF0F0F
      - Replace* [HEX]: 83FF3F0F
      - Comment: USB Port Limit Patch 4 PMHeart/DalianSky
      - MatchOS: 10.14.x
       
      Need a Kext in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
       
      Need SSDT patch in the folder /EFI/CLOVER/ACPI/patched/
       
      - Download the SSDT-EC.aml, SSDT-UIAC.aml and SSDT-USBX attached bellow.
       
      Wifi and Bluetooth (BCM94360CS)
       
      Works out of box (plug 'n' play).
       
       
      LAN Cards
       
      Need a Kext for feach card in the folder /EFI/CLOVER/kexts/Other/
       
      - Download the IntelMausiEthrenet.kext from here. I used the version 2018-1031.
      - Download the SmallTreeIntel82576.kext attached bellow. I do not remember where I found it.

       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: Periphelrals - Initial Display to IGP
      - Change value: Periphelrals - USB Configuration - XHCI Hand-off to ENABLE
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Change value: Chipset - DVMT Pre-Allocated to 128M
      - Save & Exit Setup
       
      - Now, hold the F12
      - In the list, select your flash drive.
      - It will show twice. One with UEFI prefix and another without.
      - Select with UEFI prefix. Ie.: "UEFI: Sandisk Cruzer"
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "HD".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the EFI folder inside your destination disk EFI parittion, with EFI folder inside flash card EFI partition.

      If the flash drive EFI partition of your destination disk or flash drive is unmounted:
      Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 0 for destination disk and 1 for flash drive.
       
      Then, eject the flash drive.
       
      Last step
       
      Move all Kexts from EFI partition to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/10.14/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      Updates
       
      System update 10.14.6
       
      - Download and open latest CloverConfigurator
      - Open Mount EFI and click in Mount Partition in EFI Partitions list
      - Click in Open Partition that appears
      - Go to EFI -> CLOVER
      - Backup config.plist and ACPI folder to desktop
      - Go back and delete CLOVER folder
      (If you restart now you can't boot in macOS - DON'T RESTART)
      - Download latest Clover and install (link and config above)
      - Replace config.plist and ACPI folder from your desktop
       
      - Update Lilu.kext, AppleALC.kext, WhateverGreen.kext, HWSensors kexts (FakeSMC, ACPIMonitor, IntelCPUMonitor, ITEIT87x) in /Library/Extensions/
      - Run:
       
      sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i /  
       
      - Install macOS Update 10.14.6 and restart
       

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas and all others members involved directly or indirectly.
       
       
       
      Z370N-WIFI v2.zip
    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      Download:  https://github.com/xe97/X99-8D3-Clover
       
       
       
       
       
      Anyone else I forgot
       
       
×