Jump to content
Sascha_77

Kext Updater: Keep your Kexts fresh with only one Click

80 posts in this topic

Recommended Posts

Advertisement
On 5/29/2018 at 5:40 PM, Sascha_77 said:

You are tired searching Updates for your Kexts? With my little Tool its totally easy to have up-to-date Kexts. Simply Click "Start" and it will look if a new Version of your used Kexts is available. If there is a new Version available it will downloaded it to your Desktop and you can decide if you want to install it or not. It checks APFS and Clover too. The Database with the latest Versions available is updating every 6 Hours. Never it was more easy to be up to date. Videoder Tubemate Snaptube :D 

 

I started developing this Tool since 04/2017. You can Download it on Github

 

https://github.com/ProfDrLuigi/kextupdater/releases/latest

Because M$ bought GitHub I closed my acc there immediatley. The Repo is now on Bitbucket.

https://bitbucket.org/profdrluigi/kextupdater/downloads/

 

There are some extra Options too. Loading Webdriver, Clover or Clover Nightly Build. And now have fun. :)

 

Minimum OS for running the Updater is 10.10

 

dark.thumb.png.24a75467c50611ba1f4dfee084b22627.pnglight.thumb.png.58e93f719e64125e452bdc0bb333089f.png

 

 

Already compiled Kexts from a pre-defined location (Github, Bitbucket, Sourceforge).

Edited by surdelmavo

Share this post


Link to post
Share on other sites

The software found new kext. How can i do update old kext to the new? Sorry for the newbie question.

Share this post


Link to post
Share on other sites

Nice App

A suggestion...Place Version info in about. its where most people put it.

Share this post


Link to post
Share on other sites

Thank you for this VERY helpful tool. Please keep up the good work.

And PS it is more than "one click" however it is VERY easy to use.

Six stars of Five.

Thank you for this VERY helpful tool. Please keep up the good work.

And PS it is more than "one click" however it is VERY easy to use.

Six stars of Five.

Share this post


Link to post
Share on other sites

Thanks a lot for this tool. However, regardless of what I do, it tells me I'm not connected to the internet. Any idea why?

 

 

2019-03-28 at 9.42 AM.png

Share this post


Link to post
Share on other sites

thanks for the app

 

one question. where is downloaded the sata hotplug kext from tools?

 

is possible move to clover EFI?

 

greetings

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/29/2019 at 8:58 PM, sl1pkn07 said:

thanks for the app

 

one question. where is downloaded the sata hotplug kext from tools?

 

is possible move to clover EFI?

 

greetings

It´s the Kext from 10.13.x and it´s included in the Kext-Updater Bundle. It can´t be run out of the EFI because of dependencies.

On 4/20/2019 at 1:47 AM, gingerbread said:

I ran into a problem after updating to 2.7.7 with ClamXAV. Anybody else run into this?

 

It´s Fakealert. The KUDaemon.app has never changed since v1.6.x

Edited by Sascha_77

Share this post


Link to post
Share on other sites

I've used the app (Thanks for making it!) and I think I understand where everything goes except updating "virtualsmc" and "whatevergreen" folder in Kext-Updates.  The kexts I can place in Clover/kexts/Other but the other folders (Drivers, dSYM, Tools) and "WhateverName" app I am confused where that goes as I have no corresponding folders in my EFI.

Share this post


Link to post
Share on other sites
Posted (edited)
Very interesting, but I can't access the internet. 
I can't even install my network driver.

Can you help me?
Edited by esata

Share this post


Link to post
Share on other sites

@Hifi33

Simply ignore these Folders. They are always included. It comes from the source Repository. My Server simply collect them together and provide it unaltered through Kext Updater.

 

@esata

No sorry. Please post these Problem into the right Thread. It´s nothing KU-Related. ;)

Share this post


Link to post
Share on other sites
Posted (edited)

Damn. Try this one:

 

https://we.tl/t-dLtV2Mw33u

 

I did this now:

Quote

 

Removing the DerivedData did the trick for me.

Did it through Xcode -> Preferences -> Locations -> clicked the arrow behind the DerivedData path and removed the whole DerivedData folder in the Finder.

 

 

"Always Embed Swift Standard Libraries" is already on.

Edited by Sascha_77

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Sascha_77 said:

Nice. :D It seems the Problem is solved. Lets wait for LabyOne.

 

@LAbyOne

Works for you too?

 

 

@Sascha_77 

Indeed.

Thanks for taking time to solve this..

had immediate call for updated app, and so i did, 

Now all is fine..

issue is gone.

Edited by LAbyOne

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×