Jump to content
Sign in to follow this  
Followers 0
DEL_T

Acer Aspire V3-772G and HighSierra : still waiting for root device

5 posts in this topic

Recommended Posts

Hi guys, I tried to install a Hackintosh with High Sierra on my Laptop ACER Aspire V3 772G747a8G75M (Intel Core i7-4702MQ, Board VA73, bios Hyn, 1 SDD with Windows10, 1 HDD for data, onboard HD4600+nvidia 760M ==> attached file with full description).
I followed several tutorials (https://www.aioboot.com/en/clover-boot-disk/, yours about 772G installation).
All was good : creation of the USB Stick, downloading HighSierra image on my partition (partition HFS+ created HDD SATA in the second disk).
No pb encounted during these steps : USB OK, recognized partition, 2 hours download but ok.
But I'm struck during the final HighSierra setup in the partition : the boot on clover is ok, the OSX progress bar started and stops with a sign of prohibited direction.
With verbose mode, i can see "still waiting for root device" (difficult to read because pixelized).
Many search on forums related a USB issue but I don't understand since previous steps were ok (USB install, partition recognition and downloading).
After many and many search and tries, no way, no boot 8-(
I tried :
    - all the arguments (cpus=1 npci=x2000 -v -x -f UseKernelCache=No dart=0 nv_disable=1 USBBusFix=Yes busratio=25 PCIRootUID=0) and variation (PCIRootUID=1 and 2, npci=x3000)
    - starting with options, with kext, without kext
    - change usb2 location
    - add kext (I have these ones for the moment in the Other directory : ACPIBatteryManager.kext, AppleALC.kext, ApplePS2SmartTouchPad.kext, BCM5722D.kext, FakePCIID.kext, FakePCIID_Intel_HD_Graphics.kext, FakePCIID_Intel_HDMI_Audio.kext, FakePCIID_XHCIMux.kext, FakeSMC.kext, IntelGraphicsFixup.kext, IntelMausiEthernet.kext, Lilu.kext, NullCPUPowerManagement.kext, Shiki.kext, USB_Injector.kext, USBInjectAll.kext)
    - usbownership flag
    - Fake Id for ATI set to 0x12040000

Always the same string. Damned !!!!

I need you guys. Any idea ?
Is it because my partition is upon the HDD ans not the SSD ? because the partition is not set as active ? pb with kext version ?...
In attached file : 
- technical config
- config.plist
- Clover's report (F4 key)
- some harcopies to understand

sysconfig.HTM

config.plist

preboot.log

0-clover-menu-usb-macosx.jpg

1-clover-menu-hdd-macosx.jpg

2-clover-menu-smbios-options.jpg

3-clover-menu-general-options.jpg

4-clover-menu-boot-options.jpg

5-clover-menu-binary-options.jpg

6-clover-menu-graphics-options.jpg

7-clover-menu-cpu-options.jpg

8-clover-menu-pci-options.jpg

D-Install-The-issue.jpg

A-Install-root-device.jpg

B-Install-kexts.jpg

C-Install-Before-the-issue.jpg

Share this post


Link to post
Share on other sites
Advertisement

Hello @DEL_T, welcome to InsanelyMac.

Try using the Olarila images, it's a total vanilla install. The site is: Olarila images

The kexts that you are using it's more efficient when you have the macOS already installed.

Share this post


Link to post
Share on other sites

Thx Allan for your link. 
I tried but no way for my issue.

.... But i found the pb !!! It's just (!!!) i have to value some fakeID in the clover's options : FakeId=0x12040000 (for my hd4600)  AND set the CPU fakeID with the real value of my cpu. 

HSierra is operationnal.

Some tuning yet to do (i haven't wifi only ethernet, but i read my onboard wifi wasnt supported) and set definitively fakeIDs for a smart boot (my trials to set the gfx FakeId is not successful even if the field in the clover configurator is valued... i dont know why it s not ok, i'm poor experiencedd with plist structure... if anyone knows how to setup this field...) 

But it's great, my Mac works at last !

Thank you for all and hope my feedback could help.

 

Share this post


Link to post
Share on other sites
Guest jane15818

Oh, God, I had similar problem. :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      AppleAHCIPort.kext v328 from High Sierra PB1_17A291m.
       
      Info.plist has been edited so Bundle version is 999.1.1 ---> give higher priority loading in kernel cache/pre-linked kernel than v329 from later betas/GM. Need to disable SIP (since editing info.plist invalidates Apple's kext signature).
       
      Install in /Library/Extensions (so doesn't get over-written during updates) repair permissions, rebuild caches eg
      sudo chown -R 0:0 /Library/Extensions/AppleAHCIPort.kext && sudo chmod -R 755 /Library/Extensions/AppleAHCIPort.kext sudo touch /System/Library/Extensions && sudo kextcache -u /   Test kext is loadable...
      sudo kextutil -tn /Library/Extensions/AppleAHCIPort.kext   Confirm kext is loaded after rebooting the system...
      kextstat | grep AHCIPort   To use with a USB installer, the kext needs to be included in the prelinkedkernel. Use PLK.tool attached to post#13 to create a new prelinkedkernel with AppleAHCIPort.kext v328, then replace original prelinkedkernel in the installer - post#16.
    • By b31k
      Hello
      My system is
      Asus Z170-P Motherboard
      i5 6600K Processor
      NVIDIA GeForce GTX 1050 Ti 4095 MB
      Be-quiet 500W PSU
      Crucial 16 GB 2400 MHz DDR4

      BIOS:

      xHCI Handoff enable
      Serial Port disable
      SATA AHCI mode
      IOAPIC 24-119 Entries (enable y disable) two mode stuck

      I can not build a robust and stable system, The system Sierra is already installed but when I restart or shut down, I get the error Still waiting for root device error, but after too many reboot ( from 2 times to 9) start correctly or other times leave too minutes, with prohibited symbol and finally starts.
      Once started recognised correctly HDD.
      Also I tried with a new  EVO860 nvme SSD , but I have the same problem.
       
       
      I dont know because sometimes yes sometimes no, the system stuck in this error
      I add some information files and logs.
       
      sudo touch /System/Library/Extensions && sudo kextcache -u /
      kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext HackrNVMeFamily-10_12_6.kext
      kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
      kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmPatchRAM2.kext
      kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmFirmwareRepo.kext
        thank you.


       
      Solution by Rehabman;

      Extracting my native/clean DSDT using Clover F4.
      and check with diff DSDT file.

      My SystemMemory addresses in DSDT are mismatched:

      SPEEDY-NUCatched rehabman$ diff ../origin/ ../patched/|grep SystemMemory
      < OperationRegion (GNVS, SystemMemory, 0xC74EC000, 0x06D5)
      > OperationRegion (GNVS, SystemMemory, 0xC74FE000, 0x06D5)
      < OperationRegion (CPSB, SystemMemory, 0xC6CC0F98, 0x10)
      > OperationRegion (CPSB, SystemMemory, 0xC6CD2F98, 0x10)

      and other mistake in OperationRegion(PNVA,SystemMemory,PNVB,PNVL)

      < Name (PNVB, 0xC74F1018)
      > Name(PNVB,0xC7503018)

      My system after too many month , keep stable the still waiting error no appear again, it seems that the problem was with the memory addresses in my DSDT.
    • By TheCoolGuy
      So i'm trying to install OSX 10.4 Tiger (patched for intel cpus) on a 9 year old laptop, so far i've burnt a DVD and tried to boot from it, when not starting with -v it loads and then a prohibited sign shows up, and when starting with -v it keeps saying "still waiting for root device", i've tried multipile fixes and none of them work, and im sure there isnt a problem with the computer as it also fails to boot on my core 2 duo machine, so is it possible one of you guys knows how to fix this? Thanks in advance!
    • By Bruno49
      Salve, sono passato da Yosemite ad El Capitan, dopo aver installato quest'ultimo sul PC in firma con il bootloader chameleon, tutto funziona correttamente: scheda grafica, rete ed audio, usb etc.. tutto ok, l'unico problema è che quando avvio il pc senza la USB di installazione, quindi direttamente da HD dove ho installato El Capitan, dopo diverse righe con AppleUSBEHCIPort@fd300000..... il pc si blocca su : still waiting for root device. Quindi sono costretto ad avviare sempre dalla USB.
      Qualcuno può' aiutarmi per piacere? 
    • By iStigPL
      This topic is to gather all information about "still waiting for root device" in one place.
       
      Few days ago I wrote about running El Capitan on the Skylake rig
      http://www.insanelymac.com/forum/topic/308576-success-el-capitan-build-15b30a-on-skylake-i7-6700-with-some-bugs/?p=2184344
       
       
      I passed all information to Pike R. Alpha, so hope he and others find the solution for everybody:
      The most intresting thing is some bios option called "IOAPIC 24-119 Entries" which is enabled by default. 
       

       
       
      You have to disable it to forget about "still waiting for root device" :-)
       
      Why this option is intresting ? it and the other 3 options are not avaible in the newest bios version. I've allready checked all versions and it is avaible in: 0701, 0801, 0902. The newest version 0907 is missing it:
       

          Dumping ACPI gives nothing - the tables look the same with and without that option enable. If someone want to look at it, here it is: https://dl.dropboxusercontent.com/u/40896256/Hackintosh/MB/Asus/Maximus%20VIII%20Gene/Archiwum.zip
×