Jump to content
Te0

Dell Inspiron 5567

16 posts in this topic

Recommended Posts

Ciao a tutti,

 

Ho acquistato il notebook come da titolo con le seguenti caratteristiche:

CPU i5 7200U

GPU HD620 / R7 M445

WiFi: verrá sostituita con BCM943602BAED

8GB RAM

 

Mi sono documentato prima di scrivere, per quanto possibile, purtroppo la funzione "search" del forum pare essere ancora parzialmente funzionante, forse a causa del recente upgrade.

Non si trovano purtroppo delle vere e proprie guide, soprattutto per HighSierra, ma leggo di gente che è riuscita nell'hack.

In realta il portatile ancora non mi è arrivato, ma cercavo di prepararmi al meglio e di "studiare" come siamo abituati a fare per i vari hackintosh.

Le info che non sono riuscito a trovare sono come risolvere il problema del DVMT-prealloc specificatamente per questa macchina e l'eventuale patching DDST/SSDT.

 

Ringrazio in anticipo.

 

 

Share this post


Link to post
Share on other sites
Advertisement

O trovi la guida specifica per il tuo laptop oppure il procedimento è sempre quello, guida di gengik per l'installazione, config scarno con SMBIOS e grafica settati per il proprio hardware. Poi la post installazione foto ad hoc per tutti i device.

Share this post


Link to post
Share on other sites

Buongiorno,

 

sono riuscito a far funzionare audio (ALC256), video (HD620, disattivando la AMD R7 + patch DVMT), Ethernet (driver RTL8100 2.0.0), WiFi attendo l'arrivo della scheda da sostituire.

Quello che non riesco a risolvere è un problema con il monitor.

Nel momento in cui tolgo l'alimentazione e vado con la batteria, dopo qualche minuto, lo schermo vá in standby e al "risveglio" metá schermo è glitchato.

Ho seguito alcune guide per cercare di gestire l' EDID ma non sono riuscito...

 

Vi allego i report come da guida,

Grazie

 

 

HackInfo_Report.zip

IORegistry.zip

screen1.png

screen2.png

Share this post


Link to post
Share on other sites
1 hour ago, MARZILLO said:

visto questa?

 

https://www.macos86.it/viewtopic.php?f=42&t=38

per la scheda wifi che deve arrivare sicuramente è uguale alla mia...

bluetooth con bcrmpatchram e wifi con toleda arp

https://www.macos86.it/viewtopic.php?f=13&t=66

Marzillo,

 

avevo guardato diverse guide in altri siti/forum incluso questo. 

La guida che mi hai linkato oltre ad essere semplice, ha pure risolto!. Grazie mille.

 

Il driver RTL8100 v2.00 funziona ma viene interrotto dallo sleep/wake del portatile oppure se viene scollegato l'alimentatore. Qualcuno ha risolto con la versione v1.00 che stó testando...

 

Per la parte Power Management, con il solo ssdtPRGen e l' HWPEnable potrei essere apposto?

 

Per il SSDT/DSDT Patching conoscete delle guide alternative?  Ho provato con quelle di Rehabman, di solito riesco a seguirle, ma questa del patching proprio no.

 

 

Share this post


Link to post
Share on other sites

per la guida credit all'ottimo  jolly...:lol:

per il power management in genere con la creazione del ssdt si è a posto...puoi utilizzare per l'occasione ssdt automator dell'ottimo gengik..ti posto il link perche non riesco ad allegare

https://www.macos86.it/MacOS86_Downloads/?path=Applicazioni/Script/Power_Management

le guide di rehab sono ottime ma essendo un capoccione non le capisco totalmente

per saperne di piu

https://www.macos86.it/viewtopic.php?f=42&t=57

Share this post


Link to post
Share on other sites
17 minutes ago, MARZILLO said:

per la guida credit all'ottimo  jolly...:lol:

per il power management in genere con la creazione del ssdt si è a posto...puoi utilizzare per l'occasione ssdt automator dell'ottimo gengik..ti posto il link perche non riesco ad allegare

https://www.macos86.it/MacOS86_Downloads/?path=Applicazioni/Script/Power_Management

le guide di rehab sono ottime ma essendo un capoccione non le capisco totalmente

per saperne di piu

https://www.macos86.it/viewtopic.php?f=42&t=57

Ottima app non la conoscevo; a questo punto sono obbligato ad iscrivermi al sito :D

 

Leggevo che con Skylake / Kaby Lake è sufficiente "PluginType"  in Clover/SSDT; 

con SSDT Automator V2 credo di aver ottenuto lo stesso risultato, mi fido comunque di piú ad avere l' SSDT.aml dento la EFI, spero di non sbagliare. (fá qualcosa in piú rispetto a ssdtPRGen liscio??!)

Share this post


Link to post
Share on other sites

fanno la stessa cosa.l'app è piu semplice...

se ti iscrivi puoi fare le stesse domande a gengik il quale sicuramente sarà più esaustivo

Share this post


Link to post
Share on other sites
6 hours ago, MARZILLO said:

visto questa?

 

https://www.macos86.it/viewtopic.php?f=42&t=38

per la scheda wifi che deve arrivare sicuramente è uguale alla mia...

bluetooth con bcrmpatchram e wifi con toleda arp

https://www.macos86.it/viewtopic.php?f=13&t=66

 

Stavo cercando in rete, Toleda arpt sembra non piu funzionante.

Per la scheda WiFi BCM943602BAED potrebbe essere sufficiente??:

 

FakePCIID.kext

FacePCIID_Broadcom_WiFi.kext

BrcmPatchRam2.kext

BrcmFirmwareRepo.kext

 

Grazie e scusami per le troppe domande...

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Scusate se riesumo questo topic,

 

ma contiene già le informazioni sul notebook...

 

Ho aggiornato a 10.13.5, tutto ok apparte la gpu HD620 che manda in KP il notebook (causato da AppleIntelKBLGraphicsFramebuffer.kext, pare)

 

Ho già provato a fare il boot con id volutamente non corretto, fatta la rebuild della cache e avviato con id corretto ma continua a non avviarsi andando in KP.

 

Avete consigli?

Edited by Te0

Share this post


Link to post
Share on other sites
Posted (edited)

Si, scusa, Clover aggiornato alla 4531 e tutti i kext aggiornati (incluso Lilu e plugin intel)

 

Riesco a fare boot solo con l'id scorretto, ovviamente con problemi video e senza accelerazione.

Edited by Te0

Share this post


Link to post
Share on other sites

ho trovato diversi post con il tuo caso risolti sempre con l'avvio tramite falso id e ricostruzione della cache

 

sudo rm -f /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache && sudo touch /System/Library/Extensions && sudo kextcache -u /

 

una volta fatto togli id fasullo mettendo quello giusto e riavvio

Share this post


Link to post
Share on other sites
Posted (edited)

Niente da fare... ho provato pure a ripartire dai config di base di Rehabman per la hd620 ma niente.

 

Provo ad aspettare se nei prossimi giorni uscisse un aggiornamento di Lilu, IntelGraphicsDVMTFixup...

 

Potrebbe essere necessario una nuova patch per il DVMT?? 

 

Risolto... spostati Lilu e i plugins in /L /E.  Boot con platform id non corretto e rebuild kext cache.

 

Non capisco come abbia fatto a funzionare fino alla 10.13.4...

 

Grazie

 

Edited by Te0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×