Jump to content
bilbo

[Guide 2018] Z820 - SIERRA, The great guide (Sucess)

197 posts in this topic

Recommended Posts

Hi guys!!! Again sorry for my absence. I have been insanely busy these months for more developing for our hackintosh machines. I didn't have any special answer to contribute in last pages of problems and issues in this thread, either.

 

Just to say , After the release of the final update, I´m testing the update to high Sierra. and good news, everything is going well :) . I just left test PM, and I would say we can jump to High Sierra coming soon. The good news is the 95% of the Sierra´s guide is still working. Only update the version of kexts and apps is needed. If all is OK in my tests,  I'll start to write the new guide next week, which will be a big copy / paste. :thumbsup_anim:

 

 

 

Regards

Share this post


Link to post
Share on other sites
Advertisement

PS. Amadeusex, I bet that you problem is related with your dsdt. Remind, the dsdt file is a translation of your BIOS into a file. If you change the bios version, you should extract and patch a new dsdt file. I had your problem when I update from an old bios version, years ago... different dsdt, different patches..etc

 

I ask for dsdt files from different bios version, and some users sent them to me. As I could check. the differences between some version are slightly , for instance among 3.86 , 3,90, 3,91 . Maybe last updates , with lasts security updates, will be more different , and a new extract and patching way will be required. I don't plain update the bios. " If it works, don't touch anything". 

Edited by bilbo

Share this post


Link to post
Share on other sites
On 9/15/2018 at 11:04 AM, Dr Droid said:

When I issue a shutdown in OSX (to turn off the computer purposely), the Z820 shuts down fully, but then turns back on again, and boot up. Do you guys have this issue? Could it be the BIOS setting. I looked all over.

I got this problem as well and I fixed this with "FixShutDown" variable on Acpi page of Clover Configurator.

On 9/4/2018 at 3:06 PM, antonio.clb said:

Hello!

My actual setup is really similar to your desired one: Z620, 2 x E5-2670 (v1), High Sierra (installed from scratch), NVMe SSD on a PCIe adapter (960 Pro 512 GB) and a SATA HDD (WD Black 3 TB) for slow datsa storage.

The trick is to install Clover on the SATA HDD and let it boot from there.

Here's a list of my CLOVER folder with drivers and kext expanded:

image.thumb.png.e6a55e697b04b159f9caccac4c781a83.png

 

Just follow this guide and you'll be able to install High Sierra without problems, IMHO reinstalling from scratch is the best solution for a major macOS upgrade. As always, be careful with updates!

I've noticed that, in case of BSOD on boot after an update (e.g. 10.13.5 to 10.13.6), I have to drop the generated SSDT during boot (losing PM) and recreate it.

 

Happy Hackintoshing!

AC

Thank you so much.

But is it possible to boot from NVMe SSD on a PCIe adapter.

On 9/16/2018 at 8:06 AM, bilbo said:

Hi guys!!! Again sorry for my absence. I have been insanely busy these months for more developing for our hackintosh machines. I didn't have any special answer to contribute in last pages of problems and issues in this thread, either.

 

Just to say , After the release of the final update, I´m testing the update to high Sierra. and good news, everything is going well :) . I just left test PM, and I would say we can jump to High Sierra coming soon. The good news is the 95% of the Sierra´s guide is still working. Only update the version of kexts and apps is needed. If all is OK in my tests,  I'll start to write the new guide next week, which will be a big copy / paste. :thumbsup_anim:

 

 

 

Regards

glad to hear this news. :thumbsup_anim:

Share this post


Link to post
Share on other sites
13 minutes ago, ho520726 said:

But is it possible to boot from NVMe SSD on a PCIe adapter. 

HP Zx20 cannot "see" the NVMe disk natively, only SATA/SAS disks. Therefore you've to put Clover on a SATA/SAS disk that's visible at boot time.

 

Best regards.

Share this post


Link to post
Share on other sites
2 hours ago, antonio.clb said:

HP Zx20 cannot "see" the NVMe disk natively, only SATA/SAS disks. Therefore you've to put Clover on a SATA/SAS disk that's visible at boot time.

 

Best regards.

Yes, you are right. I also found some article about using NVMe disk.

The result shows that only pro 950 work as expected with full speed and can be booted from it as well.

But also one can install pro 960 as boot drive but the speed not work as expected.

 

https://h30434.www3.hp.com/t5/Business-PCs-Workstations-and-Point-of-Sale-Systems/Does-someone-know-is-Samsung-Pro-960-M-2-NVMe-Compatible/td-p/6017694/page/2

 

https://h30434.www3.hp.com/t5/Business-PCs-Workstations-and-Point-of-Sale-Systems/NVMe-PCIe-SSD-boot-support-in-Z820/td-p/6378530

 

The reason of lower speed of pro 960 seems caused by the driver, and pro 950 is designed to work with older system.

 

 

 

Share this post


Link to post
Share on other sites
On 9/16/2018 at 3:17 AM, bilbo said:

PS. Amadeusex, I bet that you problem is related with your dsdt. Remind, the dsdt file is a translation of your BIOS into a file. If you change the bios version, you should extract and patch a new dsdt file. I had your problem when I update from an old bios version, years ago... different dsdt, different patches..etc

 

I ask for dsdt files from different bios version, and some users sent them to me. As I could check. the differences between some version are slightly , for instance among 3.86 , 3,90, 3,91 . Maybe last updates , with lasts security updates, will be more different , and a new extract and patching way will be required. I don't plain update the bios. " If it works, don't touch anything". 

 

I get that and for sure the bios update is to blame.

 

The voodoo part is that after the bios downgrade my original HDD installation did work just fine but the SSD did not.

 

Same efi folder, kexts, info.plist etc.

 

After cloning the HDD to the SSD everything worked allright.

 

To some extent all that is fun also, but sometimes it just is a pain in the ass that makes you to take a hammer and smash all to pieces hahahaha :)

 

All works fine again - thanks to Your effort in the first place of course :)

 

 

 

Share this post


Link to post
Share on other sites

Hi. Which kext install utility for High Sierra are you using? I'm not sure if the classic apps works 100% in high sierra. I'm having troubles to install kexts.

 

thanks

Share this post


Link to post
Share on other sites
7 hours ago, bilbo said:

Hi. Which kext install utility for High Sierra are you using? I'm not sure if the classic apps works 100% in high sierra. I'm having troubles to install kexts.

 

thanks

Hello Bilbo!

I'm on 10.13.6 right now and always used "Kext Wizard" for flawless kext installing.

 

Thanks for your precious work and best regards!

AC

Share this post


Link to post
Share on other sites
On 9/21/2018 at 8:26 AM, antonio.clb said:

Hello Bilbo!

I'm on 10.13.6 right now and always used "Kext Wizard" for flawless kext installing.

 

Thanks for your precious work and best regards!

AC

Hello Antonio!

I have a Z620 with 2xE5-2670 also :).

2 questions:

1- Did you install a wifi card, and if so which one?

2- Did you get your PM working?

It would be great to compare our files and settings...

Thank you!

Olivier

Share this post


Link to post
Share on other sites
44 minutes ago, oliveg said:

Hello Antonio!

I have a Z620 with 2xE5-2670 also :).

2 questions:

1- Did you install a wifi card, and if so which one?

2- Did you get your PM working?

It would be great to compare our files and settings...

Thank you!

Olivier

Hello Olivier!

I've no wi-fi card hooked on the Z620 but, from a quick Google search, looks like TP-Link Archer T8e and T9E should be 100% macOS compatible.

My PM works well with CPU clock changing between 1.2 and 3.3 GHz responsively: you can find a copy of my actual Clover folder in THIS POST.

 

Let us know about your progress in this hackintosh adventure!

 

Best regards.

AC

Share this post


Link to post
Share on other sites
6 hours ago, antonio.clb said:

Hello Olivier!

I've no wi-fi card hooked on the Z620 but, from a quick Google search, looks like TP-Link Archer T8e and T9E should be 100% macOS compatible.

My PM works well with CPU clock changing between 1.2 and 3.3 GHz responsively: you can find a copy of my actual Clover folder in THIS POST.

 

Let us know about your progress in this hackintosh adventure!

 

Best regards.

AC

Dear Antonio,

I've just replaced my CLOVER folder with yours (I kept my kexts since I'm running 10.12.6), and I got a KP on restart: "Impossible to generate P-States on this system"... Any idea?

Thank you :wink_anim:

Share this post


Link to post
Share on other sites
1 hour ago, oliveg said:

Dear Antonio,

I've just replaced my CLOVER folder with yours (I kept my kexts since I'm running 10.12.6), and I got a KP on restart: "Impossible to generate P-States on this system"... Any idea?

Thank you :wink_anim:

 

I really think you should follow bilbo's procedure to create your own SSDT/DSTD and patch necessary system kexts.

I usually do the following steps (from my own notes):

 

1) sudo perl AICPMPatch.pl /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement --patch
2) sudo ./10.13\ aicpm\ patch.command
3) insert MacMini StepContextDict:
macmini6,2 StepContextDict is here:
/System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-F65AE981FFA204ED.plist
and you should insert it here (I use to tag this file with a color to see if it changes after a system update):
/System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-F60DEB81FF30ACF6.plist

4) copy APIC.aml e SSDT-1-CpuDef.aml renaming it in DSDT.aml on Desktop (dump it with F4 on Clover while booting)
5) recompile DSDT.AML fixing various problems as per bilbo's guide (patch 1, 2 and 3)
6) install compiled DSDT.aml on CLOVER/ACPI/patched folder
7) download Pike's ssdtPRGen:
curl -o ./ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/Beta/ssdtPRGen.sh
8) ./ssdtPRGen.sh -p 'E5-2670' -c 3 -x 1 -target 0 -cpus 2 -l 32 -mode custom -d 3
   ./ssdtPRGen.sh -cpus 2 -p 'E5-2670' -x 1 -target 0 -turbo 3300 -c 3 -cpus 2 -l 32 -mode custom -d 3
9) install generated SSDT.aml on CLOVER/ACPI/patched folder
10) Install X79PlatformPlugin.kext in /System/Library/Extensions/
11) sudo ./InsanelyRepairPermission -r /Volumes/macOS\ SSD

If you experience boot problems, drop SSDT.AML on Clover boot screen

 

Hope this helps, best regards!
AC

Share this post


Link to post
Share on other sites

Hi people!

 

Does anyone have high sierra in Hp Z820 with PM working? .... I have almost complete the new how-to for High Sierra , except PM. I don't have any error patching everything, but simply... PM doesn't work. I have figure out that the Legacy ACPI CPU tables  (in bios) enabled avoid PM. This option is now mandatory to boot High Sierra, but as I said, avoid PM.

 

I have checked it because in Sierra, where this option is not important for boot, PM only works when this option is disabled in BIOS. This is a {censored}-de-sac :wacko: .

 

 

Share this post


Link to post
Share on other sites
9 hours ago, bilbo said:

Hi people!

 

Does anyone have high sierra in Hp Z820 with PM working? .... I have almost complete the new how-to for High Sierra , except PM. I don't have any error patching everything, but simply... PM doesn't work. I have figure out that the Legacy ACPI CPU tables  (in bios) enabled avoid PM. This option is now mandatory to boot High Sierra, but as I said, avoid PM.

 

I have checked it because in Sierra, where this option is not important for boot, PM only works when this option is disabled in BIOS. This is a {censored}-de-sac :wacko: .

 

 

Dear bilbo,

  could you please elaborate a bit more what you mean saying "PM working"? If you mean CPU frequency bouncing from low to high values (not stuck at CPU's stock speed), temperatures and power consumption rising and lowering according to CPU usage like the following HWMonitor screenshot (I've made some light work and closed all opened programs during this log) , I can say my Z620 (not Z820 sorry!) is working well on High Sierra 10.13.6!

Please, don't hesitate to contact me if you need further informations, it would be an honor if I can contribute to your guide and maybe we can reach to have Mojave too on our Zx20 workstations!

 

Thanks a lot for your hard work which allowed me to build my little beast!

Best regards.

AC

 

image.thumb.png.eca500c36abd460d4ba2b2c79381c8f3.png

Share this post


Link to post
Share on other sites

Yes. I meant power management.

Do you have “Legacy acpi cpu tables” in your bios, and is it activated? If you do, did you need enable it to install Highsierra?

Share this post


Link to post
Share on other sites
11 minutes ago, bilbo said:

Yes. I meant power management.

Do you have “Legacy acpi cpu tables” in your bios, and is it activated? If you do, did you need enable it to install Highsierra?

photo_2018-09-24_10-31-46.thumb.jpg.c4b92214289d17097085100d695b828a.jpg

 

Yes bilbo, looks like "Legacy ACPI CPU Tables" is mandatory for 10.13.x: I've tried to disable it and get the following KP at boot:

photo_2018-09-24_10-31-48.thumb.jpg.20de49050bcbb7c0ab8cf19c2bf79c28.jpg

 

During HS installation, I've followed THESE TIPS.

 

Best regards.

AC

Share this post


Link to post
Share on other sites

Today Apple release Mojave. For those interested in High Sierra, take advantge and download the dmg. Maybe in few hours , (depending oy your hour zone) apple will retire High Sierra from Apple store. Maybe they provide of an alternative link, as with Sierra, or maybe not ... Who knows.

 

Fly, you fools !!! :lol:

 

 

Share this post


Link to post
Share on other sites
1 minute ago, bilbo said:

Today Apple release Mojave. For those interested in High Sierra, take advantge and download the dmg. Maybe in few hours , (depending oy your hour zone) apple will retire High Sierra from Apple store. Maybe they provide of an alternative link, as with Sierra, or maybe not ... Who knows. 

 

Fly, you fools !!! :lol:

 

 

 

Share this post


Link to post
Share on other sites

Ok, Problem solved. PM working in High Sierra :rofl::rolleyes:

 

A brief resume.

 

High Sierra needs activate "Legacy acpi cpu tables" . Yes or Yes.

With this option , and our ssdt from previous version, PM doesn't work

 

Sierra doesn't mind if this option is enable or disable. I had this option disabled, so my SSDT created on days of Sierra setup, was created with this option disabled. But , testing High Sierra, with with I booted with Sierra HD, PM was gone.

 

I have read how bios with different options activated could generate different ACPI tables (ssdt, dsdt, etc) , so I decided extracting compare the api tables again with this option enabled. And bingo, dsdt doesn't change, but the ssdt -def , is completely different. It has a different structure. The fix, is obvious. Generate a new SSDT with pikes script.

 

And , et voilá, PM working on High Sierra. And in Sierra, with same ssdt, sure. 

 

 

Edited by bilbo

Share this post


Link to post
Share on other sites

Very Nice !!

 

Installed Sierra 10.12.6 Succssfully on my HP Z820 following this guide.

 

I'd like to try now the new Mojave 10.14

 

Could someone give some advice on installing Mojave 10.14 on HP Z820 - if I could still follow this guide and what should be the most important differences to consider or the best way to start ?

 

Being really new to hackintoshing

Edited by murdoc034

Share this post


Link to post
Share on other sites

if any of u guys want to give a try macos Mojave, nvidia GTX 670 is the best choice work out of box  no need any web drivers

Share this post


Link to post
Share on other sites
2 minutes ago, Rockey12 said:

if any of u guys want to give a try macos Mojave, nvidia GTX 670 is the best choice work out of box  no need any web drivers

Most of Kepler based cards should work fine 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By amadeusex
      Hi there y' all.
       
      I'm selling my hp z820 with the specs listed below since i accidentally bought me another one (that's what i told to my wife anyway).
       
      The machine runs flawlessly High High Sierra 10.13.6 and also has Win7 pro and Win10 pro licences tied to the machine.
       
      The machine is in Athens Greece
       
      I'm asking for 850 euros shipped within the European Union.
       
            Features     • Make: HP • Modell: Workstation Z820   • Processor: 2x Intel XEON Quad-Core E5-2670 • Chipset: Intel C602    • Memory: 64 GB ECC RAM • Sound: Realtek ALC262   • Graphics Card: nVidia Quadro K600   • SAS - Controller: LSI SAS2308 with RAID (0, 1, 5, 10) • SSD - 256 GB • DVD RW   • 2x Ethernet-LAN (RJ-45): 2 (Dual Gigabit - 1000Mbit/s)   • FireWire: 2x (1x Front + 1x Back) • USB 2.0: 5x (1x Front + 4x Back) • USB 3.0: 4x (2x Front + 2x Back)   • PS/2 • serial RS232 • Line-In • Line-Out • Microphone • FireWire (6polig)    • PSU: 1125 Watt    • (WxHxD): 203mm x 444mm x 525mm • Weight: 21,1kg   The machine is configured to also run MacOS 10.12.6 High Sierra without any hiccups and complete working power management.   Geekbench 4 64-bit  MacOs Results
      https://browser.geekbench.com/v4/cpu/12062123
      Geekbench 4 64-bit  Win10 Results
      https://browser.geekbench.com/v4/cpu/11972736
      The pictured drive trays are not included - the original placeholders will be mounted!


    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By JackBauer24
      Hello,
       
      I have installed OSx86 10.11 (El Capitan) on April 2016 on my Asus Z170 Deluxe system.
       
      For installation I used this Thread.
       
      I used it a lot and it worked well. Meanwhile I switched to Linux and I use Win10 time to time. So OSX was forgotten. Also it did not boot correctly anymore.
       
      Now I wanted to start with a fresh installation and use OSX more often again. I want to use OSX 10.13 High Sierra. Is it working on my Asus Z170 Deluxe? I have the same Hardware as of April 2016 only the graphics card was updated to a Nvidia GTX1080.
       
      My Hardware in detail: Asus Z-170-Deluxe (Bios 3801), i7-6700k, EVGA GeForce GTX 1080 SC GAMING ACX 3.0, Samsung 950 Pro/M2 NVME 512MB, HDD 4 TB)
      Can I use some of support files from the old thread for the installation (see attachment)? Can I still use  Clover 2.3k r3292 Special Edition v2 ? Or do I need a newer version?
       
      Has someone installed High Sierra successfully on the Asus Z170 Deluxe ?
       
      About some hints where to start I would be thankful.
       
      regards
      JackBauer24
       
      Z170DeluxeFiles.zip
    • By t0mmenhansen
      I havent used my hackintosh in a while. I wanted to boot to my mac drive. This error comes up when i try to boot. Ive tryed using explorer++ and update the lilu kext and whatevergreen kext, no luck yet. Any ideas?
       
      9700k
      16GB corsair
      1080 nvidia card
      z370-f mobo
      mac drive is an SSD from kingston
      Display port outpoot
       
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        Mojave Full DSDT patch   http://olarila.com/forum/viewtopic.php?f=59&amp;t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×