Jump to content
bilbo

[Guide 2018] Z820 - SIERRA, The great guide (Sucess)

184 posts in this topic

Recommended Posts

Advertisement
8 hours ago, bilbo said:

Well , after this week with the site down,  let's go back with our bussiness.... ^_^

 

Yessss .. good news . :)

I was about to throw all away, and really sad thinking in my options , when reading some advice and some thing in HP forums, I decided do "jumper crisis" method: I thought that it's not useful in my case, but anyway,  I tried, and... bingo... the motherboard resurrected miraculously. It seems that the guilty was my raid pci card (lsi 9260): When the motherboard died, I was changing the graphic card and to do that, I have to unplug the lsi card too. Somehow, the card blocked the motherboard.

After do jumper crisis - method,  and the resurrection , trying to plugin the card again, I get an obscure "PCI ERROR on slot 1"  bios screen. So I decided throw the card to the garbage. Without it, the z820 boots normally. I passed all hardware test with the z820 utilities. More than 12 hours. The hardware seems ok. I bought a lsi card a few days ago.

I'm still testing , just in case, but everything seems ok.  It has been in a big scare

btw, crisis  recovery  jumper is not described in any official documentation. Only the threat linked above and even in that thread there is no any official answer  . HP is an absurd company.

hey hey hey !!  nice one .. glad to hear it all came good, didnt sound good for a bit there ... well done with the peristance and the ressurection !!

Share this post


Link to post
Share on other sites

on an off topic note, whats with this bizzare quoting and replying system on this new site.. previous qoute responed to the main thread or something .. sigh ...

Share this post


Link to post
Share on other sites

Hello to everybody and thanks for this great guide!

I was able to run Sierra on my Z620 with dual CPU (Sandy Bridge) and now, after a bit of struggling due to InsanelyMac's downtime, I'm writing from my brand new High Sierra 10.13.3 installation!

High-Sierra-20180312.png.feaa2c6b0747979def2e17221cc12265.png

Right now I've managed to install thanks to another source of information, this one:

https://github.com/NTT123/Hackintosh-HP-Z420-MacOS-High-Sierra-10.13

but I'd like to refine it a bit following bilbo's guide...

Anyone could please re-share bilbo's ZIP file? I can't manage to download (0 byte archive).

Edited by antonio.clb

Share this post


Link to post
Share on other sites

re-uploaded

 

The new forum is a little unstable. It's an external link for the moment.

 

Btw, I forget thank to all people who message me by pm, with suggestions and advices ;)

Edited by bilbo

Share this post


Link to post
Share on other sites

Thanks a lot bilbo!

I confirm that, on my Z620, USB 3.0 ports are now working like a charm with your mXHCD.kext (no USB 3.0 show in system profiler but maybe it's a matter of those cosmetic fixes...)!

I'll try to optimize and summarize my settings and share them with the community in the next few days.

For now, I can tell you that audio is working really good with VoodooHDA.kext.

Thanks again for your

Share this post


Link to post
Share on other sites
1 minute ago, bilbo said:

Sorry Antonio, but is your guide for 10.12 or 10.13 ? I find your guide and your clover folder a little confused. ;)

The original guide is for 10.12 but, on top of the page, you can notice a folder named "10.13.2" that contains a Clover configuration suitable for the installation of High Sierra 10.13.3:

  1. created USB installer (I've used and old HDD attached to a USB 3.1 dock plugged, of course, in the USB 2.0 front connector of my Z620);
  2. installed Clover on this drive;
  3. copied the whole "CLOVER" folder fron the "10.13.2" folder of NTT's GitHub page;
  4. activate "Legacy ACPI CPU Tables" in BIOS (important!)
  5. installed High Sierra!

Then I've made a couple of steps from your old guide to enable MacPro 6,1 SMBIOS, PM and so on. Also installed NVIDIA web drivers.

I'll be glad to give you further details and my full configuration in a couple of days: busy at work right now, sorry!

Share this post


Link to post
Share on other sites

BTW, AppleALC was updated to ver. 1.2.3:

Quote

v1.2.3
•    Added alcid=layout boot argument for testing purposes
•    Added automatic rename for HDEF device
•    Added ALC255 layout-id 18 for Aorus X5V7 by DuNe
•    Change Platforms18.xml.zlib for ALC255 by DuNe
•    Added ALC898 layout-id 101 by Andrey1970 (4 Line Out)
•    Added ALC262 layout-id 28 for HP Z800-Z600 series by MacPeet
•    Added ALC225 layout-id 33 by ChalesYu
•    Added ALC282 layout-id 127 No input boost Acer Aspire on IvyBridge by Andrey1970
•    Added ALC294 layout-id 13 by InsanelyDeepak
•    Added IDT92HD91BXX layout-id 13 for HP Envy 6 1171-SG by MacPeet

I have replaced version from Bilbo’s pack with new one and remove CodecCommander.kext
Seems like everything is OK. Test passed ;) 

Share this post


Link to post
Share on other sites

yeap.. 1.2.3 compiled has been released... great!! 

Surprising for me that codeccommander in not needed. thanks shamman, I'll update the guide.

Share this post


Link to post
Share on other sites

oh yes, of course. When I made the guide, I though and thought about how the guide could be show the process. I decided that is better that people understand the complete process, the nature of the fixes. The quick guides , drag and replace-style, tend to give misunderstandings.

Understanding the complete process, maybe after follow the guide at least once, everybody can make it shorter. Almost in a single step, using the right version of config, dsdt, and kexts files after the first boot. That is because I included into the stuff, one final folder called FINAL STEP :) . (This doesn't include PM process). After installation, only replacing files, it can take only a few minutes to complete the guide. 

 

Share this post


Link to post
Share on other sites
On 3/15/2018 at 1:12 AM, bilbo said:

 I decided that is better that people understand the complete process, the nature of the fixes. The quick guides , drag and replace-style, tend to give misunderstandings.

Yes, I finished my own Sierra last Summer. Follow your El Capitan guides :rolleyes:

Yes, I'm not using z820 :thumbsup_anim:

I tried High Sierra recently, it still very difficult. :( 

 

Edited by wham17wham

Share this post


Link to post
Share on other sites

Thanks for bilbo. I successfully transfer from 10.11 to 10.12 with dual E5-2670 v1 and bios 3.91. 

But I got a problem which is I can't really shutdown my computer. It is always restart instead of shut down. Anyone know how to fix this minor problem.

I just directly use the file(06 CLOVER FINAL -NO-PM) provided from billbo. Of course, I fixed PM later.

Share this post


Link to post
Share on other sites
On 17/3/2018 at 9:59 PM, ho520726 said:

Thanks for bilbo. I successfully transfer from 10.11 to 10.12 with dual E5-2670 v1 and bios 3.91. 

But I got a problem which is I can't really shutdown my computer. It is always restart instead of shut down. Anyone know how to fix this minor problem.

I just directly use the file(06 CLOVER FINAL -NO-PM) provided from billbo. Of course, I fixed PM later.

Same problem here with my Z620 on High Sierra: reboot or shutdown fail with a "929-Fatal MCA error". Pressing F1 will continue the boot process.

Share this post


Link to post
Share on other sites

 :huh: no idea. I don't have any problem with shutdown , even in the early process, at first boot, without patches. Are you using your own dsdt patched, or you are using mine?

Share this post


Link to post
Share on other sites
On 3/17/2018 at 10:59 PM, ho520726 said:

Thanks for bilbo. I successfully transfer from 10.11 to 10.12 with dual E5-2670 v1 and bios 3.91. 

But I got a problem which is I can't really shutdown my computer. It is always restart instead of shut down. Anyone know how to fix this minor problem.

I just directly use the file(06 CLOVER FINAL -NO-PM) provided from billbo. Of course, I fixed PM later.

Here's my Siera EFI folder (I have the same cpu's) give it a shot (after you've adjusted everything to Your specs of course) and let us know if it works.

https://drive.google.com/open?id=1uyrw0FaqrIoBa8HZlBdxRQdjpHXyj8n8

https://drive.google.com/open?id=1B1d2EfQJ213d6cQizfa8195f8RsoIHrS (Kexts in S/L/E)

I patched aicpupm but used the cloverpatch 

post-885315-0-36028900-1519330312.png

Share this post


Link to post
Share on other sites

1. ( for ho520726 ) Newest Clover configurator has a shut down patch. Try to enable it.

2. (for bilbo) About High Sierra, there are one DSDT patch to prevent quick rebooting at very beginning. Then, you can finished the installation. I believe.:)

Edited by wham17wham

Share this post


Link to post
Share on other sites

Hello,

I have z620 with E5-2643. I try all variants but every time have KP and can't see what wrong.

Please help.

Edited by SquidGM

Share this post


Link to post
Share on other sites

@amadeusex Thank for your help. I fixed the shutdown problem with clover configurator "shutdown" path. Actually, I fixed pm by follow the way how bilbo listed and finally put your dsdt file and it works. Thank for sharing your file. Glad I have the same cpus as you.

@wham17wham Thank for your help. It did work.

Another problem, I just find out a very annoying problem, I don't know is it my motherboard is going down. When I am downloading file from Internet the lan port or motherboard make some noise(especially down as high speed like 10MB/per sec, it would be more noise). I didn't realize that problem when I installed my pc with mac 10.11 in my workplace(a more noise environment), but now I moved my pc to my home. The noise is more visible. Anyone is same?????

In this problem, I also find out one problem is that the IntelMausiEthernet.kext can't support two lan port even I used the dpci manager to check it can show two network controllers. I can only use the upper lan port. The bottom one can't use. so I replace it with Appleintele1000e.kext and it works. (I also dun know is it my own problem as well, just to mention what I experienced)

Share this post


Link to post
Share on other sites
3 hours ago, ho520726 said:
[mention=885315]amadeusex[/mention] Thank for your help. I fixed the shutdown problem with clover configurator "shutdown" path. Actually, I fixed pm by follow the way how bilbo listed and finally put your dsdt file and it works. Thank for sharing your file. Glad I have the same cpus as you.
[mention=2137512]wham17wham[/mention] Thank for your help. It did work.
Another problem, I just find out a very annoying problem, I don't know is it my motherboard is going down. When I am downloading file from Internet the lan port or motherboard make some noise(especially down as high speed like 10MB/per sec, it would be more noise). I didn't realize that problem when I installed my pc with mac 10.11 in my workplace(a more noise environment), but now I moved my pc to my home. The noise is more visible. Anyone is same?????
In this problem, I also find out one problem is that the IntelMausiEthernet.kext can't support two lan port even I used the dpci manager to check it can show two network controllers. I can only use the upper lan port. The bottom one can't use. so I replace it with Appleintele1000e.kext and it works. (I also dun know is it my own problem as well, just to mention what I experienced)

Noise i suspect is the PSU coils or chokes.. I have it also.. it's normal and often referred to as coil whine. I suspect it's due to the PSU / system not using much power. I do not get it when PM is off.

I have it bad on Windows and OSX. Under Linux it's silent... Pain in the ass and prevents me using OSX. Some fixes for this online appear to be squirt hot glue on the PSU coils but it did not work for me.

 

 

Edited by Cass67
cleanup double quoting from tapatalk post

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NoEnd
      Hi team,
       
      I have tried to update to security update 2019-001 multiple time with no luck, today I've booted the update with -verbose and attached videos shows the details.
       
      Appreciate your help
       
      Thanks
      Untitled.mov
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f13 --> build 16G1815 (thanks to flowrider) New!
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
            Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Install Clover UEFI in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace Folder CLOVER INSTALLATION.zip   --Install Sierra and boot into system!   --Install Clover UEFI and replace with my folder  CLOVER POST INSTALLATION.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches!   If you need DSDT edit... Run it RunMe.app   --DSDT My DSDT DSDT.ASUS H61M-A MaLd0n.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -EHCx -LPC -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -PNLF Clear NVRAM, Purge and Kextcache
          --FakeSMC http://www.hwsensors.com/releases --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
×