Jump to content
bilbo

[Guide 2018] Z820 - SIERRA, The great guide (Sucess)

197 posts in this topic

Recommended Posts

Advertisement
8 hours ago, bilbo said:

Well , after this week with the site down,  let's go back with our bussiness.... ^_^

 

Yessss .. good news . :)

I was about to throw all away, and really sad thinking in my options , when reading some advice and some thing in HP forums, I decided do "jumper crisis" method: I thought that it's not useful in my case, but anyway,  I tried, and... bingo... the motherboard resurrected miraculously. It seems that the guilty was my raid pci card (lsi 9260): When the motherboard died, I was changing the graphic card and to do that, I have to unplug the lsi card too. Somehow, the card blocked the motherboard.

After do jumper crisis - method,  and the resurrection , trying to plugin the card again, I get an obscure "PCI ERROR on slot 1"  bios screen. So I decided throw the card to the garbage. Without it, the z820 boots normally. I passed all hardware test with the z820 utilities. More than 12 hours. The hardware seems ok. I bought a lsi card a few days ago.

I'm still testing , just in case, but everything seems ok.  It has been in a big scare

btw, crisis  recovery  jumper is not described in any official documentation. Only the threat linked above and even in that thread there is no any official answer  . HP is an absurd company.

hey hey hey !!  nice one .. glad to hear it all came good, didnt sound good for a bit there ... well done with the peristance and the ressurection !!

Share this post


Link to post
Share on other sites

on an off topic note, whats with this bizzare quoting and replying system on this new site.. previous qoute responed to the main thread or something .. sigh ...

Share this post


Link to post
Share on other sites

Hello to everybody and thanks for this great guide!

I was able to run Sierra on my Z620 with dual CPU (Sandy Bridge) and now, after a bit of struggling due to InsanelyMac's downtime, I'm writing from my brand new High Sierra 10.13.3 installation!

High-Sierra-20180312.png.feaa2c6b0747979def2e17221cc12265.png

Right now I've managed to install thanks to another source of information, this one:

https://github.com/NTT123/Hackintosh-HP-Z420-MacOS-High-Sierra-10.13

but I'd like to refine it a bit following bilbo's guide...

Anyone could please re-share bilbo's ZIP file? I can't manage to download (0 byte archive).

Edited by antonio.clb

Share this post


Link to post
Share on other sites

re-uploaded

 

The new forum is a little unstable. It's an external link for the moment.

 

Btw, I forget thank to all people who message me by pm, with suggestions and advices ;)

Edited by bilbo

Share this post


Link to post
Share on other sites

Thanks a lot bilbo!

I confirm that, on my Z620, USB 3.0 ports are now working like a charm with your mXHCD.kext (no USB 3.0 show in system profiler but maybe it's a matter of those cosmetic fixes...)!

I'll try to optimize and summarize my settings and share them with the community in the next few days.

For now, I can tell you that audio is working really good with VoodooHDA.kext.

Thanks again for your

Share this post


Link to post
Share on other sites
1 minute ago, bilbo said:

Sorry Antonio, but is your guide for 10.12 or 10.13 ? I find your guide and your clover folder a little confused. ;)

The original guide is for 10.12 but, on top of the page, you can notice a folder named "10.13.2" that contains a Clover configuration suitable for the installation of High Sierra 10.13.3:

  1. created USB installer (I've used and old HDD attached to a USB 3.1 dock plugged, of course, in the USB 2.0 front connector of my Z620);
  2. installed Clover on this drive;
  3. copied the whole "CLOVER" folder fron the "10.13.2" folder of NTT's GitHub page;
  4. activate "Legacy ACPI CPU Tables" in BIOS (important!)
  5. installed High Sierra!

Then I've made a couple of steps from your old guide to enable MacPro 6,1 SMBIOS, PM and so on. Also installed NVIDIA web drivers.

I'll be glad to give you further details and my full configuration in a couple of days: busy at work right now, sorry!

Share this post


Link to post
Share on other sites

BTW, AppleALC was updated to ver. 1.2.3:

Quote

v1.2.3
•    Added alcid=layout boot argument for testing purposes
•    Added automatic rename for HDEF device
•    Added ALC255 layout-id 18 for Aorus X5V7 by DuNe
•    Change Platforms18.xml.zlib for ALC255 by DuNe
•    Added ALC898 layout-id 101 by Andrey1970 (4 Line Out)
•    Added ALC262 layout-id 28 for HP Z800-Z600 series by MacPeet
•    Added ALC225 layout-id 33 by ChalesYu
•    Added ALC282 layout-id 127 No input boost Acer Aspire on IvyBridge by Andrey1970
•    Added ALC294 layout-id 13 by InsanelyDeepak
•    Added IDT92HD91BXX layout-id 13 for HP Envy 6 1171-SG by MacPeet

I have replaced version from Bilbo’s pack with new one and remove CodecCommander.kext
Seems like everything is OK. Test passed ;) 

Share this post


Link to post
Share on other sites

yeap.. 1.2.3 compiled has been released... great!! 

Surprising for me that codeccommander in not needed. thanks shamman, I'll update the guide.

Share this post


Link to post
Share on other sites

oh yes, of course. When I made the guide, I though and thought about how the guide could be show the process. I decided that is better that people understand the complete process, the nature of the fixes. The quick guides , drag and replace-style, tend to give misunderstandings.

Understanding the complete process, maybe after follow the guide at least once, everybody can make it shorter. Almost in a single step, using the right version of config, dsdt, and kexts files after the first boot. That is because I included into the stuff, one final folder called FINAL STEP :) . (This doesn't include PM process). After installation, only replacing files, it can take only a few minutes to complete the guide. 

 

Share this post


Link to post
Share on other sites
On 3/15/2018 at 1:12 AM, bilbo said:

 I decided that is better that people understand the complete process, the nature of the fixes. The quick guides , drag and replace-style, tend to give misunderstandings.

Yes, I finished my own Sierra last Summer. Follow your El Capitan guides :rolleyes:

Yes, I'm not using z820 :thumbsup_anim:

I tried High Sierra recently, it still very difficult. :( 

 

Edited by wham17wham

Share this post


Link to post
Share on other sites

Thanks for bilbo. I successfully transfer from 10.11 to 10.12 with dual E5-2670 v1 and bios 3.91. 

But I got a problem which is I can't really shutdown my computer. It is always restart instead of shut down. Anyone know how to fix this minor problem.

I just directly use the file(06 CLOVER FINAL -NO-PM) provided from billbo. Of course, I fixed PM later.

Share this post


Link to post
Share on other sites
On 17/3/2018 at 9:59 PM, ho520726 said:

Thanks for bilbo. I successfully transfer from 10.11 to 10.12 with dual E5-2670 v1 and bios 3.91. 

But I got a problem which is I can't really shutdown my computer. It is always restart instead of shut down. Anyone know how to fix this minor problem.

I just directly use the file(06 CLOVER FINAL -NO-PM) provided from billbo. Of course, I fixed PM later.

Same problem here with my Z620 on High Sierra: reboot or shutdown fail with a "929-Fatal MCA error". Pressing F1 will continue the boot process.

Share this post


Link to post
Share on other sites

 :huh: no idea. I don't have any problem with shutdown , even in the early process, at first boot, without patches. Are you using your own dsdt patched, or you are using mine?

Share this post


Link to post
Share on other sites
On 3/17/2018 at 10:59 PM, ho520726 said:

Thanks for bilbo. I successfully transfer from 10.11 to 10.12 with dual E5-2670 v1 and bios 3.91. 

But I got a problem which is I can't really shutdown my computer. It is always restart instead of shut down. Anyone know how to fix this minor problem.

I just directly use the file(06 CLOVER FINAL -NO-PM) provided from billbo. Of course, I fixed PM later.

Here's my Siera EFI folder (I have the same cpu's) give it a shot (after you've adjusted everything to Your specs of course) and let us know if it works.

https://drive.google.com/open?id=1uyrw0FaqrIoBa8HZlBdxRQdjpHXyj8n8

https://drive.google.com/open?id=1B1d2EfQJ213d6cQizfa8195f8RsoIHrS (Kexts in S/L/E)

I patched aicpupm but used the cloverpatch 

post-885315-0-36028900-1519330312.png

Share this post


Link to post
Share on other sites

1. ( for ho520726 ) Newest Clover configurator has a shut down patch. Try to enable it.

2. (for bilbo) About High Sierra, there are one DSDT patch to prevent quick rebooting at very beginning. Then, you can finished the installation. I believe.:)

Edited by wham17wham

Share this post


Link to post
Share on other sites

Hello,

I have z620 with E5-2643. I try all variants but every time have KP and can't see what wrong.

Please help.

Edited by SquidGM

Share this post


Link to post
Share on other sites

@amadeusex Thank for your help. I fixed the shutdown problem with clover configurator "shutdown" path. Actually, I fixed pm by follow the way how bilbo listed and finally put your dsdt file and it works. Thank for sharing your file. Glad I have the same cpus as you.

@wham17wham Thank for your help. It did work.

Another problem, I just find out a very annoying problem, I don't know is it my motherboard is going down. When I am downloading file from Internet the lan port or motherboard make some noise(especially down as high speed like 10MB/per sec, it would be more noise). I didn't realize that problem when I installed my pc with mac 10.11 in my workplace(a more noise environment), but now I moved my pc to my home. The noise is more visible. Anyone is same?????

In this problem, I also find out one problem is that the IntelMausiEthernet.kext can't support two lan port even I used the dpci manager to check it can show two network controllers. I can only use the upper lan port. The bottom one can't use. so I replace it with Appleintele1000e.kext and it works. (I also dun know is it my own problem as well, just to mention what I experienced)

Share this post


Link to post
Share on other sites
3 hours ago, ho520726 said:
[mention=885315]amadeusex[/mention] Thank for your help. I fixed the shutdown problem with clover configurator "shutdown" path. Actually, I fixed pm by follow the way how bilbo listed and finally put your dsdt file and it works. Thank for sharing your file. Glad I have the same cpus as you.
[mention=2137512]wham17wham[/mention] Thank for your help. It did work.
Another problem, I just find out a very annoying problem, I don't know is it my motherboard is going down. When I am downloading file from Internet the lan port or motherboard make some noise(especially down as high speed like 10MB/per sec, it would be more noise). I didn't realize that problem when I installed my pc with mac 10.11 in my workplace(a more noise environment), but now I moved my pc to my home. The noise is more visible. Anyone is same?????
In this problem, I also find out one problem is that the IntelMausiEthernet.kext can't support two lan port even I used the dpci manager to check it can show two network controllers. I can only use the upper lan port. The bottom one can't use. so I replace it with Appleintele1000e.kext and it works. (I also dun know is it my own problem as well, just to mention what I experienced)

Noise i suspect is the PSU coils or chokes.. I have it also.. it's normal and often referred to as coil whine. I suspect it's due to the PSU / system not using much power. I do not get it when PM is off.

I have it bad on Windows and OSX. Under Linux it's silent... Pain in the ass and prevents me using OSX. Some fixes for this online appear to be squirt hot glue on the PSU coils but it did not work for me.

 

 

Edited by Cass67
cleanup double quoting from tapatalk post

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4961 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4961 for VMware.zip". Mount Clover-v2.4k-4961-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        Mojave Full DSDT patch   http://olarila.com/forum/viewtopic.php?f=59&amp;t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder   https://olarila.com/files/Clover.Folder/CLOVER.LGA775.zip   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://olarila.com/files/Clover.Folder/CLOVER.LGA775.zip     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By slapbass_
      Buona giornata con tutti i colleghi di Insanelymac
      Spero che tutto sia buono là fuori :-)
      # Post-installazione MOJAVE 10.14.5 / I NON HANNO IL HDMI AUDIO
      #Laptop
      #non visualizzare (Samsung TV) nel pannello delle preferenze di sistema
      ....
      Voglio chiedere il tuo supporto, dare una soluzione al mio portatile
      ....
      e così Abilita l'audio HDMI
      Ti ringrazio infinitamente compagni;
      - Il cavo hdmi dalla TV è collegato al laptop, non appare nulla
      (non riconosce) nel pannello delle preferenze di sistema
      (vedi foto)
      https://www8.zippyshare.com/v/oTOoA3Wd/file.html
       
      * qui le mie specifiche:
      Dell Inspiron 14 serie 5000 (5458)
      - CPU Intel (R) Core (TM) i5-5200U @ 2,20 GHz
      - Ram 4GB »
      - Intel HD Graphics 5500
      - Rete PCI:
      Adattatore WiFi HMC AC Wireless-AC 3160 AC Dual Band Intel
      Scheda Fast Ethernet Realtek RTL8139 / 810x
      - Audio
      Intel Broadwell HDMI @ Intel Broadwell - Mini HD Audio
      Realtek ALC255 @ Intel Wildcat Point-LP PCH Alta defi .....
      Ti sarò molto grato, miei compagni,
      saluti
      Dio ti benedica
      Four Fotos.zip
    • By slapbass_
      Insanelymacのすべての同僚と良い一日
      私はすべてがそこに良いことを願っています:-)
      #インストール後のMOJAVE 10.14.5 / HDMIオーディオを持っていません
      #ラップトップ
      システム設定パネルの#no view(Samsung TV)
      ……
      私のラップトップに解決策を与えるために、私はあなたのサポートを求めたいです
      ……
      HDMIオーディオを有効にする
      無限の仲間に感謝します。
       - テレビからのHDMIケーブルがラップトップに接続されている、何も表示されない
      システム設定パネルの(認識しない)
      (写真参照)
      https://www8.zippyshare.com/v/oTOoA3Wd/file.html
      *ここに私の仕様:
      Dell Inspiron 14 5000シリーズ(5458)
       - インテル(R)コア(TM)i5-5200U CPU @ 2.20GHz
       -  Ram 4GB»
       - インテルHDグラフィックス5500
       -  PCIネットワーク:
      インテルデュアルバンドワイヤレスAC 3160 AC HMC WiFiアダプター
      Realtek RTL8139 / 810xファーストイーサネットアダプタ
       - オーディオ
      Intel Broadwell HDMI @ Intel Broadwell  - ミニHDオーディオ
      Realtek ALC255 @インテルワイルドキャットポイント -  LP PCHハイビジョン.....
      私はあなたに、私の仲間に非常に感謝します
      ご挨拶
      神はあなたを祝福します
      Four Fotos.zip
×