Jump to content
sidX86

Kernel Panic (Coffee Lake)

15 posts in this topic

Recommended Posts

Hello everyone,

 

I managed to install HS 10.13.0 using some config.plist patches and via disabling the integrated MX150 using SSDT and DSDT patches but after install, the system refuses to boot. I get a kernel panic relating to cpu0 caller and a reboot. I'm emulating SkyLake HD520 using some patches too, can someone please check what's the fault? I've attached the whole Clover EFI folder. Using Clover r4391 UEFI.

 

Specs:

i5-8250U 

Intel UHD 620 Graphics

Nvidia Geforce MX150 DGPU (Disabled)

8GB DDR4 RAM

1TB HDD

Synaptics Touchpad

Qualcomm Atheros QCA9377 Wi-Fi Chipset

Realtek PCIe GBE Family Controller

No idea about the Audio Codec lol but I'm using AppleHDA and Lilu, these should make it work.

 

EFI.zip

Share this post


Link to post
Share on other sites
Advertisement

Create ur installer, dont use distros, check my tutorial and create a clean usb stick

http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/

attachicon.gifCLOVER.zip

Thanks for this but it didn't work.. I've attached some log pics, see into the issue.. 

And yea, I'll be creating my own installer after I manage to get this distro working. 

post-1935990-0-07700100-1518887042_thumb.jpg

post-1935990-0-23491100-1518887137_thumb.jpg

post-1935990-0-01537600-1518887221_thumb.jpg

Share this post


Link to post
Share on other sites

create ur image, check image, fakesmc fail to load ;)

Got the issue, downloading stock 10.13.3 image right now, will be using it to create a fresh installer. And btw, I see you removed the graphics patches from the config.plist, have you directly injected skylake graphics into DSDT or something?

Share this post


Link to post
Share on other sites

Got the issue, downloading stock 10.13.3 image right now, will be using it to create a fresh installer. And btw, I see you removed the graphics patches from the config.plist, have you directly injected skylake graphics into DSDT or something?

ye, apply all u need into DSDT and use SSDT for disable DGPU, but i don't check ioreg, just check ur SSDT, i think in RP01/PXSX

we can disable via DSDT too

DSDT.aml.zip

use it and put intelgfx 0x12345678

Share this post


Link to post
Share on other sites

ye, apply all u need into DSDT and use SSDT for disable DGPU, but i don't check ioreg, just check ur SSDT, i think in RP01/PXSX

we can disable via DSDT too

attachicon.gifDSDT.aml.zip

use it and put intelgfx 0x12345678

Okay! Btw, here's my original DSDT files, see if you can create a perfect one for me! 

ACPI origin.zip

Share this post


Link to post
Share on other sites

don't need, use clover folder in #2 and DSDT #6, after install we solve others

Created a fresh Installer, macOS HS 10.13.3, getting this now! 

post-1935990-0-55755500-1518897816_thumb.jpg

Share this post


Link to post
Share on other sites

try with other smbios, check Firmware Features fields too

Tried MacBook Pro 14,1, iMac 18,1, iMac 18,2, iMac 18,3 SMBIOS’es but none helped!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×