Jump to content
Sign in to follow this  
Followers 0
ross1573

Can't detect SSD when DSDT is injected

7 posts in this topic

Recommended Posts

Hi, I recently installed sierra in my laptop.

 

It's working pretty well, but I wanted to make my laptop real mac like.

 

So I tried to patch some DSDT.(Speedstep, USB and otherthings)

 

But when I try to boot with DSDT, it can't detect my SSD...

 

So I tried with no patch DSDT(Only fixing errors and warnings.)

 

But I got same result...

 

Without DSDT, it's booting well.

 

I think I fixed some errors in the phrase _SB.PCI0.SATA section.

 

Will that be the problem?(I just fixed for no errors to compile.)

 

Or do I have to patch anything?

 

Thanks for the help.

post-2366873-0-34073000-1518358116_thumb.jpg

post-2366873-0-82111300-1518358266_thumb.jpg

Errors.zip

Share this post


Link to post
Share on other sites
Advertisement

 

I changed DVMT to 64mb when using Sierra. Thanks for the tip anyway :)

 

I just installed High Sierra by using my config.plist which had intelskcframebuffer patch(kexts to patch part).

 

The problem is I can't boot on the newly installed High Sierra...

 

It gets panic and can't figure out what the problem...(just lots of numbers came out after the kernel traps sign...)

 

Plus I'm wondering that is it really installed or not...

 

Some preinstaller partion came up on the clover...

 

When I checked with the disk utility on Sierra, High Sierra is installed under hard drive named appleAPFSmedia.

And there's 4 partion named High Sierra(It's the partion I named), Preboot, Recovery, VM...

I wonder what is the preinstaller and VM thing is...

 

Anyway, thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×