Jump to content
MacPeet

[Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)

441 posts in this topic

Recommended Posts

post-1358580-0-83250400-1518187384_thumb.png  post-1358580-0-09673900-1518187394_thumb.png  post-1358580-0-45284900-1518187404_thumb.png
 
Even with High Sierra, the Optiplex780 / 760 is not quite at the end. We're still playing!
 
the Optiplex story:
10.10: http://www.insanelymac.com/forum/topic/302877-guide-yosemite-1010x-dell-optiplex-780-760/
10.11: http://www.insanelymac.com/forum/topic/308097-guide-el-capitan-1011x-dell-optiplex-780-760-755-790-990/
10.12: http://www.insanelymac.com/forum/topic/312656-guide-macos-sierra-1012-dell-optiplex-780-760-755-790-990/
10.13: this guide
 
Note: High Sierra supports only CPUs with SSE4 support, example: my Q9400 or my Q8200 working with Sierra. Core2Duo E7200 / Core2Quad Q8200 or higher works as well. See CPU-X.app for your CPU !!!
 
For a direct update from 10.12 to 10.13, you first install the latest version of Clover.
Copy your Kext's from Clover/kexts/10.12 to /other.
Note new BIOS data and firmware data in Clover's config.plist in SMBIOS. For more information read on.
 
Instructions for Clean Install:
 
1. Download Install macOS High Sierra.app
 
 
2. CreateInstall USB flash drive (8GB) with terminal (If problems with USB, then create internal Install HDD):

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction

 
3. Install current version Clover for HighSierra-Support to your Install medium (Legacy-Method):
 
Install Clover in the ESP
Bootloader / Install boot0af in the MBR
CloverEFI / Clover-EFI 64Bit SATA
Drivers64UEFI / EmuVariableUefi-64
Drivers64UEFI / OsxAptioFixDrv-64
Drivers64UEFI / PartitionDxe-64
Install RC Scripts In Target Volume
optional:
Theme, free choice
Install Clover Preference Pane
 
 
4. Copy your config.plist and DSDT from your Sierra HDD or SSD or new users from here
 
mount your EFI partition
 
DSDT.aml insert to EFI/Clover/ACPI/patched/
config.plist insert to EFI/Clover/
 
Attention! New bios data and new firmware data.
Use current version CloverConfigurator!
 
post-1358580-0-72144900-1518187463_thumb.png
 
Example Optiplex780/760:
my_DSDT.aml.zip (my DSDT, optimized for Core2Quad, configured for HD5450 and Audio LayoutID 13 (0D) for AppleALC + Lilu. Additionally Framebuffer in the Clover is "Shrike" for the HD 5450)
my_config.plist.zip (Create serial number, board serial number, MLB, ROM !!!)
 
post-1358580-0-94162200-1518187472_thumb.png
 
Example Optiplex755:
by @ricoc90 (files and info): http://www.insanelymac.com/forum/topic/332512-guide-macos-high-sierra-1013-dell-optiplex-780-760-755-790-990/#entry2598770
 
Example Optiplex790/990:

by @morpheousman (files and info): http://www.insanelymac.com/forum/topic/332512-guide-macos-high-sierra-1013-dell-optiplex-780-760-755-790-990/#entry2595193

by @chris1111 (files and info): http://www.insanelymac.com/forum/topic/332512-guide-macos-high-sierra-1013-dell-optiplex-780-760-755-790-990/#entry2595284
Thanks @morpheousman and @chris1111
 
5. Copy your kexts of your Sierra HDD or SSD to EFI/Clover/kexts/other/
 
Example760/780:
these are my kexts for 10.13: other.zip
 
 
6. Important preparation with HD5450 (780/760/755)
 
With High Sierra, there is a black screen with the HD5450, because C2D and C2Q have no Injector iGPU. Since High Sierra, the HD5450 needs a rollback from Sierra.
WhateverGreen.kext + Lilu.kext does not work with LegacyBios, unfortunately.
 
Save in advance the following Kext's from your Sierra installation from /System/Library/Extensions:
 
AMDRadeonX3000.kext
AMDRadeonX3000GLDriver.bundle
IOAccelerator2D.plugin
IOAcceleratorFamily2.kext

 

Note: Optiplex 790 (or higher) with i? CPU with Injector GPU does not require rollback.
 
 
7. apfs.efi
 
This is the current apfs.efi from 10.13.4 DP2:
 
apfs.efi.zip
 
The current original apfs.efi can be found after each install or update in usr/standalone/i386/ (use ShowAllFiles!).
The new file system is only for SSDs. HDDs continue to work with HFS+.
 
copy the apfs.efi to EFI/Clover/drivers64/
 
 
8. Now High Sierra install on your HDD or SSD (Partitions with Guid scheme)
 
The installation, even with subsequent updates, can take place in several steps.
My experiences:
APFS two steps
HFS+ one step
 
8.1 With the HD5450 there is a black screen the first time after the install.
I take the SSD out of the Dell and connect it to another Mac.
Here I am using the app "EasyKext Pro" and doing the rollback from the backup (step 6 above - AMDRadeonX3000.kext, AMDRadeonX3000GLDriver.bundle, IOAccelerator2D.plugin and IOAcceleratorFamily2.kext from Sierra 10.12.6).
Reinstall SSD in the Dell and now we get a picture in High Sierra.
 
after installation:
 
9. Terminal (for unsigned apps)

sudo spctl --master-disable

 
10. Install Clover on your HDD or SSD (Legacy-Method):
 
Install Clover in the ESP
Bootloader / Install boot0af in the MBR
CloverEFI / Clover-EFI 64Bit SATA
Drivers64UEFI / EmuVariableUefi-64
Drivers64UEFI / OsxAptioFixDrv-64
Drivers64UEFI / PartitionDxe-64
Install RC Scripts In Target Volume
optional:
Theme, free choice
Install Clover Preference Pane
 
 
11. Copy your config.plist, DSDT, Kext´s and apfs.efi to your High Sierra HDD or SSD
 
 
after installation sound:
 
Please ask if you have problems with the AppleALC method! It is not hard to get it right.
 
optional Audio Optiplex780/760:
 
current AppleALC + Lilu in the Clover's Kext folder works for the Optiplex780/760 with:
LayoutID 11 (0B) ManualMode
LayoutID 13 (0D) autodetect Speaker/HP
 
The current release can be found here:
https://github.com/vit9696/AppleALC/releases
https://github.com/vit9696/Lilu/releases
 
optional Audio Optiplex755:
 
trial_AppleALC_Lilu_Optiplex755_layoutID28_1C.zip LayoutID 28 (1C) please report
 
optional Audio Optiplex790 and 990:
 
current AppleALC + Lilu in the Clover's Kext folder works for the Optiplex790/990 with:
LayoutID 15 (0F) ManualMode
LayoutID 16 (10) autodetect Speaker/HP
 
 
 
Night Shift Patch:
 
patched_signed_Night_Shift_CoreBrightness.framework_10.13.zip
 
Replace the original in /System/Library/PrivateFrameworks/ and reboot.
 
 
Tested graphics cards with High Sierra:
my XFX one HD5450: with DSDT patch and frame buffer "Shrike" works great with HDMI audio in the Optiplex780 with kext rollback from Sierra
@morpheousman´s HD5450 Bios-Patch: http://www.insanelymac.com/forum/topic/312656-guide-macos-sierra-1012-dell-optiplex-780-760-755-790-990/page-18#entry2369870
my EVGA Nvidia GT210: works with Inject Nvidia with High Sierra, but no HDMI audio possible
other User with GT710
Zotac GeForce GT 1030 2Gig Web Drivers only  - by @chris1111

Saphire Radeon HD 6670 1 gig - by @chris1111
 
 
Tested WLAN:
PCIe: TP-Link TL-WDN4800 N900 WLAN Dual Band up to 450Mbit/s to 2.4GHz or 5GHz, works OOB as Airport
PCI: TP-Link TL-WN851ND 300Mbit/s, works as Airport, thanks Maggo Attached File AtherosWiFiInjector.kext.zip
USB: TP-Link TL-WN725N Nano WLAN USB Adapter 150Mbit/s, not as AirPort
 
 
Developer Beta program:
[How-To] macOS High Sierra Developer Beta program without special registration, if anyone is interested!
 
post-1358580-0-08988900-1518187653.gif
com.apple.seeding.plist.zip
 
Copies the com.apple.seeding.plist file to /Library/Preferences/ (not S/L/P)
 
and open Terminal:

sudo softwareupdate --set-catalog https://swscan.apple.com/content/catalogs/others/index-10.13seed-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

see AppStore/Updates  :thumbsup_anim:
 
Note:
If the value is in com.apple.seeding.plist = 2, then it is Developers Beta program.
If the value in com.apple.seeding.plist is = 3, then it is Users Beta program.
 
Users Beta:

sudo softwareupdate --set-catalog https://swscan.apple.com/content/catalogs/others/index-10.13beta-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

see AppStore/Updates  :thumbsup_anim:
 
 
Credits/Sources - Thanks to all mentioned users:

InsanelyMac.com & root86.com
@Slice and all others for the Clover Bootloader
@vit9696 and @vandroiy2012 for AppleALC and Lilu
@pepto, @polyzargone, @morpheousman, @chris1111, @owbp, @ricoc90 and all others for all Optiplex 780 (760) Guides!
 
 

have fun :wub:  Optiplex

Edited by MacPeet

Share this post


Link to post
Share on other sites
Advertisement

It's already done, but I can not try every Optiplex XXX.

Nice that everything goes with you.
 
Here are problems with DP Beta 10.13.4 right now. Audio with AppleALC / Lilu is not working anymore. I'm waiting for DP Beta 3. I'll report ...

Share this post


Link to post
Share on other sites

Running High Sierra 10.13.2 on both Optiplex 790 i7-2600 @ 3.4Ghz, and Optiplex 990 i5-2400

 

DSDT with edits for HD 5450, and Sound with AppleALC + Lilu - LayoutID 15 (0F)) 

 

DSDT edited to use USBInjectAll.kext. (no Config Edits for EHC1 to EH01 - EHC2 to EH02)

 

Both CPU's have Injector GPU, so no Video Kext Rollback is needed.

 

Nightshift works. Bluetooth, and wake from Bluetooth Device, using Broadcom USB Dongle, Chipset 20702A3.

 

Everything works. :)

 

Sapphire Radeon HD 5450 Wake from sleep video bios fix.  http://www.insanelym...18#entry2369870

 

wh06l1.png

 

790-990.zip

Edited by morpheousman
Update File

Share this post


Link to post
Share on other sites

@Macpeet

Thanks for new Guide  ;)

Here my EFI Folder Optiplex 790 for High Sierra 10.13 to 10.13.4

EFI folder containing all the Drivers64, Drivers64UEFI and a stock DSDT. GFX0 is renamed to IGPU No Graphics patch in the DSDT.

 

The default config.plist is for the Saphire Radeon HD 5570 1 gig (native support)

Sleep and wake works

 

The 5450 config works on all Radeon HD 5450 1 gig or 2 gig

 

The GT 1030 config is for the   Zotac Geforce GT 1030 2 gig (Web Drivers) Sleep and wake works

 

The config 6670 is for the Sapphire Radeon HD 6670 1 gig (Native suppoort)

 

Note: My Optiplex  790 have a ➜ CPU i5 2500k with Injector GPU so all this Graphics card works with the config.plist in the EFI Folder

​no kext rollback is need with the i5 2500k

EFI Optiplex 790 (HS-10.13).zip

Share this post


Link to post
Share on other sites

 

 

Everything works. :)

 

Sapphire Radeon HD 5450 Wake from sleep video bios fix.  http://www.insanelym...18#entry2369870

 

 

I Thank you for the tip :D I just flashing my XFX Radeon HD 5450 with this ➤ Bios XFX Radeon HD 5450 and now Sleep Wake works

 

Now I have 3 card with Working Sleep and Wake  :thumbsup_anim:

Share this post


Link to post
Share on other sites

some new experiences:

Since beta2 and beta3 10.13.4 AppleALC + Lilu no longer worked on my Dell 780 with the Analog Device AD1984A. According to kextstat both are loaded. Only HDMI audio works.
Today I tried a little. A rollback original AppleHDA of 10.13.3 and everything works again.
Apple tries again here a blockade in the new AppleHDA's?
I will continue to talk about the next beta's ...

Share this post


Link to post
Share on other sites

optional Audio Optiplex755:

 

attachicon.giftrial_AppleALC_Lilu_Optiplex755_layoutID28_1C.zip LayoutID 28 (1C) please report

As promised in the Sierra thread hereby my report :D 

The front speakers are working, back speakers are working but no microphone on both inputs

 

Example Optiplex755:

no data yet

@ricoc90 ?¿?¿?

Coming up later today  ;)

Share this post


Link to post
Share on other sites

As promised in the Sierra thread hereby my report :D 

The front speakers are working, back speakers are working but no microphone on both inputs

 

In the trial version of earlier ran the inputs? I probably deleted the data.

Share this post


Link to post
Share on other sites

In the trial version of earlier ran the inputs? I probably deleted the data.

IIRC they did not work in previous versions either 

Share this post


Link to post
Share on other sites

Hereby the essential Optiplex 755 files (currently running on 10.13.3, imac10,1 SMBIOS, Clover r4417):

- Config.plist
- DSDT
- Kexts

Optiplex_755_Essentials.zip

In addition to the other information about the 790:

 

If running onboard Intel HD 3000 graphics, DP works OOB. However, VGA does not. It does work with the following patch, however it should be noted that VGA only works once you are fully booted and manually searched for displays in the display control panel. In my case this breaks sleep.

			<dict>
				<key>Comment</key>
				<string>Patch: HD3000 VGA</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AgUAAAAEAAAHAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelSNBGraphicsFB</string>
				<key>Replace</key>
				<data>
				BgIAAAAEAAAIAAAA
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>Patch: HD3000 DP</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AwQAAAAEAAAJAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelSNBGraphicsFB</string>
				<key>Replace</key>
				<data>
				AwQAAAAEAAAGAAAA
				</data>
			</dict>

Credits to Hervé and Chris1111.

 

However, it is also possible to use the onboard graphics and a GPU card at the same time. For this you'll need to change the video settings in the BIOS and it should be noted that this only works if there actually is a monitor (or a dummy) present on both outputs upon booting. In my case the Optiplex POSTS to the onboard graphics, but once macOS is fully booted the graphics card comes up too. 

Edited by ricoc90

Share this post


Link to post
Share on other sites

I Thank you for the tip :D I just flashing my XFX Radeon HD 5450 with this ➤ Bios XFX Radeon HD 5450 and now Sleep Wake works

 

Now I have 3 card with Working Sleep and Wake  :thumbsup_anim:

 

 

@Chriss1111,

 

Are you using a custom SSDT with your 790, or just using the inject AppleIntelCPUM in clover in Clover?

 

Just checking some details on my installs, and realized that, like a dummy, i was still using NullCpuPower kext.  :wacko:

 

i7-core seems to be running a little more efficiently now. :)

Share this post


Link to post
Share on other sites

@Chriss1111,

 

Are you using a custom SSDT with your 790, or just using the inject AppleIntelCPUM in clover in Clover?

 

Just checking some details on my installs, and realized that, like a dummy, i was still using NullCpuPower kext.  :wacko:

 

i7-core seems to be running a little more efficiently now. :)

I am using this

 

<key>KernelAndKextPatches</key>
<dict>
<key>AppleIntelCPUPM</key>
<true/>
 
Never using NulCPU and AICPU patch

Share this post


Link to post
Share on other sites

That was a quick answer.  Do you sleep with your computer. lol

 

Thank you!

Sleep and wake works with my Radeon HD 5570, 5450 (bios change), GeForce GT 1030

See my config.plist in my EFI for the Radeon 5450 FakeID and Frambuffer Cedar is need

Share this post


Link to post
Share on other sites

So, now that we're back: 10.13.4 DP 4 works as expected on my 790 

 

Schermafbeelding 2018-03-10 om 19.47.42.png

 

EDIT: I see that previous attachments are gone. I'll repost the 755 files later.
EDIT2: Attachments seem to be restored already 

Share this post


Link to post
Share on other sites

I had to edit both first posts. The attachments did not work.

Here also 10.13.4 DP Beta4 works on 780.
Again rollback of the AppleHDA of 10.13.3. The new AppleHDA's do not work with the analog device AD1984A (AppleALC + Lilu).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By fusion71au
      Making a High Sierra USB Installer Entirely From Scratch in Windows
      This is a proof of concept tutorial, to show it's possible to create a vanilla High Sierra installer, entirely from scratch, in Windows (even without App Store downloaded "Install macOS High Sierra.app" from a real Mac ).  @PikeRAlpha's link to Apple's Software Catalog provides us with all the URLs necessary to download the needed files directly from Apple instead of some dubious source from the internet...
       

      Pre-Requisites
      8GB or larger USB drive Boot Disk Utility v2.1.2017rev021b from @CVAD TransMac (free 15 day trial) Paragon Hard Disk Manager Free Download Installer Files Directly from Apple
      1)  Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist (Hint - search page for "InstallESD" to find its URL and others nearby)

      to a folder named "SharedSupport" on your Windows NTFS drive.  A browser download manager (eg Chrono for Chrome, dTA for FireFox) is handy since InstallESD is >4GB ---> allows you to pause/resume interrupted download...

      2)  Rename InstallESDDmg.pkg to InstallESD.dmg
      3)  Edit InstallInfo.plist with WordPad/text editor to remove the chunklistURL and chunklistid keys for InstallESD, and renaming it from InstallESDDmg.pkg to InstallESD.dmg (example of edited file attached to this post)...
      Note:  You can verify the SHA1 checksum of your InstallESD.dmg and BaseSystem.dmg with the correct ones at this website.
      Boot Disk Utility to format the Installer USB and Restore OS X Base System HFS partition
      1.  Format USB with BDU & latest Clover ---> creates boot files in CLOVER partition + second FAT partition
      2.  Extract 4.hfs from \SharedSupport\BaseSystem.dmg with BDU --> save to it's local folder
      3.  Restore 4.hfs to USB second partition with BDU --->  2nd partition becomes bootable "OS X Base System"
      Paragon Hard Disk Manager to extend HFS Partition to its Full Extent
      Open Paragon Partition Manager Free and resize the second partition of the USB drive to the full size allowed.  Don't forget to apply the changes at the end...
      Transmac to Copy "SharedSupport" folder to OS X Base System
      1.  Open the TransMac program and navigate to the HFS+ Volume/Install macOS High Sierra.app/Contents folder.  Right click anywhere in the empty space on the RHS pane and select "Copy Here"...
      2.  In the next stage, select the "SharedSupport" folder we created above as the "Files and Folders to be copied to the Mac Volume"...
       
      Clover Settings
      Clover configuration is required now.  The default config.plist (in the Clover FAT32 partition of the USB) maybe sufficient to boot your machine if you’re lucky.  If not, the hackintosh-vanilla-desktop-guide has some good explanations on the various settings available and also offers sample configuration files based on CPU type.  Also, look at the Clover Wiki, Clover Instructions and Clover Configuration Thread for pointers and edit /EFI/Clover/config.plist accordingly with Wordpad or Notepad.
      The location of the important configuration files for Clover are summarized below
      config.plist--->EFI/CLOVER folder DSDT.aml with or without SSDT.aml--->EFI/CLOVER/ACPI/patched (don't need one if your DSDT is auto patched by Clover in config.plist) Kexts eg FakeSMC, NullCPUPowerManagement --->EFI/CLOVER/kexts/<osx version> or /Other. NB BootDiskUtility by default already has FakeSMC.kext installed here.  You may need to add VoodooPS2Controller for your laptop keyboard/trackpad to work. If UEFI booting, you will most likely need one of the OsxAptioFixDrv-64 drivers copied from /EFI/CLOVER/drivers-off/drivers64UEFI to /EFI/CLOVER/drivers64UEFI. If you want to use the installer to run High Sierra in Windows on VMware, you can follow my guide to set up the Virtual Machine and replace Clover's default config with EFI_Clover for VMware (which is compatible to run in VMware).  In the screenshots below, I have attached the USB Installer (in this case PhysicalDrive7) to my macOS Virtual Machine.  Reboot the system to the USB installer to install High Sierra ...
      What happens if we don't have access to TransMac or Paragon Hard Disk Manager?
      Not a problem, as long as we get "OS X Base System" bootable, we can launch terminal from the Utilities Menu to copy the SharedSupport folder over to the Installer app.  In essence, we will build the full installer app = 5GB+ on the target HD eg "Macintosh HD", by copying both the "small" installer app = 15MB (on "OS X Base System") and the SharedSupport folder from the NTFS volume (mounted in this example on /Volumes/DATA)...
      -bash-3.2# cd / -bash-3.2# cp -R Install\ macOS\ High\ Sierra.app /Volumes/Macintosh\ HD/ -bash-3.2# cp -R /Volumes/DATA/SharedSupport /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/  
      ...then start installation with the startosinstall utility...
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD --converttoapfs NO --applicationpath /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app  
      The above steps can be automated with the attached "startosinstall.command" script, which will assemble "Install macOS High Sierra.app" on "Macintosh HD" and launch the startosinstall utility targeting the "Macintosh HD" volume.  Copy/download to "Macintosh HD", then run in terminal (after attaching DATA USB with /Shared Support folder)...
      cd "/Volumes/Macintosh HD" chmod +x startosinstall.command ./startosinstall.command Updated Download Links for macOS Mojave 10.14.5_18F132
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      Note: In Mojave, Apple has removed the --converttoapfs NO and --applicationpath arguments from the startosinstall utility....
       
      eg to use startosinstall for the above section "What happens if we don't have access to TransMac or Paragon Hard Disk Manager?", the syntax is now
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD  
      This basically means that for Mojave, the default installation will always convert the target volume to the apfs file system.
       
       
      startosinstall.command.zip
      InstallInfo.plist_edited_10.13.6.zip
      InstallInfo.plist_edited_10.14.5.zip
       
       
    • By Pentothal.Z
      Hello all,
      I have a working hackintosh....ok.....but it takes a lot to boot and according to the boot.log there are a few problems.
      One of them is a black screen that stays on for a long time.
      I would like to ask anyone in this community some help to fine tune my machine.
      Boot.log and config.plist attached


      Any help would be appreciated.
      bootlog.txt
      config.plist
    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By 22eme_arkane
      Hi everyone !
       
       I build a new os on High Sierra and i have problem with my Skarkoon RAID 5 - 5 bay, is unmounting, work fine in windows but not in Mac Os.
      I use a card eSata in chipset Marvell 88SE9215, and i have the kext 3-party eSata  but nothings change.
      I try with the AppleAHCIPort.kext v328, nothings change.
       
      Any solution ?
       
      Thanks a lot !
       
      Config : GA-Z68X-UB3-B3 // BIOS UEFI, Version: U1f //
    • By bummercheese
      I have what's been said to be a natively supported wifi card, but for the life of me I cannot get it working properly with High Sierra. It is detected in DPCIManager but the wifi symbol at the top is hollowed and I can't turn it on.
       
      Here's some basic info about my hackintosh. It's running an i7 9700k with an MSI Z390-A PRO, a GTX 1070, and it's SMBIOS is running as an iMac 18.1

      Someone else has posted here about this with an ac66, which I think is very similar and uses the same device number 43A0. But he didn't get his problem solved in the end. And I have looked up this problem in a million different ways, I haven't found a solution that works from any yet.
       
      I've tried a large amount of different kext patches, kexts (fakepciid, airportbrcmfixup, etc), changing fake ID, modifying kext info.plist files, and every combination of those, none have gotten it to properly work.
       
      I have gotten it to work in one way but it's so unstable that it's unusable. Using the IO80211family.kext from yosemite works, but then it will randomly freeze about 10-15 minutes in, and then it'll not boot 9/10 times, and when it will it'll freeze on the login or right after. It gives errors about out of date kext, only way get back in is by reinstalling. So I figure this method is unusable.
       
      I'm just stumped on why a supposed confirmed working out of box card doesn't just just work, even with every amount of tweaking and adding kexts. I'm in my 4th day of almost nonstop testing and researching on how to fix this, and I'm too stubborn and determined to just buy a different card. Any suggestions would be greatly appreciated. 
×