Jump to content
MacPeet

[Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)

405 posts in this topic

Recommended Posts

post-1358580-0-83250400-1518187384_thumb.png  post-1358580-0-09673900-1518187394_thumb.png  post-1358580-0-45284900-1518187404_thumb.png
 
Even with High Sierra, the Optiplex780 / 760 is not quite at the end. We're still playing!
 
the Optiplex story:
10.10: http://www.insanelymac.com/forum/topic/302877-guide-yosemite-1010x-dell-optiplex-780-760/
10.11: http://www.insanelymac.com/forum/topic/308097-guide-el-capitan-1011x-dell-optiplex-780-760-755-790-990/
10.12: http://www.insanelymac.com/forum/topic/312656-guide-macos-sierra-1012-dell-optiplex-780-760-755-790-990/
10.13: this guide
 
Note: High Sierra supports only CPUs with SSE4 support, example: my Q9400 or my Q8200 working with Sierra. Core2Duo E7200 / Core2Quad Q8200 or higher works as well. See CPU-X.app for your CPU !!!
 
For a direct update from 10.12 to 10.13, you first install the latest version of Clover.
Copy your Kext's from Clover/kexts/10.12 to /other.
Note new BIOS data and firmware data in Clover's config.plist in SMBIOS. For more information read on.
 
Instructions for Clean Install:
 
1. Download Install macOS High Sierra.app
 
 
2. CreateInstall USB flash drive (8GB) with terminal (If problems with USB, then create internal Install HDD):

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction

 
3. Install current version Clover for HighSierra-Support to your Install medium (Legacy-Method):
 
Install Clover in the ESP
Bootloader / Install boot0af in the MBR
CloverEFI / Clover-EFI 64Bit SATA
Drivers64UEFI / EmuVariableUefi-64
Drivers64UEFI / OsxAptioFixDrv-64
Drivers64UEFI / PartitionDxe-64
Install RC Scripts In Target Volume
optional:
Theme, free choice
Install Clover Preference Pane
 
 
4. Copy your config.plist and DSDT from your Sierra HDD or SSD or new users from here
 
mount your EFI partition
 
DSDT.aml insert to EFI/Clover/ACPI/patched/
config.plist insert to EFI/Clover/
 
Attention! New bios data and new firmware data.
Use current version CloverConfigurator!
 
post-1358580-0-72144900-1518187463_thumb.png
 
Example Optiplex780/760:
my_DSDT.aml.zip (my DSDT, optimized for Core2Quad, configured for HD5450 and Audio LayoutID 13 (0D) for AppleALC + Lilu. Additionally Framebuffer in the Clover is "Shrike" for the HD 5450)
my_config.plist.zip (Create serial number, board serial number, MLB, ROM !!!)
 
post-1358580-0-94162200-1518187472_thumb.png
 
Example Optiplex755:
by @ricoc90 (files and info): http://www.insanelymac.com/forum/topic/332512-guide-macos-high-sierra-1013-dell-optiplex-780-760-755-790-990/#entry2598770
 
Example Optiplex790/990:

by @morpheousman (files and info): http://www.insanelymac.com/forum/topic/332512-guide-macos-high-sierra-1013-dell-optiplex-780-760-755-790-990/#entry2595193

by @chris1111 (files and info): http://www.insanelymac.com/forum/topic/332512-guide-macos-high-sierra-1013-dell-optiplex-780-760-755-790-990/#entry2595284
Thanks @morpheousman and @chris1111
 
5. Copy your kexts of your Sierra HDD or SSD to EFI/Clover/kexts/other/
 
Example760/780:
these are my kexts for 10.13: other.zip
 
 
6. Important preparation with HD5450 (780/760/755)
 
With High Sierra, there is a black screen with the HD5450, because C2D and C2Q have no Injector iGPU. Since High Sierra, the HD5450 needs a rollback from Sierra.
WhateverGreen.kext + Lilu.kext does not work with LegacyBios, unfortunately.
 
Save in advance the following Kext's from your Sierra installation from /System/Library/Extensions:
 
AMDRadeonX3000.kext
AMDRadeonX3000GLDriver.bundle
IOAccelerator2D.plugin
IOAcceleratorFamily2.kext

 

Note: Optiplex 790 (or higher) with i? CPU with Injector GPU does not require rollback.
 
 
7. apfs.efi
 
This is the current apfs.efi from 10.13.4 DP2:
 
apfs.efi.zip
 
The current original apfs.efi can be found after each install or update in usr/standalone/i386/ (use ShowAllFiles!).
The new file system is only for SSDs. HDDs continue to work with HFS+.
 
copy the apfs.efi to EFI/Clover/drivers64/
 
 
8. Now High Sierra install on your HDD or SSD (Partitions with Guid scheme)
 
The installation, even with subsequent updates, can take place in several steps.
My experiences:
APFS two steps
HFS+ one step
 
8.1 With the HD5450 there is a black screen the first time after the install.
I take the SSD out of the Dell and connect it to another Mac.
Here I am using the app "EasyKext Pro" and doing the rollback from the backup (step 6 above - AMDRadeonX3000.kext, AMDRadeonX3000GLDriver.bundle, IOAccelerator2D.plugin and IOAcceleratorFamily2.kext from Sierra 10.12.6).
Reinstall SSD in the Dell and now we get a picture in High Sierra.
 
after installation:
 
9. Terminal (for unsigned apps)

sudo spctl --master-disable

 
10. Install Clover on your HDD or SSD (Legacy-Method):
 
Install Clover in the ESP
Bootloader / Install boot0af in the MBR
CloverEFI / Clover-EFI 64Bit SATA
Drivers64UEFI / EmuVariableUefi-64
Drivers64UEFI / OsxAptioFixDrv-64
Drivers64UEFI / PartitionDxe-64
Install RC Scripts In Target Volume
optional:
Theme, free choice
Install Clover Preference Pane
 
 
11. Copy your config.plist, DSDT, Kext´s and apfs.efi to your High Sierra HDD or SSD
 
 
after installation sound:
 
Please ask if you have problems with the AppleALC method! It is not hard to get it right.
 
optional Audio Optiplex780/760:
 
current AppleALC + Lilu in the Clover's Kext folder works for the Optiplex780/760 with:
LayoutID 11 (0B) ManualMode
LayoutID 13 (0D) autodetect Speaker/HP
 
The current release can be found here:
https://github.com/vit9696/AppleALC/releases
https://github.com/vit9696/Lilu/releases
 
optional Audio Optiplex755:
 
trial_AppleALC_Lilu_Optiplex755_layoutID28_1C.zip LayoutID 28 (1C) please report
 
optional Audio Optiplex790 and 990:
 
current AppleALC + Lilu in the Clover's Kext folder works for the Optiplex790/990 with:
LayoutID 15 (0F) ManualMode
LayoutID 16 (10) autodetect Speaker/HP
 
 
 
Night Shift Patch:
 
patched_signed_Night_Shift_CoreBrightness.framework_10.13.zip
 
Replace the original in /System/Library/PrivateFrameworks/ and reboot.
 
 
Tested graphics cards with High Sierra:
my XFX one HD5450: with DSDT patch and frame buffer "Shrike" works great with HDMI audio in the Optiplex780 with kext rollback from Sierra
@morpheousman´s HD5450 Bios-Patch: http://www.insanelymac.com/forum/topic/312656-guide-macos-sierra-1012-dell-optiplex-780-760-755-790-990/page-18#entry2369870
my EVGA Nvidia GT210: works with Inject Nvidia with High Sierra, but no HDMI audio possible
other User with GT710
Zotac GeForce GT 1030 2Gig Web Drivers only  - by @chris1111

Saphire Radeon HD 6670 1 gig - by @chris1111
 
 
Tested WLAN:
PCIe: TP-Link TL-WDN4800 N900 WLAN Dual Band up to 450Mbit/s to 2.4GHz or 5GHz, works OOB as Airport
PCI: TP-Link TL-WN851ND 300Mbit/s, works as Airport, thanks Maggo Attached File AtherosWiFiInjector.kext.zip
USB: TP-Link TL-WN725N Nano WLAN USB Adapter 150Mbit/s, not as AirPort
 
 
Developer Beta program:
[How-To] macOS High Sierra Developer Beta program without special registration, if anyone is interested!
 
post-1358580-0-08988900-1518187653.gif
com.apple.seeding.plist.zip
 
Copies the com.apple.seeding.plist file to /Library/Preferences/ (not S/L/P)
 
and open Terminal:

sudo softwareupdate --set-catalog https://swscan.apple.com/content/catalogs/others/index-10.13seed-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

see AppStore/Updates  :thumbsup_anim:
 
Note:
If the value is in com.apple.seeding.plist = 2, then it is Developers Beta program.
If the value in com.apple.seeding.plist is = 3, then it is Users Beta program.
 
Users Beta:

sudo softwareupdate --set-catalog https://swscan.apple.com/content/catalogs/others/index-10.13beta-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1.sucatalog.gz

see AppStore/Updates  :thumbsup_anim:
 
 
Credits/Sources - Thanks to all mentioned users:

InsanelyMac.com & root86.com
@Slice and all others for the Clover Bootloader
@vit9696 and @vandroiy2012 for AppleALC and Lilu
@pepto, @polyzargone, @morpheousman, @chris1111, @owbp, @ricoc90 and all others for all Optiplex 780 (760) Guides!
 
 

have fun :wub:  Optiplex

Edited by MacPeet

Share this post


Link to post
Share on other sites
Advertisement

It's already done, but I can not try every Optiplex XXX.

Nice that everything goes with you.
 
Here are problems with DP Beta 10.13.4 right now. Audio with AppleALC / Lilu is not working anymore. I'm waiting for DP Beta 3. I'll report ...

Share this post


Link to post
Share on other sites

Running High Sierra 10.13.2 on both Optiplex 790 i7-2600 @ 3.4Ghz, and Optiplex 990 i5-2400

 

DSDT with edits for HD 5450, and Sound with AppleALC + Lilu - LayoutID 15 (0F)) 

 

DSDT edited to use USBInjectAll.kext. (no Config Edits for EHC1 to EH01 - EHC2 to EH02)

 

Both CPU's have Injector GPU, so no Video Kext Rollback is needed.

 

Nightshift works. Bluetooth, and wake from Bluetooth Device, using Broadcom USB Dongle, Chipset 20702A3.

 

Everything works. :)

 

Sapphire Radeon HD 5450 Wake from sleep video bios fix.  http://www.insanelym...18#entry2369870

 

wh06l1.png

 

790-990.zip

Edited by morpheousman
Update File

Share this post


Link to post
Share on other sites

@Macpeet

Thanks for new Guide  ;)

Here my EFI Folder Optiplex 790 for High Sierra 10.13 to 10.13.4

EFI folder containing all the Drivers64, Drivers64UEFI and a stock DSDT. GFX0 is renamed to IGPU No Graphics patch in the DSDT.

 

The default config.plist is for the Saphire Radeon HD 5570 1 gig (native support)

Sleep and wake works

 

The 5450 config works on all Radeon HD 5450 1 gig or 2 gig

 

The GT 1030 config is for the   Zotac Geforce GT 1030 2 gig (Web Drivers) Sleep and wake works

 

The config 6670 is for the Sapphire Radeon HD 6670 1 gig (Native suppoort)

 

Note: My Optiplex  790 have a ➜ CPU i5 2500k with Injector GPU so all this Graphics card works with the config.plist in the EFI Folder

​no kext rollback is need with the i5 2500k

EFI Optiplex 790 (HS-10.13).zip

Share this post


Link to post
Share on other sites

 

 

Everything works. :)

 

Sapphire Radeon HD 5450 Wake from sleep video bios fix.  http://www.insanelym...18#entry2369870

 

 

I Thank you for the tip :D I just flashing my XFX Radeon HD 5450 with this ➤ Bios XFX Radeon HD 5450 and now Sleep Wake works

 

Now I have 3 card with Working Sleep and Wake  :thumbsup_anim:

Share this post


Link to post
Share on other sites

some new experiences:

Since beta2 and beta3 10.13.4 AppleALC + Lilu no longer worked on my Dell 780 with the Analog Device AD1984A. According to kextstat both are loaded. Only HDMI audio works.
Today I tried a little. A rollback original AppleHDA of 10.13.3 and everything works again.
Apple tries again here a blockade in the new AppleHDA's?
I will continue to talk about the next beta's ...

Share this post


Link to post
Share on other sites

optional Audio Optiplex755:

 

attachicon.giftrial_AppleALC_Lilu_Optiplex755_layoutID28_1C.zip LayoutID 28 (1C) please report

As promised in the Sierra thread hereby my report :D 

The front speakers are working, back speakers are working but no microphone on both inputs

 

Example Optiplex755:

no data yet

@ricoc90 ?¿?¿?

Coming up later today  ;)

Share this post


Link to post
Share on other sites

As promised in the Sierra thread hereby my report :D 

The front speakers are working, back speakers are working but no microphone on both inputs

 

In the trial version of earlier ran the inputs? I probably deleted the data.

Share this post


Link to post
Share on other sites

In the trial version of earlier ran the inputs? I probably deleted the data.

IIRC they did not work in previous versions either 

Share this post


Link to post
Share on other sites

Hereby the essential Optiplex 755 files (currently running on 10.13.3, imac10,1 SMBIOS, Clover r4417):

- Config.plist
- DSDT
- Kexts

Optiplex_755_Essentials.zip

In addition to the other information about the 790:

 

If running onboard Intel HD 3000 graphics, DP works OOB. However, VGA does not. It does work with the following patch, however it should be noted that VGA only works once you are fully booted and manually searched for displays in the display control panel. In my case this breaks sleep.

			<dict>
				<key>Comment</key>
				<string>Patch: HD3000 VGA</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AgUAAAAEAAAHAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelSNBGraphicsFB</string>
				<key>Replace</key>
				<data>
				BgIAAAAEAAAIAAAA
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>Patch: HD3000 DP</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AwQAAAAEAAAJAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelSNBGraphicsFB</string>
				<key>Replace</key>
				<data>
				AwQAAAAEAAAGAAAA
				</data>
			</dict>

Credits to Hervé and Chris1111.

 

However, it is also possible to use the onboard graphics and a GPU card at the same time. For this you'll need to change the video settings in the BIOS and it should be noted that this only works if there actually is a monitor (or a dummy) present on both outputs upon booting. In my case the Optiplex POSTS to the onboard graphics, but once macOS is fully booted the graphics card comes up too. 

Edited by ricoc90

Share this post


Link to post
Share on other sites

I Thank you for the tip :D I just flashing my XFX Radeon HD 5450 with this ➤ Bios XFX Radeon HD 5450 and now Sleep Wake works

 

Now I have 3 card with Working Sleep and Wake  :thumbsup_anim:

 

 

@Chriss1111,

 

Are you using a custom SSDT with your 790, or just using the inject AppleIntelCPUM in clover in Clover?

 

Just checking some details on my installs, and realized that, like a dummy, i was still using NullCpuPower kext.  :wacko:

 

i7-core seems to be running a little more efficiently now. :)

Share this post


Link to post
Share on other sites

@Chriss1111,

 

Are you using a custom SSDT with your 790, or just using the inject AppleIntelCPUM in clover in Clover?

 

Just checking some details on my installs, and realized that, like a dummy, i was still using NullCpuPower kext.  :wacko:

 

i7-core seems to be running a little more efficiently now. :)

I am using this

 

<key>KernelAndKextPatches</key>
<dict>
<key>AppleIntelCPUPM</key>
<true/>
 
Never using NulCPU and AICPU patch

Share this post


Link to post
Share on other sites

That was a quick answer.  Do you sleep with your computer. lol

 

Thank you!

Sleep and wake works with my Radeon HD 5570, 5450 (bios change), GeForce GT 1030

See my config.plist in my EFI for the Radeon 5450 FakeID and Frambuffer Cedar is need

Share this post


Link to post
Share on other sites

So, now that we're back: 10.13.4 DP 4 works as expected on my 790 

 

Schermafbeelding 2018-03-10 om 19.47.42.png

 

EDIT: I see that previous attachments are gone. I'll repost the 755 files later.
EDIT2: Attachments seem to be restored already 

Share this post


Link to post
Share on other sites

I had to edit both first posts. The attachments did not work.

Here also 10.13.4 DP Beta4 works on 780.
Again rollback of the AppleHDA of 10.13.3. The new AppleHDA's do not work with the analog device AD1984A (AppleALC + Lilu).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By h2onions
      Hey all,
       
      First Hackintosh that I think I have completed! I've been working on it on and off for a month, but just grinded it this past weekend. I just have a small QOL issue. I have posted in the r/Hackintosh reddit, but have not gotten a reply to this specific issue, but did for other issues I was having. I also posted at tonymacx86 and was getting replies for other issues I was having, but got banned because I said, "used VM, but didn't work" in my OP I think ...
       
      I followed a PC vanilla guide from r/Hackintosh that I found as I did not have an Apple system. One monitor connected to a GTX 1080, CPU: i7-8700, Coffee Lake. Motherboard is Alienware specific 0VDT73, with chipset Z370.
       
      The issue is every time High Sierra boots up and gets to the login screen, my keyboard and mouse do not work. I only have to reseat both and then they work the whole time until I restart. They are both plugged into USB2.0 ports. I do have Lilu, WhateverGreen, USBInjectAll, and VoodooPS2 installed in my /Library/Extensions folder using #####. Mouse and Keyboard work fine each time I boot to Clover (USB). Any ideas?
       
      Thank you!
      Working: NVIDIA using (One) DisplayPort, USB3.0 (rear), USB-C (rear), USB2.0 (rear), Audio, Ethernet
       
      EDIT: Did some more testing, and it looks like my Keyboard works fine after each reboot, the only issue is that my mouse has to continuously be reseated. Any ideas? Could it just be the mouse?It's an old Inland USB mouse: 337451
    • By Gymnae
      Introduction
      The H370 chipset powers 8th generation Intel Core-i CPUs. Even though the name H370 rings comparable to Z370, the H370 is based on newer silicon. This it also requires some new approaches compared to the Z370. An example would be on-die USB 3.1 and WiFi support.
       
      Since this guide is not a "hold-your-hand-every-step" guide, I assume you know:
      Clover installation and configuration How to create an install medium for MacOS Access and configure the BIOS Have heard of ACPI patching (I'm a newb at this myself)  
      What works
      Sleep (via DSDT edits and emulated NVRAM) On-board Audio (via AppleALC and native AppleHDA) Native power management (without any kext or patch) All USB ports (and only those present are active) iGPU for both acceleration and display dGPU (I'm running an Nvidia GTX 1080)  
      Untested
      NIC --> I'm using WiFi only  
      What doesn't work
      Native NVRAM via AptioMemoryFix.efi DMVT Pre-alloc higher than 64MB (but not necessary)  
      Community additions
      User @Panzerschiffe added a helpful post, altering this guide for user with AMD cards and not needing on-board sound.
      He also runs Mojave, which I don't run yet.
       
       
      Changes to the guide:
      22.5.18: Added SSDT hot-patching to enable sleep, replacing DSDT static patching as an alternative.
      23.5.18: Add iMac18,1 as alternative SMBIOS config for those relying on the iGPU for output
      25.6.18: Added update info
      28.8.18: Small changes for clarity, changed info for afps loading & updated USB patch for 13.6
      04.10.18: Update to Mojave will come once Mojave is more mature
      02.12.18: Removed unnecessary patches, fakepciid and audio patch method & linked to AMD post & added whatevergreen.kext as replacement for previous GPU kexts
      02.03.19: Removed unnecessary fakeid and ig_platform_id injections, ACPI patches - this is all handled by whatevergreen & lilu. In testing is a Framebuffer patch, see this post.
      04.03.19: Added Germany keyboard layout and updated pre-patched DSDT.aml removed DSDT patching
       
       
      1. Installation
      This guide heavy inspired by the work of /u/corpnewt of /r/hackintosh and his (sorta) Vanilla guide
       
      1.1 Create the install media for MacOS
      Follow this, if you are using a Mac to start off with. If you are totally new to MacOS, then please check the basic guide Creation of an installer media in windows or linux
       
      1.2 Install Clover on the install media
      Using the Clover installer, ensure you are installing to the USB medium you are using for the installer.
      Chose the following options, leaving the others on default: 
       
      UEFI driver: AptioMemoryFix UEFI driver: ApfsDriverLoader UEFI booting only Install to ESP  
      You have to get your hands on an apfs.efi. A google search can help, or extracting it from the Installer package. Make sure you procure a version matching the MacOS version you are about to install. Place the apfs.efi in drivers64UEFI.
       
      1.2 Adjust the config.plist for the installer
      You can use the config.plist attached as a guideline, but take a look at it before and at least adjust the SMBIOS - otherwise it won't boot.
      Attention: The attached plist contains audio patches introduced by a post-install step. If you run into problems, you might remove those. It also contains a manual slide value, which should normally not be needed, but works fine for me. It is also tuned for usage with an Nvidia Pascal dGPU as main GPU.
       
      The config you create now should serve you nicely for install and running the system.
       
      Take care of adding the following basics:
      SMBIOS: iMac18,3 - You can generate a serial number via Clover Configurator. The creation of a proper SMBIOS is covered in many guides to good extend Note: If you aim at using the iGPU for output, a user reported that iMac18,1 works better - since iMac18,3 produces severe flicker. I'm now also testing 18,1 Look at the graphics section and adjust the injection for Intel to your situation  
      Fixes

      Patches

      Devices

      Graphics
      Important:
      Change 0x59120003 to 0x59120000 if you don't use a dGPU as your main display Driver and instead use the iGPU for output.
      Also note. SMBIOS iMac18,1 has been reported to work better in this configuration. But 18,3 works fine for me.

      Kernel and Kext patches
       
      1.3 kexts and friends
      Add the supplied SSDT-UAIC.aml to "patched" - it limits the injected USB Ports to the actual number and ports valid for this board.
       
      Required kexts on "Other":
      FakeSMC.kext Whatevergreen.kext Lilu.kext AppleALC.kext IntelMausiEthernet.kext in case you're running Ethernet USBInjectAll.kext with the HCI-300-series-injector.kext --> These two should be installed to /L/E after install  
      We are leaving sound out at the moment, this is something for post-install.
       
      1.4 Check BIOS and install
      You should be ready for install. But before you reboot, please take a look at your BIOS and set it up accordingly (copied from the aforementioned guide and adapted):
      Load Optimized Defaults Disable VT-d setting If your system has Secure Boot Mode, disable it Enable CSM - This is sometimes needed to dual screens to work Set OS Type to Windows 8/10 or OtherOS - I have not seen a difference Turn off internal Serial and Parallel port Turn off Network stack for boot Turn off wake-on-lan (for now) Set XHCI Handoff to enabled Don't enable decode over 4G Depending on your GPU, set priority for boot Set internal GPU (iGPU) to enable - not auto or disabled Set DMVT pre-alloc min to 64MB and max to 128MB. For this selection to appear you might need to reboot after setting iGPU to enable Set USB legacy to enabled Activate XMP profile 1 f your Ram has it (mine doesn't and I added the timings manually) Set ERP to enable, disable platform power management (I need to do more research if this could be enabled)  
      I've attached my current BIOS config "hack2". You can place that on a fat32 drive (the EFI partition of your install USB drive might be an idea) and see if it loads. It's made for and with the F2 BIOS.
       
      The install itself should be like other MacOS Hackintosh installs with it several reboots and ensuring to select the correct boot device in Clover.
       
      2. Post-install
       
      2.1 Install clover on target
      This is a no-brainer, but install a fresh copy of Clover on your target medium.
       
      During install select again AptioMemoryFix but also additionally
      EmuVariableUefi-64.efi Install RC scripts on target volume because otherwise NVRAM doesn't seem to work
       
      After the install, copy
      config.plist contents of "Other" content of "patched" to your new clover install.
       
      2.2 Edit ACPI for slumber
      Choose one option, not both. The hot-patch is experimental, but for the moment it is stable.
       
      2.2.1 Edit DSDT
      No more need for manual DSDT patching. If you still do it, you might run into unstable sleep. SSDT hot-patching + sane clover.config edits are enough
       
      This is necessary only once on initial install and every time, you edit or upgrade the BIOS. The DSDT.aml attached to this post might work for your system or give you a file to compare to. Don't expect it to work for you, though.
      EDIT: Since moving from F2 BIOS to F12 I did not repatch and sleep is still somewhat reliable. But to be 100% sure, you can still follow these steps.
      I won't go into the details of DSDT extraction and patching. There are better guides (the linked guide is a rip-off of rehabman's guide from a different forum). Please follow such a guide to extract your ACPI data.
       
      Locate and disassemble the DSDT with the newest iasl binary you can put your hands on, then open it with MacIASL in its newest version you can find (Hint: Here is a good source) You can check if the version is new enough if MacIASL doesn't throw error upon compiling a freshly extracted DSDT.aml or DSDT.dst
       
      Add rehabmans repo (as per linked guide) and apply the following patches:
      Rename _DSM to _XDSM Fix _WAK Arg0 v2 USB3 _PRW 0x6D Skylake (instant wake) Find the CNVW device and remove the _PWR function there.
       
      Compile the DSDT and place it in "patched".
       
      2.2.2 Use SSDT hot-patching
      Instead of having to re-extract and re-patch the DSDT on every BIOS change or update, Hardware change one can also use ACPI hot-patching.
      It's a combination of config.plist patches and an SSDT, which is hot-patched into the ACPI (if I understand the process correctly)
       
      You need to add this SSDT-GPRW.aml to your Clover folder in the designated position at Clover/ACPI/patched You need to add this patch to your config.plist. It goes into the DSDT patch section  
      Note: This works for me, but the patch removes the _PRW method from all devices in the DSDT. This could have side-effects. So far, I have seen none. At the moment I'm also not applying any other patch, compared with the additional edits I made to the DSDT method before.
       
      2.3 Install kexts to system
      As mentioned in the install section, it's better to follow rehabman's instruction and install USBinjectAll.kext to /L/E:
      sudo cp -R Release/USBInjectAll.kext /Library/Extensions sudo touch /System/Library/Extensions && sudo kextcache -u / 2.4 Enable onboard Audio - Install AppleALC kext
      Make sure your EFI partition is mounted and that you have a vanilla AppleHDA kext available. See below for a guide how to get a vanilla AppleHDA if needed
      Note: Our Audio codec is ALC887 and it's running with layout ID 1.
      Download the newest AppleALC kext from here and install it together with lilu.kext from here into your usual /clover/kexts/others location. Done. No scripts or config.plist patches necessary.
      Add layout ID 1 to config.plist, if it's not there yet:
      <key>Audio</key> <dict> <key>Inject</key> <integer>1</integer> <key>ResetHDA</key> <true/> </dict> If you previously  installed any  audio patches, please follow this guide to "vanilla-ize" your install.
       
      2.5 Optional steps for Graphics
      If you have a dGPU, now it's the time to install its drivers and adjust the config.plist for it. The detaisl are specific to your GPU and thus of scope of this guide. Yet, my supplied config.plist is ready to be used with Nvidia Pascal cards and using the Nvidia web driver.
      Whatevergreen.kext helps with Intel iGPU and NVIDIA dGPU fixes.
       
      At the moment I'm also testing out a special bootflag: 'shikigva=12' to enable faster rendering in Final Cut Pro X. Without whatevergreen.kext and a shikigva bootflag, rendering in final cut seem very slow.
       
      2.5.1 Framebuffers
      If you're facing problems with output from your internal GPU, you can try the framebuffer patches listed by @BackwardMac:
       
      2.6 Install a proper keyboard layout
      You might not be using a fancy Apple branded keyboard. If you use a PC keyboard, you might be annoyed by the differing layout and usage of keys. As a German, you might find yourself quitting applications, since alt gr + Q won't add an @, but quit your current application. To fix this, you can simply install a different keyboard layout. Copy it to /Library/Keyboard Layouts/ and chose the layout in System Preferences, Keyboard in the section "Other". Deleting the previously selecting layout makes sure that only this one is used. Nice little trick.
       
      A keyboard layout for German keyboards is attached and works wonders
       
      3. Updating
      Updating inside 10.3.x/ 10.4.x point updates doesn't require much attention:
      Download the update from the AppStore as any Mac would do Allow the system to reboot Before booting MacOS with Clover, make sure to disable extra drivers for dGPUs which require non-native support. If using an Nvidia dGPU: Remove "nvda_drv=1"  from your boot arguments and disable Nvidia injection If using a non natively supported AMD card, do the same for AMD (I'm not using AMD, thus I cannot be specific) Boot into the newly created Install MacOS partition Repeat this process until the Install partition is gone Boot MacOS again, still following 3., and potentially install updated drivers Your Audio might require re-patching  
      4. ToDo
      Move away from static DSDT patching to SSDT hotpatching --> requires my work Native NVRAM --> requires developer work Audio without AppleHDA patching --> requires developer work  
      5. Thanks to
      @MaLd0nfor helping finding the right way with the DSDT
      @RehabMan, for being a legend and helping me out patching
      @toleda, for audio patches for the 300 series
      /u/corpnewt, for his superb vanilla guide
      @wmchris for his super XPS 9550 guide and introducing me to hot-patching
      @Panzerschiffe for his addition to this guide
      all the developers of clover and it's awesomeness
       
      SSDT-UIAC.aml
       
       
       
      win-germany.keylayout
       
    • By Utku
      Hi guys, I have a big problem for VT -x. I tried any things for example: dark=0 or already bios option is virtualization is enable. I don't understand this problem.
       
      Thanks guys!! And yes I have intel Q8400 quad core cpu, motherboard is Asus asus p5g41c-m lx.
       


    • By NoEnd
      Hi team,
       
      I have tried to update to security update 2019-001 multiple time with no luck, today I've booted the update with -verbose and attached videos shows the details.
       
      Appreciate your help
       
      Thanks
      Untitled.mov
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
×