Jump to content
About Just Joined group Read more... ×
MacPeet

[Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)

623 posts in this topic

Recommended Posts

Mojave running fine on my Optiplex 755.
 

Only two "issues":

TL-WN851ND did not work, since AirportAtheros40.kext has been removed from  Mojave. Taking the kext from High Sierra fixed that.


No sound with AppleALC
G5K0yEr.png

 

Edit: Not sure why, but after a reboot AppleALC started to work again.

Edited by ricoc90

Share this post


Link to post
Share on other sites
Advertisement

@ricoc90

 

Sound -> try this:

 

Archiv.zip

 

AppleALC1.3.0 and Lilu1.2.5 with custum boot flags in Clover: -alcbeta -lilubetaall

 

...and...

 

Yes, here too Mojave on non SSE4.2 systems:

Optiplex780 with C2Q 9400 and HD5450 (HD5450 still without QE / CI)
my P9614 with C2D T9600 and GT330M full QE/CI

Edited by MacPeet

Share this post


Link to post
Share on other sites

Hi, I've followed this guide as closely as possible (with the exception the "mount your EFI partition" step because I wasn't sure how to) for my Optiplex 755 with an E8400 (with and without the Quadro NVS 295 I hope to use), but I could not boot into Clover/the installer. Are there any troubleshooting steps I should do other than attempt another clean install?

Share this post


Link to post
Share on other sites

I have ordered a MSI GT710 2GB, is there tomorrow. More hope for Mojave.

 

@chris1111
Which runs without a web driver? Nativ with Inject Nvidia?
 

 

@ricoc90

The audio solution Mojave in the post you have not seen?

Edited by MacPeet

Share this post


Link to post
Share on other sites
22 hours ago, MacPeet said:

I have ordered a MSI GT710 2GB, is there tomorrow. More hope for Mojave.

 

@chris1111
Which runs without a web driver? Nativ with Inject Nvidia?
 

 

@ricoc90

The audio solution Mojave in the post you have not seen?

I have the Gygabyte GeForce GT 710

71Y05Ap0RuL._SL1500_.jpg.36ebbfde2de72da312f3f222a66d158d.jpg

No web Drivers Your only have setup Inject Nvidia =False

No audio HDMI I dont care Iam not using HDMI Audio

I see your picture METAL is not support ?

Edited by chris1111

Share this post


Link to post
Share on other sites

OK thanks
The GT710 works in Mojave with and without Inject Nvidia. Both tried and both goes.
HDMI Audio I test later.

Metal is supported.
Metal: "Unterstützt" = supported (Features: 1v1 and 1v2)

Share this post


Link to post
Share on other sites

Success on Gygabyte GeForce 210 1Gig

Spoiler

With Dell Optiplex 790 

Cpu i5 2500

61p3asl3WtL._SL1000_.jpg.c5b21aa5e7c609eb07433be225cb4ed7.jpg

buy today at Canada Computer for $ 45 Canadians box :lol:
Everything works Full QE / CI

Video Screen recorder works :hysterical:
Only problem he recognizes me two identical display

Double Display Fix Using DVI

Slow boot stall on AppleHDA fix by install VoodooHDA 2.9.0 

Boot is super fast! :plane:
NEW *** Video How to make GeForce 210 working in macOS Mojave 10.14

captur82.png.74b344a045131f66f3ba1829630924ce.png

When I fix all issue I will post a Package installer for make perfect functioning :thumbsup_anim:

 

EDIT *** All issue Fix

New Video and README.pdf How to make GeForce 210 working in macOS Mojave 10.14

Sleep and wake works!

Credit: dosdude1, ASentientBot 
Credit: Packager chris1111
Credit: Testeur emax31

Credit VoodooHDA Developer Slice, Zenith432, autumnrain 

My config:

- Dell Optiplex 790

- CPU i5 2500

- SSD Kingston 250 g

- Gygabyte Nvidia GeForce 210 1Gig

- 8 Gig Ram Corsaire ddr3

Clover 4600 mode ESP

README.pdf.zip

 

Edited by chris1111

Share this post


Link to post
Share on other sites

news from my Optiplex780 :wub: with the gt710 (Mojave)


Onboard audio works again with rollback AppleHDA 10.13.3 (AudioCodec Optiplex780 in AppleALC has broken since 10.13.4)
HDMI Audio with the gt710 now works with HDMIAudio.kext in Clover /other

 

Edit:

@chris1111

sorry, the first test was still with InjectNvidia=true
now with InjectNvidia=false I have 4 ports and Metal
now everything is perfect with graphics and audio

sorry and thanks :thumbsup_anim:

 

Dell_GT710_Mojave2.thumb.png.56fb4e748277fa642cca8926081566e1.png

 

Edit2:

amazing, the GT710 works in the Optiplex780 with 10.13.6 also native, despite missing Injector iGPU. Also no WhateverGreen needed.

Edited by MacPeet

Share this post


Link to post
Share on other sites
On 7/13/2018 at 5:13 PM, MacPeet said:

 

@ricoc90

The audio solution Mojave in the post you have not seen?


I did, but no time to test yet. I'll have a day off tomorrow and then I'll take a look :D

Thanks

Share this post


Link to post
Share on other sites
On 7/15/2018 at 6:22 AM, MacPeet said:

news from my Optiplex780 :wub: with the gt710 (Mojave)


Onboard audio works again with rollback AppleHDA 10.13.3 (AudioCodec Optiplex780 in AppleALC has broken since 10.13.4)
HDMI Audio with the gt710 now works with HDMIAudio.kext in Clover /other

 

Edit:

@chris1111

sorry, the first test was still with InjectNvidia=true
now with InjectNvidia=false I have 4 ports and Metal
now everything is perfect with graphics and audio

sorry and thanks :thumbsup_anim:

 

Dell_GT710_Mojave2.thumb.png.56fb4e748277fa642cca8926081566e1.png

 

Edit2:

amazing, the GT710 works in the Optiplex780 with 10.13.6 also native, despite missing Injector iGPU. Also no WhateverGreen needed.

Hi Macpeet, 

   I use the same Dell optiplex and the same GT710, Could you zip up the HDMIAudio.kext you used so I can test my HDMI audio.

Share this post


Link to post
Share on other sites

@Deanor30

HDMIAudio.kext.zip

 

@all users

 

trial_AppleALC_Lilu_Optiplex780_755.zip


Please try (this is trial AppleALC1.3.0 and Lilu1.2.5):

Here the LineIn's work on my Optiplex780 now with simple external Mic.
For Optiplex755 also changed, please try.

 

Optiplex780 / 760:
LayoutID 11 or LayoutID 13
The codec in AppleALC is broken for 780/760 since 10.13.4. Rollback AppleHDA from 10.13.3 is necessary.
only Mojave Bootflags -lilubetaall -alcbeta

 

Optiplex755:
LayoutID 28
only Mojave Bootflags -lilubetaall -alcbeta

Share this post


Link to post
Share on other sites

Hey Folks, 

    Trying to build an installer for mojave on a dell 760. Please see screen shot of system spec. Can you advise if you used the steps as per the High Sierra guide?? I have used these steps to create the installer and I keep getting a crash.... black screen  with white stop circle..... 

Share this post


Link to post
Share on other sites

Considering jumping to Mojave. I have a 780 SFF with GT 710 1GB running Sierra. Should I upgrade to High Sierra before trying Mojave or do you think I could go straight to Mojave? Thanks!

Share this post


Link to post
Share on other sites
14 hours ago, Deanor30 said:

Hey Folks, 

    Trying to build an installer for mojave on a dell 760. Please see screen shot of system spec. Can you advise if you used the steps as per the High Sierra guide?? I have used these steps to create the installer and I keep getting a crash.... black screen  with white stop circle..... 


Creating the installer is somewhat the same process, but depending on the SMBIOS you're using you'll need to boot with -no_compat_check

Share this post


Link to post
Share on other sites
1 hour ago, ricoc90 said:


Creating the installer is somewhat the same process, but depending on the SMBIOS you're using you'll need to boot with -no_compat_check

HI Ricoc, 

 Please see my specs attached!!

Screen Shot 2018-07-19 at 17.48.30.png

Share this post


Link to post
Share on other sites

@Deanor30 Should be fine. Boot with -v and send a pic

Share this post


Link to post
Share on other sites

create usb install flash drive Mojave DP or Beta (8GB)
Install new Clover (Mojave Ready)
Copy your DSDT and Kext's to Clover (/ other)
SMBIOS iMac13.1 or later is supported for Mojave

 

- Install Mojave
- after install and before the first start:
C2D or C2Q in the Optiplex 755/760/780 are unsupported SSE4.2
SSE4.1 Patch:
Replace Mojave ... /System/Library/UserEventPlugins/com.apple.telemetry.plugin with PlugIn from HighSierra ... /System/Library/UserEventPlugins/com.apple.telemetry.plugin

(This step is necessary after every update)

 

done, now first start after install

Share this post


Link to post
Share on other sites
On 7/20/2018 at 12:54 PM, MacPeet said:

create usb install flash drive Mojave DP or Beta (8GB)
Install new Clover (Mojave Ready)
Copy your DSDT and Kext's to Clover (/ other)
SMBIOS iMac13.1 or later is supported for Mojave

 

- Install Mojave
- after install and before the first start:
C2D or C2Q in the Optiplex 755/760/780 are unsupported SSE4.2
SSE4.1 Patch:
Replace Mojave ... /System/Library/UserEventPlugins/com.apple.telemetry.plugin with PlugIn from HighSierra ... /System/Library/UserEventPlugins/com.apple.telemetry.plugin

(This step is necessary after every update)

 

done, now first start after install

Hey folks, 

   When I create the USB installer using the method as in the High Sierra tutorial and apply clover to same and import my config.plist and DSDT I cannot get the Dell to boot from the USB installer. I have added my kexts to 10.14 kext folder and other folder in clover.  I am putting mojave on a blank hdd. When I connect my high sierra hdd which has the latest clover bootloader on it, I can boot from same and select the USB installer and install mojave on the blank drive. When i then apply clover to same again importing my config.plist,  DSDT and kexts folder, again I cannot boot from the mojave drive. This is identical to the EFI partition I have on my High Sierra drive which boots with the exception of the 10.14 & Other folder in EFI/Clover/Kexts. Anybody have any suggestions on why the Mojave drive or USB installer are not bootable??

Share this post


Link to post
Share on other sites
On 7/25/2018 at 3:37 PM, MacPeet said:

Clover installed correctly ?
the newest apfs.efi in EFI/CLOVER/drivers64/ ?
Telemetry patch done ?

Hi Macpeet, 

  Yes clover r4617 installed correctly mounting the EFI in the process. I have used the latest apfs.efi and I cannot see how the telemetry patch affects the usb installer since this is applied after the install. Would it be possible to get a zip of your clover folder without your config.plist for the dell 780??

Share this post


Link to post
Share on other sites

oh sorry @ Deanor30 now I understand

Yes, telemetry patch is for after the install, sorry.

Yes, with the DSDT from a long time ago and USB_Injector.kext no USB stick worked here.
Long ago, I deleted the EHCI devices in my DSDT and switched to USBInjectAll.kext. OSX configures the USB2 with it alone.
try this !!!

 

Archiv.zip

 

Note:
config.plist -> I deleted my serial's / MLB / ROM!

my DSDT is configured for GT710 (HD5450 patch is deleted)

Share this post


Link to post
Share on other sites
On 7/18/2018 at 10:28 AM, MacPeet said:

@Deanor30

HDMIAudio.kext.zip

 

@all users

 

trial_AppleALC_Lilu_Optiplex780_755.zip


Please try (this is trial AppleALC1.3.0 and Lilu1.2.5):

Here the LineIn's work on my Optiplex780 now with simple external Mic.
For Optiplex755 also changed, please try.

  

Optiplex780 / 760:
LayoutID 11 or LayoutID 13
The codec in AppleALC is broken for 780/760 since 10.13.4. Rollback AppleHDA from 10.13.3 is necessary.
only Mojave Bootflags -lilubetaall -alcbeta

 

Optiplex755:
LayoutID 28
only Mojave Bootflags -lilubetaall -alcbeta

 

I tested the new trial (July 18) AppleALC and Lilu on my Optiplex 755 using macOS 10.12.6 (Sierra). Before and after installing the latest security updates for Sierra, both audio outputs worked perfectly and headphones auto-detected. For the input, there are now two Line-In options in the sound preferences, but neither option worked with a known good microphone using the front microphone port. I do not know how to safely test the combined line-in/microphone port on the back; suggestions?

Share this post


Link to post
Share on other sites

OK thanks. On the Optplex780, the new patch has helped.
I was hoping for the 755, too. Unfortunately, apparently not. Thanks for the report.
Combined LineIn back just try with external mic!

Share this post


Link to post
Share on other sites

Unfortunately, the combined input also did not work with a working microphone, which I checked again after testing to make sure it still works.

 

Additionally, it is worth noting that in the April trial there was only one line-in option and it did not have a "Reduce Ambient Noise" check box. This new one has that option for two inputs.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By gekko.be
      I have an old Hackintosh that I have brought back to life. An ASUS P5KPLAM-SE mobo, Intel Core 2 Quad, with a Sapphire HD 5670 1GB graphics card. It used to work just fine on High Sierra 10.13.3 (I think it was .3) However I only used the DVI port. Updated to 10.13.6 and with AMD kexts rollback to the previous versions I got everything o wrk just fine: boot, HDMI video, HDMI audio etc etc. The only problem I face is that my USB keyboard and mouse freeze/hang seemingly very random... I can not seem to get it right. Unplugging and replugging the USB device makes it work again, sometimes for a few seconds sometimes for an hour ... No idea what's wrong... Have tried tons of options in clover, USBInjectall.kext with port limit patch, whatever I could find... Would there be anyone out there who would have an idea of what could be the problem?
    • By macinsane
      *This guide is deprecated and will not be maintained anymore*

      Update: Now running Mojave! Thanks to mojave2core! Yeah   Still using C2D in 2019!
      Inserted a nice and cheap GT710 that is not relying on nVidias Webdrivers and runs OOB under Mojave.
       
      Nice, seeing High Sierra running on this old but capable system! It rocks with a new ASUS GT1030
       
      Config:
      Gigabyte EP43-DS3L
      Core2Quad Q9300
      6 GB DDR2 RAM
      Asus GT1030 2GB
      Sandisk SSD 128GB
      TP-Link AC1200 Wifi USB
      Inateck KT4006 USB 3.0 PCIe (No boot)
       
      SMBIOS: iMac14,1
      Clover: 4297  4360
       
      A good deal of DSDT editing was necessary to get this machine to boot High Sierra but finally it works flawlessly, even sleep and wake!
      You NEED to have the DSDT put in place for installation because otherwise macOS doesn't recognize the SATA ports.
      There are a few important BIOS settings: SATA hast to be set to AHCI and "native" and HPET has to be run "64-bit", I'd recommend to disable IDE and the serial and parallel port.
      For the GT1030 nVidia Webdrivers are needed, have to boot with nv_disable=1 until you have them installed.
      You have to install Clover in legacy mode because this old fella does not support UEFI.
       
      Only downside: The so often recommended Inateck USB-card isn't recognized by BIOS, so you cannot boot from it. It works perfectly within macOS though, have the ac-Wifi connected to it.
      config.plist.zip
      DSDT.aml.zip
    • By eLDeus
      Hello, can't figure out why there's no Line-In input option with VoodooHDA, but I definetly have it in my built-in audio card on the motherboard.
      Thanks!
    • By Rajan Pandit
      Hai, I have i5 2500k with 8GB Ram, GA-Z86 AP-D3 Rev. 1 (F3 Bios) with Samsung EVO SSD... 
      I Installed High Sierra 10.13.6, I use ##### to activate boot... everything is fine..
      but sometime my system Freeze..... and sometimes screen freeze but mouse worked
      means system is running.. mouse is also moving.. but Screen got freeze...
      please help me to resolve.. I really frustrated now. I install many times...
      but same problem... There is no graphic card in my system...
       
      please help me.. I am attaching my clover folder.. please help
      CLOVER.zip
    • By fusion71au
      Making a High Sierra USB Installer Entirely From Scratch in Windows
      This is a proof of concept tutorial, to show it's possible to create a vanilla High Sierra installer, entirely from scratch, in Windows (even without App Store downloaded "Install macOS High Sierra.app" from a real Mac ).  @PikeRAlpha's link to Apple's Software Catalog provides us with all the URLs necessary to download the needed files directly from Apple instead of some dubious source from the internet...
       

      Pre-Requisites
      8GB or larger USB drive.  Edit: Recommend 16GB or larger for macOS Catalina 10.16 Boot Disk Utility v2.1.2017rev021b from @CVAD TransMac (free 15 day trial) Paragon Hard Disk Manager Free Download Installer Files Directly from Apple
      1)  Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist (Hint - search page for "InstallESD" to find its URL and others nearby)

      to a folder named "SharedSupport" on your Windows NTFS drive.  A browser download manager (eg Chrono for Chrome, dTA for FireFox) is handy since InstallESD is >4GB ---> allows you to pause/resume interrupted download...

      2)  Rename InstallESDDmg.pkg to InstallESD.dmg
      3)  Edit InstallInfo.plist with WordPad/text editor to remove the chunklistURL and chunklistid keys for InstallESD, and renaming it from InstallESDDmg.pkg to InstallESD.dmg (example of edited file attached to this post)...
      Note:  You can verify the SHA1 checksum of your InstallESD.dmg and BaseSystem.dmg with the correct ones at this website.
      Boot Disk Utility to format the Installer USB and Restore OS X Base System HFS partition
      1.  Format USB with BDU & latest Clover ---> creates boot files in CLOVER partition + second FAT partition
      2.  Extract 4.hfs from \SharedSupport\BaseSystem.dmg with BDU --> save to it's local folder
      3.  Restore 4.hfs to USB second partition with BDU --->  2nd partition becomes bootable "OS X Base System"
      Paragon Hard Disk Manager to extend HFS Partition to its Full Extent
      Open Paragon Partition Manager Free and resize the second partition of the USB drive to the full size allowed.  Don't forget to apply the changes at the end...
      Transmac to Copy "SharedSupport" folder to OS X Base System
      1.  Open the TransMac program and navigate to the HFS+ Volume/Install macOS High Sierra.app/Contents folder.  Right click anywhere in the empty space on the RHS pane and select "Copy Here"...
      2.  In the next stage, select the "SharedSupport" folder we created above as the "Files and Folders to be copied to the Mac Volume"...
       
      Clover Settings
      Clover configuration is required now.  The default config.plist (in the Clover FAT32 partition of the USB) maybe sufficient to boot your machine if you’re lucky.  If not, the hackintosh-vanilla-desktop-guide has some good explanations on the various settings available and also offers sample configuration files based on CPU type.  Also, look at the Clover Wiki, Clover Instructions and Clover Configuration Thread for pointers and edit /EFI/Clover/config.plist accordingly with Wordpad or Notepad.
      The location of the important configuration files for Clover are summarized below
      config.plist--->EFI/CLOVER folder DSDT.aml with or without SSDT.aml--->EFI/CLOVER/ACPI/patched (don't need one if your DSDT is auto patched by Clover in config.plist) Kexts eg FakeSMC, NullCPUPowerManagement --->EFI/CLOVER/kexts/<osx version> or /Other. NB BootDiskUtility by default already has FakeSMC.kext installed here.  You may need to add VoodooPS2Controller for your laptop keyboard/trackpad to work. If UEFI booting, you will most likely need one of the OsxAptioFixDrv-64 drivers copied from /EFI/CLOVER/drivers-off/drivers64UEFI to /EFI/CLOVER/drivers64UEFI. If you want to use the installer to run High Sierra in Windows on VMware, you can follow my guide to set up the Virtual Machine and replace Clover's default config with EFI_Clover for VMware (which is compatible to run in VMware).  In the screenshots below, I have attached the USB Installer (in this case PhysicalDrive7) to my macOS Virtual Machine.  Reboot the system to the USB installer to install High Sierra ...
      What happens if we don't have access to TransMac or Paragon Hard Disk Manager?
      Not a problem, as long as we get "OS X Base System" bootable, we can launch terminal from the Utilities Menu to copy the SharedSupport folder over to the Installer app.  In essence, we will build the full installer app = 5GB+ on the target HD eg "Macintosh HD", by copying both the "small" installer app = 15MB (on "OS X Base System") and the SharedSupport folder from the NTFS volume (mounted in this example on /Volumes/DATA)...
      -bash-3.2# cd / -bash-3.2# cp -R Install\ macOS\ High\ Sierra.app /Volumes/Macintosh\ HD/ -bash-3.2# cp -R /Volumes/DATA/SharedSupport /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/  
      ...then start installation with the startosinstall utility...
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD --converttoapfs NO --applicationpath /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app  
      The above steps can be automated with the attached "startosinstall.command" script, which will assemble "Install macOS High Sierra.app" on "Macintosh HD" and launch the startosinstall utility targeting the "Macintosh HD" volume.  Copy/download to "Macintosh HD", then run in terminal (after attaching DATA USB with /Shared Support folder)...
      cd "/Volumes/Macintosh HD" chmod +x startosinstall.command ./startosinstall.command Updated Download Links for macOS Mojave 10.14.6_18G103
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      Note: In Mojave, Apple has removed the --converttoapfs NO and --applicationpath arguments from the startosinstall utility....
       
      eg to use startosinstall for the above section "What happens if we don't have access to TransMac or Paragon Hard Disk Manager?", the syntax is now
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD  
      This basically means that for Mojave, the default installation will always convert the target volume to the apfs file system.
       
      Updated Download Links for macOS Catalina 10.15.6_19G73
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      startosinstall.command.zip
      InstallInfo.plist_edited_10.13.6.zip
      InstallInfo.plist_edited_10.14.6.zip
      InstallInfo.plist_edited_10.15.6.zip
×