Jump to content
MacPeet

[Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)

405 posts in this topic

Recommended Posts

Advertisement

ive successfully run high sierra now, but i dont know how to get my audio work. Only the HDMI and AirPlay devices are listed in the Settings. Ive already tried copying the recent lilu and AppleHDA kexts into the /kexts/other folder on the EFI Partition

Share this post


Link to post
Share on other sites

Hi all ... I have managed to set up my 780 with High Sierra after a bit of struggle but now it boots without interruption and I'm rapt.

 

I had to edit the Clover boot loader options to specifically disable the ATI Injection option to get this to work.  I thought I would need this since I am using an ATI 5450 as many have recommended but with the option enabled this just threw a bunch of errors on the screen after trying to run the install or load options from the boot loader.

 

So now, my next priority is to get the resolution right.  The display should be set at 1920x1080 but it's set lower and stretched. 

 

How can I go about tweaking this resolution setting?  In the display properties there is only one option - 1280x1024.

 

Cheers

 

Paul

Share this post


Link to post
Share on other sites

Did you rollback kexts as explained in Step 6 & 8?

 



Save in advance the following Kext's from your Sierra installation from /System/Library/Extensions:
 
AMDRadeonX3000.kext
AMDRadeonX3000GLDriver.bundle
IOAccelerator2D.plugin
IOAcceleratorFamily2.kext

Share this post


Link to post
Share on other sites

hi morpheusman ... no.. I didn't ... I thought that was only necesary if the screen went black -- which it didn't

 

I'll try that tonight.

 

While I have your ear - so to speak - can you suggest how I would go about making whatever changes I need to make so that I can connect remotely (using eg VNC) to my hackintosh?  I tried from another machine on my home network and I keep getting "connection refused"

 

Cheers

 

Paul

Share this post


Link to post
Share on other sites
On 5/3/2018 at 10:03 PM, unrealpants said:

While I have your ear - so to speak - can you suggest how I would go about making whatever changes I need to make so that I can connect remotely (using eg VNC) to my hackintosh?  I tried from another machine on my home network and I keep getting "connection refused"

 

Cheers

 

Paul

 

I use TeamViewer, but have not used it in a while.

4 hours ago, Arsalan.ghaffar said:

hi, i got to installer but cant find my  HDD there, its currenlty in ntfs, running windows... optiplex 780, c2d...

31531605_641229302908015_6759720053601468416_n.jpg

 

 

Are your Bios Settings Correct, and is the Hard Drive seen in your Bios?

Share this post


Link to post
Share on other sites

Hi morpheusman

 

Did you rollback kexts as explained in Step 6 & 8?

 

Yes, I now have done this and it has worked!

 

Next challenge -- audio.  I tried following the steps but I had no luck with my Optiplex 7780 using the ALC method.

 

Any tips?  .... or are there some more detailed steps somewhere I can try to follow for this?

 

Cheers

 

Paul

Share this post


Link to post
Share on other sites
On 5/4/2018 at 4:03 AM, unrealpants said:

hi morpheusman ... no.. I didn't ... I thought that was only necesary if the screen went black -- which it didn't

 

I'll try that tonight.

 

While I have your ear - so to speak - can you suggest how I would go about making whatever changes I need to make so that I can connect remotely (using eg VNC) to my hackintosh?  I tried from another machine on my home network and I keep getting "connection refused"

 

Cheers

 

Paul


Maybe I'm joining the party a little late, but in order to use remote access you'll need to enable this in settings > sharing > screen sharing.

DP5 running without issues (as expected) on my 790 

UfrHaq6.png

Share this post


Link to post
Share on other sites

DP5 update Optiplex780 also without problems

As always:
rollback graphics kext for the HD5450
rollback AppleHDA for audio

 

 

@unrealpants

rollback appelhda works?

Edited by MacPeet

Share this post


Link to post
Share on other sites

This process has been fun and productive... but more problems keep appearing ... 

 

now the network drops out rather regularly....  I notice on another forum they suggest to do a 'NIC restart' 

https://www.tonymacx86.com/threads/network-stops-working-when-downloading-large-files.22473/

 

If that's the solution and it's something I can automate, I'm happy to try.

Share this post


Link to post
Share on other sites

@MacPeet

 

no.... I tried using EasyKext to rollback using the kexts you supplied from 10.13.3 but no joy.  Is there something else I need to do?... in your first post, you suggested using 11 or 13 to match the on-board audio in Clover Configurator.  I'll try searching for those instructions and give it another go.  In other news, my network dropouts seem to have gone away.... yay!

 

....

 

ok so I've found these instrucitons https://hackintosher.com/guides/get-hackintosh-audio-working/

 

Should I be following these? I don't want to mess anything up now things are working so well (except for audio)

Edited by unrealpants

Share this post


Link to post
Share on other sites

@MacPeet I replaced my config.plist, DSDT.aml and the AppleALC and Lilu files with the ones that that you supplied but still I see no option at all for audio output device.

 

it feels like I'm *so* close but have missed some minor but important step.

 

In this dialogue there are no options when I click "Selected sound output device"

 

601836387_ScreenShot2018-05-20at9_28_57pm.png.f5db1e7e4fc33ff32f0c676e5c63bf0e.png

 

Share this post


Link to post
Share on other sites

voodoohda disabler still on board
check L / E
check terminal "kextstat"
check Systeminformationen.app/Extensions if AppleHDA is loaded

Share this post


Link to post
Share on other sites
On 5/13/2018 at 11:51 PM, unrealpants said:

Hi morpheusman

 

Did you rollback kexts as explained in Step 6 & 8?

 

Yes, I now have done this and it has worked!

 

Next challenge -- audio.  I tried following the steps but I had no luck with my Optiplex 7780 using the ALC method.

 

Any tips?  .... or are there some more detailed steps somewhere I can try to follow for this?

 

Cheers

 

Paul

 

Sorry, the Video kexts rollback is something I have not had to deal with because I upgraded to 790 and 990. 

Share this post


Link to post
Share on other sites
13 hours ago, MacPeet said:

voodoohda disabler still on board
check L / E
check terminal "kextstat"
check Systeminformationen.app/Extensions if AppleHDA is loaded

 

how could you tell that the voodoohda disabler is "still on board"?  if this is a bad thing, how do I get rid of it?

 

by "Check L / E" do you mean Library/Extensions ?

Share this post


Link to post
Share on other sites
14 hours ago, MacPeet said:

voodoohda disabler still on board
check L / E
check terminal "kextstat"
check Systeminformationen.app/Extensions if AppleHDA is loaded

 

OK I've checked Library/Extensions - AppleHDA.kext is there

I checked System/Library/Extensions - AppleHDA.kext is there

I ran "kextstat" and could not see any reference to ApplieHDA.kext in the output.. the only thing close was com.apple.driver.AppleHDAController

i couldn't find any "Systeminformation.app/Extensions"

Is this meaningful?

Share this post


Link to post
Share on other sites

AppleHDA does not belong to Library / Extensions
You probably installed the rollback AppleHDA 10.13.3 after Library / Extensions
delete AppleHDA in Library / Extensions
and Rollback AppleHDA 10.13.3 to S / L / E

Share this post


Link to post
Share on other sites
17 hours ago, MacPeet said:

AppleHDA does not belong to Library / Extensions
You probably installed the rollback AppleHDA 10.13.3 after Library / Extensions
delete AppleHDA in Library / Extensions
and Rollback AppleHDA 10.13.3 to S / L / E

Hi MacPeet .. I deleted AppleHDA in L / E and rolled back AppleHDA 10.13.3 to S / L / E
AppleHDA.kext definitely appears in S / L / E now and not in L / E but still no sound options and kextstatus is not showing even the AppleHDAController I saw yesterday
 

Should I try playing with the 'Options' that appear when the Clover bootloader comes on at startup?

Share this post


Link to post
Share on other sites

Audio is activated in the BIOS ???

 

DSDT.aml is in EFI/Clover/ACPI/patched/ ???

 

Check System Information Extensions in Utilities:

check.thumb.png.ee15072152d170aaecfd7f23cd004cc6.png

 

Let KextUtility run again for cache rebuild

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By h2onions
      Hey all,
       
      First Hackintosh that I think I have completed! I've been working on it on and off for a month, but just grinded it this past weekend. I just have a small QOL issue. I have posted in the r/Hackintosh reddit, but have not gotten a reply to this specific issue, but did for other issues I was having. I also posted at tonymacx86 and was getting replies for other issues I was having, but got banned because I said, "used VM, but didn't work" in my OP I think ...
       
      I followed a PC vanilla guide from r/Hackintosh that I found as I did not have an Apple system. One monitor connected to a GTX 1080, CPU: i7-8700, Coffee Lake. Motherboard is Alienware specific 0VDT73, with chipset Z370.
       
      The issue is every time High Sierra boots up and gets to the login screen, my keyboard and mouse do not work. I only have to reseat both and then they work the whole time until I restart. They are both plugged into USB2.0 ports. I do have Lilu, WhateverGreen, USBInjectAll, and VoodooPS2 installed in my /Library/Extensions folder using #####. Mouse and Keyboard work fine each time I boot to Clover (USB). Any ideas?
       
      Thank you!
      Working: NVIDIA using (One) DisplayPort, USB3.0 (rear), USB-C (rear), USB2.0 (rear), Audio, Ethernet
       
      EDIT: Did some more testing, and it looks like my Keyboard works fine after each reboot, the only issue is that my mouse has to continuously be reseated. Any ideas? Could it just be the mouse?It's an old Inland USB mouse: 337451
    • By Gymnae
      Introduction
      The H370 chipset powers 8th generation Intel Core-i CPUs. Even though the name H370 rings comparable to Z370, the H370 is based on newer silicon. This it also requires some new approaches compared to the Z370. An example would be on-die USB 3.1 and WiFi support.
       
      Since this guide is not a "hold-your-hand-every-step" guide, I assume you know:
      Clover installation and configuration How to create an install medium for MacOS Access and configure the BIOS Have heard of ACPI patching (I'm a newb at this myself)  
      What works
      Sleep (via DSDT edits and emulated NVRAM) On-board Audio (via AppleALC and native AppleHDA) Native power management (without any kext or patch) All USB ports (and only those present are active) iGPU for both acceleration and display dGPU (I'm running an Nvidia GTX 1080)  
      Untested
      NIC --> I'm using WiFi only  
      What doesn't work
      Native NVRAM via AptioMemoryFix.efi DMVT Pre-alloc higher than 64MB (but not necessary)  
      Community additions
      User @Panzerschiffe added a helpful post, altering this guide for user with AMD cards and not needing on-board sound.
      He also runs Mojave, which I don't run yet.
       
       
      Changes to the guide:
      22.5.18: Added SSDT hot-patching to enable sleep, replacing DSDT static patching as an alternative.
      23.5.18: Add iMac18,1 as alternative SMBIOS config for those relying on the iGPU for output
      25.6.18: Added update info
      28.8.18: Small changes for clarity, changed info for afps loading & updated USB patch for 13.6
      04.10.18: Update to Mojave will come once Mojave is more mature
      02.12.18: Removed unnecessary patches, fakepciid and audio patch method & linked to AMD post & added whatevergreen.kext as replacement for previous GPU kexts
      02.03.19: Removed unnecessary fakeid and ig_platform_id injections, ACPI patches - this is all handled by whatevergreen & lilu. In testing is a Framebuffer patch, see this post.
      04.03.19: Added Germany keyboard layout and updated pre-patched DSDT.aml removed DSDT patching
       
       
      1. Installation
      This guide heavy inspired by the work of /u/corpnewt of /r/hackintosh and his (sorta) Vanilla guide
       
      1.1 Create the install media for MacOS
      Follow this, if you are using a Mac to start off with. If you are totally new to MacOS, then please check the basic guide Creation of an installer media in windows or linux
       
      1.2 Install Clover on the install media
      Using the Clover installer, ensure you are installing to the USB medium you are using for the installer.
      Chose the following options, leaving the others on default: 
       
      UEFI driver: AptioMemoryFix UEFI driver: ApfsDriverLoader UEFI booting only Install to ESP  
      You have to get your hands on an apfs.efi. A google search can help, or extracting it from the Installer package. Make sure you procure a version matching the MacOS version you are about to install. Place the apfs.efi in drivers64UEFI.
       
      1.2 Adjust the config.plist for the installer
      You can use the config.plist attached as a guideline, but take a look at it before and at least adjust the SMBIOS - otherwise it won't boot.
      Attention: The attached plist contains audio patches introduced by a post-install step. If you run into problems, you might remove those. It also contains a manual slide value, which should normally not be needed, but works fine for me. It is also tuned for usage with an Nvidia Pascal dGPU as main GPU.
       
      The config you create now should serve you nicely for install and running the system.
       
      Take care of adding the following basics:
      SMBIOS: iMac18,3 - You can generate a serial number via Clover Configurator. The creation of a proper SMBIOS is covered in many guides to good extend Note: If you aim at using the iGPU for output, a user reported that iMac18,1 works better - since iMac18,3 produces severe flicker. I'm now also testing 18,1 Look at the graphics section and adjust the injection for Intel to your situation  
      Fixes

      Patches

      Devices

      Graphics
      Important:
      Change 0x59120003 to 0x59120000 if you don't use a dGPU as your main display Driver and instead use the iGPU for output.
      Also note. SMBIOS iMac18,1 has been reported to work better in this configuration. But 18,3 works fine for me.

      Kernel and Kext patches
       
      1.3 kexts and friends
      Add the supplied SSDT-UAIC.aml to "patched" - it limits the injected USB Ports to the actual number and ports valid for this board.
       
      Required kexts on "Other":
      FakeSMC.kext Whatevergreen.kext Lilu.kext AppleALC.kext IntelMausiEthernet.kext in case you're running Ethernet USBInjectAll.kext with the HCI-300-series-injector.kext --> These two should be installed to /L/E after install  
      We are leaving sound out at the moment, this is something for post-install.
       
      1.4 Check BIOS and install
      You should be ready for install. But before you reboot, please take a look at your BIOS and set it up accordingly (copied from the aforementioned guide and adapted):
      Load Optimized Defaults Disable VT-d setting If your system has Secure Boot Mode, disable it Enable CSM - This is sometimes needed to dual screens to work Set OS Type to Windows 8/10 or OtherOS - I have not seen a difference Turn off internal Serial and Parallel port Turn off Network stack for boot Turn off wake-on-lan (for now) Set XHCI Handoff to enabled Don't enable decode over 4G Depending on your GPU, set priority for boot Set internal GPU (iGPU) to enable - not auto or disabled Set DMVT pre-alloc min to 64MB and max to 128MB. For this selection to appear you might need to reboot after setting iGPU to enable Set USB legacy to enabled Activate XMP profile 1 f your Ram has it (mine doesn't and I added the timings manually) Set ERP to enable, disable platform power management (I need to do more research if this could be enabled)  
      I've attached my current BIOS config "hack2". You can place that on a fat32 drive (the EFI partition of your install USB drive might be an idea) and see if it loads. It's made for and with the F2 BIOS.
       
      The install itself should be like other MacOS Hackintosh installs with it several reboots and ensuring to select the correct boot device in Clover.
       
      2. Post-install
       
      2.1 Install clover on target
      This is a no-brainer, but install a fresh copy of Clover on your target medium.
       
      During install select again AptioMemoryFix but also additionally
      EmuVariableUefi-64.efi Install RC scripts on target volume because otherwise NVRAM doesn't seem to work
       
      After the install, copy
      config.plist contents of "Other" content of "patched" to your new clover install.
       
      2.2 Edit ACPI for slumber
      Choose one option, not both. The hot-patch is experimental, but for the moment it is stable.
       
      2.2.1 Edit DSDT
      No more need for manual DSDT patching. If you still do it, you might run into unstable sleep. SSDT hot-patching + sane clover.config edits are enough
       
      This is necessary only once on initial install and every time, you edit or upgrade the BIOS. The DSDT.aml attached to this post might work for your system or give you a file to compare to. Don't expect it to work for you, though.
      EDIT: Since moving from F2 BIOS to F12 I did not repatch and sleep is still somewhat reliable. But to be 100% sure, you can still follow these steps.
      I won't go into the details of DSDT extraction and patching. There are better guides (the linked guide is a rip-off of rehabman's guide from a different forum). Please follow such a guide to extract your ACPI data.
       
      Locate and disassemble the DSDT with the newest iasl binary you can put your hands on, then open it with MacIASL in its newest version you can find (Hint: Here is a good source) You can check if the version is new enough if MacIASL doesn't throw error upon compiling a freshly extracted DSDT.aml or DSDT.dst
       
      Add rehabmans repo (as per linked guide) and apply the following patches:
      Rename _DSM to _XDSM Fix _WAK Arg0 v2 USB3 _PRW 0x6D Skylake (instant wake) Find the CNVW device and remove the _PWR function there.
       
      Compile the DSDT and place it in "patched".
       
      2.2.2 Use SSDT hot-patching
      Instead of having to re-extract and re-patch the DSDT on every BIOS change or update, Hardware change one can also use ACPI hot-patching.
      It's a combination of config.plist patches and an SSDT, which is hot-patched into the ACPI (if I understand the process correctly)
       
      You need to add this SSDT-GPRW.aml to your Clover folder in the designated position at Clover/ACPI/patched You need to add this patch to your config.plist. It goes into the DSDT patch section  
      Note: This works for me, but the patch removes the _PRW method from all devices in the DSDT. This could have side-effects. So far, I have seen none. At the moment I'm also not applying any other patch, compared with the additional edits I made to the DSDT method before.
       
      2.3 Install kexts to system
      As mentioned in the install section, it's better to follow rehabman's instruction and install USBinjectAll.kext to /L/E:
      sudo cp -R Release/USBInjectAll.kext /Library/Extensions sudo touch /System/Library/Extensions && sudo kextcache -u / 2.4 Enable onboard Audio - Install AppleALC kext
      Make sure your EFI partition is mounted and that you have a vanilla AppleHDA kext available. See below for a guide how to get a vanilla AppleHDA if needed
      Note: Our Audio codec is ALC887 and it's running with layout ID 1.
      Download the newest AppleALC kext from here and install it together with lilu.kext from here into your usual /clover/kexts/others location. Done. No scripts or config.plist patches necessary.
      Add layout ID 1 to config.plist, if it's not there yet:
      <key>Audio</key> <dict> <key>Inject</key> <integer>1</integer> <key>ResetHDA</key> <true/> </dict> If you previously  installed any  audio patches, please follow this guide to "vanilla-ize" your install.
       
      2.5 Optional steps for Graphics
      If you have a dGPU, now it's the time to install its drivers and adjust the config.plist for it. The detaisl are specific to your GPU and thus of scope of this guide. Yet, my supplied config.plist is ready to be used with Nvidia Pascal cards and using the Nvidia web driver.
      Whatevergreen.kext helps with Intel iGPU and NVIDIA dGPU fixes.
       
      At the moment I'm also testing out a special bootflag: 'shikigva=12' to enable faster rendering in Final Cut Pro X. Without whatevergreen.kext and a shikigva bootflag, rendering in final cut seem very slow.
       
      2.5.1 Framebuffers
      If you're facing problems with output from your internal GPU, you can try the framebuffer patches listed by @BackwardMac:
       
      2.6 Install a proper keyboard layout
      You might not be using a fancy Apple branded keyboard. If you use a PC keyboard, you might be annoyed by the differing layout and usage of keys. As a German, you might find yourself quitting applications, since alt gr + Q won't add an @, but quit your current application. To fix this, you can simply install a different keyboard layout. Copy it to /Library/Keyboard Layouts/ and chose the layout in System Preferences, Keyboard in the section "Other". Deleting the previously selecting layout makes sure that only this one is used. Nice little trick.
       
      A keyboard layout for German keyboards is attached and works wonders
       
      3. Updating
      Updating inside 10.3.x/ 10.4.x point updates doesn't require much attention:
      Download the update from the AppStore as any Mac would do Allow the system to reboot Before booting MacOS with Clover, make sure to disable extra drivers for dGPUs which require non-native support. If using an Nvidia dGPU: Remove "nvda_drv=1"  from your boot arguments and disable Nvidia injection If using a non natively supported AMD card, do the same for AMD (I'm not using AMD, thus I cannot be specific) Boot into the newly created Install MacOS partition Repeat this process until the Install partition is gone Boot MacOS again, still following 3., and potentially install updated drivers Your Audio might require re-patching  
      4. ToDo
      Move away from static DSDT patching to SSDT hotpatching --> requires my work Native NVRAM --> requires developer work Audio without AppleHDA patching --> requires developer work  
      5. Thanks to
      @MaLd0nfor helping finding the right way with the DSDT
      @RehabMan, for being a legend and helping me out patching
      @toleda, for audio patches for the 300 series
      /u/corpnewt, for his superb vanilla guide
      @wmchris for his super XPS 9550 guide and introducing me to hot-patching
      @Panzerschiffe for his addition to this guide
      all the developers of clover and it's awesomeness
       
      SSDT-UIAC.aml
       
       
       
      win-germany.keylayout
       
    • By Utku
      Hi guys, I have a big problem for VT -x. I tried any things for example: dark=0 or already bios option is virtualization is enable. I don't understand this problem.
       
      Thanks guys!! And yes I have intel Q8400 quad core cpu, motherboard is Asus asus p5g41c-m lx.
       


    • By NoEnd
      Hi team,
       
      I have tried to update to security update 2019-001 multiple time with no luck, today I've booted the update with -verbose and attached videos shows the details.
       
      Appreciate your help
       
      Thanks
      Untitled.mov
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
×