Jump to content
MacPeet

[Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)

564 posts in this topic

Recommended Posts

1 hour ago, cele_82 said:

 

 

 

Thanks, I was looking if someone is running a DELL 780 with GT610 so a ready to go EFI folder would have been easier for me. I think most of the stuff probably is unchanged from 10.13 but I wanted something ready to deploy... if there is anyone running this config.

 

I have a Dell 780 Minitower with GT710 and build my Mojave install with Dosdude1 patch (http://dosdude1.com/mojave/).

Try my clover files.

Cheers.

config.plist

Other.zip

Share this post


Link to post
Share on other sites
Advertisement
On 1/6/2020 at 11:23 AM, chris1111 said:

Use this config, its adapted for Catalina and works for ancient macOS

config.plist.zip

 

This is strange the user does not come back after he has had what he asked for :bye:

Many thanks for your help and sorry for answering late.

Tried your config.plist but had the the same effect, the installer get stuck at the same point. :wallbash: 

Share this post


Link to post
Share on other sites

Hi all,

I recently decided to re-install Mojave on my 790.

I wanted to go down the APFS route, after not receiving the updates correctly using HFS+.

However, after an installation I end up with a grey screen with mouse icon. If I press a button the icon disappears.

I'm sure this is something silly.

 

Thanks in advance

 

IMG_6841.JPG

Share this post


Link to post
Share on other sites
11 minutes ago, Aaronation said:

Hi all,

I recently decided to re-install Mojave on my 790.

I wanted to go down the APFS route, after not receiving the updates correctly using HFS+.

However, after an installation I end up with a grey screen with mouse icon. If I press a button the icon disappears.

I'm sure this is something silly.

 

Thanks in advance

 

 

what graphics card do you have?

With my test Optiplex 790 with the GeForce 210 I have thE same issue, if I not used VoodooHDA

This is relate to AppleHDA 

Try to used VoodooHDA in clover

Edited by chris1111

Share this post


Link to post
Share on other sites
1 hour ago, chris1111 said:

what graphics card do you have?

With my test Optiplex 790 with the GeForce 210 I have thE same issue, if I not used VoodooHDA

This is relate to AppleHDA 

Try to used VoodooHDA in clover

I have a GT720 in the machine at the moment. I do have a 710 that I can try.

Although this card has worked before.

I'll swap them over real quick.

 

So the graphics card swap did nothing. But I did end up loading on a newer clover boot loader. Which got me into the OS.

And as you mentioned before, I have no sound.

Which folder in clover do I add the Voodoo kext ?

And does it affect the sound in any way?

 

Thanks in advance

Edited by Aaronation

Share this post


Link to post
Share on other sites
15 minutes ago, Aaronation said:

I have a GT720 in the machine at the moment. I do have a 710 that I can try.

Although this card has worked before.

I'll swap them over real quick.

With the Geforce 720 don't use AppleALC, use only VoodooHDA

With the 710 no problem to use AppleALC

Share this post


Link to post
Share on other sites

Hello all,

 

I have a Dell Optiplex 780 (Core 2 Quad 9400), and I am atempting to install macOS Catalina. I used dosdude1's patcher tool to create a bootable installer, and installation went without any issues. I installed Catalina to my internal SSD, but now, when I try to boot from it my system crashes. In verbose, I get all the way to IOConsoleUsers:GIOScreenLock, (When the macOS GUI initializes) however after that message, my system simply reboots. I have attached my config.plist below, any help or guidance anyone can give me would be greatly apreciated. 

 

Specs:

CPU: Core 2 Quad 9400

Ram: 4GB (Stock)

GPU: Nvidia Geforce GT 710

config.plist

Share this post


Link to post
Share on other sites
1 hour ago, CD100 said:

Hello all,

 

I have a Dell Optiplex 780 (Core 2 Quad 9400), and I am atempting to install macOS Catalina. I used dosdude1's patcher tool to create a bootable installer, and installation went without any issues. I installed Catalina to my internal SSD, but now, when I try to boot from it my system crashes. In verbose, I get all the way to IOConsoleUsers:GIOScreenLock, (When the macOS GUI initializes) however after that message, my system simply reboots. I have attached my config.plist below, any help or guidance anyone can give me would be greatly apreciated. 

 

Specs:

CPU: Core 2 Quad 9400

Ram: 4GB (Stock)

GPU: Nvidia Geforce GT 710

config.plist

try this let me know

 

config.plist.zip

Share this post


Link to post
Share on other sites
42 minutes ago, chris1111 said:

try this let me know

 

config.plist.zip

Thank you for your reply

 

Unfortunately, I have had no luck, even with the new config.plist, the same issue still persists.

 

I don't know if this is relevant or not, but before the crash I get the following message repeated over lots of times

 

apfs_spec_read_wrapper:10890:apfs_spec_read_wrapper : f_info->fsroffset 49152IMG_20200126_135426965.thumb.jpg.fbc47caf04d55293f358a8582885a82b.jpg

 

Again, I don't know if this is actually important or not, but I figured I would mention it.

Share this post


Link to post
Share on other sites
1 hour ago, CD100 said:

Thank you for your reply

 

Unfortunately, I have had no luck, even with the new config.plist, the same issue still persists.

 

I don't know if this is relevant or not, but before the crash I get the following message repeated over lots of times

 

apfs_spec_read_wrapper:10890:apfs_spec_read_wrapper : f_info->fsroffset 49152IMG_20200126_135426965.thumb.jpg.fbc47caf04d55293f358a8582885a82b.jpg

 

Again, I don't know if this is actually important or not, but I figured I would mention it.

Try to Use this for the USB Installer

then after change the config 

Share this post


Link to post
Share on other sites
7 hours ago, chris1111 said:

With the Geforce 720 don't use AppleALC, use only VoodooHDA

With the 710 no problem to use AppleALC

I ended up putting the 720 back in.

I did exactly what you've said. And it seems to be working perfectly.

 

Thank you very much for the help, much appreciated. :)

Share this post


Link to post
Share on other sites
3 hours ago, chris1111 said:

Try to Use this for the USB Installer

then after change the config 

chris1111,

 

I re-downloaded my Catalina install app (From MAS this time instead of dosdude patch tool) and re created my usb with the method you specified. I then wiped my system disk, and reinstalled from my new usb. Unfortunately it still won't boot to the desktop, and reboots in the same spot. :(

 

On the bright side, the strange apfs_spec error message is gone, and the system boots much faster now (But still wont boot ALL the way)

Edited by CD100

Share this post


Link to post
Share on other sites
8 minutes ago, CD100 said:

chris1111,

 

I re-downloaded my Catalina install app (From MAS this time instead of dosdude patch tool) and re created my usb with the method you specified. I then wiped my system disk, and reinstalled from my new usb. Unfortunately it still won't boot to the desktop, and reboots in the same spot. :(

 

On the bright side, the strange apfs_spec error message is gone, and the system boots much faster now (But still wont boot ALL the way)

I think You have to patch the system for the Core 2 Quad 9400

read here how to 

 

Edited by chris1111

Share this post


Link to post
Share on other sites
2 hours ago, chris1111 said:

I think You have to patch the system for the Core 2 Quad 9400

read here how to 

 

 

SUCCESS!!!!

 

I successfully applied the mojave2core patch to my system, and it is now working great. Thanks a lot for the help, and for pointing me in the direction of the SSE patch.

IMG_20200126_210948113.jpg

Share this post


Link to post
Share on other sites
7 minutes ago, CD100 said:

 

SUCCESS!!!!

 

I successfully applied the mojave2core patch to my system, and it is now working great. Thanks a lot for the help, and for pointing me in the direction of the SSE patch.

 

Super :thumbsup_anim:

Share this post


Link to post
Share on other sites
On 1/24/2020 at 7:28 PM, cele_82 said:

 

Does the audio work ? Internal speaker too ? 

 

Audio works normally, internal speaker not.

Share this post


Link to post
Share on other sites
18 hours ago, vbmota said:

 

Audio works normally, internal speaker not.

Do I just need those Other kexts you sent ? Anything else ? I was expecting more kexts somehow... but maybe just used to my laptop needing more...

Share this post


Link to post
Share on other sites
4 hours ago, cele_82 said:

Do I just need those Other kexts you sent ? Anything else ? I was expecting more kexts somehow... but maybe just used to my laptop needing more...

 

Yes, use the "Other" kexts only... theres no reason to use more kexts (only if you have some new hardware). Laptops are more complex to properly setup.

Share this post


Link to post
Share on other sites
1 hour ago, vbmota said:

 

Yes, use the "Other" kexts only... theres no reason to use more kexts (only if you have some new hardware). Laptops are more complex to properly setup.

Thanks for all the help. Last thing before I start attempting this later this week - Are you HFS+ or APFS formatted ?

Share this post


Link to post
Share on other sites

Audio codec 780/760:

AD1984A - for Dell Optiplex 780/760 - LayoutID 11 (0B) Version 1 - ManualMode
AD1984A - for Dell Optiplex 780/760 - LayoutID 13 (0D) Version 2 - SwitchMode

The hardware internal mini speaker is deleted in the codec.

The display "internal speaker" is then the LineOut connection in the back green.

Share this post


Link to post
Share on other sites

@chris1111 sorry to disturb, do you think I'll get into problems trying the GT610 on 10.14.6 ?

 

I saw you are maintaining a package for 10.15 but wondering if you can advise on 10.14.6 for GT610.

 

 

Sorry a bit rusty on this.

Share this post


Link to post
Share on other sites
4 hours ago, cele_82 said:

@chris1111 sorry to disturb, do you think I'll get into problems trying the GT610 on 10.14.6 ?

 

I saw you are maintaining a package for 10.15 but wondering if you can advise on 10.14.6 for GT610.

 

 

Sorry a bit rusty on this.

GT 610 is not support for the package Old Nividia

GeForce 610 is a bad card after Yosemite

Share this post


Link to post
Share on other sites
3 minutes ago, chris1111 said:

GT 610 is not support for the package Old Nividia

GeForce 610 is a bad card after Yosemite

 

Would the HD5450 be better ? I have both ....somewhere. Just need to find it. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By midi-sama
      After a long time of cooking this computer up with a lot of stuff, I'm finally releasing my guide for this P50 with OpenCore.
       
      Lenovo ThinkPad P50 macOS Install with OpenCore
       
      This thread may be used for questions/corrections/additions. Good Luck.
    • By RyzenDude
      Hi everyone,
      Today I finished my High Sierra install with OpenCore. I got everything up and running but I can't seem te get rid of this text on te boot screen while booting up. Does anyone have a solution to this?
      Thanks in advance!
      Hardware:
      CPU: Ryzen 5 1600
      GPU: GTX 980
      RAM: 16 GB DDR4 2666 MHz
      Motherboard: ASUS EX-A320M-GAMING
      Audio Codec: AppleALC
      Ethernet Card: Realtek RTL8111
      Bootloader: OpenCore 0.5.5

    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
    • By NoEnd
      Hi team,
       
      I'm looking for the best route to achieve this upgrade, so I have been stuck with HS since Nvidia drivers stopped being supported on newer MacOS releases. Now I'm having an AMD 5700 xt on the way and want to plan the upgrade properly. I have added some information below and questions that might help with your recommendation.
       
      Current GPU 1080 ti with Nvidia webdrivers installed. So should I uninstall the webdriver before adding the new GPU? Clover is being used and EFI attached. Any kext must be removed? or parameters adjusted MacOS HS 10.13.6, should I upgrade before using the new GPU? CPU: 9900K Motherboard:ROG MAXIMUS XI HERO (WI-FI) Dual Monitors I have a Time machine backup, Do you recommend a fresh install? and If I did, will I be able to restore my data/apps as-is?  
      Please let yourself free to explore further aspects to considers.
      EFI-20200204.zip
×