Jump to content
About Just Joined group Read more... ×
MacPeet

[Guide] macOS High Sierra 10.13 - Dell Optiplex 780 (760) (755) (790) (990)

623 posts in this topic

Recommended Posts

11 minutes ago, chris1111 said:

here attaching correct config

replace it

config.plist.zip

 

Yes that slowed down all those symptoms but now acceleration seems to be a little sluggish. When I hit launchpad it takes about 5 seconds to pop up 5 more to go back to finder. 

 

6 minutes ago, chris1111 said:

Also don't using a DSDT wit a radeon HD 5450 Patch because the config.plist  as a FadeID for the Radeon HD 5450

I removed the DSDT and acceleration is worse for some reason.

Share this post


Link to post
Share on other sites
Advertisement
6 minutes ago, bocajoe said:

 

Yes that slowed down all those symptoms but now acceleration seems to be a little sluggish. When I hit launchpad it takes about 5 seconds to pop up 5 more to go back to finder. 

 

Try this DSDT

I remove the patch Radeon HD 5450

DSDT.aml.zip

Edited by chris1111

Share this post


Link to post
Share on other sites
3 minutes ago, chris1111 said:

Try this DSDT

I remove the patch Radeon HD 5450

DSDT.aml.zip

 

Thanks chris1111. Unfortunately I am back to no acceleration with that DSDT :(

Share this post


Link to post
Share on other sites
2 minutes ago, bocajoe said:

 

Thanks chris1111. Unfortunately I am back to no acceleration with that DSDT :(

OK reput the first DSDT and use this config.plist

I remove FakeID in config :D

config.plist.zip

Edited by chris1111

Share this post


Link to post
Share on other sites
6 minutes ago, chris1111 said:

I will go to sleep I see the result tomorrow hope that work

Sleep well my friend and thanks for all the help. I'll update shortly...

Share this post


Link to post
Share on other sites
40 minutes ago, chris1111 said:

OK reput the first DSDT and use this config.plist

I remove FakeID in config :D

config.plist.zip

 

UPDATE: I put my original DSDT that I got from step4 of this guide and used your attached config.plist and still have the lag (5 seconds to launch launchpad, etc.). I have full resolution, it is just super slow.

 

Here are my current IOreg (RunMe) files since we were changing all kinds of stuff. I really appreciate all the help trying to get this old 780 shining again!

Send me Macs-iMac.at.net.zip

 

Here are my S/L/E files in case maybe they are old or modified (just thinking of everything):

https://www.dropbox.com/s/mhg23h6oevg7xqo/S%3AL%3AE.zip?dl=0

 

 

MY SPECS:

Dell Optiplex 780 Mini Tower

Q9400 Core2Quad CPU

Sapphire 5450 1GB 

 

Edited by bocajoe

Share this post


Link to post
Share on other sites
8 hours ago, bocajoe said:

 

UPDATE: I put my original DSDT that I got from step4 of this guide and used your attached config.plist and still have the lag (5 seconds to launch launchpad, etc.). I have full resolution, it is just super slow.

 

Here are my current IOreg (RunMe) files since we were changing all kinds of stuff. I really appreciate all the help trying to get this old 780 shining again!

Send me Macs-iMac.at.net.zip

 

Here are my S/L/E files in case maybe they are old or modified (just thinking of everything):

https://www.dropbox.com/s/mhg23h6oevg7xqo/S%3AL%3AE.zip?dl=0

 

 

MY SPECS:

Dell Optiplex 780 Mini Tower

Q9400 Core2Quad CPU

Sapphire 5450 1GB 

 

what is the Clover revision you have ?

send me complet EFI Folder you are use

Edited by chris1111

Share this post


Link to post
Share on other sites
3 hours ago, chris1111 said:

what is the Clover revision you have ?

send me complet EFI Folder you are use

 

Hey Chris1111!!!!!! I have the latest Clover_v2.4k_r4700. I have attached my complete EFI folder below. THANKS!!!!!! :D

 

https://www.dropbox.com/s/ooxodynxgwm9tfu/EFI.zip?dl=0

Edited by bocajoe

Share this post


Link to post
Share on other sites
14 minutes ago, bocajoe said:

 

Hey Chris1111!!!!!! I have the latest Clover_v2.4k_r4700. I have attached my complete EFI folder below. THANKS!!!!!! :D

 

https://www.dropbox.com/s/ooxodynxgwm9tfu/EFI.zip?dl=0

try this config 

I setup FrameBuffer Shrike

config.plist.zip

Share this post


Link to post
Share on other sites
49 minutes ago, bocajoe said:

 

Thanks for that. Unfortunately it's still doing the same. :(

Ok use this package to Install your old kext

I made package for you, just install and reboot

 

Edited by chris1111

Share this post


Link to post
Share on other sites
6 minutes ago, chris1111 said:

Ok use this package to Install your old kext

I made package for you, just install and reboot

SLE-Packages.pkg.zip

 

I installed but unfortunately that didn't help. BUT I'm more impressed that you made a dang installer!!!!!!!!!!!!!! How the heck?????? You are one smart man.

Share this post


Link to post
Share on other sites
Just now, bocajoe said:

 

I installed but unfortunately that didn't help. BUT I'm more impressed that you made a dang installer!!!!!!!!!!!!!! How the heck?????? You are one smart man.

Try Kext Utility to install the old kext, not need to repare permission with Kext Utility

maybe that's work ?

 

Share this post


Link to post
Share on other sites
10 minutes ago, chris1111 said:

Try Kext Utility to install the old kext, not need to repare permission with Kext Utility

maybe that's work ?

 

 

10 minutes ago, chris1111 said:

Try Kext Utility to install the old kext, not need to repare permission with Kext Utility

maybe that's work ?

 

 

I just used KextUtility to install old kexts with no luck. I'm going to do a fresh install because it has to be something on my end as you really know your stuff! I'll update shortly. Thanks again for all the help, it is greatly appreciated! :D

Share this post


Link to post
Share on other sites
1 hour ago, chris1111 said:

Try Kext Utility to install the old kext, not need to repare permission with Kext Utility

maybe that's work ?

 

 

UPDATE: I just did a fresh 10.13.6 install "just in case" something was wrong. I added the original S/L/E with KextWizard and used our latest EFI folder we've been working on and have same slowness. Resolution is fine and it shows proper ATI Radeon HD 5000 1024 MB in about this Mac. 

 

Any ideas, this thing is kicking my butt?

 

Here are my IOreg files:

Send me Macs-iMac.at.net.zip

 

And my current EFI:

https://www.dropbox.com/s/9cx99r4gt8dx5lw/EFI-.zip?dl=0

 

MY SPECS:

Dell Optiplex 780 Mini Tower

Q9400 Core2Quad CPU

Sapphire 5450 1GB 

 

Edited by bocajoe

Share this post


Link to post
Share on other sites
2 hours ago, bocajoe said:

 

UPDATE: I just did a fresh 10.13.6 install "just in case" something was wrong. I added the original S/L/E with KextWizard and used our latest EFI folder we've been working on and have same slowness. Resolution is fine and it shows proper ATI Radeon HD 5000 1024 MB in about this Mac. 

 

Any ideas, this thing is kicking my butt?

 

Here are my IOreg files:

Send me Macs-iMac.at.net.zip

 

And my current EFI:

https://www.dropbox.com/s/9cx99r4gt8dx5lw/EFI-.zip?dl=0

 

MY SPECS:

Dell Optiplex 780 Mini Tower

Q9400 Core2Quad CPU

Sapphire 5450 1GB 

 

I said use Kext Utility why using kexwizard

Share this post


Link to post
Share on other sites
Just now, chris1111 said:

I said use Kext Utility why using kexwizard

 

Oppppppppssssss!!!!!! Sorry, I'll use kext utility now. Hope I didn't screw anything up :(

Share this post


Link to post
Share on other sites
On 10/13/2018 at 4:39 PM, chris1111 said:

I said use Kext Utility why using kexwizard

 

I used Kext Utility to install S/L/E and this dang thing is still messing with me with slow acceleration. I'm going to try a 6450 next to see if i have better luck

Edited by bocajoe

Share this post


Link to post
Share on other sites
7 minutes ago, fedaamahmoud said:

Any updated DSDT and config.plist for mojave for HD 5450 ATI ??

It read as ATI 5000 but with 5M !

Radeon HD 5X and 6X is not support in Mojave

Share this post


Link to post
Share on other sites
8 minutes ago, fedaamahmoud said:

any updated dsdt and config.plist for it ??

Stock DSDT no graphics patch

config.plist ➜ Inject Nvidia = False

this card works OOB from macOS Sierra to macOS Mojave

 

See here

 

Edited by chris1111

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By gekko.be
      I have an old Hackintosh that I have brought back to life. An ASUS P5KPLAM-SE mobo, Intel Core 2 Quad, with a Sapphire HD 5670 1GB graphics card. It used to work just fine on High Sierra 10.13.3 (I think it was .3) However I only used the DVI port. Updated to 10.13.6 and with AMD kexts rollback to the previous versions I got everything o wrk just fine: boot, HDMI video, HDMI audio etc etc. The only problem I face is that my USB keyboard and mouse freeze/hang seemingly very random... I can not seem to get it right. Unplugging and replugging the USB device makes it work again, sometimes for a few seconds sometimes for an hour ... No idea what's wrong... Have tried tons of options in clover, USBInjectall.kext with port limit patch, whatever I could find... Would there be anyone out there who would have an idea of what could be the problem?
    • By macinsane
      *This guide is deprecated and will not be maintained anymore*

      Update: Now running Mojave! Thanks to mojave2core! Yeah   Still using C2D in 2019!
      Inserted a nice and cheap GT710 that is not relying on nVidias Webdrivers and runs OOB under Mojave.
       
      Nice, seeing High Sierra running on this old but capable system! It rocks with a new ASUS GT1030
       
      Config:
      Gigabyte EP43-DS3L
      Core2Quad Q9300
      6 GB DDR2 RAM
      Asus GT1030 2GB
      Sandisk SSD 128GB
      TP-Link AC1200 Wifi USB
      Inateck KT4006 USB 3.0 PCIe (No boot)
       
      SMBIOS: iMac14,1
      Clover: 4297  4360
       
      A good deal of DSDT editing was necessary to get this machine to boot High Sierra but finally it works flawlessly, even sleep and wake!
      You NEED to have the DSDT put in place for installation because otherwise macOS doesn't recognize the SATA ports.
      There are a few important BIOS settings: SATA hast to be set to AHCI and "native" and HPET has to be run "64-bit", I'd recommend to disable IDE and the serial and parallel port.
      For the GT1030 nVidia Webdrivers are needed, have to boot with nv_disable=1 until you have them installed.
      You have to install Clover in legacy mode because this old fella does not support UEFI.
       
      Only downside: The so often recommended Inateck USB-card isn't recognized by BIOS, so you cannot boot from it. It works perfectly within macOS though, have the ac-Wifi connected to it.
      config.plist.zip
      DSDT.aml.zip
    • By eLDeus
      Hello, can't figure out why there's no Line-In input option with VoodooHDA, but I definetly have it in my built-in audio card on the motherboard.
      Thanks!
    • By Rajan Pandit
      Hai, I have i5 2500k with 8GB Ram, GA-Z86 AP-D3 Rev. 1 (F3 Bios) with Samsung EVO SSD... 
      I Installed High Sierra 10.13.6, I use ##### to activate boot... everything is fine..
      but sometime my system Freeze..... and sometimes screen freeze but mouse worked
      means system is running.. mouse is also moving.. but Screen got freeze...
      please help me to resolve.. I really frustrated now. I install many times...
      but same problem... There is no graphic card in my system...
       
      please help me.. I am attaching my clover folder.. please help
      CLOVER.zip
    • By fusion71au
      Making a High Sierra USB Installer Entirely From Scratch in Windows
      This is a proof of concept tutorial, to show it's possible to create a vanilla High Sierra installer, entirely from scratch, in Windows (even without App Store downloaded "Install macOS High Sierra.app" from a real Mac ).  @PikeRAlpha's link to Apple's Software Catalog provides us with all the URLs necessary to download the needed files directly from Apple instead of some dubious source from the internet...
       

      Pre-Requisites
      8GB or larger USB drive.  Edit: Recommend 16GB or larger for macOS Catalina 10.16 Boot Disk Utility v2.1.2017rev021b from @CVAD TransMac (free 15 day trial) Paragon Hard Disk Manager Free Download Installer Files Directly from Apple
      1)  Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist (Hint - search page for "InstallESD" to find its URL and others nearby)

      to a folder named "SharedSupport" on your Windows NTFS drive.  A browser download manager (eg Chrono for Chrome, dTA for FireFox) is handy since InstallESD is >4GB ---> allows you to pause/resume interrupted download...

      2)  Rename InstallESDDmg.pkg to InstallESD.dmg
      3)  Edit InstallInfo.plist with WordPad/text editor to remove the chunklistURL and chunklistid keys for InstallESD, and renaming it from InstallESDDmg.pkg to InstallESD.dmg (example of edited file attached to this post)...
      Note:  You can verify the SHA1 checksum of your InstallESD.dmg and BaseSystem.dmg with the correct ones at this website.
      Boot Disk Utility to format the Installer USB and Restore OS X Base System HFS partition
      1.  Format USB with BDU & latest Clover ---> creates boot files in CLOVER partition + second FAT partition
      2.  Extract 4.hfs from \SharedSupport\BaseSystem.dmg with BDU --> save to it's local folder
      3.  Restore 4.hfs to USB second partition with BDU --->  2nd partition becomes bootable "OS X Base System"
      Paragon Hard Disk Manager to extend HFS Partition to its Full Extent
      Open Paragon Partition Manager Free and resize the second partition of the USB drive to the full size allowed.  Don't forget to apply the changes at the end...
      Transmac to Copy "SharedSupport" folder to OS X Base System
      1.  Open the TransMac program and navigate to the HFS+ Volume/Install macOS High Sierra.app/Contents folder.  Right click anywhere in the empty space on the RHS pane and select "Copy Here"...
      2.  In the next stage, select the "SharedSupport" folder we created above as the "Files and Folders to be copied to the Mac Volume"...
       
      Clover Settings
      Clover configuration is required now.  The default config.plist (in the Clover FAT32 partition of the USB) maybe sufficient to boot your machine if you’re lucky.  If not, the hackintosh-vanilla-desktop-guide has some good explanations on the various settings available and also offers sample configuration files based on CPU type.  Also, look at the Clover Wiki, Clover Instructions and Clover Configuration Thread for pointers and edit /EFI/Clover/config.plist accordingly with Wordpad or Notepad.
      The location of the important configuration files for Clover are summarized below
      config.plist--->EFI/CLOVER folder DSDT.aml with or without SSDT.aml--->EFI/CLOVER/ACPI/patched (don't need one if your DSDT is auto patched by Clover in config.plist) Kexts eg FakeSMC, NullCPUPowerManagement --->EFI/CLOVER/kexts/<osx version> or /Other. NB BootDiskUtility by default already has FakeSMC.kext installed here.  You may need to add VoodooPS2Controller for your laptop keyboard/trackpad to work. If UEFI booting, you will most likely need one of the OsxAptioFixDrv-64 drivers copied from /EFI/CLOVER/drivers-off/drivers64UEFI to /EFI/CLOVER/drivers64UEFI. If you want to use the installer to run High Sierra in Windows on VMware, you can follow my guide to set up the Virtual Machine and replace Clover's default config with EFI_Clover for VMware (which is compatible to run in VMware).  In the screenshots below, I have attached the USB Installer (in this case PhysicalDrive7) to my macOS Virtual Machine.  Reboot the system to the USB installer to install High Sierra ...
      What happens if we don't have access to TransMac or Paragon Hard Disk Manager?
      Not a problem, as long as we get "OS X Base System" bootable, we can launch terminal from the Utilities Menu to copy the SharedSupport folder over to the Installer app.  In essence, we will build the full installer app = 5GB+ on the target HD eg "Macintosh HD", by copying both the "small" installer app = 15MB (on "OS X Base System") and the SharedSupport folder from the NTFS volume (mounted in this example on /Volumes/DATA)...
      -bash-3.2# cd / -bash-3.2# cp -R Install\ macOS\ High\ Sierra.app /Volumes/Macintosh\ HD/ -bash-3.2# cp -R /Volumes/DATA/SharedSupport /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/  
      ...then start installation with the startosinstall utility...
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD --converttoapfs NO --applicationpath /Volumes/Macintosh\ HD/Install\ macOS\ High\ Sierra.app  
      The above steps can be automated with the attached "startosinstall.command" script, which will assemble "Install macOS High Sierra.app" on "Macintosh HD" and launch the startosinstall utility targeting the "Macintosh HD" volume.  Copy/download to "Macintosh HD", then run in terminal (after attaching DATA USB with /Shared Support folder)...
      cd "/Volumes/Macintosh HD" chmod +x startosinstall.command ./startosinstall.command Updated Download Links for macOS Mojave 10.14.6_18G103
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      Note: In Mojave, Apple has removed the --converttoapfs NO and --applicationpath arguments from the startosinstall utility....
       
      eg to use startosinstall for the above section "What happens if we don't have access to TransMac or Paragon Hard Disk Manager?", the syntax is now
      -bash-3.2# /Volumes/Macintosh\ HD/Install\ macOS\ Mojave.app/Contents/Resources/startosinstall --volume /Volumes/Macintosh\ HD  
      This basically means that for Mojave, the default installation will always convert the target volume to the apfs file system.
       
      Updated Download Links for macOS Catalina 10.15.6_19G73
      Browse Apple's Regular Software Catalog and find the URLs to download the following 6 installer files...
      BaseSystem.dmg BaseSystem.chunklist InstallInfo.plist InstallESDDmg.pkg AppleDiagnostics.dmg AppleDiagnostics.chunklist  
      startosinstall.command.zip
      InstallInfo.plist_edited_10.13.6.zip
      InstallInfo.plist_edited_10.14.6.zip
      InstallInfo.plist_edited_10.15.6.zip
×