Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By rvilbert
      Good evening,
       
      I apologies for the broadcast message but i have decided to reinstall my Hackintosh machine using Catalina 10.15.6 and .... I'm stuck at "PCI configuration begin".. 
       
      My configuration is:
      Asus X99 Deluxe Core i7 5960x 32 Gb memory GTX 980  
      Knowing that my graphic card would not be fully recognised in Catalina i have also tried to install High Sierra but I managed to get exactly to the same point  and i have therefore decided to give another try to Catalina and .... I'm still stuck.
       
      (FYI I had managed to install 10.8 on my machine a while ago but a few things have changed since then and I may be missing a trick).
       
      In a nutshell I believe my issue is linked to this message that i'm getting:
       
      Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourcesMatch</key><string ID="2">boot-uuid-media</string></dict> 
       
      I tried all options (with/without flags and with/without kext) but i think that my issue is between my DSDT, SSDT and config.plist files.
       
      Any help would be much appreciated!
       
      I have attached my EFI folder and the print screen with the error message.
       
      Let me know if you need any further information.
       
      Thanks a lot
       
       
       
       

      EFI.zip
    • By macinsane
      *This guide is deprecated and will not be maintained anymore*

      Update: Now running Mojave! Thanks to mojave2core! Yeah   Still using C2D in 2019!
      Inserted a nice and cheap GT710 that is not relying on nVidias Webdrivers and runs OOB under Mojave.
       
      Nice, seeing High Sierra running on this old but capable system! It rocks with a new ASUS GT1030
       
      Config:
      Gigabyte EP43-DS3L
      Core2Quad Q9300
      6 GB DDR2 RAM
      Asus GT1030 2GB
      Sandisk SSD 128GB
      TP-Link AC1200 Wifi USB
      Inateck KT4006 USB 3.0 PCIe (No boot)
       
      SMBIOS: iMac14,1
      Clover: 4297  4360
       
      A good deal of DSDT editing was necessary to get this machine to boot High Sierra but finally it works flawlessly, even sleep and wake!
      You NEED to have the DSDT put in place for installation because otherwise macOS doesn't recognize the SATA ports.
      There are a few important BIOS settings: SATA hast to be set to AHCI and "native" and HPET has to be run "64-bit", I'd recommend to disable IDE and the serial and parallel port.
      For the GT1030 nVidia Webdrivers are needed, have to boot with nv_disable=1 until you have them installed.
      You have to install Clover in legacy mode because this old fella does not support UEFI.
       
      Only downside: The so often recommended Inateck USB-card isn't recognized by BIOS, so you cannot boot from it. It works perfectly within macOS though, have the ac-Wifi connected to it.
      config.plist.zip
      DSDT.aml.zip
    • By VortexisTV
      I'm trying to enable UHD 620 graphics on my laptop since it's almost impossible to use Catalina with it disabled (freezing), so after I followed this guide, every time I try to boot into Catalina it does get stuck at the apple logo and progress bar. Heres also the EFI if anyone wants to look at. I'm using this UHD 620 plist to try to get my graphics to work.
       
      ASUS Zenbook UX331FN
      i5-8265U
      Intel UHD Graphics 620
      8GB of SDDR4 Ram

       
    • By Lakkantha
      i install mac Catalina osx but can't boot without fake intel inject. And no audio or wifi. Can you help to make my clover config please
      Efi folder
       


    • By ludufre
      Installing macOS Big Sur 11.0 DP1 on Gigabyte Z370N WIFI + i7 8700K + UHD 630



      Changelog:
       
      06/28/2020 22:05h GMT-0
      - Replaced detach command when creating ISO.
      - Thanks @ham4ever 
      - Added instruction to run one line at time.
       
      06/27/2020 02:37h GMT-0
      - iMessage works too. Just not at first boot.
       
      06/26/2020 18:54h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i7-8700K ->  Work. All SpeedStep stages.
      - Video Card: Intel UHD 630 ->  Work. QE/CI and Metal.
      - Chipset: Intel Z370 ->  Work.
      - HDMI 2.0 (1st) ->  Work.
      - HDMI (2nd) ->  Work.
      - DP ->  Work.
      - Audio: ALC1220 ->  Work.
      - HDMI Audio ->  Work.
      - WiFi/Bluetooth ->  Not work. Replaced with BCM94360CS2.
      - Ethernet (1st) ->  Work.
      - Ethernet (2nd) ->  Work.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Todo
       
      - Fix iMessage (other iServices works perfectly)
      - Nothing
       
       
      Disclaimer! 
       
      Bootloaders are currently unable to start the installation.
      The solution is to use a virtual machine and use a physical disk (additional, USB or SATA, NVME) as a target in the installation.
      Change the OpenCore compiled from the source code, and add some entries in NVRAM through config.plist.
       
      This is not the best solution. But it is the only way at the moment. There are some ready-made images available out there, but I prefer not to use them and create a clean installation.
       
       
      What you need to install
       
      - Running install of macOS
      - Already working OpenCore with this setup
      - Create bootable ISO file
      - Spare Disk/SSD
      - macOS Big Sur DP1 install app
      - Latest OpenCore + Kexts compiled from sources
      - Some KEXTs and SSDT patches
       
       
       
      UEFI configuration
       
      My BIOS is F10 (I use an 8th generation processor, so I don't need to upgrade)
       
      You can configure manually or load my BIOS profile.
       
      Manually:
      - Shutdown and insert the flash.
      - Power on with DEL pressed to enter BIOS setup.
      - Change value: BIOS - CSM Support to Disabled
      - Change value: BIOS - Secure Boot to Disabled
      - Change value: Peripherals - Initial Display to IGP
      - Change value: Chipset - VT-d to DISABLE
      - Change value: Chipset - Internal Graphics to ENABLE
      - Save & Exit Setup
       
      or, BIOS profile
      You can use one of my BIOS profiles attached bellow.
      It's two versions. One stock and another with overclock [5.0 GHz]
      - Put the profile in the root of the flash drive at EFI partition.
      - Restart with DEL pressed to enter BIOS setup.
      - Go to Save & Exit.
      - Select Load Profiles.
      - Select last option and then the flasdrive in the list.
      - And finally choose MACOS_STOCK or MACOS_5GHZ.
      - Save & Exit Setup



      How create bootable ISO file
       
      Download Big Sur DP1
       
      Run this command on Temrinal:
      sudo /System/Library/PrivateFrameworks/Seeding.framework/Resources/seedutil enroll DeveloperSeed Go to System Updater and download the Install macOS Beta app.
       
      Create ISO
       
      Then run on Terminal (One line at a time):
      hdiutil create -size 12G -fs hfs+ -volname install -type SPARSEBUNDLE ~/Desktop/install hdiutil attach ~/Desktop/install.sparsebundle sudo /Applications/Install\ macOS\ Beta.app/Contents/Resources/createinstallmedia --volume /Volumes/install --nointeraction hdiutil detach `diskutil list |grep 'Install macOS Beta' |awk '{print $8}'` -force hdiutil makehybrid -o ~/Desktop/install ~/Desktop/install.sparsebundle rm -rf ~/Desktop/install.sparsebundle
       
      Now you have install.iso on desktop.
       
       
      How create create the virtual machine and install to disk/SSD
       
      Download and install the trial version of the VMware Fusion from their site. I'm used the version 11.5.5.
       
      - Create a custom virtual machine
       

       
      - Operating System: Apple OS X - macOS 10.15
       

       
      - Create a new virtual disk (The size doesn't matter, We'll delete later)
       

       
      - Click in "Customize Settings"
       

       
      - Save the VM on desktop with name: bigsur
       

       
       
      - Insert the spare disk/SSD on PC (reboot if necessary) and identify what /dev/diskX is.
      You can look on Disk Utility.app:

       
      - Create VMDK that point to it:
      sudo diskutil unmountDisk diskX /Applications/VMware\ Fusion.app/Contents/Library/vmware-rawdiskCreator create /dev/diskX fullDevice ~/Desktop/bigsur.vmwarevm/physical sata - Edit the virtual machine settings created previously
       

       
      - Click in Hard Disk (SATA) and delete it (Remove Hard Disk)
       

       
      - Then add the physical disk
       

       
      - There's a bug in Fusion. To select the physical.vmdk, right click then "Quick Look", then "Share virtual disk with the virtual machine that created it"
       

       
      - Click Apply.
       

       
      - Now mount de install.iso
       


       
      - Start the VM and install as usual until: Disk Utility, format GUID with APFS (VMware Virtual SATA Hard Drive Media), Install macOS, wait few reboots and stop at first boot wizard.
       
      This can take up to 45 minutes. It may seem like it is stopped, but it is not.
       

       
      - Press Command + Q and shutdown (usually WIN + Q)
       

       
      - Close VMware Fusion.
       
       
      Copy OpenCore to EFI
       
      - Mount the EFI with:
      sudo diskutil mount diskXs1  
      - Copy your current working OpenCore EFI to that mounted EFI.
       
      - Download mine attached or Update your OpenCore, Kexts and driver UEFI.
              - You can use the @MaLd0n script attached to compile all (OlarilaOC.command.zip)
              - If using mine add your MLB, ROM, SystemUUID and SystemSerialNumber. (see how to)
       
      - Add following items do config.plist:
       
      NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> boot-args -> -lilubetaall (append)
      NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-basesystem + Data + <00>
      NVRAM -> Add -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-kernel + Data + <00>
      NVRAM -> Delete -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-basesystem
      NVRAM -> Delete -> 7C436110-AB2A-4BBB-A880-FE41995C9F82 -> booter-fileset-kernel
       

       
      Done!
       
      Boot from the new disk/SSD and finish de first boot wizard.
       
       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @khamsakamal48, @MaLd0n, @joedm and @vit9696 and all others members involved directly or indirectly.
       
      Attachments
       
      MACOS_5GHZ
      MACOS_STOCK
      OlarilaOC.command.zip
      EFI.zip
       
       
×