Jump to content
Twml

Mac 10.13.1 DSDT help needed

17 posts in this topic

Recommended Posts

I have an HP Elitebook 8460P running High Sierra 10.13.1


 


I'm trying to get battery status working and if I'm understanding it right I need to patch my DSDT.aml to get it working.


I have attempted this and can't seem to get it to compile, always an error. 


 


Also i have managed to brick the system a few times attempting edits. I cant seem to figure it out


 


I need to patch the DSDT to get battery status working even before patching, if attempting a compile with MaciASL I have 2 errors.


 


Im fairly new to getting Mac running on Intel Based PCs. 


any help would be greatly appreciated.


 


Attached is my DSDT.aml file pulled from: EFI/Clover/ACPI/origin/DSDT.aml 


generated by using clover bootloader help menu, via the F4 option. 


 


I used MaciASL to attempt the edits.


using battery patches from here: https://github.com/RehabMan/Laptop-DSDT-Patch


 


Is it possible for someone to patch the file for me, or is it something i have to do?


As i said im fairly new to mac and would like to get this working


 


DSDT.zip

Share this post


Link to post
Share on other sites
Advertisement

I installed the .Kext and put the DSDT in EFI/Clover/ACPI/patched/

I downloaded the newest kext. that had a high number of downloads. not sure if its the right one or what one i actually need.

 

Rebooted in verbose mode boot didnt hang but when getting to the system i still have no battery icon or battery detected.

 

attached in a pic of the battery settings...

 

am i doing something wrong or does it just not work?

do i need to do something special to load the modified dsdt or does it do it automatically when in the patched folder?

 

 

sorry for the stupid questions but im new to mac and have no clue what im doing.

 

post-2396558-0-71365200-1518009122_thumb.jpg

Share this post


Link to post
Share on other sites

I rebooted again and I have the battery icon and no percentage using the first dsdt

 

https://prnt.sc/ibfolb

 

ill try the second dsdt when I get back home.


I got working battery status with the second dsdt.

 

thank you very much.

Share this post


Link to post
Share on other sites

hello

 

second test

 

attachicon.gifDSDT.aml.zip

 

good hack

 

 

Bad new. My battery percentage is gone! I dont know why or how.

Turned off the laptop was working, Next morning Turned back on... nothing.

 

Not sure if an update or something broke it but i have all automatic updates off i though.

 

 

Tried refreshing the origin dsdt files (f4 in clover), tried recopying the dsdt to patched in my efi.

Tried reinstalling the battery kexts.

Tried updating the os to 10.13.3 . (currently running this now if that makes a difference)

 

Still i have no battery percentage, everything else is working like it was before, just my battery is gone again. 

 

 

here is output of kextstat -i for the battery kext. not sure if it helps. but tell me what commands to run and i can post their outputs.

 

post-2396558-0-31020400-1519948151_thumb.png

Share this post


Link to post
Share on other sites

I did try the newest kext, downloaded  RehabMan-Battery-2017-1001.zip   and still doesnt work...

 

 

Edit: 

 

I reinstalled macOS10.13.1 on another hdd.

got battery working and my sound, after a few reboots, its goes away again too. 

and so did my sound this time.

Share this post


Link to post
Share on other sites

New info:

 

This is what i have happening and can reproduce...

 

 

Boot > No battery icon > Install newest battery kext > Reboot > Have battery working > Shutdown > Boot > No Battery...

 

Then if i reinstall the kext, reboot, i have battery until i shutdown. then on next boot up i have no battery again. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By midi-sama
      After a long time of cooking this computer up with a lot of stuff, I'm finally releasing my guide for this P50 with OpenCore.
       
      Lenovo ThinkPad P50 macOS Install with OpenCore
       
      This thread may be used for questions/corrections/additions. Good Luck.
    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
    • By RyzenDude
      Hi everyone,
      Today I finished my High Sierra install with OpenCore. I got everything up and running but I can't seem te get rid of this text on te boot screen while booting up. Does anyone have a solution to this?
      Thanks in advance!
      Hardware:
      CPU: Ryzen 5 1600
      GPU: GTX 980
      RAM: 16 GB DDR4 2666 MHz
      Motherboard: ASUS EX-A320M-GAMING
      Audio Codec: AppleALC
      Ethernet Card: Realtek RTL8111
      Bootloader: OpenCore 0.5.5

    • By hacking2apple
      It's been known that there is indeed support for VGA in Coffe Lake and that support for prior iGPUs was deprecated as the VGA port was removed since Sierra. However, using port patches in Devices Properties (Open Core), I made the VGA port to work again with graphics acceleration.
      But there's a catch, the port is glitchy. Once macOS displays the accounts, you can see the Enter Password box with the blur effect. But after some seconds, the whole display will turn to another color (depends on the background). I'm not sure why that happens.
      I would suggest learning what are Ports, Connectors, Indexes, Types, and BusIDs before continuing, otherwise, you would get lost.
      These are the patches that are supposed to enable the VGA port according to the Whatevergreen Intel guide:
      06020000 02000000 30000000 // Option 1 06020000 01000000 30000000 // Option 2 None of those ports seem to work. The first problem is that the Index is 6, which does not make any sense as the Azul framebuffer only supports up to 3 Indexes (software ports). So we first have to change the Index for the VGA port on your motherboard, which is 2 (physical port is 0x06)) for me.
      So that means that the target port is the Index 2, which is 02040A00 00040000 87000000.
      bus-id 4 is for DP so we would change that to 2, which is VGA. That is according to what Hackintool says. I also proved other bus-ids but none of the other ones seem to work.
      I have no idea what pipe does so I just type zeros.
      I think pipe is basically another way group ports. So later I changed that to 10, which is 0A in hex. That means pipe remains the same as it was originally.  02020A00 01000000 87000000
      The next part is the connector-type, for which I used 02000000.
      I tried the VGA connector-types that Hackintool suggested but I noted some weird differences whereas 02000000 and 01000000 seem to work okay.
      Finally, I don't know what flags do so I tried with 30000000 and 87000000. The only difference is that with 87000000 I'd gain more seconds before the whole screen turns to another color.
       
      This is the final configuration:
      AAPL,ig-platform-id <0300220D> framebuffer-con1-alldata <02020A00 0100000 87000000> framebuffer-con1-enable <01000000> framebuffer-patch-enable <01000000> This is the video proof:
      https://i.imgur.com/bd6jtFh.mp4
       
      macOS Catalina 10.15.3
      Kexts: Whatevergreen 1.3.7
      Boot loader: OpenCore 0.5.6
      PC Specs:
      Intel Core i5 4460
      Intel HD Graphics 4600
      ECS H81H3-M4
      4GB RAM DDR3
      bd6jtFh.mp4
×