Jump to content
reneo

How to get Intel HD 4000 working on a DESKTOP hackintosh

6 posts in this topic

Recommended Posts

I have a Dell All In One desktop 2710, it uses integrated CPU graphics the Intel HD 4000, and has no PCI-e slot for other graphics card. In About Mac it is showing only 14mb of video memory and has glitchy graphics. I think the config is not recognizing the Intel HD 4000 fully. I looked at the Clover instructions, it says to put Inject Intel and put ig-platform-id 0x01620005, 0x01620006 or 0x01620007. I tried all this, with no success. There are many threads about how to get Intel HD 4000 working on LAPTOPS, mine is not a laptop, and there is no guide on how to get it working on Desktop like mine. Please someone help me make it work?

Share this post


Link to post
Share on other sites
Advertisement

I have a Dell All In One desktop 2710, it uses integrated CPU graphics the Intel HD 4000, and has no PCI-e slot for other graphics card. In About Mac it is showing only 14mb of video memory and has glitchy graphics. I think the config is not recognizing the Intel HD 4000 fully. I looked at the Clover instructions, it says to put Inject Intel and put ig-platform-id 0x01620005, 0x01620006 or 0x01620007. I tried all this, with no success. There are many threads about how to get Intel HD 4000 working on LAPTOPS, mine is not a laptop, and there is no guide on how to get it working on Desktop like mine. Please someone help me make it work?

on a series 6 or 7?

 

try 0x01660003 too on desktop

Share this post


Link to post
Share on other sites

hello

 

last clovers do that for u .. will patch the video

 

only inject intel

5:821  0:000  Intel HD Graphics 4000 [8086:0166] :: PciRoot(0x0)\Pci(0x2,0x0)5:821  0:000    Found Full Wide XGA Display - 16:9 :: Width=1366 Height=768
5:821  0:000    Beginning DualLink auto-detection
5:821  0:000    Low Resolution Display
5:821  0:000    AAPL00,DualLink: not used
5:821  0:000    FakeID Intel GFX: not set
5:821  0:000    ig-platform-id = 0x01660003
5:821  0:000    Beginning Intel GFX auto-detection with ACPI injection
5:821  0:000    Found FakeID Intel GFX = 0x01668086
5:821  0:000  Intel GFX revision  = 0x9
5:822  0:000   detected codec: 14F1:5115
5:822  0:000  stringlength = 3224
5:822  0:000  CurrentMode: Width=1366 Height=768

good hack

Share this post


Link to post
Share on other sites

List of HD4000 layouts available in Clover Configurator shown below:

post-851564-0-18971500-1517318746_thumb.png

 

Don't hesitate to use the tool...

 

Edited by Hervé

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×