Jump to content
MaLd0n

[pre-release] macOS High Sierra 10.13.4

457 posts in this topic

Recommended Posts

Can your Ryzen Hackintosh boot to desktop at 10.13.4 DB1 ?

My FX-6300 hackintosh got frozen.

Need update of new AMD kernel I think.

 

It worked but I removed the extra Prelinked kernel immutable kernel first.   

 

http://www.insanelymac.com/forum/topic/331985-pre-release-macos-high-sierra-10134/page-3?do=findComment&comment=2576945

Fury Cards should have support now.    HS 13.1-13.3 had the AMD9300Controllerkext but in 13.4 beta they removed it.   Now the Fury IDs are back in the 9000Controllerkext and 4000kext so it should work now.

Share this post


Link to post
Share on other sites
Advertisement

The same to you…And finally I sloved this problem with inject FB. Maybe we should do something like "CFG_FB_limit" in WhateverGreen.

Which FB are you injecting to get all four ports running?

Doesn't sound like a bad idea to add into the WhateverGreen btw :)

 

EDIT: Apparently having the default FB injected allows all ports to work though I tried manually injecting a few out of the 

AMD10000Controller.kext

 such as Iriri and Japura but didn't have much luck so I might go down the list of FB at some point to get the matching ones that matches against the Vega 64.

Share this post


Link to post
Share on other sites

It worked but I removed the extra Prelinked kernel immutable kernel first.   

 

http://www.insanelymac.com/forum/topic/331985-pre-release-macos-high-sierra-10134/page-3?do=findComment&comment=2576945

Fury Cards should have support now.    HS 13.1-13.3 had the AMD9300Controllerkext but in 13.4 beta they removed it.   Now the Fury IDs are back in the 9000Controllerkext and 4000kext so it should work now.

Thanks.

But I can not rebuild prelinkedkernel successfully even after removed the extra Prelinked kernel immutable kernel first. 

Its size always showed Zero bytes and unable to boot to desktop.

Can you share the working info of kernel, System.kext, & FakeSMC.kext ?

e.g. kernel from Bronya or Shaneee ?

any patched System or FakeSMC.kext, etc.

Edited by jsl

Share this post


Link to post
Share on other sites

Hello,

 

USB remove limit (10.13.4)

 

Find <837d940f 0f839704>

 

Name com.apple.driver.usb.AppleUSBXHCI

 

Replace <837d9411 0f839704>

 

 

 

Fred

hi,fredwst..this patch can works?

Share this post


Link to post
Share on other sites

no

you have splitted only a line find /replace

you have to use both from fredwst original message

 

It's from a clover configurator. Is it right or not?

 

usb.png


no

you have splitted only a line find /replace

you have to use both from fredwst original message


Hello,

 

USB remove limit (10.13.4)

 

Find <837d940f 0f839704>

 

Name com.apple.driver.usb.AppleUSBXHCI

 

Replace <837d9411 0f839704>

 

 

 

Fred

Share this post


Link to post
Share on other sites

I use 1d instead 11 to replace  0f

 

USB remove limit (10.13.4)

 

Find <837d940f 0f839704>

 

Name com.apple.driver.usb.AppleUSBXHCI

 

 

Replace <837d9411 0f839704>

 

hi which value do you replace? thanks 

Share this post


Link to post
Share on other sites

Well, another interesting changes started with 10.13.4 Beta is, "Deprecation of macOS 32-bit support" for apps as described on it's released notes..

 

 

hV4y1at.jpg

 

Share this post


Link to post
Share on other sites

Hello,

 

USB remove limit (10.13.4)

 

Find 0f 0f839704>

 

Name com.apple.driver.usb.AppleUSBXHCI

 

Replace 11 0f839704>

 

 

 

Fred

thx, Fred. bone.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By zee.malik2008
      Nvidia GT 640 3Gb not working in High sierra PC Dell Optiplex 9010. Spinning icon with mouse curser nothing else
    • By rich_mark
      My Mac recovery mode is not working and I haven't found the valid solutions on internet. 
      How to boot Mac into recovery mode and recover the files?
      Thanks in advance!
    • By _ivan_palmisano_
      Ho provato tutti i modi ma sono arrivato alla conclusione che ha bisogno di una patch DSDT.
      Ciao, ho recentemente un hackintosh nel mio laptop e devo risolvere l'attacco video HDMI che non ha eseguito quando collego il mio laptop alla TV.
      le foto con queste informazioni sono state fatte con un programma quando che avrei vinto 10 nell'altra foto l'informazione di hackintosh.
      Acer Aspire 5741g Modello High Sierra System!
      Caratteristiche:
      CPU: Intel Core I3 350M 2.27Ghz Arrandale 32nm Tecnologia
      Ram: 6: 00GB
      Grafica: Monitor Pnp generico (1366x768 Ghz) 1024mb Nvidia GeForce GT 320M (Acer Incorporated)
      Archiviazione: 465 GB Sata
      Driver Optiocal: Optiarc DVD RW- AS-7585H
      Audio: dispositivo audio ad alta degradazione
      Qualcuno può aiutarmi!?! E 'la terza volta che faccio questo post in questo gruppo visto che sono nuovo nel mondo hackintosh preferisco se qualcuno è capace a risolvere il mio problema che lo faccia in remoto così non faccio sbagli.
    • By Prt91
      Ciao ragazzi, sono incappato in un problema che di sicuro sono io stupido.
      Premetto che: Chiavetta 32giga, formattata Journaled e GUID, Clover installato.
      In primis la cartella che crea Clover dei Driver non si chiama drivers64EFI e ne crea una drivers e basta, de facto non legge i driver e di conseguenza la chiavetta per fare l'installazione.
      Pazienza, ho scaricato i driver altrove e li ho buttati in una cartella drivers64EFI, ergo chiavetta rilevata dentro clover.
      Arrivo all'utility disco, inizializzo l'SSD(samsung 860pro) in APFS e facendo partire l'installer non mi fa cliccare l'SSD APPENA formattato dicendomi che sto provando ad installare un MacOS più VECCHIO di quello attualmente installato o.0????????
      Ok, CMD Q e torno all'utility, formatto in Journaled ma nulla di fatto, mi ridice la stessa frase. Faccio hackintosh da snow leopard ma una roba del genere mai vista.
      La chiavetta l'ho creata col classico create installer media da una virtual machine con Mojave. E il driver APFS l'ho cercato apposta per 10.13 e i driver scaricati li ho trovati sul web per una MOBO identica alla mia ma Mojave (Aorus Ultra Z390).
      Non ne vengo a capo. Devo forse formattare la chiavetta in MBR?
      GRAZIE A TUTTI e soz per la nabbaggine
×