Jump to content
MaLd0n

[pre-release] macOS High Sierra 10.13.4

457 posts in this topic

Recommended Posts

5 hours ago, fabiosun said:

@FredWst

this your finding is useful also for DP audio?

I have tried to replace my device id but it is not working (I am using AppleALC kext in my efi previously working till beta 5)

Thank you

 I don't know but give it a try, attach your ioreg

Fred

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)
23 minutes ago, FredWst said:

 I don't know but give it a try, attach your ioreg

Fred

nevermind Fred

It is working as your original post said

I have replaced with my device id (DE10EF10) and my first try was with a wrong config.plist

 

Thank you again

 

Screen Shot 2018-03-28 at 6.50.49 PM.png

Edited by fabiosun
aggiunta immagine

Share this post


Link to post
Share on other sites
Posted (edited)

I did in this way as your original post said

com.apple.driver.AppleHDAController

f
DE100B0E
r
DE10EF10

matchOS 10.13.4

 

@FredWst

have you also a working replacement patch for performance fix?

f
C1E30848 63D389D0 48C1EA20 B9990100 000F3048 FF05C940 6E004883 C4085B5D C3662E0F 1F840000 000000
r
BB00FF00 004863D3 89D048C1 EA20B999 0100000F 3048FF05 C9406E00 4883C408 5B5DC390 90909090 909090

is not working from beta 5

 

 

8 minutes ago, FredWst said:

For AppleALC you need to add your id like this

 

HDAU.thumb.jpeg.dd053eb814ecfa26531490131aeae965.jpeg

 

Edited by fabiosun

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks to @PMheart for sharing this new performance fix kernel patch (if EIST is enabled) working in beta 7 (10.13.4)

find
C1 E3 08 48 63 D3 89 D0 48 C1 EA 20 B9 99 01 00 00 0F 30 48 FF 05 C9 9E 6B 00 48 83 C4 08 5B 5D C3 66 2E 0F 1F 84 00 00 00 00 00
repl
BB 00 FF 00 00 48 63 D3 89 D0 48 C1 EA 20 B9 99 01 00 00 0F 30 48 FF 05 C9 9E 6B 00 48 83 C4 08 5B 5D C3 90 90 90 90 90 90 90 90

Edited by fabiosun

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Ganesh1990
      Hi,
       
      Can Anyone suggest how to disable USB mass Storage in High Sierra, iam currently running 10.12.6 version, 
      I have Tried the Following steps which came across search in google, 
      I Have deleted,
      IOUSBMassStorageClass.kext
      IOUSBMassStorageDriver.kext
      from /System/Library/Extensions folder and tried 
      sudo touch /System/Library/Extensions
      But still My USB Pendrive is detecting.
      Can anyone please help me...
    • By malvibra
      Hi everyone, this is my first post in the forum.

      I have an hackintosh since 2014, built by myself. I installed macOS using ##### two or three times and everything always worked fine.
      I'm still with Sierra, and I'd like to move to High Sierra using Vanilla method. I created the USB, installed Clover, made all the setup in three or four different ways according to different guides, but I get always the same errors.
      It seems that the installer pen drive can't see itself in the drives scheme. I tried different pen drives, tried to change from 3.0 to 2.0 and so on.
       
      Below the links to download the EFI folder and the screenshots of the verbose boot. The configuration of the workstation is in signature.
      EFI
      Screenshots
       
      I hope to have not break any rule in this post, I used the search function but I didn't found anything that help me to fix the installation.
       
      Thanks in advance for help.
       
      Mitch
       
       
       
    • By ludox
      Installazione eseguita con successo al primo colpo.
       
       
    • By Mario1964
      Hello guys,
      Today i installed the beta on my external SSD ( cause i don't have more space in the case)
      i tried in this way:

      and also using this:

      All goes right but, when i 1st boot the hdd it appears as this:
      (the photo was just old , i'm using the new clover)

      and he stuck at apple logo.
      This are the setting i use to make the usb boot:

      what can i do ?
       
      thx
       
       
    • By MaLd0n
      First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with patches for Skylake DSDT.MaLd0n ASUS Z170M PLUS.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DMAC -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -IMEI -PNLF -HDMI --FakeSMC
      http://www.hwsensors.com/releases   --Audio https://github.com/vit9696/AppleALC   --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   --LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!
×