Jump to content
MaLd0n

[pre-release] macOS High Sierra 10.13.4

457 posts in this topic

Recommended Posts

Posted (edited)
10 hours ago, taylorsyn said:

@fabiosun Where is the source of this info from PMHeart?

Hi

private conversation from her blog email

by the way

patch is not working by now with latest beta

Edited by fabiosun

Share this post


Link to post
Share on other sites
Advertisement

Anyone knows the USB limit patch for beta 5?

Ive lost my front panel USB ports with beta 5

Share this post


Link to post
Share on other sites
47 minutes ago, jya said:

Anyone knows the USB limit patch for beta 5?

Ive lost my front panel USB ports with beta 5

 

Patch proposed at beginning of thread is always working.

 

Fred

Share this post


Link to post
Share on other sites
11 hours ago, fabiosun said:

Hi

private conversation from her blog email

by the way

patch is not working by now with latest beta

@fabiosun I have been struggling to get my system stable with XNU kernel patches I have my bios modded to unlock MSR. But I keep getting random freezes. Perhaps you can point me in the right direction?

Share this post


Link to post
Share on other sites
 
Patch proposed at beginning of thread is always working.
 
Fred


The patch changed between beta 3 and 4.

Certainly no longer working for me here...

I've reverted to beta 4 for now,..

Share this post


Link to post
Share on other sites
It removed all but one of my DP ports on the Vega FE.
HDMI is still ok.
Someone care to test their Vega (RX and FE) to see if it's just me?


I have the same issues.

I've written a small kext to get around that problem.
It's available there, need to install it in CLOVER/kexts/Other
https://github.com/jyavenard/Vega5KFixup/releases/download/1.2.1/VegaGraphicsFixup.kext.zip

Along with Lilu.kext (release version)

Share this post


Link to post
Share on other sites
26 minutes ago, jya said:

 


I have the same issues.

I've written a small kext to get around that problem.
It's available there, need to install it in CLOVER/kexts/Other
https://github.com/jyavenard/Vega5KFixup/releases/download/1.2.1/VegaGraphicsFixup.kext.zip

Along with Lilu.kext (release version)

 

I used this kext to patch:

AppleGraphicsDevicePolicy  626F6172 642D6964  626F6172 642D6978   AppleGraphicsDevicePolicy board-id -> board-ix

which I guess is what your kext does?

However, since the 10.13.4 beta 5 update I haven't needed it :)

 

Share this post


Link to post
Share on other sites
5 hours ago, jya said:

 


The patch changed between beta 3 and 4.

Certainly no longer working for me here...

I've reverted to beta 4 for now,..

 

this Pmheart implementation of Fred finding is working well in beta 5

com.apple.driver.usb.AppleUSBXHCI

f
837D940F 0F839704 0000
r
837D940F 90909090 9090

MatchOS
10.13.4

Share this post


Link to post
Share on other sites
On March 13, 2018 at 9:48 AM, d5aqoep said:

How did you patch sound? I have lost HDMI audio.

Rollback to 10.13.3 version of AppleHDA.kext can enable HDMI audio from GTX-1060 and GT-730 again at 10.13.4 DB4/5 !

 

Share this post


Link to post
Share on other sites
I used this kext to patch:
AppleGraphicsDevicePolicy  626F6172 642D6964  626F6172 642D6978   AppleGraphicsDevicePolicy board-id -> board-ix
which I guess is what your kext does?
However, since the 10.13.4 beta 5 update I haven't needed it default_smile.png
 
Yes, that's what it does.
However I found that patching through clover didn't work for me, while when doing so in a kext it did.
My guess was that it was a timing issue as to when to do it.
I do need it even with beta 5, otherwise my 5k screen stays black.

Sent from my SM-G950F using Tapatalk

Share this post


Link to post
Share on other sites
2 hours ago, fabiosun said:

this Pmheart implementation of Fred finding is working well in beta 5

com.apple.driver.usb.AppleUSBXHCI

f
837D940F 0F839704 0000
r
837D940F 90909090 9090

MatchOS
10.13.4

Thanks which is working for me too at 10.13.4 DB5.

Share this post


Link to post
Share on other sites
3 hours ago, jsl2000 said:

Rollback to 10.13.3 version of AppleHDA.kext can enable HDMI audio from GTX-1060 and GT-730 again at 10.13.4 DB4/5 !

 

I think Apple is close to allowing Nvidia to enable HDMI audio on their drivers as well as 4K @ 60Hz through HDMI

Share this post


Link to post
Share on other sites
9 hours ago, d5aqoep said:

I think Apple is close to allowing Nvidia to enable HDMI audio on their drivers as well as 4K @ 60Hz through HDMI

Based on what?

10.13.4 Beta: current AppleHDAController.kext revision no longer sees the still present Nvidia HDMI audio controller device-id. Disables macOS Nvidia HDMI audio on all native Nvidia graphics supported Apple products, in addition, to all Nvidia Web driver installations.  Expect a bug fix prior to 10.13.4 release.

Share this post


Link to post
Share on other sites

here also, real AppleHDA problems with 10.13.4 Beta's and my AD1984A audio with AppleALC and Lilu.
rollback AppleHDA 10.13.3 with AppleALC and Lilu -> works
my ALC888 works without problems with beta HDA's and AppleALC and Lilu
only the AnalogDevices AD1984A no longer
so far I have not found a mistake

Share this post


Link to post
Share on other sites
3 hours ago, MacPeet said:

here also, real AppleHDA problems with 10.13.4 Beta's and my AD1984A audio with AppleALC and Lilu.
rollback AppleHDA 10.13.3 with AppleALC and Lilu -> works
my ALC888 works without problems with beta HDA's and AppleALC and Lilu
only the AnalogDevices AD1984A no longer
so far I have not found a mistake

In my hackintoshs AppleHDA.kext of 10.13.4 DB4 or DB5 broke HDMI audio from Nvidia GTX-1060 & GT-730 as well as AMD R9 290X, only rollback to previous working version can fix it immediately. But ALC888 or ALC1150 were not broken.

Share this post


Link to post
Share on other sites

Guys,
Has anyone succeeded to install macOS 10.13.4 DP5?

All I get is the kernel error when I try to boot into the installer.

I tried to boot with AptioMemoryFix.efi Rev.16, OSXAptioFix3Drv. I tried to remove the prelinkedkernel and caches.

Share this post


Link to post
Share on other sites
Guys,
Has anyone succeeded to install macOS 10.13.4 DP5?
All I get is the kernel error when I try to boot into the installer.
I tried to boot with AptioMemoryFix.efi Rev.16, OSXAptioFix3Drv. I tried to remove the prelinkedkernel and caches.
Me. No problem. I'm using free2000 version. I never have been exprienced kernel error.

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

@Cyberdevs No issues on my Optiplex 755, Optiplex 790 and HP Probook. All three updated through AppStore

Share this post


Link to post
Share on other sites

Maybe this is happening on my rig because I have 3 EFI partitions with clover, once I booted into the second stage of the installer and it gave me the old installer damaged error. I'll try to remove those efi folders and try again.

Thanks for the replies @Sherlocks and @ricoc90 :)

Share this post


Link to post
Share on other sites
Posted (edited)
25 minutes ago, Cyberdevs said:

What is the latest beta’s build number?

17E182a :)

EDIT: SV0911 was faster.

Edited by ricoc90

Share this post


Link to post
Share on other sites
7 hours ago, Cyberdevs said:

Guys,
Has anyone succeeded to install macOS 10.13.4 DP5?

All I get is the kernel error when I try to boot into the installer.

I tried to boot with AptioMemoryFix.efi Rev.16, OSXAptioFix3Drv. I tried to remove the prelinkedkernel and caches.

no problems here.. i use aptiomeory.efi of clover r4398

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Ganesh1990
      Hi,
       
      Can Anyone suggest how to disable USB mass Storage in High Sierra, iam currently running 10.12.6 version, 
      I have Tried the Following steps which came across search in google, 
      I Have deleted,
      IOUSBMassStorageClass.kext
      IOUSBMassStorageDriver.kext
      from /System/Library/Extensions folder and tried 
      sudo touch /System/Library/Extensions
      But still My USB Pendrive is detecting.
      Can anyone please help me...
    • By malvibra
      Hi everyone, this is my first post in the forum.

      I have an hackintosh since 2014, built by myself. I installed macOS using ##### two or three times and everything always worked fine.
      I'm still with Sierra, and I'd like to move to High Sierra using Vanilla method. I created the USB, installed Clover, made all the setup in three or four different ways according to different guides, but I get always the same errors.
      It seems that the installer pen drive can't see itself in the drives scheme. I tried different pen drives, tried to change from 3.0 to 2.0 and so on.
       
      Below the links to download the EFI folder and the screenshots of the verbose boot. The configuration of the workstation is in signature.
      EFI
      Screenshots
       
      I hope to have not break any rule in this post, I used the search function but I didn't found anything that help me to fix the installation.
       
      Thanks in advance for help.
       
      Mitch
       
       
       
    • By ludox
      Installazione eseguita con successo al primo colpo.
       
       
    • By Mario1964
      Hello guys,
      Today i installed the beta on my external SSD ( cause i don't have more space in the case)
      i tried in this way:

      and also using this:

      All goes right but, when i 1st boot the hdd it appears as this:
      (the photo was just old , i'm using the new clover)

      and he stuck at apple logo.
      This are the setting i use to make the usb boot:

      what can i do ?
       
      thx
       
       
    • By MaLd0n
      First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with patches for Skylake DSDT.MaLd0n ASUS Z170M PLUS.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DMAC -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -IMEI -PNLF -HDMI --FakeSMC
      http://www.hwsensors.com/releases   --Audio https://github.com/vit9696/AppleALC   --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   --LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!
×