Jump to content
Sign in to follow this  
Followers 0
rxm888

fresh install on intel DQ67OW board

4 posts in this topic

Recommended Posts

i have ended up getting high sierra installed on my intel DQ670w board. i used a premade high sierra/clover dmg i extracted to a usb flash drive. right now the audio, networking arnt working and the video card i have in the machine an nvidia geforce 1050 gtx ti it works but has very very very choppy/jittery video. i did find some kext files for the network and audio but when i put them in the extensions folder they didnt do anything to add audio or networking. also i have to get the machine to boot from the hard drive rather then having to boot the usb flash drive to get the hard drive to boot and i have to work on the video card stuff as well. i am not to good at this stuff cause usually when i have tried stuff i end up breaking stuff or that stuff doesnt work. i am not all that code or certain tech savy. i am not the brightest. i like things laid out where its all like this is the files and where you get them from this is how u work with them kind of thing. it does agravate me when people just wont lay out stuff as like a dummy book does and makes everything easy. i tried on facebook groups and got as far as to be told what kexts to find but never told where to find them. i did try to look on my own and i did find a few kexts but they where ones that needed alterations to the os to even make them usable. the video kext or driver i was told to install it and do something like change something to true. all i need are the kext files and to make the machine boot from the hard drive rather then complaining it doesnt have an os on the drive or having to use the usb flash drive to make it boot and the video files and to know how to deal with the files and make them work without having to start over with everything and reinstalling stuff

Share this post


Link to post
Share on other sites
Advertisement

 

i have the files that are on your post now i have to figure out how to deal with them. the clover file u have you say install clover first then replace with this one that you have. how am i to do that when i dont have clover in the first place also i need to be able to install the kexts as well but unless i am able to do this stuff i may end up with a system that wont work at all and be back to square one making a new usb installer and such and reinstalling the os and booting from the usb to get the hard drive to work

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By arsradu
      Hi guys,
       
      So, this little tutorial is meant to help people fix a new issue with Mojave: opening jpg files (looks like it happens with larger files, not so much with smaller ones) using Quick Look (on spacebar key pressed) or Preview app using the dedicated GPUs.
      The issue is that, when trying to open jpg files (for some reason, it doesn't occur with pngs), the pop-up window would remain in an endless loop. And from that point forward, any other app trying to open the same file, will either become unresponsive (in the case of the Preview app) or just stay in endless loop (in case of Quick Look)
       
      As a workaround, in case the tutorial below doesn't work for you, you can use Grab (built-in app in MacOS) to open said files.
       
      This issues DOES NOT occur using the iGPU. So...if you're comfortable using the iGPU, just switch to that and you should be good to go. You don't need this tutorial.
       
      This tutorial is based on @Cyberdevs' research and testing on this topic (especially useful if you're using an RX series AMD video card), and my own very limited time testing this on my rig. I just thought it would be useful to create a new thread for it so that people can discuss this particular issue here.
       
      The main thing we need to do is actually very simple: we need to enable the iGPU (integrated GPU) by default, in BIOS, while actually being connected to the dedicated GPU.

       
      With that being said, I'll just move on to the actual tutorial.
       
      For ATI (curtesy of @Cyberdevs' post here).
       
      The discreet GPU should be set as primary in BIOS and your displays should be connected to your discreet GPU
      The iGD/iGPU/iGFX must be enabled in BIOS/UEFI as the secondary GPU.
       
      I removed the DSDT Reconfigured the config.plist to and removed some flags which weren't needed because of the DSDT added the InjectATI + Ornioco Framebuffer (I removed the Orinoco framebuffer because of some weird glitches but it might be useful for other AMD GPUs if you inject the correct framebuffer according to your GPU. No need to inject anything for nVidia GPUs unless your GPU needs it) Added the InjectIntel + ig-platform-id for my intel HD530 (for intel HD 530 I use the 0x19120001 ig-platform-id) Removed com.apple.finder.plist Removed com.apple.QuickLookDaemon.plist rebuild the kextcache and reset the nvram  
      Steps 5 to 7 might not be necessary I just did them anyway, if anyone succeeded to get quicklook working without those steps let me know so I can exclude those steps.

           Also confirmed to work with AMD R9 270X on a SandyBridge rig (without an iGPU) using WhateverGreen + Lilu kexts, which also helped to solve the transparency issue along with the Quick Look problem, it also resolved the buggy Screen Capture (Command+Shift+5) issue as well. 
       
          Also, do:
      nvram cleanup kextcache & prelinked kernel rebuild reboot   
      More info on that here.
       
       
      For NVIDIA
       
      This is what I needed for my NVIDIA rig and the MSI motherboard in the signature. Your milage may vary, depending on your hardware. But, the idea should be the same regardless.
       
      Set your BIOS to use PEG (dedicated GPU) so you can boot.
      Since you're reading this, chances are that you're already connected to the dedicated GPU and the BIOS is set to PEG. So just go into BIOS and see if you're using the iGPU or the dedicated (PEG) graphics device by default.
      If you're already using this, skip to Step 3 (the part AFTER Reboot). Reboot (I think you don't necessarily need to boot into the OS...but you do need to reboot at least until Clover UI) Reboot back into BIOS and set it from PEG to IGD (integrated graphics) WITHOUT removing the cable. Reboot again.  
      The result should be that the OS is tricked into thinking you're booting with the IGPU when in fact you're using the dedicated GPU.
       
      You will also need to patch the iGPU from Clover config.
      1. Graphics -> Inject Intel (UNCHECK Inject Nvidia or ATI if it's checked).
      2. ig-platform-id (in my case for Intel HD 4600 Desktop) it was: 0x0d220003
       
      And use IntelGraphicsFixup.kext in Clover/kexts/Other. In my particular case, without the kext, I would get freezes in Safari.
       
      This might be a bug with Mojave and it could be fixed by Apple in the future. but in the meantime, feel free to use this if it helps you fix the issue.
       
      Cheers!
    • By IPN96
      Ciao mi scuso per il disturbo, io vorrei abilitare la mia scheda grafica Nvidia geforce gtx 950m per avere delle prestazioni migliori quando lavoro su after effect, la scheda Intel non è ha abbastanza memoria non so se sia possibile fare qualcosa, spero possiate aiutarmi, vi lascio delle info. 
      Sistema operativo Mac osx sierra 10.12.6 
      Modello laptop : Asus N551jx-cn043t
      Il resto è nella screen 
       
       

    • By MaLd0n
      Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Mojave Full DSDT patch http://olarila.com/forum/viewtopic.php?f=59&t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder   CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   CLOVER Post Install.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By Buildahackintosh
      Hi everyone,
       
      I was able to successfully install OS X High Sierra on a 8700k with a GTX 1080Ti
       
      Everything seems to be working fine but I've been reading on other people suggesting to make sure hardware acceleration *is* working fine.
       
       
      I installed the web drivers for nvidia (and disabled SIP after installation)
       
      Web drivers version: 387.10.10.10.35.106
      CUDA Driver version: 396.64
      OS X system version is 10.13.5 (17F77)
       
       
      After installing the latest CUDA drivers, I was able to select the GPU option in "ray-trace" in After Effects (preferences > previews > fast previews > GPU Information...)
       
      I'm not sure how else am I able to test whether the GPU acceleration in other applications is enabled and running properly?
       
      PS: I don't have final cut pro so I'm unable to test that application...
      PS 2: ig-platform-id in config.plist is set to 0x59120003
       
    • By Gymnae
      Introduction
      The H370 chipset powers 8th generation Intel Core-i CPUs. Even though the name H370 rings comparable to Z370, the H370 is based on newer silicon. This it also requires some new approaches compared to the Z370. An example would be on-die USB 3.1 and WiFi support.
       
      Since this guide is not a "hold-your-hand-every-step" guide, I assume you know:
      Clover installation and configuration How to create an install medium for MacOS Access and configure the BIOS Have heard of ACPI patching (I'm a newb at this myself)  
      What works
      Sleep (via DSDT edits and emulated NVRAM) On-board Audio (via CloverALC script) Native power management (without any kext or patch) All USB ports (and only those present are active) iGPU for both acceleration and display dGPU (I'm running an Nvidia GTX 1080)  
      Untested
      NIC --> I'm using WiFi only  
      What doesn't work
      Native NVRAM via AptioMemoryFix.efi DMVT Pre-alloc higher than 64MB (but not necessary)  
      Changes to the guide:
      22.5.18: Added SSDT hot-patching to enable sleep, replacing DSDT static patching as an alternative.
      23.5.18: Add iMac18,1 as alternative SMBIOS config for those relying on the iGPU for output
      25.6.18: Added update info
       
      1. Installation
      This guide heavy inspired by the work of /u/corpnewt of /r/hackintosh and his (sorta) Vanilla guide
       
      1.1 Create the install media for MacOS
      Follow this, if you are using a Mac to start off with. If you are totally new to MacOS, then please check the basic guide Creation of an installer media in windows or linux
       
      1.2 Install Clover on the install media
      Using the Clover installer, ensure you are installing to the USB medium you are using for the installer.
      Chose the following options:
      AptioMemoryFix UEFI booting only Install to ESP You have to get your hands on an apfs.efi. A google search can help, or extracting it from the Installer package. Make sure you procure a version matching the MacOS version you are about to install. Place the apfs.efi in drivers64UEFI.
       
      1.2 Adjust the config.plist for the installer
      You can use the config.plist attached as a guideline, but take a look at it before and at least adjust the SMBIOS - otherwise it won't boot.
      Attention: The attached plist contains audio patches introduced by a post-install step. If you run into problems, you might remove those. It also contains a manual slide value, which should normally not be needed, but works fine for me. It is also tuned for usage with an Nvidia Pascal dGPU as main GPU.
       
      The config you create now should serve you nicely for install and running the system.
       
      Take care of adding the following basics:
      SMBIOS: iMac18,3 - You can generate a serial number via Clover Configurator. The creation of a proper SMBIOS is covered in many guides to good extend Note: If you aim at using the iGPU for output, a user reported that iMac18,1 works better - since iMac18,3 produces sever flicker. Look at the graphics section and adjust the injection for Intel to your situation  
      Fixes

      Patches

      Devices

      Graphics

      Kernel and Kext patches
       
      1.3 kexts and friends
      Add the supplied SSDT-UAIC.aml to "patched" - it limits the injected USB Ports to the actual number and ports valid for this board.
       
      Required kexts on "Other":
      FakeSMC.kext IntelGraphicsFixup.kext Lilu.kext When having an Nvidia card: NvidiaGraphicsFixup.kext IntelMausiEthernet.kext in case you're running Ethernet USBInjectAll.kext with the HCI-300-series-injector.kext --> These two should be installed to /L/E after install  
      We are leaving sound out at the moment, this is something for post-install. Please note the absence of Shiki, I don't find it necessary. Video material I tried made use of the iGPU without shiki.
       
      1.4 Check BIOS and install
      You should be ready for install. But before you reboot, please take a look at your BIOS and set it up accordingly (copied from the aforementioned guide and adapted):
      Load Optimized Defaults Disable VT-d setting If your system has Secure Boot Mode, disable it Set OS Type to Windows 8/10 or OtherOS - I have not seen a difference Turn off internal Serial and Parallel port Turn off Network stack for boot Turn off wake-on-lan (for now) Set XHCI Handoff to Enabled Don't enable decode over 4G Depending on your GPU, set priority for boot Set internal GPU to enable Set DMVT pre-alloc to 64MB Set USB legacy to enabled Activate XMP profile 1 f your Ram has it (mine doesn't and I added the timings manually) Set ERP to enable, disable platform power management (I need to do more research if this could be enabled)  
      I've attached my current BIOS config "hack2". You can place that on a fat32 drive (the EFI partition of your install USB drive might be an idea) and see if it loads. It's made for and with the F2 BIOS.
       
      The install itself should be like other MacOS Hackintosh installs with it several reboots and ensuring to select the correct boot device in Clover.
       
      2. Post-install
       
      2.1 Install clover on target
      This is a no-brainer, but install a fresh copy of Clover on your target medium.
       
      During install select again AptioMemoryFix but also additionally
      EmuVariableUefi-64.efi Install RC scripts on target volume because otherwise NVRAM doesn't seem to work
       
      After the install, copy
      config.plist contents of "Other" content of "patched" apfs.efi from drivers64UEFI to your new clover install.
       
      2.1 Edit ACPI for slumber
      Choose one option, not both. The hot-patch is experimental, but for the moment it is stable.
       
      2.1.1 Edit DSDT
      This is necessary only once on initial install and every time, you edit or upgrade the BIOS. The DSDT.aml attached to this post might work for your system or give you a file to compare to. Don't expect it to work for you, though.
      I won't go into the details of DSDT extraction and patching. There are better guides (the linked guide is a rip-off of rehabman's guide from a different forum). Please follow such a guide to extract your ACPI data.
       
      Locate and disassemble the DSDT with the newest iasl binary you can put your hands on, then open it with MacIASL in its newest version you can find (Hint: Here is a good source) You can check if the version is new enough if MacIASL doesn't throw error upon compiling a freshly extracted DSDT.aml or DSDT.dst
       
      Add rehabmans repo (as per linked guide) and apply the following patches:
      Rename _DSM to _XDSM Fix _WAK Arg0 v2 USB3 _PRW 0x6D Skylake (instant wake) Find the CNVW device and remove the _PWR function there.
       
      Compile the DSDT and place it in "patched".
       
      2.1.2 Use SSDT hot-patching
      Instead of having to re-extract and re-patch the DSDT on every BIOS change or update, Hardware change one can also use ACPI hot-patching.
      It's a combination of config.plist patches and an SSDT, which is hot-patched into the ACPI (if I understand the process correctly)
       
      You need to add this SSDT-GPRW.aml to your Clover folder in the designated position at Clover/ACPI/patched You need to add this patch to your config.plist. It goes into the DSDT patch section  
      Note: This works for me, but the patch removes the _PRW method from all devices in the DSDT. This could have side-effects. So far, I have seen none. At the moment I'm also not applying any other patch, compared with the additional edits I made to the DSDT method before.
       
      2.2 Install kexts to system
      As mentioned in the install section, it's better to follow rehabman's instruction and install USBinjectAll.kext to /L/E:
      sudo cp -R Release/USBInjectAll.kext /Library/Extensions sudo touch /System/Library/Extensions && sudo kextcache -u / 2.3 Enable onboard Audio
      This is where I'm not so happy currently, I'd like it to work without altering AppleHDA. But currently I find no other way.
       
      2.3.1 Install FakePCIID & FakePCIID_Intel_HDMI_Audio
      Rehabman tells us to use a kext installer to install it to /S/L/E. Chose the RELEASE folder
       
      2.3.2 Run CloverALC command
      Ensure your EFI partition is mounted before running this command
      Get the newest version of CloverALC command (audio_cloverALC-xxx.sh) and run it. Our Audio codec is RTL887 and I'm running with layout ID 1
       
      2.4 Optional steps
      If you have a dGPU, now it's the time to install its drivers and adjust the config.plist for it.
      This is out of scope of this guide. Yet, my supplied config.plist is ready to be used with Nvidia Pascal cards and using the Nvidia web driver.
       
      3. Updating
      Updating inside 10.3.x point updates doesn't require much attention:
      Download the update from the AppStore as any Mac would do Allow the system to reboot Before booting MacOS with Clover, make sure to disable extra drivers for dGPUs which require non-native support. If using an Nvidia dGPU: Remove "nvda_drv=1"  from your boot arguments and disable Nvidia injection If using a non natively supported AMD card, do the same for AMD (I'm not using AMD, thus I cannot be specific) Boot into the newly created Install MacOS partition Repeat this process until the Install partition is gone Boot MacOS again, still following 3., and potentially install updated drivers Your Audio might require re-patching  
      4. ToDo
      Move away from static DSDT patching to SSDT hotpatching --> requires my work Native NVRAM --> requires developer work Audio without AppleHDA patching --> requires developer work  
      5. Thanks to
      @MaLd0nfor helping finding the right way with the DSDT
      @RehabMan, for being a legend and helping me out patching
      @toleda, for audio patches for the 300 series
      /u/corpnewt, for his superb vanilla guide
      @wmchris for his super XPS 9550 guide and introducing me to hot-patching
      all the developers of clover and it's awesomeness
       
      SSDT-UIAC.aml
      config.plist
      DSDT.aml
      hack2
×