Jump to content
Dan ZG

Some questions about DSDT (*.aml) loading in Clover

4 posts in this topic

Recommended Posts

Say I have TWO .aml files in EFI/CLOVER/ACPI/patched -- dsdt1.aml and dsdt2.aml.

I want to compare how they affect my machine.

Now, I wanted to try NOT loading either of them. So in config.plist I set 'DSDT Name' set to null, i.e., there is no value.

But checking bdmesg it shows

Inserting dsdt1.aml from EFI\CLOVER\ACPI\patched ... Success
Inserting dsdt2.aml from EFI\CLOVER\ACPI\patched ... Success

Does "Inserting" mean they were loaded? Or just recognized?

Did BOTH of them get loaded?

Do they have to be called DSDT or is that arbitary?


Do I need to actually remove them from ACPI/patched in order to NOT load them?


I'd like to be able to choose a DSDT, or none, from within Clover at boot.


I'm hesitant to remove them because if one option prevents me from booting MacOS, then I'm SOL because putting it back will be a PITA.


Can I put them in a different folder and still load one from Clover options?



Share this post

Link to post
Share on other sites

just use it...

press O key in Clover boot screen, go to Acpi Patching/DSDT Name and put DSDT3.aml(file dont exist in ur folder Clover/Acpi/Patched and clover use native table), best for test, problematic edit, etc

Share this post

Link to post
Share on other sites

That's what I thought ... though I typed "xxx" instead of "dsdt3.aml" ... that should block also, yes?


So when bdmesg says "Injecting" ... what does that mean? It's not applying them?


Is there any way to be sure which AML was loaded, if any?

Share this post

Link to post
Share on other sites

That's what I thought ... though I typed "xxx" instead of "dsdt3.aml" ... that should block also, yes?


So when bdmesg says "Injecting" ... what does that mean? It's not applying them?


Is there any way to be sure which AML was loaded, if any?

u can extract DSDT after boot and check if have ur patches, if yes DSDT load

u can put name here

MaLd0n 2018-01-20 às 22.52.08.png

dsdt1, dsdt2, i put MaLd0n ;) just for fast check

just open Maciasl and u see if load or not


i never test xxx, but i think work too

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By KrzychuX86
      Hello my friends!
      First, idk if that's proper place for this post, if not, please move it.
      I'm trying to get Mojave working on my laptop. I have all proper kexts. Everything works great on Yosemite and Sierra, because I'm using Enoch bootloader for them. But I can't get Mojave to work with Enoch, so my only option is Clover.
      But I have some troubles with it:
      - I don't have uefi interface in my laptop, so my only option is Clover for BIOS,
      - Niresh Mojave contains only option to install Clover for UEFI. After installing it my system drops to PXE because it doesn't have UEFI so hard disk becomes non-bootable.
      But these problems can be solved, I "just" need to install Sierra first, which can be booted via Enoch and then I install Clover using official pkg installer, which has option to install BIOS version of Clover. Then I connect Niresh Mojave USB, Clover detects it and boots installer. I uncheck "Install bootloader" and I get bootable Mojave. Yay
      But the real problem is:
      Clover on my device is not working as well as Enoch. Why? Because when I'm on Enoch (for example on Sierra) my kexts for PS/2 keyboard and touchpad (Voodoo PS2 Controller kext) and for Wi-Fi are working good. They are installed in S/L/E and just works. But Clover somehow doesn't want to load them... or has something missing. System booted with Clover has not working keyboard, touchpad working as mouse and not working Wi-Fi.
      Guys! What I have to do to make Clover work as good as Enoch? What Enoch has that Clover hasn't? Why Clover can't load any kext EVEN from CLOVER/kexts/other?
      I have tried booting with -v but I don't see any error related to that...
      Can you help me please?
      Both Enoch and Clover configs are default ones without any modifications. 
      Any help is appreciated.
      P.S. I have lost all DMGs so I can't install MacOS right now, I need to redownload them but my Internet connection is very slow, so for any logs we'll need to wait. But maybe my problem is very easy to fix so I don't need to send any logs? Thanks for any answer
    • By viktr
      A few days ago I faced a problem - installed ocquirks and it somehow broke my prelinked kernel. System won't boot then, and I spent more than a day restoring from the netatalk  backup to copy working prelinked kernel directory from the backup to the s/l
      So, my question is - how to relink prelinked kernel without that? I found boot args -f UseKernelCache=No but it didn't work. I was able to boot to the recovery, if that can help.
    • By anokic
      I have been using clover to install and configuration my Hackintosh High Sierra 10.13.6. It's been a struggle and a pain. Can't restart/shutdown/wake from sleep. Random freezes. When freeze happens mouse works but in loading state. UI and open apps freeze not the mouse. I can make the apps smaller and move them.

      I haven't used any DSDT nor SSDT. Tried 5 or 6 of them from others but sometimes i end up not booting. Could someone explain me do i even need them and why? Do i need DSDT or SSDT or both?

      I'm going to try to install everything OpenCore. The first thing is i can't use a method that needs an internet while installing MacOS cause my ethernet/internet only works when i install MacOS. So i can't use the images i need full installation. Okay i have the full installation for 10.13.6. I need to use a version 10.13.4-6 versions cause application Sketch needs the newer one High Sierra 10.13.4++ version.

      Can you tell me? Can i use same kexts from Clover on OpenCore? Secondly how can i install full USB MacOS installer? (High Sierra 10.13.6 version i have is 7gb i think thats it)
      Is there a version of AMDHigh Sierra version made from the community for 10.13.4++ version?
      If i use the normal 10.13.6 High Sierra should i use this AMD 10.13.6 Kernel when i have installed the MacOS or some other kernel that's better for my system? https://github.com/Shaneee/AMD-High-Sierra-XNU/releases
      Whats the best version of High Sierra to use for Ryzen and Nvidia system?

      Will it be better to use OpenCore?

      Mortar Max B450M
      Ryzen 2600x
      Nvidia GTX 1060
      16gb DDR4 2400mhz
    • By TimothyF
      My steps so far:
      Set up Catalina install USB exactly according to Plain Vanilla guide. Disconnect my Windows drive in PC, so that only the empty Hard Drive is connected to Motherboard. Boot to USB, select Install Catalina option. BIOS set to UEFI, Safe mode Off. Always get stuck at the same IOconsoleUsers: GIOScreenLockState point. Tried -radvesa, -radoff, nv-disable=0 boot options (separately), and disabling BIOS virtualization (vt-d) -> NO luck. This from the top search result https://www.reddit.com/r/hackintosh/comments/b5a6ry/ioconsoleusersgioscreenlockstate_3_blackscreen/  
      Screen pics attached. Here are the last couple of lines that could be important:
      GTrace synchronization point 4
      Unsupported CPU
      Unsupported PCH
      Adding ADGP mode validate property
      hmm.. mismatch sizes 3100 vs 20
      IOConsoleUsers: time(0) 0->0, lin 0, llk 1,
      IOconsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
      Please give me some ideas what else might work. Thank you.

      Other details of Clover and Desktop PC below:
      Clover USB specs OS installer used: Catalina (10.15) Clover revision: 5103 Kexts included: ATH9KFixup.kext AppleALC.kext Lilu.kext RealtekRTL8111.kext USBInjectAll.kext VirtualSMC.kext WhateverGreen.kext config.plist: config.plist ------------------------------------------ Target Desktop specs: Dell Inspiron 3847 (64 bit) CPU: Intel Core i5-4460, 3.2 GHz, 4 cores Architecture: Haswell GPU: Intel HD 4600 Motherboard: Dell 088DT1 (version A01) Chipset: Intel H81 Install method: with USB, configured with Clover, 100% following Plain Vanilla guide for Desktops RAM: 12 GB, 2 slots Hard drive for installation: SATA HDD 4TB, by HGST LAN: RTL8111/8168/8411 WLAN: AR9565 (atheros) Audio: Realtek ALC661 (not 100% sure this is correct)  
    • By MaLd0n
      Install MacOS with Olarila Image, Step by Step, Install and Post Install  
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Install Sierra/High Sierra and boot into system!   Post Installation   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.GA H110M-S2.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!