Jump to content
Zsparrow0

[Guide] Dell XPS 15 9560 - High Sierra 10.13.2

39 posts in this topic

Recommended Posts

NOT WORKING
 
SD Card Reader (Use USB adapter )
Hibernation
Nvidia Graphic Cards
Fingerprint Reader
Thunderbolt HotPlug
REQUIREMENTS
 
Fresh installation
One working OSX environment
Whole disk available (No partitions)
Knowledge in PLIST edition
Backup Made (EVERYTHING WILL BE ERASED)
Latest BIOS version
4k sector patch NVME
WIFI CARD DW1560 (EFI FOLDER CONTAIN PATCH FOR THIS CARD ONLY)
 
 
1 - CREATE USB
 
 
  • Download High Sierra from AppStore
  • Plug in your USB Key (16GB or More)
  • Format it with Disk Utility and name it « MyVolume »
  • Launch Terminal and type : sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume
  • Mount the EFI partition /MyVolume/EFI/ with Clover Configurator (See in the EFI Folder)
  • Copy the entire EFI folder linked to the post to /MyVolume/
2 - BIOS SETTINGS
 
MAKE SURE EVERYTHING IS CORRECT BEFORE CONTINUE OR IT WILL FAIL ON BOOT !
 
  System Information
 
 
  •      Check that Video Memory is already 64MB 
  •      Advanced Boot Options (all off
 
 
  System Configuration
  •      SATA Operation (AHCI)
  •      Drives (all on)
  •      SMART Reporting (on)
  •      USB Configuration (all on)
  •      Dell Type-C Dock Configuration (on)
  •      Thunderbolt Adapter Configuration (all on, no security)
  •      USB PowerShare (on)
  •      Audio (all on)
  •      Touchscreen (on)
  •      Miscellaneous Devices (all on except SD Card Reader)
  •      CPU XD (on) 
 
  Secure Boot
 
  •      Secure Boot Enable (disabled
 
  Intel Software Guard Extensions
 
  •      Intel SGX Enable (Software-Controlled) 
 
  Performance
 
  •      (Everything on/enabled
 
 
  Power Management
 
  •      (USB Wake Support = off)
  •      (Wake on Dell USB-C Dock = on) 
  •      Wake on WLAN (off)
  •      Block Sleep (off) 
 
 
  Virtualization Support
 
  •      (Everything on) 
 
3 - BOOT PROCESS
 
  • Start your computer and press F12 to open the boot menu
  • Boot from your USB Key
  • Select the "Installer from (Your usb key)" (Verbose mode is enable by default to see what's going on if it fail)
 
-----------------------------------------------------------------------------------------------------------------------------------------
 
 
WAIT ! EVEN IF YOU THINK THAT THE LOADING BAR IS STUCKED IT COULD TAKE 5MIN TO LOAD ENTIRELY
 
 
IF IT FAIL SEE THE REHABMAN GUIDE BEFORE ASKING QUESTION
 
 
IF YOU CAN'T BOOT YOU CAN TRY TO USE A FAKE IG-PLATFORM
GO TO THE CLOVER OPTION IN THE GRAPHIC PARTS AND USE A FAKE IG-PLATFORM SUCH AS 34567898764
 
----------------------------------------------------------------------------------------------------------
 
 
4 - INSTALLATION
 
- Once arrived on the installation screen
- Open Disk Utility and Erase your Main Hard Drive and format to : MacOS AFPS (not encrypted)
- Go back to the installer continue and choose your Formated Hard Drive to install MacOS.
- The computer will reboot after about 2 min
- Press F12 to choose your usb key and hit ENTER
 
(YOU COULD HAVE 2 CHOICE DURING THE REBOOT : INSTALLER ON "YOUR DRIVE NAME" OR PRELOADER "YOUR DRIVE NAME". You have to use "Installer on your "drive name" in case it FAIL select the OTHER OPTION.
You will have to do this twice if I remember correctly.
 
BE CAREFUL YOU HAVE TO ALWAYS BOOT ON YOUR USB KEY BECAUSE CLOVER IS NOT YET INSTALLED ON THE SYSTEM, SO PRESS F12 ON EVERY REBOOT AND CHOOSE YOUR USB KEY UNTIL CLOVER PROPERLY INSTALLED
 
 
5 - POST INSTALLATION
 
- Open Kext Wizard in My EFI folder
- Click on installation tabs browse kext and select ALL THE KEXT IN USB/EFI/CLOVER/KEXT/OTHER
- Make sure that the destination drive is your MAIN HARD DRIVE and press INSTALL
- Once done go to MAINTENANCE TAB and select the radio button for System/Library/Extensions and press EXECUTE.
 
6 - RESTART WITHOUT USB
 
- Disconnect your usb and reboot normally, everything should work properly now.
 
 
!!! CONGRATULATION YOU DID IT !!!
 
 
 
03cd165b414f0315422c6931ac21c016.gif 
 
 
 
if not...
 
 
 
Give us enough clear information in the comments section so we can help you to have this laptop working.
 
A BIG
 
thanks.gif 
 
 
TO
 
 
  • Dell for making this laptop
  • Apple for Mac OS
  • RehabMan for so many detailed posts, enormous collection of SSDT files, kext development, and being overall incredibly helpful throughout this whole process
  • KNNSpeed for this amazing guide
  • Pike R. Alpha for his in-depth blog and the 0xE2 patch (among being the source of many other developments and patches)
  • The Clover team for the Clover bootloader
  • netkas, kozlek, and Slice for FakeSMC
  • wmchris for his initial XPS 9550 write-up
  • Jonny4911 for posting his 9560 setup and his version of the AudioFix folder
  • syscl for a lot of work into the XPS 9360 and his build of VoodooPS2Controller
  • darkhandz for his XPS 9550 repo
  • toleda and goodwin_c for audio, ALCPlugFix
  • goodwin_c for HWP
  • dpassmor for the Thunderbolt/USB-C ExpressCard trick
  • vit9696 for Lilu and AppleALC
  • PMHeart for CoreDisplayFixup
  • lvs1974 for NvidiaGraphicsFixup
  • darkvoid for Wi-Fi patches
  • filequit for the 5GHz global channel bonding patch
  • denskop for the "Boot Graphics Glitch" patch
  • netkas, kid2010, and syscl for the Thunderbolt 3 blacklist bypass patch
  • Blazinsmokey for all his good advice and knowledge
 
AND ALL THE OTHER THAT I DIDN'T QUOTE BUT WHO CONTRIBUTED TO MAKE THIS DREAM HAPPENED !
 
 
MORE CUSTOMIZATION
 
Improve battery life and CPU temperature :
 
 
 

EFI.7z

Share this post


Link to post
Share on other sites
Advertisement

Thanks bro!   :thumbsup_anim:


I successfully updated from 10.12 to 10.13 without formating my ssd  :DD

So far almost everything is working as expected and all apps are working just like under 10.12.   :w00t:

 

The only thing i am missing is working display brightness control.

Share this post


Link to post
Share on other sites

@zsparrow0 thank you for making the guide. I see that you are moving all kexts to S/L/E. how come you chose to do that instead of moving to L/E or just leaving the kexts in Clover/Kexts/Other?

 

 

Hi Ferchizzle it really depend of people from @Rehabman point of you it load kext early and better, but I didn't have any issue so far pasting in S/L/E and "Kext wizard" is doing this by default so should work fine =)

Thanks bro!   :thumbsup_anim:

I successfully updated from 10.12 to 10.13 without formating my ssd  :DD

 

So far almost everything is working as expected and all apps are working just like under 10.12.   :w00t:

 

The only thing i am missing is working display brightness control.

 

Hi you are welcome =)

 

Try to see if there is a new version of VoodooPS2Controller on rehabman github.

 

And open kext wizard in "Load tab" to check if he is properly loaded, if not reimport it and don't forget to rebuild the cache.

Share this post


Link to post
Share on other sites

I am using Clover to load the kexts.

After switching to the EMlyDinEsH Smart Touchpad driver instead of Voodoo brightness control is working.

Also the touchpad feels a lot better now.

Share this post


Link to post
Share on other sites

why do you say the nvdia card doesnt work but have files for it?

 

Which files are talking about ?

 

The Nvidia Graphics Cards will never work with this type of hardware config

Only the intel HD 630 is working.

Share this post


Link to post
Share on other sites

you have in your kext folder, NvidiaGraphicsFixup.kext

 

This one is not loading it help me to boot while using the nv_disable flag on clover.

But of course nothing useful once your MacOS environment Setup !

Share this post


Link to post
Share on other sites

you dont have nv_disable=1 in your config.plist... you can remove NvidiaGraphicsFixup.kext and youll be able to boot fine.... if not. then the nvidia card must work.

 

have you loaded the web drivers for it?

 

have you checked ioreg?

 

I think your are talking to the wrong guy..

I ve got my System Up and running and don't need this Nvidia graphic card to work and IF I would like to that would be impossible.

Because that's optimus technology and Everybody knows that it didn't work on this Pc

Share this post


Link to post
Share on other sites

yeah i know that it doesnt work because of optimus...

 

thats fine, u can continue to run an un-optimized system.

 

sorry for wanting to help you.

 

I just didn't have time to go further in this type optimization..

I'm happy with my Intel GC, but

If you want to do it and you have time that would be awesome because people are really looking for this feature.

Share this post


Link to post
Share on other sites

you dont have nv_disable=1 in your config.plist... you can remove NvidiaGraphicsFixup.kext and youll be able to boot fine.... if not. then the nvidia card must work.

 

have you loaded the web drivers for it?

 

have you checked ioreg?

 

NvidiaGraphicsFixup is not just for NVIDIA. There's actually multiple uses for it besides making a NVIDIA card work.

The reason for our laptops using this is stated clearly in the original guide created by KNNSpeed. Quoted below.

 

NvidiaGraphicsFixup.kext - Enables video out on the HDMI port by causing the board-id check in AppleGraphicsDevicePolicy to fail and default to the “none” ConfigMap. (https://sourceforge.net/projects/nvidiagraphicsfixup/)

 

Just like how a desktop can use this kext it to avoid black screen on boot by using a ConfigMap of "none" our laptops can use this method so that our HDMI out will function properly.

 

yeah i know that it doesnt work because of optimus...

 

thats fine, u can continue to run an un-optimized system.

 

sorry for wanting to help you.

 

Don't be sorry for wanting to help. If he removes that kext, how would you get the HDMI working the "optimized" way? I'm fascinated by your tremendous knowledge on how our hack's components are setup to function. Please enlighten us.

Share this post


Link to post
Share on other sites

Hi :)

I'm quite scared of changing the following BIOS settings:

 

SATA Operation (AHCI),

Thunderbolt Adapter Configuration (all on, no security),

USB PowerShare (on), 

Miscellaneous Devices (all on except SD Card Reader),

Secure Boot Enable (disabled)

 

Can I avoid changing some of these? What happens if I don't change the one referring to SDs? At the end of the day hackintosh won't use them.

 

Do I actually risk anything by changing the power management of the I/O ports?

 

 

Moreover, I should add that I'd like to install the OS on a external SSD (via USB3.0): can I follow the guide from Zsparrow0 and simply select my external Drive in Disk Utility?

 

 

Thanks!

Share this post


Link to post
Share on other sites

Hi :)

 

I'm quite scared of changing the following BIOS settings:

 

SATA Operation (AHCI),

Thunderbolt Adapter Configuration (all on, no security),

USB PowerShare (on),

Miscellaneous Devices (all on except SD Card Reader),

Secure Boot Enable (disabled)

 

Can I avoid changing some of these? What happens if I don't change the one referring to SDs? At the end of the day hackintosh won't use them.

 

Do I actually risk anything by changing the power management of the I/O ports?

 

 

Moreover, I should add that I'd like to install the OS on a external SSD (via USB3.0): can I follow the guide from Zsparrow0 and simply select my external Drive in Disk Utility?

 

 

Thanks!

Hi, these options for the BIOS are just advise to make sure you can access to the boot installation.

You can try different options and see if it work =)

 

The SD card will be disable just to use less energy and will never be compatible with that pc.

 

You can use it on your SSD external but make sure that he is compatible and properly erased in the right format.

Share this post


Link to post
Share on other sites

Thank you for the kind reply :) What Bios option do you think are strictly necessary then?

 

Moreover, do you think I should follow this guide or this other one?

 

Thanks!

 

 

Of course you can follow the guide from KNNSpeed which is really good. You have a mix of people with sierra and High Sierra so double check their config before making change.

For me th most important are these options :

 

Secure Boot Enable (disabled)

SATA Operation (AHCI)

USB PowerShare (on)

 

Share this post


Link to post
Share on other sites

Hey, I’m having issues booting into the installer. In verbose mode it loads really quick and ends in what looks like a panic. I attached a picture to my post. Can you try and help me out? Thanks

post-2313670-0-89425500-1517373519_thumb.jpg

Share this post


Link to post
Share on other sites

Hey, I’m having issues booting into the installer. In verbose mode it loads really quick and ends in what looks like a panic. I attached a picture to my post. Can you try and help me out? Thanks

Did you manage to solve this? I'm still on the fence and don't know to try this tutorial or not :)

Share this post


Link to post
Share on other sites

Thanks bro!   :thumbsup_anim:

I successfully updated from 10.12 to 10.13 without formating my ssd  :DD

 

So far almost everything is working as expected and all apps are working just like under 10.12.   :w00t:

 

The only thing i am missing is working display brightness control.

 

I did the same, but are you able to update to 10.13.3?

The ones who did a clean install apparently were able to, but I'm stuck at 10.13.1 and I upgraded from 10.12 (the update downloads and restarts but I get a bunch of errors when it's upgrading so it reverts)

Share this post


Link to post
Share on other sites

Like with 10.12 I can't seem to get HDMI audio working... did anyone else have any luck?

 

Hi make sure that you have the latest FakePCIID_Intel_HDMI_Audio.kext and FakePCIID.kext.

 

See the rehabman bitbucket repo for download

I did the same, but are you able to update to 10.13.3?

The ones who did a clean install apparently were able to, but I'm stuck at 10.13.1 and I upgraded from 10.12 (the update downloads and restarts but I get a bunch of errors when it's upgrading so it reverts)

 

I'm actually in 10.13.2 did'nt do the update to 10.13.3 because I get panic maybe need to wait for kext update.

But 10.13.1 to 10.13.2 should work smoother.

 

Check one by one your kext to see if you have the latest version if not replace theme, rebuild the cache and do the direct update.

Hey, I’m having issues booting into the installer. In verbose mode it loads really quick and ends in what looks like a panic. I attached a picture to my post. Can you try and help me out? Thanks

 

Restart the tutorial and follow it step by step.

Everything should work fine.

 

If you have a kernel panic it means that you missed one boot option or you have a conflict between kext.

Check this and retry

Share this post


Link to post
Share on other sites

Hi make sure that you have the latest FakePCIID_Intel_HDMI_Audio.kext and FakePCIID.kext.

 

See the rehabman bitbucket repo for download

 

I'm actually in 10.13.2 did'nt do the update to 10.13.3 because I get panic maybe need to wait for kext update.

But 10.13.1 to 10.13.2 should work smoother.

 

Check one by one your kext to see if you have the latest version if not replace theme, rebuild the cache and do the direct update.

 

Hi, I got the latest FakePCIID.kext and FakePCIID_Intel_HDMI_Audio.kext (I had to get the newest FakePCIID_Broadcom_WiFi.kext for the wifi to work), used KextWizard to install/repair permissions/rebuild cache/etc. and put it in my EFI clover folder as well but the HDMI audio still isn't working. Is yours working? A lot of people had trouble getting it to work for 10.12

 

& I guess I'll wait for the kext update for 10.13 as well.. it seems like this user has already gotten it though https://github.com/gunslinger23/XPS15-9560-High-Sierra

Share this post


Link to post
Share on other sites

I new to hackintosh scene, sorry for the dumb question. Is this tutorial for upgrading a hackintosh to its latest version or to do a fresh install?

 

Hi Antomaug and welcome in the Hackintosh Scene lol.

I made this guide only for fresh install.

 

The direct upgrade is not possible from 10.12 to 10.13 because they made changes in the system files.

 

Let me know if you have any questions

Share this post


Link to post
Share on other sites

I successfully upgraded from 10.12 to 10.13 without loosing any data, configs or programs.

At 4) Installation don't format your ssd and select your previous installation as destination.
Follow all other steps as described.

 

Did it 3 Weeks ago.
No problems with the system so far.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By h2onions
      Hey all,
       
      First Hackintosh that I think I have completed! I've been working on it on and off for a month, but just grinded it this past weekend. I just have a small QOL issue. I have posted in the r/Hackintosh reddit, but have not gotten a reply to this specific issue, but did for other issues I was having. I also posted at tonymacx86 and was getting replies for other issues I was having, but got banned because I said, "used VM, but didn't work" in my OP I think ...
       
      I followed a PC vanilla guide from r/Hackintosh that I found as I did not have an Apple system. One monitor connected to a GTX 1080, CPU: i7-8700, Coffee Lake. Motherboard is Alienware specific 0VDT73, with chipset Z370.
       
      The issue is every time High Sierra boots up and gets to the login screen, my keyboard and mouse do not work. I only have to reseat both and then they work the whole time until I restart. They are both plugged into USB2.0 ports. I do have Lilu, WhateverGreen, USBInjectAll, and VoodooPS2 installed in my /Library/Extensions folder using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. Mouse and Keyboard work fine each time I boot to Clover (USB). Any ideas?
       
      Thank you!
      Working: NVIDIA using (One) DisplayPort, USB3.0 (rear), USB-C (rear), USB2.0 (rear), Audio, Ethernet
    • By glasgood
      GLASGOOD'S
       
      MOJAVE HACKINTOSH GUIDE 
       
       

       
      **FOR**  GIGABYTE Z390 AORUS PRO
       

       
       
      CREDITS & THANKS
       
      @MaLd0n
      His help with EFI configuration and DSDT
       
      CLOVER  TEAM
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, rehabman, Download-Fritz, Zenit432, cecekpawon Et al
       
      APPLEALC
      Acidanthera, vit9696
       
      VOODOOHDA
      autumnrain, slice2009, zenith432
       
      ESP PRO MOUNTER
      @Micky1979 
       
      HACKINTOOL
      @headkaze
       
      CLOVER CONFIGURATOR
      Mackie100
       
      THEME ENGINE
      Alex Zielenski
       
      INSANELYMAC
      OLARILA
       
      Hackintool Tutorial
      daliansky
       
       
      and many more....
       
      ------------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
       
      PART LIST
       
      • Intel I7 8700 
      • Gigabyte Z390 AORUS PRO
      • Gigabyte AORUS RADEON RX 580 8GB
      • Corsair Vengeance LPX 16GB ( 2 x 8GB ) 2666MHz – CMK16GX4M2A2666C16
      • Corsair RM650x 80 Plus Gold Power Supply Unit
      • Corsair H100i V2 AIO Hydro/Water RGB LED CPU Cooler
      • Samsung EVO 500GB SSD (2.5) macOS Mojave
      • Samsung EVO 250 GB SSD (2.5) Windows 10 Pro
      • NZXT H500 Mid Tower ATX Case
       
      • RECOMMENDED WIFI CARD → ABWB 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS  
      OR
      • WIFI and Bluetooth with BCM94331CD with PCI-e adapter (but will require AirportBrcmFixup.kext for AirDrop.. )
       
       
       
      WORKING
       
      • Sound 
      • HDMI audio on RX580
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Handoff
      • Continuity
       
       
       

       

       

       
       
       
       
       
      PART 1 - DOWNLOAD 
       
       
      Download the following:
       
      • CLOVER
       
      • Aorus Z390 Pro EFI .zip
       
      • ESP MOUNTER PRO v1.9
       
      • macOS MOJAVE 
       
      • CLOVER CONFIGURATOR
       
      • EmuVariableUefi-64.efi  ( Used only to initialise iMessages. It then must be removed from Clover drivers64UEFI folder, explained in guide)
       
      • OsxAptioFix2Drv-free2000.efi ( Replace AptioMemoryFix-64.efi post install )
       
       
      OPTIONAL DOWNLOADS
       
      • VoodooHDA.kext.zip 

      • ThemeEngine 
       
      • Assets.car 
       
       
       
      PART 2 - BIOS SETTINGS (version F5 )
       
       
      Here is a list of the BIOS settings that I have used ( Screenshots in spoiler below )
       
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • BIOS → Windows 8/10 Features → Other OS
      • BIOS → CSM Support → Enabled
       
      • Peripherals → Initial Display Output → PCIe 1 Slot
      • Peripherals → Trusted Computing → Security Device Support →  Disable
      • Peripherals → Intel(R)Bios Guard → Intel BIOS Guard Support →  Disable
      • Peripherals → USB Configuration → Legacy USB Support →  Enabled
      • Peripherals → USB Configuration → XHCI Hand-off →  Enabled
      • Peripherals → Network Stack Configuration → Network Stack →  Disabled
      • Peripherals → SATA And RST Configuration → SATA Mode Selection →  AHCI
       
      • Chipset → Vt-d → Disabled
      • Chipset → Internal Graphics → Enabled
      • Chipset → DVMT Pre-Allocated → 64M
      • Chipset → DVMT Total Gfx Mem → 256M
      • Chipset → Audio Controller → Enabled
      • Chipset → Above 4G Decoding → Enabled
       
      • Power → ErP → Disabled
      • Power → RC6 (Render Standby) → Enabled
       
      // IF USING  CORSAIR H100i V2 AIO CPU WATER COOLER 
      • MIT → Smart Fan 5 Settings → CPU Fan Control mode → PWM 
       
      • Save & Exit → Save & Exit Setup
       
      SCREEN DUMP SPOILERS
       
       
       
       
       
      PART 3 – CREATE A MOJAVE USB FLASH INSTALLER
       
      Prepare USB Installer for Mojave ( Video below )
       
      • Insert USB drive
      • Launch /Applications/Utilities/Disk Utility
      • Disk Utility → View → Show All Devices
      • On Left-hand panel → External →(Identify your USB device in left hand panel)
      • Click and highlight your USB device in the left-hand panel.
      • Click erase button.
      • Name: USB
      • Format: Mac OS Extended (Journaled )
      • Scheme: GUID Partition Map
      • Click Erase button.
       
      • Place the downloaded MacOS Mojave app into Applications folder.
      • Open Terminal copy and paste:
       
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --nointeraction && say Mojave Drive Created  • Enter
       
       
       
       
       
       
       
      PART 4 – INSTALL CLOVER ON THE MOJAVE USB INSTALLER 
       
      Make Mojave USB flash drive installer bootable.( Video below )
       
      • Launch Clover application, double click.
      • Click Continue → Continue → Continue 
      • Click Change Install Location button.
      • Click Install macOSMojave USB installer → Continue
      • Click Customize button
      • Choose:
      Clover for UEFI booting only Install Clover in the ESP Themes UEFI Drivers Install RC scripts on target volume • Click Install button
      • Installation Complete!
       
      Video:
       
       
       
       
       
       
      PART 5 – CUSTOMIZE MOJAVE USB INSTALLER FOR AORUS Z390 PRO
       
      Replace Clover EFI folder with the customised AORUS Z390 configuration ( Video below )
       
      • Install ESP Mounter Pro v1.9
      • Using ESP Mounter Pro, Mount ESP on disk2s1 ( Your disk name may be different )
       

       

       
       
       
      • Open mounted EFI partition found on desktop
      • Copy all the contents from Aorus 390 Pro EFI folder
      • Replace USB EFI folder with all the contents inside the Aorus 390 Pro EFI folder.
       
       

       
       
       
       
       
       
       
       
      PART 6 – INSTALL MAC OS MOJAVE ON INTERNAL DRIVE

      • INSERT USB INSTALLER INTO THE USB 2.0 PORT  
       
       
      • Power on PC and press F12• Choose bootable USB drive from boot menu.
       
       
       
      • Install macOS Mojave to internal solid state or hard drive.
       
      NOTE
      During install the system will reboot and you will see onscreen message EXC_CORPSE_NOTIFY exception. This instance is normal,  no skeletons !.
       
       
      When system returns to the Clover boot menu choose:
       
      • Boot macOS Install Prebooter from Preboot
       
       
       
      After next restart choose:
       
      • Boot macOS from Macintosh
       
       
       
      Proceed with macOS Mojave install
       
       
      macOS Mojave is now installed, but it can only boot at this moment thanks to FakeSMC and Clover on the Mojave USB flash drive installer.
       

       
       
       
       
       
       
      PART 7 – MAKE AORUS Z390 PRO INTERNAL DRIVE BOOTABLE
       
      Make internal drive bootable ( Video below )
       
      So far, Aorus Pro can only boot with the aid of the Mojave USB Installer.
      To boot from the internal drive, copy Clover EFI folder from  Mojave USB installer into the  Internal EFI drive.
       
      • Using ESP Mounter Pro, mount internal EFI/ESP partition and external USB EFI/ESP
      • Copy contents from USB EFI/ESP partition and paste into internal EFI/ESP
       
       
      Video:
       
       
       
      • Remove USB Mojave installer and shut down and restart.
       
      Aorus Hackintosh should now be able to boot to macOS Mojave, Done, well almost ! 
       
       
       
       
       
      PART 8 – ENABLE IMESSAGES & FACETIME 
       
       
      Configure Config.plist for iMessages. ( Video below )
       
      • SMBIOS = Mac Mini 8.1
      • Rt Variables —> ROM —> is your MAC address (delete colons from Mac address)
      • MLB field =  Enter serial number generated and append 5 random characters
      • SmUUID = in Terminal run command “uuidgen” and copy it to SmUUID field
      • Board Serial is same as MLB field.
      • Clover Configurator —>  Save 
       
      Video:
       
       
       
      • Mount internal drive EFI/ESP partition
      • Go to folder CLOVER → drivers64UEFI 
      • Delete AptoMemoryFix-64.efi
      • Place both EMUVariableUefi-64.efi and OsxAptoFix2Drvfree2000.efi inside → drivers64UEFI
       
       
      Using Clover Configurator, add the following argument to config.plist using Clover Configurator.
       
      • Slide = 0
       

       
       
      Shutdown and then press power on button on PC.
       
      • You should now be able to Log into iCloud, iMessages and FaceTime
      • NOW delete EMUVariableUefi-64.efi from CLOVER → drivers64UEFI Folder 
      • Shutdown and restart Aorus Pro hackintosh. iMessages etc is now operational without EMUVariableUefi-64.efi ( EMUVariableUefi-64.efi only needed to initialise iMessages )
      • It is important to delete EMUVariableUefi-64.efi, this will avoid very intermittent boot errors such as: “Couldn’t allocate runtime area”  post errors.
       
       
       
       
       
       
       
       
      ------------    GUIDE FINISHED YOU SHOULD NOW HAVE WORKING AORUS Z390 PRO HACKINTOSH  WITH SSDT USB FIX   --------------- 
       
       
       
       
       
       
      OPTIONAL:  Enable HDMI Audio on RX580
       
       
       
       
       
       
      OPTIONAL:  Replace the default "About This Mac" Apple Logo with RED AORUS APPLE
       
       
       
       
       
       
      OPTIONAL - ALTERNATIVE SSDT 1 –  SSDT Ports configuration below - replace SSDT inside Clover /ACPI/PATCHED folder 
       
       
       
       
       

      OPTIONAL - ALTERNATIVE SSDT 2 -  SSDT Ports configuration below - replace SSDT inside Clover /ACPI/PATCHED folder 
       
       
       
       
       

      OPTIONAL - ALTERNATIVE SSDT 3 – Create your own SSDT
       
       
       
       
       
       
      DEFAULT SSDT USB FIX IN AORUS Z390 PRO EFI FOLDER  –  default SSDT ports configuration below - SSDT already inside Aorus Z390 EFI folder 
       

       

       

       
       
      Limitation: USB2 devices can not be used on SS03 → SS08
       
       
       
       
       
       
      FOR MORE HACKINTOSH INFORMATION SUCH AS USB PORTS FIX, CLOVER CONFIGURATOR, HACKINTOSH BACKUP WITH CARBON COPY CLONER .....   THEN SEE MY PREVIOUS GUIDE FOR ASUS Z370-G Strix
       
       
       
       
       
       
       
       
       
       
       

       
       
       
       
       
       
       
       
      SSDT-UIAC.aml.zip
      SSDT-UIAC.dsl.zip
    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?p=77102#p77102
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM / REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By Chaznex
      Ciao ragazzi, sono alle prime armi e vorrei provare MacOS sul mio HP Pavilion 15-cb006nl. Potreste darmi una mano? Non so proprio da dove iniziare.
      Specifiche:
      CPU   Intel Core i7 7700HQ @ 2.80GHz   Kaby Lake 14nm Technology
      RAM   16GB Dual-Channel
      Motherboard   HP 836B (U3E1)
      Graphics   Generic PnP Monitor (1920x1080@60Hz)   Intel HD Graphics 630 (HP)  Nvidia GeForce GTX 1050   SLI Disabled
      Storage   1TB HDD + 128GB SSD
      Audio   Realtek HD Audio
      Keyboard   standard PS/2 HPQ
      ELAN Clickpad   ETD
      Network   Intel Dual Band Wireless-AC 7265
    • By AllIsDust
      Salve, vorrei fare un Hackintosh come da titolo, solo che avendo poco budget volevo chiedere se la mia attuale postazione fosse buona e ci fossero componenti compatibili per mac:
      i5 4590
      h97 pro4
      amd r9 280x
      ram 2x4 1600
      alu 620w
       
      Se non erro però la gru non dovrebbe esserlo dato che è amd. Grazie in anticipo
×