Jump to content
Sign in to follow this  
Followers 0
TmxPro

Clover doesnt boot on Asus Vivobook

3 posts in this topic

Recommended Posts

So I wanted to install OS X onto my vivobook E403SA and got installer almost to boot via rEFInd by fiddling with the boot flags, but not quite.

 

I am pretty sure i need clover to get it to work properly, but clover doesn't even start. When i go through (uefi) bios it will just hang on black screen, through refind its basicly same but it doesn't even delete the messages that refind writes on the screen(booting with flags '' or smth like that).

And it is set up correctly cuz i can boot into both, clover and refind in virtualbox(physical usb disk as boot disk) and i can boot into refind with my vivobook.

 

I have also tried older clover versions, but still have same issue.

 

Any kind of help appriciated :)

Share this post


Link to post
Share on other sites
Advertisement

HyeYa :) ,

 

Assuming you installed Clover the UEFI way. 

 

Did you go into bios to enable "Other OS"? Set UEFI OS as first boot partition. 

Test if any of this works. :)

Share this post


Link to post
Share on other sites

HyeYa :) ,

 

Assuming you installed Clover the UEFI way. 

 

Did you go into bios to enable "Other OS"? Set UEFI OS as first boot partition. 

Test if any of this works. :)

 

Yea, i tried to boot into clover 2 ways, 

first off straight from bios by adding new entry pointing to the clover efi file(tried both, BOOTX64 and CLOVERX64 efi files) but then i just got black screen,

2nd way, when i boot into rEFInd it autodetects the clover efi and when i try to boot from there i get the text in the image, so basicly same as straight from bios. And clover install seems to be working fine since virtualbox can boot into it.

I installed clover by creating 512mb partition with gparted at the start of the installation hdd with fat32 and esp and boot flags checked and then copied all all the files from rEFInd and clover iso-s(except BOOTX64 for clover, so it wont overwrite rEFInd) i have tried deleting rEFInd and using only clover but still no luck.

 

And my laptop doesnt support legacy boot, ONLY uefi so that wont be a problem.3AckgXD.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4542 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 14 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4542 for VMware.zip". Mount Clover-v2.4k-4542-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By PingoLinkin
      Motherboard: ASUS / X99 Deluxe II
      Chipset: Intel® X99
      Processador: i7-6800 LGA2011 v3
      Memoria: HyperX - DDR4 24000MHz - 32GB(2x16gb)
      Rede: Intel® I218V, 1 x Gigabit LAN; Intel® I211-AT, 1 x Gigabit LAN LAN; Dual Gigabit LAN controllers- 802.3az Energy Efficient Ethernet (EEE) appliance
      Audio: Realtek® ALC1150 com 8 canais
      Video: Geforce GTX 750 Ti 2GB SC DDR5 128 bits PCI-E 3.0 (1x DVI, 1x DisplayPort, 1x HDMI)
      Keyboard: Apple Aluminium
      Mouse: Microsoft
      HD: SAMSUNG SSD 840 EVO 1TB
       
      ///////////////////////////////////////////
       

       
      1 - Preparando PENBOOT:
        1.1 - Baixe a imagem do Sierra e deixe na pasta "Applications";
        1.2 - Formate o PenDrive e altere o nome para: "MyVolume";
        1.3 - Abra o Terminal e digite a seguinte linha de código, dê enter e quando solicitado digite sua senha. Aguarde o término da instalação, geralmente demora em torno de 20min:
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ macOS\ Sierra.app  
       
      1.4 - Baixe a última versão do Clover EFI bootloader: Download
        1.5 - Abra o Clover, na última etapa, clique em Customize, depois marque a opção "Install for UEFI booting only", como na imagem abaixo:

       
        1.6 - Provavelmente a partição "EFI" estará montada, abra a partição e substitua a pasta "CLOVER" por esta CLOVER Asus X99 Deluxe II - Sierra.zip.
       
      2 - Configurando BIOS
        2.1 - Atualize sua BIOS para a versão mais recente, a minha é: 1902
        2.2 - Reset as configurações de sua BIOS em: Exit/Load Optimized Defaults;
        2.3 - Vá para: Boot/CMS (Compatibility Support Module)/Launch CMS: ENABLED;
        2.4 - Vá para: Boot/Secure Boot/OS Type: Other OS;
       
      3 - Instalando OS
        3.1 - Ligue o computador com o Pendrive espetado, ele automaticamente irá iniciar o Clover, caso isso não aconteça, na tela inicial da ASUS, pressione F8 para escolher o pendrive como boot primário;
        3.2 - Em algum momento futuro, seu clover pode não arrancar corretamente, caso isso aconteça, na tela inicial do CLOVER pressione F11 para limpar o NVRAM, ele irá reiniciar a máquina automaticamente, em seguida voltará a arrancar normalmente;
       
      4 - PÓS-INSTALAÇÃO
        4.1 - Inicie seu MAC temporariamente pelo Pendrive como boot primário;
        4.2 - Instale o clover seguindo as etapas 1.4, 1.5 e 1.6 . Apenas não esqueça de alterar o destino para o HD Interno com a instalação do Sierra.
        4.3 - Feito isso, reinicie seu mac, agora sem o pendrive;
       
      5 - VÍDEO
        5.1 - Na pasta CLOVER que anexei acima, já possui as kexts NvidiaGraphicsFixup.kext e Lilu.kext ;
        5.2 - Baixe e instale o nVidia Web Driver(Download) de acordo com a versão do seu OS;
        5.3 - A minha versão, por exemplo, é: "macOS 10.12.6 (16G1408)";
        5.4 - Veja abaixo onde encontrar sua versão:

       
      Obs.: Existe um bug no vídeo, caso queira utilizar a entrada DVI, é preciso iniciar a máquina já com o cabo plugado, caso contrário ele deixará sua tela preta e não voltará mais ao normal até que reinicie a máquina.
       
        5.5 - INSTALANDO O CUDA:
           1 - A última versão não funcionou, então baixei a penúltima e funcionou perfeitamente. A versão instalada foi: CUDA 387.178 driver for MAC.

       
       
      6 - ÁUDIO
        6.1 - Baixe o Voodoo HDA 2.9.0 Clover (Download)
        6.2 - Siga as etapas das imagens que estão dentro do anexo;
       
       
      Não solucionado:
      Não consigo habilitar a placa ThunderboltEX 3;
       
       
      Valeu.
    • By MaLd0n
      First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with patches for Skylake DSDT.MaLd0n ASUS Z170M PLUS.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DMAC -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -IMEI -PNLF -HDMI --FakeSMC
      http://www.hwsensors.com/releases   --Audio https://github.com/vit9696/AppleALC   --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   --LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!
    • By zebity
      Hi Hypervisors,
       
      EDITED - 9 JUNE 2018 - as all other issues resolved but am now stuck with QEMU Error: "PFLASH: Possible BUG - Write Block Confirm" details on testing lower in thread (to follow).
       
      I have been working to move my Late 2009 Xserve MacOS Server onto Ubuntu 18.04 LTS QEMU/KVM based virtual machine using OVMF and Clover.
       
      After much effort and testing based on the following information from: Kraxel's, Kholia, Gordon Turner and Clover site:
      https://www.kraxel.org/blog/2017/09/running-macos-as-guest-in-kvm/
      https://github.com/kholia/OSX-KVM
      https://gist.github.com/gordonturner/2a2e5ecde5e7860b52e2
      https://clover-wiki.zetam.org/Home
       
      I have now managed to get OVMF/Clover boot and install of MacOS Sierra.
       
      I started with Ubuntu 16.04 initially but this required download and compile of QEMU to get update of machines to: pc-q35-2.9 or better, so I moved to Ubuntu 18.04, which has pc-q35.2.11 available as standard.
       
      So I am now working with standard Ubuntu 18.04 LTS based systems with following packages: kvm/qemu/libvirt/bridge-utils/ovmf/virt-manager
       
      As I want to use PCIe Passthrough for a number of PCIe card currently installed in the server (SmallTree 10GbE & Areca ARC-1883 SAS RAID) I set up my machine with linux kernel boot configuration (/etc/default/grub) of: 
      GRUB_CMDLINE_LINUX_DEFAULT="iommu=1 intel_iommu=on" (as my machine is intel VT-d based HW virtualisation)
       
      This resulted in creation of a number of iommu groups (see /sys/kernel/iommu_group directory for this and this posting for information: https://forum.level1techs.com/t/ubuntu-17-04-vfio-pcie-passthrough-kernel-update-4-14-rc1/119639 , noting that Ubuntu 18.04 LTS has kernel version: 4.15.0-22-generic so there is no need to do kernel update for iommu to work).
       
      Using bare minimal Clover config.plist:
       
       
      And following Clover UEFI drivers:
       
      I can boot MacOS, but it is very very slow... it sits on the apple boot logo for over a minutes before finally moving onto the progress bar.
      The other problem I have is that no PCI or Network devices appear in the "About This Mac" System Information Report and I cannot get any network connectivity from bridged E1000 network device.
       
      Here is my virtlib.xml dump for the virtual machine:
       

      Can any one advise of whether I need to update the CLOVER config.plist to add extra items in to allow network and PCI Passthrough to work.
       
      Thank you.
       
      Regards,
       
      Zebity
       
×