Jump to content
Sign in to follow this  
Followers 0
Titus Tucan

No IP address after waking up from sleep causes after update

6 posts in this topic

Recommended Posts

Hi everyone, 

I recently direct updated from 10.12 to 10.13.2. I use a Z170MTB with an Intel built-in ethernet I219-V. I used the have the IntelMausiEthernet 2.2.1 in the past, now I think I use IntelMausiEthernet 2.3. (Not really sure how to check this)

If I put the machine to sleep, when it wakes up, the network adapter self-assigs an IP, even if I <Renew DHCP Lease>. Obviously I do not have Internet, and I have to reboot, then it works again.
Here is the en0 extract from ifconfig -v before
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 index 5
eflags=41000840<ACCEPT_RTADV,ARPLL,ECN_ENABLE,FASTLN_ON>
options=b<RXCSUM,TXCSUM,VLAN_HWTAGGING>
ether 40:8d:5c:58:2f:61 
inet6 fe80::869:9118:a0e:e4bb%en0 prefixlen 64 secured scopeid 0x5 
inet 192.168.1.17 netmask 0xffffff00 broadcast 192.168.1.255
nd6 options=201<PERFORMNUD,DAD>
media: autoselect
status: active
type: Ethernet
link quality: 100 (good)
state availability: 0 (true)
link rate: 1.00 Gbps
qosmarking enabled: yes mode: none


And after
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 index 5
eflags=41000041<AUTOCONFIGURING,ACCEPT_RTADV,ECN_ENABLE,FASTLN_ON>
options=b<RXCSUM,TXCSUM,VLAN_HWTAGGING>
ether 40:8d:5c:58:2f:61 
inet6 fe80::869:9118:a0e:e4bb%en0 prefixlen 64 secured scopeid 0x5 
nd6 options=201<PERFORMNUD,DAD>
media: autoselect
status: active
type: Ethernet
link quality: 100 (good)
state availability: 0 (true)
link rate: 1.00 Gbps
qosmarking enabled: yes mode: none


In both cases the en0 is UP, but after sleep there is no IPv4 address. Bringing the en0 down and up does not help.
Anyone with the same problem, any ideas guys? I am totally lost
Thanks a lot,
Titus

MTB: GA-Z170X-UD5 TH with Intel GBe I219-V

Share this post


Link to post
Share on other sites
Advertisement

Thanks, based on the link you sent, I should use IntelMausi... V2.1.0d0

Update. I set the ethernet to static, but there is no difference. After sleep, although network it displays the static address, nothing works as if the ethernet interface is not functioning. I suspect it is something related to the kext I use for ethernet.

BTW how can I find out what is the kext that is being used? and whites the best way to change it? [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×