Jump to content
ammoune78

Ozmosis for 100 Series Skylake CPU's and up

168 posts in this topic

Recommended Posts

From bios settings select that HFS+ partition that appears in boot override and press enter to boot from

 

 

Sent from ammoune78's iPhone using Tapatalk

 

From bios settings select that HFS+ partition that appears in boot override and press enter to boot from

 

 

Sent from ammoune78's iPhone using Tapatalk

 

Boot Override can not see any HFS + partitions. . .

Share this post


Link to post
Share on other sites
Advertisement

yes

on skylake mobo,ozmosis has some bugs

 

don't check it if work well by mobo boot menu(F12)

 

just check with uefishell,and add boot menu by bcfg commond

Share this post


Link to post
Share on other sites

yes

on skylake mobo,ozmosis has some bugs don't check it if work well by mobo boot menu(F12) just check with uefishell,and add boot menu by bcfg commond

efishell 

 

try these:

 

 

https://transfer.sh/fHIgX/hfs_x64.efi

https://transfer.sh/j7Ysy/hfsplus_x64.efi

 

ps:

1.APFS work well but need add boot by uefishell with bcfg commond

2.ozmosis do not work good with EFI partition,only work with blablabla in rom

 

good luck

 

mobo: ASUS Z170 AR

 

HFS can be directly identified in F12 or need bcfg added

Share this post


Link to post
Share on other sites

Sorry for being this direct, but...

DO NOT USE THE OzmosisToolKit (this equals OZMTool)!!! "Why" you may ask? Here is the answer:

 

When you look at your usual rom, you will find 5 volumes in your Bios. The second one is the DXE Driver volume and thus takes all the Ozmosis files that are being inserted. Here you can see my original rom's last file of that volume and the following volumes (image is longer, but does not fit to screenshot):

 

post-1459824-0-56722300-1516389396_thumb.png

 

This is the modified version:

 

post-1459824-0-83151000-1516389439_thumb.png

 

This file ends right under the marked spot. The following volumes are missing! I think this is because of the following:

OZMTool tries to insert more than possible. This effects, that the 2nd volume is being resized (grown, others shrink) and this effects the other volumes to become invalid and thus they disappear. You would be able to flash this rom, but (!!!) your Bios will not be able to see any further Devices. If these are hard drives, USB sticks, dvd drives, whatever. They just can't be accessed and, resulting from this, also not booted. So you basically aren't even able to flash a new rom, because your bios does not see any external or internal drives. Do yourself a favour and leave this tool for AMI 4 Bioses (if this is the plural form...) and use MMTool instead. It might be more safe. OZMTool uses the engine of UEFITool, so try to avoid that as well maybe. I've had these problems before. Or, if you do want to work with these, check the volumes using MMTool afterwards. You can cause immense damage to your Bios

 

Furthermore this OZMTool doesn't even work with Skylake Roms because of the indifference of the AMIBoardInfo UUID. In AMI 5 roms this uuid is different than in AMI 4 Bioses (and it is called AMIBoardInfo2). Because of this, OZMTool can't access all the volumes and insert the files. After modifying the UUID it works, but still: You damage your rom!! Don't try to flash this!!!!

Share this post


Link to post
Share on other sites

yes

on skylake mobo,ozmosis has some bugs

 

don't check it if work well by mobo boot menu(F12)

 

just check with uefishell,and add boot menu by bcfg commond

 

No bugs with Ozmosis it's only HfsPlus issue, to fix that problem we need working HfsPlus on ROM! 

Can you try Extracting HfsPlus from new iMac17,1 firmware that's on HS Install app, and inserting it in your Motherboard ROM.

Apple firmwares now have modules name displayed!  

Share this post


Link to post
Share on other sites

No bugs with Ozmosis it's only HfsPlus issue, to fix that problem we need working HfsPlus on ROM! 

Can you try Extracting HfsPlus from new iMac17,1 firmware that's on HS Install app, and inserting it in your Motherboard ROM.

Apple firmwares now have modules name displayed!  

 

I use imac18.1

 

The problem is that bcfg adds ozmosis.efi Better to run than bios. bcfg can automatically add the installation disk boot

Share this post


Link to post
Share on other sites

You can use bcfg only for HfsPlus also, until we find some working one!

Share this post


Link to post
Share on other sites

There's no Ozm upgrade, it support big ROM's chip 128Mb, your mobo ASUS H110T has enough ROM space free, no need compressing setup, just extract from the capsule the Intel image, and start inserting modules directly, there's up to 4096 Kb free.

 

Here's modded Ozm rom:

attachicon.gifH110T-ASUS-3601.BIN.zip

In this weekend,I've test the BIOS, but cannot see any boot partition, either 12.6 or 13, 

So, is there something wrong ?

 

This is the bios U had modded, and I have modded to work with i3 8100 cpu base on U.

Now, 8100 cpu is working fine on this mobo, do U have time to have a look ?

I really want to use OZM

 

Share this post


Link to post
Share on other sites

Guy's please, have to read guide before posting questions, so you can have answers in the guide itself!

it's already wrote: Skylake beta features

Share this post


Link to post
Share on other sites

I have small script to share with you guys to extract Apple efi driver(s) from bios file (FirmwareUpdate.pkg / bit outdated repo).

https://gist.github.com/cecekpawon/e38bda384ff115f09e638482849deb2d

Please re-adjust the values below:

// Bios filename
$FF = "MBP143_0169_B00.fd";
// LongSoft UEFIExtract filename
$UEFIExtract = "UEFIExtract";
// Array of drivers to extract (guid - label)
$aUEFIExtract = array (
                    array ("35628CFC-3CFF-444F-99C1-D5F06A069914", "EfiDevicePathPropertyDatabase"),
                    array ("961578FE-B6B7-44C3-AF35-6BC705CD2B1F", "Fat"),
                    array ("AE4C11C8-1D6C-F24E-A183-E1CA36D1A8A9", "HfsPlus")
                  );

 

Share this post


Link to post
Share on other sites
20 hours ago, cecekpawon said:

I have small script to share with you guys to extract Apple efi driver(s) from bios file (FirmwareUpdate.pkg / bit outdated repo).

https://gist.github.com/cecekpawon/e38bda384ff115f09e638482849deb2d

Please re-adjust the values below:


// Bios filename
$FF = "MBP143_0169_B00.fd";
// LongSoft UEFIExtract filename
$UEFIExtract = "UEFIExtract";
// Array of drivers to extract (guid - label)
$aUEFIExtract = array (
                    array ("35628CFC-3CFF-444F-99C1-D5F06A069914", "EfiDevicePathPropertyDatabase"),
                    array ("961578FE-B6B7-44C3-AF35-6BC705CD2B1F", "Fat"),
                    array ("AE4C11C8-1D6C-F24E-A183-E1CA36D1A8A9", "HfsPlus")
                  );

 

Thanks my MAN, as this will simplify extracting procedure  :thumbsup_anim:

Share this post


Link to post
Share on other sites
50 minutes ago, kieffer said:

I've purchased GA-Z170X-Ultra Gaming rev 1.0, I'll try your ozmosis bios for HighSierra installation, is there any way to enable imessage/facetime using nvram commands or we're forced to use clover?.

Ozmosis Bios repository available on: https://www.dropbox.com/sh/6kdmued9m8d3sgq/AADd2Hwb3L4Mdx_Ecfa5C5MWa/ROM directory?dl=0

Thanks in advance,

iMessage/Facetime need only working serials and working custom uuid, use the shake button from Clover Configurator and then terminal to get new custom uuid serial using this command: uuidgen

Share this post


Link to post
Share on other sites

Dear,

I have a z170x Designare.

I flashes my mobo with the bios in the repo (23d)

But i don't see my hdd ( nvme apfs)

What can i do?

cmd + art +p +r does nothing.

 

Help please

 

Share this post


Link to post
Share on other sites
48 minutes ago, jym said:

Dear,

I have a z170x Designare.

I flashes my mobo with the bios in the repo (23d)

But i don't see my hdd ( nvme apfs)

What can i do?

cmd + art +p +r does nothing.

 

Help please

 

 

Hi!

You have to download cecekpawon UEFTW, and follow the instructions to know how to use kernextpatcher, and add it's patch, follow Ozmosis topic to know how to insert the kernextPatcher in the rom, you can use UEFITool 1 or 2 to do the job.

 

I'll update the repository as soon as I have time, but I'm here, if you want to ask for something 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×