Jump to content
MaLd0n

High Sierra on Supermicro X10DAI / Dual Xeon E5-2690V4 / DSDT

169 posts in this topic

Recommended Posts

Advertisement

@MaLd0n, Thanks for the guide.

I'm running Mojave. Just lacking CPU PM.

performance fix from oarksit- what is it for?

xcpm_pkg_scope_msrs © Pike R. Alpha - Can this be used with Mojave?

Share this post


Link to post
Share on other sites
23 minutes ago, The Tech said:

@MaLd0n, Thanks for the guide.

I'm running Mojave. Just lacking CPU PM.

performance fix from oarksit- what is it for?

xcpm_pkg_scope_msrs © Pike R. Alpha - Can this be used with Mojave?

User Sherlocks update all for mojave, try in search forum

Share this post


Link to post
Share on other sites
3 minutes ago, MaLd0n said:

User Sherlocks update all for mojave, try in search forum

Thanks for the reply. I tried to search now but what exact to search?

 

Share this post


Link to post
Share on other sites

I'm able to get this.

AppleIntelInfo.kext v1.4 Copyright © 2012-2015 Pike R. Alpha. All rights reserved

Settings:
------------------------------------
logMSRs............................: 1
logIGPU............................: 0
logIntelRegs.......................: 1
logCStates.........................: 1
logIPGStyle........................: 1
InitialTSC.........................: 0xd374e63fb12
MWAIT C-States.....................: 4384

Model Specific Regiters
------------------------------------
MSR_CORE_THREAD_COUNT......(0x35)  : 0xA0014
MSR_PLATFORM_INFO..........(0xCE)  : 0xC10E4811E00
MSR_PMG_CST_CONFIG_CONTROL.(0xE2)  : 0x8403
MSR_PMG_IO_CAPTURE_BASE....(0xE4)  : 0x10414
IA32_MPERF.................(0xE7)  : 0x76492D1934
IA32_APERF.................(0xE8)  : 0x744B85D151
MSR_FLEX_RATIO.............(0x194) : 0x100000
MSR_IA32_PERF_STATUS.......(0x198) : 0x212500001E00
MSR_IA32_PERF_CONTROL......(0x199) : 0x1E00
IA32_CLOCK_MODULATION......(0x19A) : 0x0
IA32_THERM_STATUS..........(0x19C) : 0x88370000
IA32_MISC_ENABLES..........(0x1A0) : 0x850089
MSR_MISC_PWR_MGMT..........(0x1AA) : 0x400001
MSR_TURBO_RATIO_LIMIT......(0x1AD) : 0x2121212121222324
IA32_ENERGY_PERF_BIAS......(0x1B0) : 0x0
MSR_POWER_CTL..............(0x1FC) : 0x2104005B
MSR_RAPL_POWER_UNIT........(0x606) : 0xA1003
MSR_PKG_POWER_LIMIT........(0x610) : 0x684E0005A8410
MSR_PKG_ENERGY_STATUS......(0x611) : 0x4504C276
MSR_PKG_POWER_INFO.........(0x614) : 0x2F064002200410
MSR_PP0_CURRENT_CONFIG.....(0x601) : 0x14149480000520
MSR_PP0_POWER_LIMIT........(0x638) : 0x80000000
MSR_PP0_ENERGY_STATUS......(0x639) : 0x3216B752
MSR_PP0_POLICY.............(0x63a) : 0x0
MSR_PKGC3_IRTL.............(0x60a) : 0x0
MSR_PKGC6_IRTL.............(0x60b) : 0x0
MSR_PKG_C2_RESIDENCY.......(0x60d) : 0x0
MSR_PKG_C6_RESIDENCY.......(0x3f9) : 0x0
IA32_TSC_DEADLINE..........(0x6E0) : 0xD3750B05D06
PCH device.................: 0x1D418086

CPU Ratio Info:
------------------------------------
CPU Low Frequency Mode.............: 1200 MHz
CPU Maximum non-Turbo Frequency....: 3000 MHz
CPU Maximum Turbo Frequency........: 3600 MHz
CPU P-States [ (12) 29 30 ]
CPU C6-Cores [ 1 5 6 7 10 11 15 ]
CPU C6-Cores [ 0 1 2 5 6 7 10 11 14 15 ]
CPU P-States [ 12 26 29 (30) ]
CPU C6-Cores [ 0 1 2 3 5 6 7 10 11 14 15 ]
CPU C6-Cores [ 0 1 2 3 5 6 7 10 11 14 15 16 ]
CPU P-States [ (12) 26 28 29 30 ]
CPU C6-Cores [ 0 1 2 3 5 6 7 10 11 14 15 16 ]
CPU C6-Cores [ 0 1 2 3 5 6 7 10 11 13 14 15 16 ]
CPU C6-Cores [ 0 1 2 3 5 6 7 10 11 13 14 15 16 ]
CPU C6-Cores [ 0 1 2 3 5 6 7 10 11 13 14 15 16 ]
CPU P-States [ (12) 25 26 28 29 30 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 10 11 13 14 15 16 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 10 11 12 13 14 15 16 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 9 10 11 12 13 14 15 16 ]
CPU P-States [ (12) 25 26 27 28 29 30 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 ]

 

Is this correct?

However, i cannot verify X86PlatformPlugin loading under the CPU0 node.

Please help.

Share this post


Link to post
Share on other sites

Hello Mald0n, 

I also have a SM X10DAi mbo with

2x  Xeon E5 2680 v3,

a Nvidia GTX 1080 Ti OC for the video

and a Samsung 970 EVO nvme SSD. (I have modded the bios to detect the nvme and boot from it)

 

This DSDT is also valid for macOS Sierra or it’s just suitable for High Sierra?

Right now I am struggling to just boot the installation stick to get Sierra running, but I encounter all kind of errors.
First of all the installation stuck at "PCI configuration begin" which I resolved with npci=0x2000.

Second of all I was stuck at “gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0” which I bypassed by removing dart=0 from the attributes.
After that the system restarts after “System uptime in nanoseconds: ….”
I mention that I have in the Clover folder lilu and nvidiagraphicsfixup kexts…

I have also tried your Clover folder but it restarts right after the first lines with: “Using reloc block: no, hibernate wake: no +++++++++.

Can you please point me what I am doing wrong here? 

Thank you and I would very much appreciate your help.

Edited by negru13
typo

Share this post


Link to post
Share on other sites
3 hours ago, negru13 said:

Hello Mald0n, 

I also have a SM X10DAi mbo with

2x  Xeon E5 2680 v3,

a Nvidia GTX 1080 Ti OC for the video

and a Samsung 970 EVO nvme SSD. (I have modded the bios to detect the nvme and boot from it)

 

This DSDT is also valid for macOS Sierra or it’s just suitable for High Sierra?

Right now I am struggling to just boot the installation stick to get Sierra running, but I encounter all kind of errors.
First of all the installation stuck at "PCI configuration begin" which I resolved with npci=0x2000.

Second of all I was stuck at “gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0” which I bypassed by removing dart=0 from the attributes.
After that the system restarts after “System uptime in nanoseconds: ….”
I mention that I have in the Clover folder lilu and nvidiagraphicsfixup kexts…

I have also tried your Clover folder but it restarts right after the first lines with: “Using reloc block: no, hibernate wake: no +++++++++.

Can you please point me what I am doing wrong here? 

Thank you and I would very much appreciate your help.

my clover folder is very old, u need update, kexts

Share this post


Link to post
Share on other sites
8 minutes ago, MaLd0n said:

my clover folder is very old, u need update, kexts

Very helpful man, thanks a lot!

Share this post


Link to post
Share on other sites
5 minutes ago, 8car said:

I used your DSDT in the 10.14.1,but XCPM cant work and Geekbench had a lower score than in 10.12.6.

extract new DUMP, the topic is ver old

RunMe.app

Share this post


Link to post
Share on other sites
12 hours ago, MaLd0n said:

extract new DUMP, the topic is ver old

RunMe.app

I removed the dsdt.aml for dump orgion dsdt 。When start with Windows 10 the cinebench had 3600 score ,but Mac Os 10.14.1 only got a score less than 2600。

Share this post


Link to post
Share on other sites
6 hours ago, 8car said:

I removed the dsdt.aml for dump orgion dsdt 。When start with Windows 10 the cinebench had 3600 score ,but Mac Os 10.14.1 only got a score less than 2600。

DSDT.aml.zip

 

use smbios Macpro6,1

Share this post


Link to post
Share on other sites
1 hour ago, MaLd0n said:

DSDT.aml.zip

 

use smbios Macpro6,1

Thanks,I put it into the Clover ,removed nullcpupowermanagement.kext and got a panic with  appleintelcpupowermannagement X86PlatformShim error.

smbios has changed to Macpro6,1

Edited by 8car

Share this post


Link to post
Share on other sites
29 minutes ago, 8car said:

Thanks,I put it into the Clover ,removed nullcpupowermanagement.kext and got a panic with  appleintelcpupowermannagement X86PlatformShim error.

smbios has changed to Macpro6,1

the problem is there, u need use x86platform not appleintelcpuPM ;) 

Share this post


Link to post
Share on other sites
3 minutes ago, MaLd0n said:

the problem is there, u need use x86platform not appleintelcpuPM ;) 

I don't know how to fix it , can u help me ?

Share this post


Link to post
Share on other sites
5 minutes ago, MaLd0n said:

u can try with iMac17+ smbios and check Plugintype in config.plist

 

can I try the iMac Pro?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By DSA2
      Salve a tutti
      Fin' ora non mi sono informato molto su come sistemare il boot , prima schermata di avvio.
      In pratica ogni volta devo spostare con freccetta e selezionare mio Hard disk .
      Allego foto fatte da cell. della schermata boot .
      Bisognerebbe cancellare le entries ?
      E nel caso in cui vorrei modificare la grafica clover ?
      Grazie in anticipo per le delucidazioni.

       





    • By zkingtut
      Hello Everyone ,,
       
      I'd  like to share with you my experience with Lenovo ThinkPad P50 ( EFI , and Installation Process with some tips ) Hopefully to be useful for anyone who own Lenovo ThinkPad P50 
       
      Before start I want to show you my device specs , and I'm  sure 99% this will work too with any P50 have different spec. specially Intel i7 CPUs:
       
      - Intel Xeon E-3 1535 v5 ( P530 Intel HD Graphics )
      - 32 GB RAM
      - 256 GB SK Hynix Nvme SSD pc401 hfs256gd9tng-62a0a - for Mac OS  ( be careful not all nvme ssd are compatible)
      - 256 GB Samsung Evo 850 SSD - for Windows 
      - 4K Screen 
      - Nvidia Quadro M2000M 4 GB ( Useless - Disabled )
      - Intel WiFi Card ( Should be change to a compatible Broadcom one )
       
      BIOS SETUP :
       
      I highly recommend this steps before going to BIOS SETUP according to my experience with this Laptop :
       
            *( Update your BIOS Firmware to the latest one using windows )
       
            *( Remove Battery , Open the back cover and unplug the small CMOS BATTERY for about  4~5 minutes and put everything back again )
       
             * ( Remove any SSD HDD Nvme disks , USB , DisplayPort , Dock .. etc during installation, keep only the target Disk )
       
      -------------------------------------------
      Now Power your PC and Press F1 to enter the BIOS SETUP
       
         - Reset BIOS to its defaults
         - Adjust Date and Time 
         - Config ----> Network ---> Wake Up on Lan ( AC Only )
                                                         Network Stack ( Disabled )
       
        - USB ----> USB UEFI support  ( Enabled)
       
        - Display ------> Total Graphic Memory (256 MB)
                                     Graphic Device ( Hybrid)
       
        - RAID -----> Disabled
       
        - Security -----> Security Chip Selection ( Discrete TPM )
                                     Secure BOOT ( Disabled )
                                     Intel SGX Control ( Software Control )
       
        - Start Up ------>BOOT Priority order ( USB HDD - Mac OS Disk - Windows - and so on ....... with this order )
                                     UEFI/Legacy ( UEFI Only )
                                     CSM Support  ( NO )
      ----------------------------------------------------------------------------------------------------------------------------------
       
      **   F1 to Enter Bios - F12 for Boot Menu
      ***   Delete the EFI Folder in your Installation USB and replace it with the Attached one 
      ****   Generate new serial for SMBIOS MacBook Pro 13.1
      *****    If your CPU is XEON then go to Config.plist CPU Section and Add 0x05A5 under Type ( Fix for Unknown CPU )
      ****** You can delete boot-args "brcmfx=1 & brcmfx-driver=#a" if you want , I used it in my case with 1820A card to fix wifi issue
      ******    After you successfully installed OS , now Copy the same EFI Folder to your main EFI Boot Disk Partition 
      *******    Now install all the attached KEXTS to "Library / Extensions"  using Hackintool.app or by any method and rebuild cache and repair permissions
      ********    Check and compare the KEXTS in Library/ Extensions and Delete the repeated ones from Clover / Kexts / Others ( Important don't duplicate the same kexts here and there )
       
      FYI : LiluFriend.kext include ( Lilu , WhatEverGreen, AppleALC , AirportBrcmFixup ) All In One 
       
       
       
      You are Done 
      ---------------------------------------------------------------------------------------------------------------------------------
       
      What is working :
       
      - 4K Intel HD P530 2048 MB 
      - AUDIO
      - CAMERA 
      - ALL USB 3 PORTS , NO THUNDERBOLTS 
      - Keyboard and TouchPad 
      - Battery indicator 
      - Display Brightness 
      - Sleep 
      - DSDT has been patched , USB Ports modified only to MacBookPro 13.1
       
                   See the Screen Shot 
       
      Important Notice For Future OS Updates Installations : 
       
      To avoid Kernel Panic during install any future updates process please remove ( FakeSMC.kext and LiluFriend.kext ) from Library/Extensions directory to Clover / Kexts / Others .
      After update process finish put them back to Library/Extensions and delete them from clover . I hope this is clear enough
      ---------------------------------------------------------------------------------------------------------------------------------
       
      Happy Hackintosh , Let me know if you have any issue or difficulties during installation or later , I will try to help you
       
      EFI.zip
      kexts.zip

    • By Drovosek
      Unfortunately this is not my PC, I just decided to share the found config successful installation.
      https://vk.com/photo-12954845_457251886
       
      Hardware:
      OS X 10.15.0 Beta 2 
      CPU Intel XEON E5 2650 v3
      MB MSI X99A RAIDER
      AMD Radeon RX VEGA 56 video card
      Kingston HyperX Fury DDR4 2133Mhz 20gb memory
      Crucial 4gb 2400Mhz
      Sound E-MU 0202, Alc892 and AMD DisplayPort Audio
      Intel Gigabit LAN network
      WI-FI Broadcom BCM94360CS2
      BCM20702 BT (trackpad and keyboard work in the BIOS)
      BP Enermax Platimax 1000W
      AirDrop works.
      SSD NVMe Reina 480gb
      Samsung 850 Pro 120gb
      Dell U2713H monitor
      USB 15 ports are registered manually. 3.0 works. 
      Services usual, SpeedStep instituted through kekst. 
      Sleep is unstable.
       
      EFI: https://vk.com/doc207634019_512032268
       

      EFI.zip
    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM / REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×