Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By markilark
      So I have an HP Envy Notebook (15t-q400) which features two Band & Olufsen speakers (tweeters) and one subwoofer - the audio codec used is the ALC290 (aka the ALC 3241). I'm running on Mojave. So far I've tried AppleALC with Lilu and have no luck - the audio plays through the headphones - although very poorly - but not the external speakers at all, and I've tried everything short of writing my own XML file for it. So I've decided to go for using the VoodooHDA kext.  
       
      While VoodooHDA sees my devices immediately, they are strangely configured, and I cannot use the subwoofer or even see it listed as a device. This is my main problem.
       
      As I'm aware the proper configuration of the laptop is: 
      Three speakers - one left, one right, and one subwoofer module One 3.5mm headphone jack An internal microphone for the webcam (this is one I'm not sure about, I don't know if it is two separate microphones or one as there are two holes in the display chasis)   
       
      In my devices while using the default VoodooHDA kext, I have 
                Output:
      Speaker (Analogue) - Type= Apple speaker port <--- only tweeters work  Headphones (Back Right) - Type= Headphone Port <--- this seems to work well           Input:
      Microphone (Black Right) - Type: Microphone Port <---- this works a little, sounds like it's muffled, not from the webcam Microphone (ATAPI) - Type: Microphone Port  <--- this works well, is definitely the webcam microphone  
       

      Here is my Pin Config (with disabled devices not ignored as I think the subwoofer is one of those devices):

      Here is my Pin Config for the photo above (disabled devices NOT ignored, fix not applied).
      01371c00 01371d00 01371e00 01371f40 01871c10 01871d01 01871e17 01871f90 01a71c20 01a71d10 01a71ea1 01a71f04 01d71c2d 01d71d81 01d71e75 01d71f40 01271c30 01271d01 01271ea3 01271f99 01571c40 01571d10 01571e21 01571f04 01471cf0 01471d11 01471e11 01471f41 01671cf0 01671d11 01671e11 01671f41 01771cf0 01771d11 01771e11 01771f41 01971cf0 01971d11 01971e11 01971f41 01b71cf0 01b71d11 01b71e11 01b71f41 01e71cf0 01e71d11 01e71e11 01e71f41  
       
       
       

      Here is my Pin Config for the photo above (disabled devices ignored, fix not applied):
      01871c10 01871d01 01871e17 01871f90 01a71c20 01a71d10 01a71ea1 01a71f04 01271c30 01271d01 01271ea3 01271f99 01571c40 01571d10 01571e21 01571f04  
      I have been attempting to add the subwoofer as a node in the Info.plist of VoodooHDA but can't seem to get it to work (and frankly I'm not sure which device it is!) . I've tried adding both NID 19 and 20 into my Info.plist file for VoodooHDA but neither have done any good. Am I supposed to add the NID and PinDefault to the Info.plist AFTER Pin Configurator's fix? I was under the impression this only helped with a patched AppleHDA which VoodooHDA overwrites. 

      Thanks for all the help, I hope I conveyed this clearly! 
       
      I've attached my codec dump as well. 
      dumpcodec.rtf
    • By spec3
      hi,
       
      Is someone using ultrawide monitor 75hz whit hackintosh?
       
      I would like to buy LG 34UC99 (resolution 3440x1440 and freq: 75hz)
       
      will it work for you?
       
       
    • By BugsB
      SleepOnLowBattery (“SOLB”)
      by BugsB, based on a script by Toggi3 * + more code snippets from the www
       
      For those of us whose HackBook/ MacBook does not go to into power saving mode automatically on very low battery but just powers down coldly: “SOLB”, a small and low load footprint AppleScript based utility that checks the battery level every 2 minutes. You can choose between two versions, either with or without sound. Both display a notification in the top right of your screen.
       
      Between ≤10 and >8% battery charge:

       
      Between ≤8 and >5% battery charge:

       
      On ≤ 5% battery charge you will see a 10 seconds countdown dialog box in 1 second intervals:

       

       
      which you can cancel, or have your your *ac*Book be sent to sleep when down to 0.
       
      The version with sound uses the pleasant macOS US female voice Allison. If the lady is not installed, you can download "her" via System Preferences, Accessibility, Speech (pane tab should get opened by the install script), click onto the two arrows to the right of System Voice, Customize, English (Unites States) -- Female, activate Allison, OK (macOS downloads voices to /System/Library/Speech/Voices - Allison consumes 120 MB).
       
      If you want to see/ see and listen first, disconnect your Mac from its power supply and double click the “run Demo” file in either folder, with or without sound.
       
      The launcher is installed per user, so one user can use the script with and another user the script without sound.
       
      Run your desired install.command, with or without sound. The script should be active right away without restart.
       
      Regarding the sound version, you can also:
      - download any other English voice of your liking and edit the name inside the script at the very top
      - download any language voice and translate the text inside the script
      Edit with Apple Script Editor, save, install, reboot.
       
      Tested working in macOS High Sierra 10.13.6. Please feedback if this utility also works in Mojave.
       
      If you have ideas, experience bugs, etc., please contribute as precise, succinct, productive and friendly as possible. In case of a bug, always include your version of macOS for me or others to try and help. Thank you.
       
      ENJOY
       
      VERSION HISTORY:
      2018-11-10:
      1.0 (initial version)
       
      IDEAS TO IMPLEMENT IN FUTURE RELEASES:
      Have the sound version install script check if Allison is installed, and if not, offer to download and install it. Purely cosmetic: find a way to have the display notification in the top right of the screen not display the Script Editor icon but the one of the utility without turning the utility into an app but by maintaining a script to keep the load footprint low. This is currently neither possible with an Apple Script nor with an Apple Script Bundle file, only with the script compiled into an app. One possibility might be a Perl approach, if someone volunteers. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      * Thanks to Toggi3 for the base script:
      https://hints.macworld.com/article.php?story=20110219013713667
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      THE CODE (of the version with sound):
      install.command:
       
      LaunchAgent SleepOnLowBatterySound.plist:
       
      Script SleepOnLowBatterySound.scpt:
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      SleepOnLowBattery (SOLB) by BugsB v.1.0 (2018-11-10).zip
    • By Slice
      I successfully installed macOS 10.11.6 and Windows 7 Pro SP1 in UEFI mode on the laptop.
      I know, there are detailed guides here and on osxlatitude.com but I was not agree with them and carefully check and test every step to tune my Mac.
       
      Hardware
      Intel® Core� i5-3320M CPU @ 2.60GHz, speedstep works with Clover default settings
      Chipset Intel 7 series, no patches needed
      Video: IntelHD4000 or NVS5200M switchable in BIOS, work in both cases
      LAN; Intel 82579LM, works with IntelMausiEthernet.kext v2.2.1
      Audio: IDT 92HD93BXX, works with VoodooHDA 2.9.0.
      SDHC reader O2Micro; works with native AppleSDHC.kext with Clover Arbitrary properties.
      USB3.0 works natively if not disabled in DSDT
      PS2 keyboard and touchpad works with VoodooPS2.
      WiFi: Dell Intel WiFi was replaced by Dell DW1520, Broadcom BCM943224HMS. DeviceID=4353
      LCD Screen 1366x768
      BIOS A12. Initially was A02. Then I flashed A23 and found it is quite bad. The screen is full of artefacts. Flash A12 and all is OK. Not tested other versions.
      For some reason BIOS can switched from Intel to Nvidia by itself so I have to do my solution working independent on this state.
       
      WiFi
      It is not working OOB although it has DeviceID known to Apple. The reason is WhiteList in the driver.
      I set MacModel as MacBookPro10,1 while the WiFi will work on MacBookAir. I make a patch in Clover.
      As well a patch for channels.
      I deleted a kext Brcm4331 because it has the same DeviceID. Let kext Brcm4360 to work alone.
       
      VideoCards
      In Bios we can set Optimus = Enable/Disable
      If Enable then we have two videocards Intel first and Nvidia second. In this case additional SSDT-3.aml will switch off Nvidia.
      If Disable then we have only Nvidia card. It will work if Board-ID taken from iMac13,2.
      But here there is contradiction with WiFi with required Board-ID from MacBookAir.
      So I take MacModel as MacBookPro10,1 which is most close by CPU IvyBridge.
      Set BoardID like iMac13,2 to make Nvidia working.
      Patch BoardID in Brcm4360 to make WiFi working.
      Now I have
      Inject->
      ->Intel=YES
      ->Nvidia=YES
      and SSDT-3.aml in ACPI\patched folder. This SSDT will switch off Nvidia if Intel card ON.
      For Intel graphics there is a patch against 8 apples at start.
       
      Brightness
      No special kexts.
      The brightness controlled by keys F1,F2 and slider in Control Panel in both case Intel or Nvidia. Details here  #72 
       
      DSDT and SSDT
      This is very long story and finally I have working sleep in both cases Intel or Nvidia.
       
      Sensors
      I use my HWSensors3 with FakeSMC 3.5.0.
      I got monitoring:
      CPU temperature
      GPU temperature
      GPU main frequency
      GPU shader frequency
      Battery state % full, time to charged or time to empty.
      Battery voltage dinamically.
      Battery amperage dynamically. I can see it changes on heavy games.
      HDD temperature.

       
      Audio
      I like VoodooHDA and have no problems with it.
      The sound is clear, loud, and switchable between internal speaker and headphone.
      Mic is working.
       
      Bluetooth
      Just tested with BTFirmwareUpdate.kext and it works. I not needed it so switched off by wireless switch at right side.
       
      Keyboard, Touchpad and Touchstick
      Post #14
       
      My config, ACPI files and kexts are in attachment.
      05.12.2017
      EFI.7z
       
      EDITED:
      Better DSDT in the post #6.
      Sleep working even when AC inserted.
       
      EDITED 06.12.2018
      Now I have HighSierra and this is my EFI folder
       

       
       
      Welcome to discussion!
      EFI-E6430.7z
    • By RogerDodger93
      Salve a tutti ragazzi,
      Mi sono appena iscritto e innanzi tutto vorrei esprimere la mia gratitudine per l'aiuto offerto. Il mio problema come da titolo riguarda il mio Pavilion Power 15 più precisamente il modello cb015nl. Ho notato che c'era un altro topic su un modello simile ma immagino che anche se i modelli sono simili non è detto che siano compatibili quindi ne ho creato uno per il mio modello. Per arrivare al dunque, sono riuscito ad installare con successo Mojave 10.14 ma ho riscontrato diversi problemi una volta avviato l'OS. Quello che non riesco a far funzionare è l'indicatore della batteria, il power managment (Stop non funziona e la luminosità), la porta ethernet e credo che la scheda wifi sia incompatibile, le gesture del trackpad, e l'audio che con una scheda audio esterna funziona a meraviglia e l'ultimo grosso problema è che non riesco a far partire clover senza la usb di installazione, ho installato clover bootoader sull'hd dove ho mojave ma niente senza la usb mi parte il bootloader di hp/windows. Premetto che sono partito con una copia di mojave scaricata dall'appstore. Vi allego il report di HackInfo sperando che possa essere d'aiuto per il troubleshooting
      HackInfo_Report.zip
×