Jump to content
martinomma

Portatile più compatibile con 10.13

79 posts in this topic

Recommended Posts

Ciao a tutti , ho notato che se imposto csractiveconfig su 0x0 , non mi funziona l’audio . A cosa può essere dovuto ?

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites
Advertisement

Si lo so ma perché mi blocca l’audio ? Anche riparando i permessi o reinstallando la kext patchata . Proprio non ne vuole sapere

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Devi usare 0x3

Oppure usa metodi migliori di kext patchati

Esempio AppleALC da tenere in efi

Come la maggior parte dei kext, allora potrai usare anche 0x0

Share this post


Link to post
Share on other sites

aggiornamento , do installato la scheda 

Azurewave Broadcom BCM94352HMB/BCM94352

wifi perfetto subito ma bluetooth non viene visto . c'è modo di farlo partire ? che ne sa qualcosa ?

Share this post


Link to post
Share on other sites

Metti questi due kext nella EFI

 

EDIT: Cancellato l'allegato perchè avevo sbagliato un kext

Share this post


Link to post
Share on other sites

ho provato ma niente...... 

ho provato ma niente...... 

Con quei due kext, posta l'output da terminale di

kextstat | grep -i brcm

Share this post


Link to post
Share on other sites

Grazie appena rientro da lavoro posto , in caso allego anche una foto delle kext nella efi , magari c’è qualcosa che fa conflitto

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Rileggi attentamente il post #65. Uno dei due kext è sbagliato. hai BrcmNonPatchRAM2.kext invece di BrcmPatchRAM2.kext.

allora com’è si dice a Pisa sono un brodo .... grazie , ritento .

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Rileggi attentamente il post #65. Uno dei due kext è sbagliato. hai BrcmNonPatchRAM2.kext invece di BrcmPatchRAM2.kext.

 

Io non so come ringraziarti, è incredibile , funziona!! ora è tutto ma proprio tutto funzionante ..

Una domanda a scopo istruttivo e anche per chi come me non è proprio un mago e legge il forum.

 cosa fanno di preciso questi Kext in efi? 

anche azulpatcher e appleALC

Share this post


Link to post
Share on other sites

per chi come me non è proprio un mago e legge il forum.

Qui nessuno è un mago. Al massimo si ha più esperienza (si ha letto di più o si ha provato personalmente).

cosa fanno di preciso questi Kext in efi? 

https://github.com/RehabMan/OS-X-BrcmPatchRAM

 

anche azulpatcher e appleALC

 

Se non sbaglio, azulpatcher cambia i cursor byte da 6MB a 9MB (patch che si può applicare anche tramite Clover. Per esempio se usi ig-platform-id=0A002606, questo è quello che compare in AppleIntelFramebufferAzul:

0600260A 01030303 00000002 00003001 00006000

00 00 60 00 indica i byte assegnati al cursore. Invertendoli si ha 00 60 00 00 che convertito in decimali è 6291456 byte = 6 MB (inteso come 1 kB = 1024 B). 9MB corrispondono a 9437184 byte. In esadecimali diventano 900000 => 00 90 00 00. Invertiti sono 00 00 90 00.

0600260A 01030303 00000002 00003001 00009000

In più, azulpatcher disabilita il terzo display (0204). Per far ciò con Clover, bisogna ridurre il numero di porte da 3 a 2:

0600260A 01030202 00000002 00003001 00009000

e bisogna eliminare la porta dal platform-id, da:

02040900 00040000 87000000

a:

FF000000 01000000 40000000

Quindi si avranno due patch:

Find:

0600260A 01030303 00000002 00003001 00006000

Replace:

0600260A 01030202 00000002 00003001 00009000

e Find:

02040900 00040000 87000000

Replace:

FF000000 01000000 40000000

Entrambe applicate a com.apple.driver.AppleIntelFramebufferAzul

Più info qui: https://pikeralpha.wordpress.com/2013/06/27/appleintelframebufferazul-kext/

e qui: http://forum.osxlatitude.com/index.php?/topic/8723-enabling-dvidphdmi-and-increasing-vram-with-intel-haswell4th-gen-hd420044004600etc-igpu/

Le patch sono più versatili, ma con il kext è più semplice.

 

AppleALC invece applica patch ad AppleHDA senza la necessità di modificare quest'ultimo. Molto comodo con gli aggiornamenti del sistema operativo. Inoltre, essendo in EFI, permette di avere l'audio anche nella Recovery e nell'installer.

Share this post


Link to post
Share on other sites

Grazie davvero . Sono stato fortunato a interfacciarmi a questo forum perché altrimenti grafica audio e Bluetooth non avrebbero mai e poi mai funzionato .

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Ragazzi , ulteriore aggiornamento .

Wi-Fi e bt funzionanti . È fino qua tutto ok ma ho notato che Handoff rileva il telefono , appare l’icona del continuity in OS X ma non riesce ad aprire l’app che sto utilizzando su iOS nemmeno le pagine web . Insomma funziona al 50% . Se invio foto in AirDrop invece perfetto . Ora non è una cosa che mi rovina la vita sia chiaro . Mi interessa il giusto ma qualcuno Sa da cosa può essere dipeso ?

Su hackintosh fisso che ho invece tutto perfetto

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×