Jump to content
martinomma

Portatile più compatibile con 10.13

79 posts in this topic

Recommended Posts

Aggiornamento .

 

 

Inviato dal mio iPhone utilizzando Tapatalkabab38716536f30a3417840849b893ea.jpg

Ho avuto fortuna a questo giro . Tutto funzionante , sostituirò il modulo Wi-Fi bt a breve . Unica pecca che mi manda fuori di testa è un glitch video probabilmente dovuto alla scheda video NVIDIA che non è disattivabile e disturba la HD4600 .

Come posso risolvere ciò ?

Qualcuno ha esperienze con problematiche di questo tipo ?

9277fe7e3e217e4d6006513dbe5adc48.jpg

Lo fa principalmente con foto e la camera video , anche durante la riparazione permessi con kext Utility

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites
Advertisement

Unica pecca che mi manda fuori di testa è un glitch video probabilmente dovuto alla scheda video NVIDIA che non è disattivabile e disturba la HD4600 .

Puoi allegare un ioreg?

Share this post


Link to post
Share on other sites

Riguardo ai glitch, così su due piedi non ti so rispondere. Quel che è certo è che la Nvidia è disabilitata (come mi sembrava di aver visto dall'SSDT-HACK). Domani guardo meglio.

Share this post


Link to post
Share on other sites

Infatti non compare da punte parti la NVIDIA . Ma non trovo altri motivi a questa piaga

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Aggiornamento : ho tolto la kext hd5000 dalla cartella System extention e mi è sparito il problema glitch ma non ho più accelerazione ...

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Hd5000graphics è il kext della grafica haswell. Se lo togli, perdi l'accelerazione grafica e forse la scheda va in modalità vesa (su questo non sono siciro al 100%).

Share this post


Link to post
Share on other sites

Allora é il kext non perfettamente funzionante perché nelle applicazioni che mi davano il problema non si verifica più il glitch . Sarà qualche id da impostare in Clover o nel dsdt?

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Beh, i mac hanno solo modelli GT3 (HD5000, Iris 5100, Iris Pro 5200), quindi è normale che non vada proprio OOB. L'unica GT2 con supporto è la 4600 Desktop.

Servono i due kext FakePCIID in EFI/CLOVER/kexts/10.13 (o Other). Devi avere una patch sul DSDT o sul config.plist che inietti un device-id supportato (0x04128086).

Se hai ancora glitch, puoi modificare i bytes del cursore da 6MB a 9MB e puoi disabilitare il terzo display (0204). Per fare ciò, puoi applicare due patch sul config.plist o usare azulpatcher4600, come già suggerito sopra.

Share this post


Link to post
Share on other sites

Proverò ma ho fatto un mezzo casino . Ho cancellato il kext e non riesco più a ripristinarlo ....

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Adesso sono in giro e non posso allegarlo. Comunque per ripristinare i kext di sistema, avvii in Recovery e reinstalli il sistema operativo senza formattare. Se hai i kext nella EFI, non dovresti avere alcun problema.

Share this post


Link to post
Share on other sites

Adesso sono in giro e non posso allegarlo. Comunque per ripristinare i kext di sistema, avvii in Recovery e reinstalli il sistema operativo senza formattare. Se hai i kext nella EFI, non dovresti avere alcun problema.

so di essere un rompi Maroni , Ma se potessi allegarmelo mi faresti un gran piacere perché nella reinstallazione mi dice che non può contattare il server

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Grazie mille . Se riesco a risolvere questa piccola cosa della grafica , direi di essere cascato bene con questo portatile . Geekbench mi da 13000 che è quasi quanto il fisso con 4790k

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

 

Se hai ancora glitch, puoi modificare i bytes del cursore da 6MB a 9MB e puoi disabilitare il terzo display (0204). Per fare ciò, puoi applicare due patch sul config.plist o usare azulpatcher4600, come già suggerito sopra.

 

questo passaggio proprio non so come fare . in Clover aumento i bytes ? azulpatcher è un Kext da inserire nella eri Clover Kext?

Share this post


Link to post
Share on other sites

La patch da aggiungere nel config (via clover configurator) è questa:

 

Name : com.apple.driver.AppleIntelFramebufferAzul

Find : 0600260a 01030303 00000002 00003001 00006000 

Replace : 0600260a 01030303 00000002 00003001 00009000 

Comment : Enable 9MB cursor bytes, 0x0a260006

 

Qui scarichi azulpatcher ; https://github.com/coderobe/AzulPatcher4600/releases

da mettere i EFI, insieme a Lilu altrimenti non funziona.

 

Fai le cose per passi, prova prima il kext se le cose non migliorano toglilo e metti la patch.

Insieme non le metterei, perchè in fondo fanno la stessa cosa.

Share this post


Link to post
Share on other sites

Concordo in pieno, anche perché il kext disabilita anche un display, la patch no (ne serve un'altra che se vuoi posto appena sono al pc).

Share this post


Link to post
Share on other sites

Non ci posso credere !!!!!!!! SUCCESSO !!

 

 

Ragazzi grazie infinite di tutto , spero che questa discussione sia utile per che vorrà provare su un portatile come il mio .

Share this post


Link to post
Share on other sites

Se dici anche cosa ha funzionato potrebbe essere utile ai posteri.

ha funzionato la kext

 

 

Inviato dal mio iPhone utilizzando Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×