Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   1 member

  • Similar Content

    • By rtke333
      Acer Aspire V15 V5-591G - Mojave 10.14.4
       
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS:Insyde Corp. v 1.15
      - CPU:Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM:SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth:Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio:Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader:Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam:HD Webcam
      - HDD:TOSHIBA MQ01ACF032 320 GB HDD
      - SSD:SPCC M.2 230 GB SSD
      - Display:1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad:Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      -Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      -HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255):(Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud(native)
      - Integrated webcam(native)
      - 3.0 USB (native)
      - Touchpad and Keyboard(ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info:Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method:You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      -2nd and I think the best method:Replace your M.2 Qualcomm Card with a compatible BCM94352Zcard (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareData.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode:UEFI
      Getting ready for Installation:
      - Download the install zip (bootpack & postinstall): Click here -> acer_aspire_v591g_installfiles.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

       
      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.7 beta 5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Mojave please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Mojave & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart
      list vol (Now select the "System" volume,(FAT 32) For example I select 4)
      sel vol 4
      list part(Select System type partition, for example 2)
      sel part 2
      assign letter=b(This will "mount" your EFI partition)
      Open Explorer++ or TotalCommander in administrator mode to manage EFI
      remove letter=b (This will "unmount" your EFI)
      2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI)
      Open Explorer++ or TotalCommander in administrator mode to manage EFI
      mountvol b: /d (This will unmount your EFI)
      Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip"-> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
    • By glasgood
      GLASGOOD'S
       
      MOJAVE HACKINTOSH GUIDE 
       

       
       
      **FOR**  GIGABYTE Z390 AORUS PRO
       

       
       
      CREDITS & THANKS
       
      @MaLd0n
      His help with EFI configuration and DSDT
       
      CLOVER  TEAM
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, rehabman, Download-Fritz, Zenit432, cecekpawon Et al
       
      APPLEALC
      Acidanthera, vit9696
       
      VOODOOHDA
      autumnrain, slice2009, zenith432
       
      ESP PRO MOUNTER
      @Micky1979 
       
      HACKINTOOL
      @headkaze
       
      CLOVER CONFIGURATOR
      Mackie100
       
      THEME ENGINE
      Alex Zielenski
       
      INSANELYMAC
      OLARILA
       
      Hackintool Tutorial
      daliansky
       
      Hackintosh Guide
      CorpNewt
       
       
      MONITORCONTROL
      JoniVR & theOneyouseek
       
       
       
      ------------------------------------------------------------------------------------------------------------------------------------------------------------
       
      UPDATES
       
       
      ------------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      PART LIST
       
      • Intel I7 8700 
      • Gigabyte Z390 AORUS PRO
      • Gigabyte AORUS RADEON RX 580 8GB
       
      • Corsair Vengeance LPX 16GB ( 2 x 8GB ) 2666MHz – CMK16GX4M2A2666C16  In this build, both memory modules are installed in memory slots DDR4_A1  and DDR4_B1 
       
      • Corsair RM650x 80 Plus Gold Power Supply Unit
      • Corsair H100i V2 AIO Hydro/Water RGB LED CPU Cooler
      • Samsung EVO 500GB SSD (2.5) macOS Mojave
      • Samsung EVO 250 GB SSD (2.5) Windows 10 Pro
      • NZXT H500 Mid Tower ATX Case
       
      • RECOMMENDED WIFI CARD → ABWB 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS  
      OR
      • WIFI and Bluetooth with BCM94331CD with PCI-e adapter (but will require AirportBrcmFixup.kext for AirDrop.. )
       
      ** Avoid Samsung EVO 970 PLUS as Hackintosh has problem with that device **
       
       
      WORKING
       
      • Sound 
      • HDMI audio on RX580
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Handoff
      • Continuity
       

       
       

       

       
       
       
       
       
      PART 1 - DOWNLOAD 
       
       
      Download the following:
       
      • CLOVER
       
      • PRE-INSTALL Aorus Pro Z390 EFI - RX580.zip
       
      • POST-INSTALL Aorus Pro Z390 EFI - RX580.zip    
       
       
       
       
       
      // INTEL UHD 630 EFI  Aorus Pro Z390 EFI's below. For those who do not have a Graphics Card Installed in PCIe Slot, requires Initial Display Output BIOS setting to be changed to IGFX  spoiler below!
       
      • PRE-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip 
      • POST-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip
       
       
       
       
       
      • ESP MOUNTER PRO v1.9
       
      • macOS MOJAVE 
       
      • CLOVER CONFIGURATOR
       
      • EmuVariableUefi-64.efi  ( Used only to initialise iMessages. It then must be removed from Clover drivers64UEFI folder as will cause intermittent memory allocation errors on boot, explained in guide)
       
      • OsxAptioFix2Drv-free2000.efi
       
       
      OPTIONAL DOWNLOADS
       
      • Native Display Brightness with MonitorControl
       
      • VoodooHDA.kext.zip 

      • ThemeEngine 
       
      • Assets.car 
       
       
       
       
      PART 2 - BIOS SETTINGS (version F5 )
       
       
      Here is a list of the BIOS settings that I have used ( Screenshots in spoiler below )
       
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • BIOS → Windows 8/10 Features → Other OS
      • BIOS → CSM Support → Enabled
       
      • Peripherals → Initial Display Output → PCIe 1 Slot
      • Peripherals → Trusted Computing → Security Device Support →  Disable
      • Peripherals → Intel(R)Bios Guard → Intel BIOS Guard Support →  Disable
      • Peripherals → USB Configuration → Legacy USB Support →  Enabled
      • Peripherals → USB Configuration → XHCI Hand-off →  Enabled
      • Peripherals → Network Stack Configuration → Network Stack →  Disabled
      • Peripherals → SATA And RST Configuration → SATA Mode Selection →  AHCI
       
      • Chipset → Vt-d → Disabled
      • Chipset → Internal Graphics → Enabled
      • Chipset → DVMT Pre-Allocated → 64M
      • Chipset → DVMT Total Gfx Mem → 256M
      • Chipset → Audio Controller → Enabled
      • Chipset → Above 4G Decoding → Disabled 
       
      • Power → ErP → Disabled
      • Power → RC6 (Render Standby) → Enabled
       
      // IF USING  CORSAIR H100i V2 AIO CPU WATER COOLER 
      • MIT → Smart Fan 5 Settings → CPU Fan Control mode → PWM 
       
      • Save & Exit → Save & Exit Setup
       
      SCREEN DUMP SPOILERS
       
       
       
       
       
      PART 3 – CREATE A MOJAVE USB FLASH INSTALLER
       
      Prepare USB Installer for Mojave ( Video below )
       
      • Insert USB drive
      • Launch /Applications/Utilities/Disk Utility
      • Disk Utility → View → Show All Devices
      • On Left-hand panel → External →(Identify your USB device in left hand panel)
      • Click and highlight your USB device in the left-hand panel.
      • Click erase button.
      • Name: USB
      • Format: Mac OS Extended (Journaled )
      • Scheme: GUID Partition Map
      • Click Erase button.
       
      • Place the downloaded MacOS Mojave app into Applications folder.
      • Open Terminal copy and paste:
       
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --nointeraction && say Mojave Drive Created  • Enter
       
       
       
       
       
       
       
      PART 4 – INSTALL CLOVER ON THE MOJAVE USB INSTALLER 
       
      Make Mojave USB flash drive installer bootable.( Video below )
       
      • Launch Clover application, double click.
      • Click Continue → Continue → Continue 
      • Click Change Install Location button.
      • Click Install macOSMojave USB installer → Continue
      • Click Customise button
      • Choose:
      Clover for UEFI booting only Install Clover in the ESP Themes UEFI Drivers Install RC scripts on target volume    NO NEED TO INSTALL RC SCRIPTS ON USB INSTALLER • Click Install button
      • Installation Complete!
       
      Video:
       
       
       
       
       
       
      PART 5 – CUSTOMIZE MOJAVE USB INSTALLER FOR AORUS Z390 PRO
       
      Replace Clover EFI folder with PRE-INSTALL Aorus Pro Z390 EFI - RX580.zip  OR  if no graphics card installed in PCIe slot, then use PRE-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip ( Video below ) 
       
      • Install ESP Mounter Pro v1.9
      • Using ESP Mounter Pro, Mount ESP on disk2s1 ( Your disk name may be different )
       

       

       
       
       
      • Open mounted EFI partition found on desktop
      • Copy all the contents from Aorus 390 Pro EFI folder
      • Replace USB EFI folder with all the contents inside the Aorus 390 Pro EFI folder.
       
       

       
       
       
       
       
       
       
       
      PART 6 – INSTALL MAC OS MOJAVE ON INTERNAL DRIVE
       
      INSTALL NOTE
       
      ENSURE BIOS: Above 4G Decoding is set to Disabled 
      if Above 4G decoding is set to enabled then macOS Mojave install will freeze at 2 mins remaining and will not shut down properly!!!!
       
      Please be patient during install, so when install gets to 2 or 3 mins remaining then it may take extra time. Be ready to boot from UEFI USB installer by pressing F12 when install initiates restarts. 

      • INSERT USB INSTALLER INTO THE USB 2.0 PORT  
       
       
      • Power on PC and press F12• Choose bootable USB drive from boot menu.
       
       
       
      • Install macOS Mojave to internal solid state or hard drive.
       
       
       
      When system returns to the Clover boot menu choose:
       
      • Boot macOS Install from Macintosh
       
       
       
      At next restart, press F12 and boot from external UEFI USB device and choose:
       
      • Boot macOS Install from Macintosh
       
       
       
      Proceed with macOS Mojave install
       
       
      macOS Mojave is now installed, but it can only boot at this moment thanks to FakeSMC and Clover on the Mojave USB flash drive installer.
       

       
       
       
       
       
       
      PART 7 – MAKE AORUS Z390 PRO INTERNAL DRIVE BOOTABLE
       
      Make internal drive bootable ( Video below )
       
      So far, the Aorus Pro can only boot the internal system drive with the aid of the Mojave USB Installer.
      To boot from the internal system drive without the installer: 
       
      Download and install Clover with RC Scripts on target volume.  
      If your Aorus Pro Z390 has AMD RX 580 then copy the EFI folder from inside POST-INSTALL Aorus Pro Z390 EFI - RX580.zip folder and paste it inside the the System Drive EFI partition.          OR
      If your Aorus Pro Z390 has no graphics card installed in PCIe slot, then copy the EFI folder from inside POST-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip folder and paste it inside the the System Drive EFI partition.   
       

       
       
       
      • Remove USB Mojave installer and shut down and restart.
       
      Aorus Hackintosh should now be able to boot to macOS Mojave, Done, well almost ! 
       
       
       
       
       
      PART 8 – ENABLE IMESSAGES & FACETIME 
       
       
      Configure Config.plist for iMessages. ( Video below )
       
      • SMBIOS = Mac Mini 8.1
      • Rt Variables —> ROM —> is your MAC address (delete colons from Mac address)
      • MLB field =  Enter serial number generated and append 5 random characters
      • SmUUID = in Terminal run command “uuidgen” and copy it to SmUUID field
      • Board Serial is same as MLB field.
      • Clover Configurator —>  Save 
       
      Video:
       
       
       
      • Mount internal drive EFI/ESP partition
      • Go to folder CLOVER → drivers64UEFI 
      • Delete AptoMemoryFix-64.efi
      • Place both EMUVariableUefi-64.efi and OsxAptoFix2Drvfree2000.efi inside → drivers64UEFI
       
       
      Using Clover Configurator, add the following argument to config.plist using Clover Configurator.
       
      • Slide = 0
       

       
       
      Shutdown and then press power on button on PC.
       
      • You should now be able to Log into iCloud, iMessages and FaceTime
      • NOW delete EMUVariableUefi-64.efi from CLOVER → drivers64UEFI Folder 
      • Shutdown and restart Aorus Pro hackintosh. iMessages etc is now operational without EMUVariableUefi-64.efi ( EMUVariableUefi-64.efi only needed to initialise iMessages )
      • It is important to delete EMUVariableUefi-64.efi, this will avoid very intermittent boot errors such as: “Couldn’t allocate runtime area”  post errors.
       
       
       
       
      PART 9 – ENABLE TRIM for Solid State Flash Drives
       
      Open Terminal and enter the following command:
      sudo trimforce enable  
       
       
       
       
      DEFAULT SSDT –  DEFAULT SSDT USB PORTS FIX CONFIGURATION - SSDT ALREADY INSIDE AORUS Z390 EFI FOLDER
       

       

       

       
       
      Limitation: USB2 devices can not be used on SS03 → SS08
       
       
       
       
       
      ------------    GUIDE FINISHED YOU SHOULD NOW HAVE WORKING AORUS Z390 PRO HACKINTOSH  WITH SSDT USB FIX   ------------
       
       
       
      OPTIONAL: Set Wi-Fi Country Code
       
       
       
       
       
       
      OPTIONAL: System Information - PCI
       
       
       
       
       
       
       
      OPTIONAL:  Enable HDMI Audio on RX580
       
       
       
       
       
       
       
      OPTIONAL:  Native Display Brightness - with MonitorControl

       
       
       
       
       
       
      OPTIONAL:  Dual Boot macOS Mojave & Windows 10 
       
       
       
       
       
       
       
       
      OPTIONAL:  Replace the default "About This Mac" Apple Logo with RED AORUS APPLE
       
       
       
       
       
       
      OPTIONAL - ALTERNATIVE SSDT 1 –  SSDT Ports configuration below - replace SSDT inside Clover /ACPI/PATCHED folder 
       
       
       
       
       

      OPTIONAL - ALTERNATIVE SSDT 2 -  SSDT Ports configuration below - replace SSDT inside Clover /ACPI/PATCHED folder 
       
       
       
       
       

      OPTIONAL - ALTERNATIVE SSDT 3 – Create your own SSDT
       
       
       
       
       
      FRAMEBUFFER PATCHING  – For working Intel UHD 630 Graphics, working HDMI Port, working HDMI Audio on Aorus Z390 Pro
       


       
       
       
       
      FOR MORE HACKINTOSH INFORMATION SUCH AS USB PORTS FIX, CLOVER CONFIGURATOR, HACKINTOSH BACKUP WITH CARBON COPY CLONER .....   THEN SEE MY PREVIOUS GUIDE FOR ASUS Z370-G Strix
       
       
       
       
       
       
       
       
       
       
       

       
       
       
       
       
       
       
       
      SSDT-UIAC.aml.zip
      SSDT-UIAC.dsl.zip
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
    • By Gorec
      Hi.
      I apologize in advance if I didn't post in the right category and if my title and description aren't specific enough :c
       
      My config in a nutshell:
      CPU: i7 5820k GPU: MSI GTX 1060 3GB RAM: 16 GB MOBO: MSI X99 SLI PLUS I attached RunMe output with all the details of my built.
       
      Some background:
      I have my Hackintosh for about half a year. That time I managed to make it works and fix major issues, but some of them left unresolved since then and I ignored them until now.
      I use my Hackintosh for Adobe projects (PR, AE, PS, IL, AU and a lot more) - most of them connected with video editing of course browsing with Chrome and other small tasks.
       
      Problems:
      Random restarts - this is the biggest one. I'm starting to work on bigger and bigger projects and at this time I think I can't allow this to happen that often. In the past, they happened like once a day or a couple of times a week. However, now it's just frustrating when it happens even 5 or more times a day. I've tried to observe and find out what can be the cause but I haven't managed to find any connections. I thought it happens when Premiere or another app is using GPU, but I haven't seen increased usage when it restarts. I think that it can be connected with GPU, memory or PSU or... meh, anything else. I don't have resources to check if it'll work with other components. There should be some fix for this. I will really appreciate any help with this :c Restart instead of shutdown & sleep doesn't work. I've tried to look through some Google results for this and tried many solutions (as you can see in attached Clover folder), but I think the right one for many of these issues is to make my own DSDT. Glitches, freezes and other things while encoding a video. It happens very often when I try to do this. Maybe it is an issue with GPU or (hopefully) only with GPU drivers which can be fixed with some patch. Today my headphones stopped working. I have a multi-output device configured in the Audio MIDI Setup app which includes my headphones (HyperX Cloud via USB) and Soundflowerbed virtual audio device for capturing system audio. Today while I was trying (like 15 times) to encode a video in Media Encoder in the background and watch video on YouTube I stopped hearing anything from my system. Of course, it restarted a couple of times as always, but even this didn't solve this. If I plug them directly with mini jack (not via USB Soundcard which was in the box and which I always used) in the front IO or the back I only hear some loud noise It takes EX-Fat formatted volumes a few minutes to mount after each restart. I found a workaround to format it with NTFS since I have Tuxera installed and I will reformat these volumes when I will find time for this, but maybe there is some fix for this. GPU is a little bit hot. HW Monitor shows it is only 45-55 degrees, but for my hand is a little bit hot, idk. Also related to GPU - glitch after POST but before entering Clover boot menu. It is a black screen with little white squared glitches for a few seconds. Maybe it indicates the GPU drivers are loading, but maybe it shouldn't be like this. And if I can ask about that - I can't make all applications hide on startup. I, obviously, have "Hide" checkbox checked on every login item in settings, but it doesn't work, none of the apps is hidden in the dock. Is there a way to fix this? Also a small but annoying problem - I can't turn off permanently Mojave update notification (since I tried to install it, and I had to reverse to High Sierra because I had a black screen and I didn't have time for repairing all of them. Tags are not working in Finder - every time I tag a file or folder and make a change in it (for example save a text file) the tag disappears.  
      So, with knowing all of that, is there a way to make a proper DSDT file for my Hackintosh? I tried to look through some guides on how to make it but I think I reached my abilities to understand how Mac OS works and what all of these things are, so I'm asking you guys politely, would someone like to help me? At least with these random restarts? :/
      I really begin to think that I'm a newbie in configuring all of that Clover things - even after what I managed to do with my PC. Help me, pleease... :c
       
      If you have any questions post it below, I will really appreciate any help <3
      Send me MBP-Gorec.home.zip
    • By ciriousjoker
      TLDR:
      I'm trying to boot MacOS on a Chromebook without UEFI. I'm stuck at getting the bootloader (Chameleon/Clover) to work.  
      My setup / context:
      I have an Acer Chromebook Spin 13.
      Available ports:
      2 x USB-C 1 x USB-A 3.0 MicroSD Slot No USB A 2.0 (I've read that Clover has problems with USB 3.0) Firmware:
      There's no UEFI firmware available and by default, it doesn't even allow booting anything other than ChromeOS. Thanks to MrChromebox (big shoutouts!), I flashed a custom legacy bios that allows me to boot anything linux related. This bios is flashed into the RW_LEGACY section of the existing bootloader (coreboot afaik) and doesn't have any configuration options. If I have to change a setting, I could try compiling his bios payload myself with the specific setting enabled.  
      What I've tried so far:
      Chameleon attempts:
      Only selected setting was "Install chameleon on the chosen path", rest was unselected.
       
      1 - Install chameleon first without restoring the basesystem:
      Output:
      > boot0: GPT
      > boot0: done
      (hangs; pressing power button once shuts down
      Chameleon installation log is attached as "Chameleon_Installer_Log_BEFORE".
       
      2 - Install Chameleon after restoring the base system:
      Output:
      > boot0: GPT
      > boot0: GPT
      > boot0: doneboot1: /boot       <- Exactly like that, no line break in between
      (hangs; pressing power button once shuts down)
       
      I haven't been able to reproduce #2 after wiping the drive and doing the same thing again. Subsequent attempts have resulted in either #1 of either Chameleon or Clover.
      Chameleon installation log is attached as "Chameleon_Installer_Log_AFTER".
       
      Clover attempts:
      I tried multiple settings and configurations, but all of them boiled down to either one of these.
       
      1 - Doesn't do anything, just hangs at "Booting from usb..."
      2 - Boots into the blue/grey mode as shown in the attached images.
      According to MrChromebox, this could be an old Tianocore DUET It doesn't detect anything (cpu frequency, ram, partitions or disks)  
      I've read pretty much every article, github readme and other types of documentation for coreboot, tianocore, clover, chameleon and MrChromebox' rw_legacy payloads and right now, I'm totally clueless as to what to try next...
       
      A few questions that came up:
      Why does chameleon hang? What is it looking for, /boot was clearly written to the disk by the Chameleon installer? What exactly is the blue/grey image? According to MrChromebox, it could be Tianocore DUET Where does it come from? Clover? The mainboard itself? Why does the blue/grey thing not detect my processor frequency or any partitions/drives? Can I use some sort of DUET bootloader to chainload Clover?  
      If you guys could answer any of them or if you have any other guesses or information as to what's happening, I'd be really happy!
      Chameleon_Installer_Log_BEFORE.txt
      Chameleon_Installer_Log_AFTER.txt





    • By outdoormagic
      Short Version:
      I have two drives with the exact same EFI folder (and I can boot into Clover from either one), shouldn't I be able to boot into MacOS from either one?
       
      More Detail:
      I've done a few hacks so far and this never happened. (Gigabyte z370 / 8700k / Vega, Asus z390 / i5-9600k / 1080). Now, I'm setting up a ThinkPad X1 Gen 6. (Yes, I do expect problems on laptops, but that's not the question).
       
      Mojave 10.14.4 now boots from the internal SSD. So far, so good. Here's the problem.
       
      I installed Mojave on a USB drive (for backup / rescue) and copied the entire EFI partition of my boot drive to the EFI partition on the USB drive. So... I should be able to boot from the USB drive, right? Wrong. Ran Clover installer on the USB itself. Same outcome.
       
      With F12, I can boot from the USB into Clover and select the OS on the USB. The boot sequence hangs on End Random Seed, but before the usual '++++++++' line.
      So, boot into Clover on internal boot drive, then select OS on USB. Same thing.
       
      Read the forums, I saw the posts about AptioMemoryFix, so I tried the various other drivers on the USB. No go.
       
      I haven't found the solution yet to the USB boot issue, but what puzzles me is that if I have two drives with the exact same EFI folder (and I can boot into Clover from either one), shouldn't I be able to boot into MacOS from either one?
       
       
×