Jump to content
Mork vom Ork

macOS 10.13.2 Update is out

122 posts in this topic

Recommended Posts

I used the kext in the EFI partition (CLOVER/kexts/Other/) ... however that should not make a difference as s/l/e/ should work too (but you can try) . To verify if AMD9xxxControllerPatcher.kext does it's job issue the following command :  ioreg -lw0 | grep CFG_FB_LIMIT . You should get: CFG_FB_LIMIT"=5 in that output string. If you get CFG_FB_LIMIT"=0 it means the kext did not load properly.

 

Other options I used in Clover for graphics are: 0x59120003 for ig-platform-id (no other options except RadeonDeInit).

 

 

I deleted whatever green used radeondeinit
Place the kext you uploaded and placed in s/l/e
Getting same issue with sleep. It just hangs
And I’m using the latest clover you mentioned

Share this post


Link to post
Share on other sites
Advertisement

For me the kext did not work as is, having still the sleep / wake issues - however I used the AMD9xxxControllerPatcher.kext and edited the Info.plist to change CFG_FB_LIMIT from 0 to 5 (the number of my card's ports) - and now the sleep/wake issue is resolved. Combined with RadeonDeInit and I'm back on track. 

 

The other option is to use WhateverGreen and a patch to change the value - but that's a bit more involved. Hopefully Clover will incorporate the patch by default at some point. Attached the modified kext if someone needs it and is too lazy to change the value :)

 

Can confirm, this one works on my RX480 too. Is there any other way to set the CFG_FB_LIMIT besides using this kext?

Share this post


Link to post
Share on other sites

Can confirm, this one works on my RX480 too. Is there any other way to set the CFG_FB_LIMIT besides using this kext?

 

Yes, all (?, most?) of these modifiers of the AMD9xxxControllers can be put in DSM methods within your GFX0 device in your DSDT or a SSDT.

 

An example are the various SSDTs which are implementing the wakeup fix (what Clover's RadeonDeinit does) or the sample SSDT which vandroiy2012 linked to some pages ago: https://github.com/vit9696/WhateverGreen/blob/master/Manual/Sample.dsl

Share this post


Link to post
Share on other sites

Usually short after when apple pushes the updates in App Store they will add the full installer in their support/download page you can find the updates there

 

https://support.apple.com/en_US/downloads/macos

 

I always download the Combo update and then install it on my Macs and Hacks.

Thanks for this link  :)

Share this post


Link to post
Share on other sites

Yes, all (?, most?) of these modifiers of the AMD9xxxControllers can be put in DSM methods within your GFX0 device in your DSDT or a SSDT.

 

An example are the various SSDTs which are implementing the wakeup fix (what Clover's RadeonDeinit does) or the sample SSDT which vandroiy2012 linked to some pages ago: https://github.com/vit9696/WhateverGreen/blob/master/Manual/Sample.dsl

 

I never understood how to inject those SSDTs... Change the "Sample.dsl" to match my GPU card and convert to .aml with(macIasl) and put in EFI>CLOVER>ACPI>patched ???

Share this post


Link to post
Share on other sites

Ok, i tried setting CFG_FB_LIMIT by SSDT like in vit9696's example file. But it doesn't work. ioreg -lw0 | grep CFG_FB_LIMIT still outputs zero. I'm using Whatevergreen 1.1.3 and -rad4200 boot option on my RX 560. GFX1 device name is correct. Card is in first PCIE slot. Maybe someone can verify or help...
 

DefinitionBlock ("", "SSDT", 2, "APPLE ", "SSDTAMDGPU", 0x00001000)
{
    External (_SB_.PCI0, DeviceObj)
    External (_SB_.PCI0.PEG0, DeviceObj)
    External (_SB_.PCI0.PEG0.GFX1, DeviceObj)

    Scope (\_SB.PCI0)
    {
        Scope (PEG0)
        {
            Scope (GFX1)
            {
                Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                {
                    Store (Package ()
                    {
                        
                        // This will change CFG_FB_LIMIT in aty_config to 6
                        // Starting with 10.13.2 AAPL hardcodes framebuffer limit in certain kexts.
                        // In particular, for AMD9500Controller the value is 6.
                        // This is not correct for some GPUs (e.g. Radeon Pro, which has 3), so you are to specify
                        // the correct value right here.
                        "CFG_FB_LIMIT",
                        0x03,

                        
                        
                    }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                }
            }


        }

        
        Method (DTGP, 5, NotSerialized)
        {
            If (LEqual (Arg0, ToUUID ("a0b5b7c6-1318-441c-b0c9-fe695eaf949b")))
            {
                If (LEqual (Arg1, One))
                {
                    If (LEqual (Arg2, Zero))
                    {
                        Store (Buffer (One)
                            {
                                 0x03
                            }, Arg4)
                        Return (One)
                    }

                    If (LEqual (Arg2, One))
                    {
                        Return (One)
                    }
                }
            }

            Store (Buffer (One)
                {
                     0x00
                }, Arg4)
            Return (Zero)
        }
    }
}

Share this post


Link to post
Share on other sites

hi guys,

Anyone have noticed that the freezes in safari returned?

Today I have experienced the return of safari freezes when playing a video in endgadget... I have updated shiki and intelgraphicsfix.kext, but nothing happens, anyone have a solution?

Share this post


Link to post
Share on other sites

Sys prefferences>Displays>Changed from scaled to default till Apple fix bugs. Safari freeze are gone.

If i let scaled resolution i receive "com.apple.xpc.launchd[1] (com.apple.preference.displays.MirrorDisplays): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.".

Share this post


Link to post
Share on other sites

hope nobody has OSInstall.mpkg issue in r4334.

if you have a OSInstall.mpkg issue, please don't update 10.13.2 official.

 

What can I do? Before the upgrade I get this:

The path /System/Installation/Packages/OSInstall.mpkg appears to be missing or damaged.

I update with OSInstall.mpkg problem and now i get a KP...

 

Topic here: http://www.insanelymac.com/forum/topic/330418-kp-after-updating-to-macos-10132/

 

Can you help me?

Share this post


Link to post
Share on other sites

in which slot is your gpu?

if the one (first one) near cpu socket i will send to you my ssdt

Yes, you can send it if you do not mind and I'll do the test. It is mounted in the first slot.

Thanks fabiosun

 

Edit: Have you seen the new bios update on the Asus website? Version 3801  :yes: 

Share this post


Link to post
Share on other sites

attached your patched bios and my ssdt for renaming gfx (thanks to gengix84 for some optimization)

I suggest to you to use only this ssdt and cpu related one to test

Also in kext I would delete all usb related kext and I will enabled on bios USB from smartauto to enable

but I don't know if your system could start in this way

I attach also my config if you want to take a look to rename part for usb and High Sierra port limit)

 

On 12/8/2017 at 5:00 PM, Fergarth said:

Yes, you can send it if you do not mind and I'll do the test. It is mounted in the first slot.
Thanks fabiosun

Edit: Have you seen the new bios update on the Asus website? Version 3801  :yes: 

 

 

 

 

Edited by fabiosun
cleaning quota

Share this post


Link to post
Share on other sites

For those Radeon RX560 users that still suffering sleep issues: this kext is for you! SSDT way sadly doesn't work. It should be working for both Whatevergreen.kext or Clover Radeondeinit.

 

I edited the kext posted by derailed_spark (or macinsane) to CFG_FB_LIMIT=3 and CFG_USE_AGDC=true. At least for now, this is working here.

AMD9xxxControllerPatcher.kext.zip

Share this post


Link to post
Share on other sites

attached your patched bios and my ssdt for renaming gfx (thanks to gengix84 for some optimization)

I suggest to you to use only this ssdt and cpu related one to test

Also in kext I would delete all usb related kext and I will enabled on bios USB from smartauto to enable

but I don't know if your system could start in this way

I attach also my config if you want to take a look to rename part for usb and High Sierra port limit)

Thank you fabiosun! As soon as I can I test and then report the result.?

Share this post


Link to post
Share on other sites

 

Ok, i tried setting CFG_FB_LIMIT by SSDT like in vit9696's example file. But it doesn't work. ioreg -lw0 | grep CFG_FB_LIMIT still outputs zero. I'm using Whatevergreen 1.1.3 and -rad4200 boot option on my RX 560. GFX1 device name is correct. Card is in first PCIE slot. Maybe someone can verify or help...

 

 

 

Same here, tried everything and always failed. For some reasom macIASL refactors the code upon saving and it breaks. So I'm guessing this could be the reason..

 

post-838036-0-53185400-1512779016_thumb.png

Share this post


Link to post
Share on other sites

@ Nightf4ll
That line should be: DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Maciasl compiles fine here without problem.
I reckon that this ssdt correctly works but the custom value gets overwritten later by AMD9500Controller.kext. For me, info.plist patching or injection is the only easy working way to go.

Share this post


Link to post
Share on other sites

@ Nightf4ll

That line should be: DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Maciasl compiles fine here without problem.

I reckon that this ssdt correctly works but the custom value gets overwritten later by AMD9500Controller.kext. For me, info.plist patching or injection is the only easy working way to go.

Yeah I know, I save it like it should be, but later, once I open it up again it becomes what I posted. Anyways, I'll keep using "AMD9xxxControllerPatcher.kext.zip" fro now..

Share this post


Link to post
Share on other sites

For those Radeon RX560 users that still suffering sleep issues: this kext is for you! SSDT way sadly doesn't work. It should be working for both Whatevergreen.kext or Clover Radeondeinit.

 

I edited the kext posted by derailed_spark (or macinsane) to CFG_FB_LIMIT=3 and CFG_USE_AGDC=true. At least for now, this is working here.

Thanks for this AMD9xxxControllerPatcher.kext which works for RX-560 at 10.13.2 (17C88) now !

But it may interfere previous versions such as 10.13.1 or 10.12.6.

So it's better to patch info.plist of AMD9500Controller.kext directly at 10.13.2 until Apple fixes it in future version.

Share this post


Link to post
Share on other sites

just did it. also the full 10.13.2 Installaer is now available on the AppStore

10.13.2 multiple fails on AppStore update using ASUS Z170 Pro Gaming i5 6600K XFX R9 Fury(doesn't work) Intel on board graphics works Hackintosh macOS high sierra 10.13 on HDD. After fail PC restarts to Clover which shows 2 internal drive icons first drive fails second drive boots original install perfectly back into macOS 10.13. AppStore update option shows 10.13.2 available again?? HDD shows folder with update installation. Any fix for this also any fix for XFX Radeon R9 Fury triple it's going to waste so far. SB combo updater not 10.13.2!

Share this post


Link to post
Share on other sites

10.13.2 multiple fails on AppStore update using ASUS Z170 Pro Gaming i5 6600K XFX R9 Fury(doesn't work) Intel on board graphics works Hackintosh macOS high sierra 10.13 on HDD. After fail PC restarts to Clover which shows 2 internal drive icons first drive fails second drive boots original install perfectly back into macOS 10.13. AppStore update option shows 10.13.2 available again?? HDD shows folder with update installation. Any fix for this also any fix for XFX Radeon R9 Fury triple it's going to waste so far. SB combo updater not 10.13.2!

 

Happens to me too sometimes. Usually I do redownload it again until it works. Also, I think clover will select the right partition on its own upon reboot.. if not you just select the partition which has "install MacOs" in it until it dissapears, then you can boot from your original partition.

Share this post


Link to post
Share on other sites

Happens to me too sometimes. Usually I do redownload it again until it works. Also, I think clover will select the right partition on its own upon reboot.. if not you just select the partition which has "install MacOs" in it until it dissapears, then you can boot from your original partition.

I am new at this hackintosh project so I am not comfortable with it. The update issue is not as important as the AMD R9 Fury not working it has 8 led's that show its fully active using macOS high sierra hdd. Intel graphics is connected to monitor with hdmi cable AMD R9 Fury uses display port cable, macOS see's both cards but I only get video on Intel graphics HDMI if I switch monitor to displayport screen is black?? when I use my  windows 10 hdd the leds on card go on and off based on usage they never stay on all the time. I don't use both hdd at same time one is not connected so I can only boot into windows  or macOS clover depending on which hdd is connected it's safer not dual booting for me. My concern is the AMD R9 Fury card is going to be damaged, all on all the time, if its only the 3 cooling fans drawing power that's OK but who knows what's happening

Share this post


Link to post
Share on other sites

I am new at this hackintosh project so I am not comfortable with it. The update issue is not as important as the AMD R9 Fury not working it has 8 led's that show its fully active using macOS high sierra hdd. Intel graphics is connected to monitor with hdmi cable AMD R9 Fury uses display port cable, macOS see's both cards but I only get video on Intel graphics HDMI if I switch monitor to displayport screen is black?? when I use my  windows 10 hdd the leds on card go on and off based on usage they never stay on all the time. I don't use both hdd at same time one is not connected so I can only boot into windows  or macOS clover depending on which hdd is connected it's safer not dual booting for me. My concern is the AMD R9 Fury card is going to be damaged, all on all the time, if its only the 3 cooling fans drawing power that's OK but who knows what's happening

 

Try adding Lilu + whatevergreen kext. If you installed 10.13.2, you might want to add the AMD9xxxControllerPatcher.kext.zip and modify it to mach the number of ports on your GPU to get sleep working.

 

My Sapphire RX480 used to stop fans when idle, but this is now broke in 10.13.2. It only works on initial boot (fans stop), but after waking from sleep, they keep on spinning permanently.

Share this post


Link to post
Share on other sites

Yeah I know, I save it like it should be, but later, once I open it up again it becomes what I posted. Anyways, I'll keep using "AMD9xxxControllerPatcher.kext.zip" fro now..

 

Maybe you are trying to compile against older ACPI version. Try Maciasl Fork from Rehabman and switch to ACPI 6.1 in preferences.

 

 

###edit###

Regarding your fan issues: You can try experimenting on enabling/disabling AGDC in AMD9xxxControllerPatcher.kext

Share this post


Link to post
Share on other sites

for me always 17c88 for both

downloaded now from Appstore full installer but always 17c88 version

 

Is 17c88 the combo update and 17c89 the full installer? Difference?

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

for me always 17c88 for both

downloaded now from Appstore full installer but always 17c88 version

Strange, I see some with 17c89 and not sure why.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×