Jump to content
Sign in to follow this  
Followers 0
black.dragon74

[TOOL] [PROBLEM REPORTING FILES GENERATOR]

3 posts in this topic

Recommended Posts

Last update: 2 Dec 2017

 

Hello guys,

 

I have seen many instances where people start a thread with the problem they are facing on their hack.

 

They try to describe the issue in their own way that most of the times, is not able to properly describe what's going wrong with their system.

 

The developers and other members can point out the problem exactly when they have a set of files, called problem reporting files.

 

These are basically a set of files that contain various logs and some other components.

 

Many a times a normal user can not generate those files properly and it leads to a lot of wastage of good time, frustrated by this, I wrote a script to generate proper problem reporting files. You can have a look here

 

The purpose of this guide is to tell the normal user on how to generate those files properly for debugging.

 

I wrote a script that automatically installs that debug report generator script and then gives you a .zip output.

 

If you are seeking help about a problem and you are not attaching your problem reporting files, you will be redirected to this thread.

 

How to generate debug report:-

 

It is very simple, you just have to download the attached script and run it. The script in attachment will install the tool for you and will then prompt if you want to generate the files.

 

If you want to generate files next time, you just have to invoke: "gen_debug" from terminal (without quotes)

 

How to download and run attached script :-

 

Unzip the downloaded zip file

 

Open terminal

 

Assuming your script is in Downloads folder, type the following code :-

chmod a+x ~/Downloads/install_tools.sh
~/Downloads/install_tools.sh 

Note: It is recommended to attach output of gen_debug whenever you are reporting a new problem (helps to debug and saves a lot of time). Whenever you change anything, it is compulsory to attach NEW output of gen_debug.

 

Note 2: It is recommended to update your copy of gen_debug every alternate month (for fixes and new features). To do so, If you are running version 2.1 or above, you can simply type "gen_debug -u" (without quotes) in terminal. If you are running version 2.0 or less, you can use the attached script to update your copy.

 

Note 3: To check gen_debug version you can run it and then you will see version in the output.

 

CHANGELOGS:

Update 2.3 - 2 Dec 2017:

  • Fixed an issue where timestamp of dump was overridden with current system time, reported by RehabMan. Update using "gen_debug -u"

Update 2.2 - 27Nov 2017:

  • Added option to generate system information dump as requested by Jake, like
# To generate normal report
gen_debug

# To include system dump
gen_debug -sysprofile

# To include system dump but in txt format
gen_debug -sysprofile txt

# Default format is .spx so that the dump opens up with System Information.app

# Any option other than txt will be ignored as script will fallback to .SPX extension  

Update 2.1 - 27Nov 2017:

  • Fixed an issue where IOREG was not saved on some machines
  • You can now update your copy of OSX-Debug by using "-u" arg, like
gen_debug -u

Regards

 

Notice to mods: Can you please move it to appropriate section HERE and then delete this line?

install_tools.zip

Share this post


Link to post
Share on other sites
Advertisement

could be great to use it from a other /Volumes :

 

ask for volume

volume selected eg /Volumes/Power

search is done on this Volume

 

:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rdall96
      Hello everyone!
       
      I am fairly new to the world of Hackintosh. I recently moved my previous build into a smaller form factor. However, I am running into a series of problems with the USB ports on the new case and the new motherboard.
       
      Part List:
      - i7-7700k
      - Gigabyte Z270N Gaming 5
      - 16GB Trident Z RGB 3200 MHz
      - Sapphire RX 470
      - NZXT Kraken x62
      - NZXT H200 for the case
       
      Everything in the Hackintosh works just like it did before, nothing changed in the hardware department other than the motherboard (previously a gigabyte Z20X Ultra) and the case.
      This motherboard does not have any USB 2.0 ports in the back, there is only one header on the board, currently taken by the Kraken x62. The rest of the ports are all either USB 3.1 Gen1 or USB 3.1 Gen2, and the front of the case has 3.1 Gen1 ports as well.
       
      This is my current problem:
      When I plug something into either the type A or type C Gen2 ports, it works fine as a normal USB 3.x device with normal speeds, but when I plug something into any other USB port, it only works at lower 2.0 speeds. This is a big problem for me, since I have a few external devices that need the 3.0+ speeds and I don't know what to do.
      I tried to follow many different guides on how to patch USB ports, remove the limits, etc... But nothing seems to work.
       
      Please someone help me!
    • By Allan
      In this forum is possible to use the file manager to upload files, photos/.plists or kexts.
       
      Follow this steps in the video bellow:
       
      Post files.mov
    • By Nopam456
      SPECS:
      Motherboard: MSI Z170A
      Cpu: I7 6700K
      GPU,Graphics card: Nvidia GTX 1070
      Ram: 16GB
      Drives: I have 1 SSD for my windows and 2 HDD from 1tb and 2 tb, The 1TB is available for the hackintosh.

      Also disabled VD-T and enabled XHCI and disabled CFG Lock

      So i went through all the steps first i had an issue with my usb that it wasn't bootable
      Fix: Go to disk utility, find your USB and erase the data and use GUID Partition Map

      Now further with my problem,

      So i fixed that issue i had and then the installation was freezed on loading, then i turned on XHCI in bios usb configuration..
      And also in clover into settings and removed dart=0,

      Then it started loading!
      BUT now after the loading i get the parking sign and i do not know what to do now.

      I tried everything, sometimes when i reinstalled everything i didn't have parking sign but just a reboot when the apple logo showed up very weird here is some verbose output:

      https://imgur.com/a/Re1oOsI#JRTeX63

      So i tried literally everything...

      Please someone help me..
      And like i don't know call in discord or anything and go through the installation with me cuz its just not working.
      And i don't know what i'm not doing or doing wrong...
      Thanks for the help
    • By b31k
      Report Problem Files.zip
    • By BOB4UK
      Я выполнил инструкции, но когда я запустил установку, после загрузки полосы под яблоком у меня есть установочные окна, но их очень сложно понять, яркость ниже минимальной в Windows. Извините за мой плохой английский
       
      Specs: Core i7-6500u, 8GB RAM, GTX 950M (DISABLED)
×