Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
kami11o

ThinkPad W520 High Sierra and Nvidia graphic card

6 posts in this topic

Recommended Posts

Hi, 

 

I've got W520 with running High Sierra on it with configuration based on the great guide by @tluck (http://www.insanelymac.com/forum/topic/285678-lenovo-thinkpad-t420-with-uefi-only). I works great with integrated video card, the only thing that I'm unable to get working is Nvidia card (Nvidia Quadro 1000m). 

 

By far I tired the following configuration:

 

  • SMBIOS set to MBP 10.1 / 9.1 / 8.1
  • Nvidia Web Driver 378.10.10.10.20.107
  • Nvidia enabled in the Clover
  • Video card set to discrete in BIOS 

 

As a result, after boot, I've got flickering screen with disappearing windows and some artifacts, unfortunately not usable at all.

 

Does anyone has managed to get this discrete card working on this notebook?

Thanks

Share this post


Link to post
Share on other sites

I have a W520 too. Been using it with El Capitan, didn't tried High Sierra yet. Discrete GPU should be enabled via DSDT. Do you patched your DSDT, or using someone else's patched one?

Share this post


Link to post
Share on other sites

@kami11o i have also tried to installl high sierra on my thinkad w520 but failed....flickering screen with quadro 1000m....so i now get back to sierra 12.6 version with nvidia card...all works fine.

Share this post


Link to post
Share on other sites

Same laptop, same thing.  I have everything else working perfectly on latest high sierra (10.13.1, just updated to patch the root exploit the other day).  I had the Quadro 1000m GPU working with DSDT injection (not clover) before.  Web drivers have never worked on this laptop, I just get a black wallpaper with lots of artifacting, no acceleration.

 

I tried rolling back the nVidia drivers to the 10.12.6 drivers.  No more artifacting and I was able to open the DVD player app and move pieces in chess, which I believe means that Core Image is working but Quartz Extreme is not.  So, I think I'm on to something here.  Not sure what else I'd need to swap out for 10.12.6 components, but I assume it's going to be the graphics related frameworks (OpenGL, etc).

 

I'm going to look at the Sierra Patcher tool I used to install Sierra on some unsupported Macs I own and see what components it swaps out and see if I can't get any closer.  Having a Core i7 laptop w/ 32 GB of DDR3 running on Intel graphics is kind of lame.

Share this post


Link to post
Share on other sites

I tried rolling back /S/L/Frameworks/CoreDisplay.framework to the version from 10.12.6 and it just crashes on boot.  without the rollback, I get a black screen after replacing all of the geforce* and NV* kexts in 10.13.1 with 10.12.6 versions... In the process of un borking my laptop from recovery at the moment... back to the drawing board.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×