Jump to content
InsanelyMac Forum
Sign in to follow this  
brendanc

Dell XPS 15 9560 10.12.6 - Sleep issues + Apple Watch Unlock issue.

Recommended Posts

Hi all,

 

I recently successfully completed a dual boot with macOS Sierra 10.12.6 and Windows 10. I have a Dell XPS 15 9560 with 4k, i7, 32gb, and SK Hynix 1TB SSD.

 

I've got pretty much everything working, however there are a couple issues I'd like help resolving if possible:

 

#1 - I have a Dell U3818DW (38" ultrawide with built-in usb hub/"kvm"). The monitor works great over the usb-c cable! Full 3840x1600 resolution with no issues, and the usb hub/kvm works as well. I can use my keyboard and mouse no problem.

 

The issue then is when the laptop goes to sleep... when I wake it up, the monitor works fine but the keyboard and mouse (really, the monitor's usb ports) are dead and replugging it does not fix it. The monitor will come back, the USB hub shows up under the "card" icon, but the inputs are not recognized. Built-in keyboard and mouse are unaffected. Any thoughts on this?

 

I disabled Wake for Wifi Network Access as I've heard that causes issues, but it has no effect on this issue.

 

#2 - I've got an Apple Watch that I use to unlock a real (late 2012 with updated wifi card) macbook pro and an i7-4790k/ASUS Maximus VII Hero-based hackintosh with an apple bcm94306 mini-pci card (with the full-size pci-e adapter + 4 antennas). I can unlock these after coming back to them with no issues.

The XPS, on the other hand, stalls and stalls for about 10 seconds and then finally just shows the password box. I read somewhere that disabling Wake for Wifi Network Access can help with this, but it was already disabled when I enabled the Apple Watch unlock feature.

 

I've tried going to the login window via the user switcher and it won't attempt apple watch unlock, so I don't know how to test if it's a sleep (bluetooth+wifi?) issue or not.

 

#3 - Not really an issue per-se but does the trackpad support on these laptops just suck? None of my multitouch stuff works. Scrolling with 2 fingers works, 2-finger right clicking works OK, but nothing with 3 fingers works except exposé and that only works 1 of 5 tries. Cursor jumps around wildly if I accidentally rest my finger on it while another one is moving, too. I tried the extra kext in the @KNNSpeed thread but it seemed to make things worse.

Share this post


Link to post
Share on other sites
Advertisement

@Brendananc having problems with my USB C port that I am using with a USB/Gigabit ethernet hub not being recognized as plugged in after sleep. When I plug an iPhone cable to the hub via a charging cable, the laptop recognizes that Ethernet as plugged in. Not sure if this is a hub issue or not. Have you made any progress with your issue?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By MaLd0n
      Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder CLOVER Post Install.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan and Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder CLOVER Install.zip   --Install EL Capitan / Sierra / High Sierra and boot into system! for Sierra/High Sierra you need a Processor with SSE4.1 instruction   Post Installation --Install Clover and replace with my folder CLOVER Post Install.zip   --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time! -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) and tell me what your hardware! -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generate in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609    My DSDT GA P35-DS3 DSDT.MaLd0n LGA775.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By pepitillo
      Hi there, I noticed that my system cannot sleep properly, so I run pmset.
      Here are the results. The strange thing is that I got "sleep   0 (sleep prevented by mds)". What does it mean? Do you think that all other parameters are good to go?
      Recently I managed to fix reboot on shutdown. Maybe its linked with that.
       
      iMac:~ diego$ pmset -g
      System-wide power settings:
      Currently in use:
      standby              1
      Sleep On Power Button 1
      womp                 0
      autorestart          0
      hibernatefile        /var/vm/sleepimage
      powernap             0
      networkoversleep     0
      disksleep            10
      sleep                0 (sleep prevented by mds)
      autopoweroffdelay    28800
      hibernatemode        0
      autopoweroff         1
      ttyskeepawake        1
      displaysleep         0
      tcpkeepalive         1
      standbydelay         10800
       
      Thanks!
    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.02.02.25f08 --> build 16G1314 (thanks to BreBo)  New!
      Nvidia Web Driver - 378.02.02.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fwood
      Ciao ragazzi, torno a voi dopo moltissimo tempo per chiedere un aiuto.
      Sierra 10.12.6 - motherboard z68xp-ud4 - i7 2600k - Gigabyte gtx 780 FE 3072mb - imac 14,2  - ultimo clover e clover configurator.
      La scheda 780 viene vista con una lunghezza pcilane di 1X,  il clock ed powermanagement tuttavia sembrano correti e funzionare ( anche se il powermanagement è abbastanza lento).
      Il kext Apple GraphicsPowermanagement non viene caricato, Cercando AGPM nella consolle non trova nulla, a volte unknown platform.
      Ho provato sia con che senza cuda, sia con che senza webdriver ( con relativi flag nel config.plist).
      Ho provato ad iniettare l'id 10de_1004  al posto di quello 10de_119e ( gtx 780m) nel kext AGPm alla sezione della board relativa ad imac 14,2 , sia mettendo un doppione del kext nella EFi, sia sostituendolo direttamente in s/l/e.
      Ho provato anche a mettere il fix GFX0 to IGPU con il clover configurator.
      Ho provato a mettere il fake id delal 780m direttamente con clover configurator.
      NULLA tutto invariato.
      Ora mi chiedo.. pensate che sia una questione estetica, oppure ho la scheda semi-difettosa ( comprata da un privato 5gg fa) ?
      Grazie a chi mi aiuta.
      Come detot In generale la scheda sembra andare bene , come detto sopra, solo vedo 1x, agpm non caricato ( ma il clock è dinamico) e scalda abbastanza anche solo nella navigazione con firefox ( che ha accellerazione hardware  attiva) arrivando a volte durante la navidazione anche a 52 gradi..
      Il metal viene riconosciuto dal profiler.
      Help.
       
       
×