Jump to content
ErmaC

Clover problems report & features request

652 posts in this topic

Recommended Posts

On 5/29/2018 at 7:29 AM, Slice said:

Sorry about 32 bits, Xcode 9.3.1 don't like it.

-arch i386 builds fine with Xcode 9.4, but after removed 10.11 sdk which I don't have.

Share this post


Link to post
Share on other sites
Advertisement

A kext produced with SDK10.13 will not work in 10.12 and early. VoodooHDA for example.

I am not sure about applications but I prefer to have SDK10.11 which is noticably better.

 

About clover-genconfig. It uses SETTINGS_DATA structure which can deviate between revisions. So clover-genconfig will work only with the same clover revision.

Moreover clover-genconfig must be 64 bit if clover-64 used for the same reason.

It is possible to run OSX 10.7.5-32 using Clover-64 and in this case clover-genconfig-64 should be used even in system-32.

And yes, 32-bit only computer requires Clover-32 and macOS 10.6, not more, and all 32-bit application. Looks like museum exhibit.

Share this post


Link to post
Share on other sites
22 minutes ago, Slice said:

And yes, 32-bit only computer requires Clover-32 and macOS 10.6, not more, and all 32-bit application. Looks like museum exhibit.

It was requested

https://www.insanelymac.com/forum/topic/329777-clover-problems-report-features-request/?do=findComment&comment=2615056

 

https://www.insanelymac.com/forum/topic/329777-clover-problems-report-features-request/?do=findComment&comment=2615112

 

I thought you meant it doesn't compile.

 

PS: Why are links to specifc posts on new forum broken?

Edited by Zenith432

Share this post


Link to post
Share on other sites

Okay, something in AptioMemoryFix is broken (I'm on 4458).

 

When I try to boot, the booting process gets stuck at:

 

Start RandomSeed

End RandomSeed

Error allocating 0x11d60 pages at 000000001531a000 alloc type 2

Couldn't allocate runtime area

.......(and at this point, its dead)....

 

I have an X99 with a 6950x processor, and to get my system to boot I had to go back OSX free 2000 and EMU.  I also tried the AptioMemoryFix from Clover 4509, and it did the same.  Does anyone have any idea what this error means or why with the newer versions of AptioMemoryFix it's showing up?

 

Anyone have the latest AptioMemoryFix and AptioInput (compiled versions)?

Edited by meaganmargaret

Share this post


Link to post
Share on other sites
4 hours ago, meaganmargaret said:

Okay, something in AptioMemoryFix is broken (I'm on 4458).

 

When I try to boot, the booting process gets stuck at:

 

Start RandomSeed

End RandomSeed

Error allocating 0x11d60 pages at 000000001531a000 alloc type 2

Couldn't allocate runtime area

.......(and at this point, its dead)....

 

I have an X99 with a 6950x processor, and to get my system to boot I had to go back OSX free 2000 and EMU.  I also tried the AptioMemoryFix from Clover 4509, and it did the same.  Does anyone have any idea what this error means or why with the newer versions of AptioMemoryFix it's showing up?

 

Anyone have the latest AptioMemoryFix and AptioInput (compiled versions)?

 

lastest AptioMemoryFix and AptioInput attached.

AptioInputFix.efi

AptioMemoryFix.efi

Share this post


Link to post
Share on other sites

please move away from sf to github, for a more reliable service, easier for everyone to  contribute code and build wiki, as well as PR reviews. 

Edited by Hackmac101

Share this post


Link to post
Share on other sites
On 6/12/2018 at 5:57 AM, Hackmac101 said:

please move away from sf to github, for a more reliable service, easier for everyone to  contribute code and build wiki, as well as PR reviews. 

 

What? Anyone can contribute now.... What are you talking about? There is a wiki, that is outdated because the login is broken. There is also a wiki at sourceforge and I have asked several times for users to help migrate and update. Not ONE single person has contacted me to even try. So don't act like we are a support team and you paid for this software. This is educational software and we do this in our spare time for fun. And github has been going downhill and as someone wisely said:

 

17 hours ago, bronxteck said:

LOL are you sure about that Microsoft just bought git[hub]....

 

Share this post


Link to post
Share on other sites

i noticed while building clover on 10.14 with xcode 9.4 that i got a popup about lzma compression being out dated and that it was only going to allow it to run this time because it was to old and that i needed to update it for future use. so my question is... should it get updated.

 clover is still using the first public release. https://sourceforge.net/p/cloverefiboot/code/4543/tree//Library/LzmaCustomDecompressLib/LzmaCustomDecompressLib.inf#l6

yet latest is version 18 https://www.7-zip.org/sdk.html.

my question is should that not  be updated especially if OSX will not allow the one in the clover code to run any more? im guessing with another mojave future update

Share this post


Link to post
Share on other sites
4 hours ago, bronxteck said:

i noticed while building clover on 10.14 with xcode 9.4 that i got a popup about lzma compression being out dated and that it was only going to allow it to run this time because it was to old and that i needed to update it for future use. so my question is... should it get updated.

 clover is still using the first public release. https://sourceforge.net/p/cloverefiboot/code/4543/tree//Library/LzmaCustomDecompressLib/LzmaCustomDecompressLib.inf#l6

yet latest is version 18 https://www.7-zip.org/sdk.html.

my question is should that not  be updated especially if OSX will not allow the one in the clover code to run any more? im guessing with another mojave future update

This compression used by EDK2

/MdeModulePkg/Library/LzmaCustomDecompressLib

Share this post


Link to post
Share on other sites

@slice maybe ANV old project can give you some ideas for edid since it can do multi monitor edid I can't post in the other thread 

 

Edited by bronxteck

Share this post


Link to post
Share on other sites
55 minutes ago, bronxteck said:

@slice maybe ANV old project can give you some ideas for edid since it can do multi monitor edid I can't post in the other thread 

 

It is system application using system drivers. I asked about Clover.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Reel
      All work except camera
      You need SwitchResX that the screen does not freeze
         


    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By Slice
      Since rev 4844 Vector Themes are supported and there are ready-to-use Clovy by Clovy, cesium by Slice and BGM_SVG by Blackosx.
      You may see it's structure to create own theme
      -------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
      Pictures from Badruzeus
      https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=301597
×