Jump to content
ErmaC

Clover problems report & features request

661 posts in this topic

Recommended Posts

Already done.

What Clover version you mean?

@grayen

 

I had an experience to boot macOS and Windows 7 Pro 64bit UEFI on GPT formatted disk on legacy-BIOS computer with Core2Duo CPU by Clover. It is possible as you said. I don't know if Windows 10 required something more.

I mean make Clover boot like BIOS, if Clover can't find macOS installer to update. It'll boot into macOS partition, it'll make update easier. Also, I'm using the latest.

Share this post


Link to post
Share on other sites
Advertisement

Clover can find macOS installer to update. Thousands users do update this way.

Show your preboot.log where can we look on all partitions and loaders.

STATIC CHAR16 *OSXInstallerPaths[] = {
  L"\\Mac OS X Install Data\\boot.efi",
  L"\\macOS Install Data\\boot.efi",
  L"\\macOS Install Data\\Locked Files\\Boot Files\\boot.efi",
  L"\\OS X Install Data\\boot.efi",
  L"\\.IABootFiles\\boot.efi"
};
 

Share this post


Link to post
Share on other sites

 

Clover can find macOS installer to update. Thousands users do update this way.

Show your preboot.log where can we look on all partitions and loaders.

STATIC CHAR16 *OSXInstallerPaths[] = {
  L"\\Mac OS X Install Data\\boot.efi",
  L"\\macOS Install Data\\boot.efi",
  L"\\macOS Install Data\\Locked Files\\Boot Files\\boot.efi",
  L"\\OS X Install Data\\boot.efi",
  L"\\.IABootFiles\\boot.efi"
};
 

No, I mean we have an option to set default boot volume right? But it only boots into 1 volume, sometimes I need to update macOS. App Store will create another volume of macOS Install or something, anyway I can make Clover boot into macOS install first like BIOS. If Clover can't find macOS install then it'll boot into second default boot volume like macOS system

Share this post


Link to post
Share on other sites

slice I think what he wants is that after an apple update clover use boot next to automatically finish the os update install instead of having to manually select the updater volume from clover gui

Share this post


Link to post
Share on other sites

slice I think what he wants is that after an apple update clover use boot next to automatically finish the os update install instead of having to manually select the updater volume from clover gui

 

 

You are right, that way I can set App Store to update macOS automatically

Share this post


Link to post
Share on other sites

I started macOS as usual then I see update in AppStore and click OK. 

macOS loads update, begins it and then restarted into "macOS install". 

It is already happens.

I can't set "BootNext" variable because Clover is not working during this process.

Share this post


Link to post
Share on other sites

I started macOS as usual then I see update in AppStore and click OK. 

macOS loads update, begins it and then restarted into "macOS install". 

It is already happens.

I can't set "BootNext" variable because Clover is not working during this process.

 

I mean, we have Default Boot Volume to help Clover to boot into "that partition" when you Clover starting. I set it to my macOS volume, it works perfectly but when I try to update to some macOS version. App Store will create a volume name "macOS install" right, so what I asking for is can you make more option like Default Boot Volume 2, 3,... If Clover can't find the first Default Boot Volume 1, it'll boot into Default Boot Volume 2. It'll make we update macOS easier

Share this post


Link to post
Share on other sites

OK, I understand.

I have DefaultBootVolume=LastBootedVolume. As far as I remember it automatically switched to update.

But it didn't switch back to my macOS partition. If I have more option, Clover will switch to update when I reboot from App Store. Or if Clover can't find that update partition, it'll switch back to my macOS partition. That's simple

Share this post


Link to post
Share on other sites

My case, Single SSD

High Sierra Vol name = Macintosh HD

DefaultBootVolume = Macintosh HD in config

Timeout 3 in config

 

Update from appstore, clover automatically enter high sierra installer(macOS install Macintosh HD). After install update, there is no installer in GUI, and enter Macintosh HD.

 

 

 

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

My case, Single SSD

High Sierra Vol name = Macintosh HD

DefaultBootVolume = Macintosh HD in config

Timeout 3 in config

 

Update from appstore, clover automatically enter high sierra installer(macOS install Macintosh HD). After install update, there is no installer in GUI, and enter Macintosh HD.

 

 

 

 

나의 LG-F800S 의 Tapatalk에서 보냄

Mine too

1 SSD, macOS High Sierra vol name = macOS (same with DefaultBootVolume)

Timeout = 5

Clover still boot into macOS even Clover found macOS install when I try to update

Share this post


Link to post
Share on other sites

Mine too

1 SSD, macOS High Sierra vol name = macOS (same with DefaultBootVolume)

Timeout = 5

Clover still boot into macOS even Clover found macOS install when I try to update

Strange. In my case. There is no problem that i mentioned above.

 

On my laptop, i can't use lastvolumename option. So i selected mac partition name for defaultvolumename.

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

i have same issue on haswell laptop 1ssd with win10/10.13.x clover timeout does not work config set to 5sec but at boot clover sits there forever until i manually chose os. works fine on my other machines though. it has always happened on this machine so it does not bother me any longer LOL.

Share this post


Link to post
Share on other sites

On some more recent HP UEFI implementations (including the Spectre x360 and Envy x360's) Clover is unable to boot OS X without a workaround. HP's UEFI loads some sort of touch keyboard (likely indicative of a debug mode), and when OS X is loaded boot.efi will hang and never proceed. No kernel panic occurs, boot.efi simply does not start loading. This problem can be resolved by chainloading clover from a text only bootloader (grub works, secure boot workarounds like Preloader.efi work best), or by modifying the source code of clover. The issue is something left over from rEFIt, as rEFInd also loads the touch keyboard. It appears that the function

BOOLEAN ReadAllKeyStrokes(VOID)

is broken. When the function body is commented and the function is modified to only return false, like so:

BOOLEAN ReadAllKeyStrokes(VOID)
{
    //problem code
    /*
    BOOLEAN       GotKeyStrokes;
    EFI_STATUS    Status;
    EFI_INPUT_KEY key;
    
    GotKeyStrokes = FALSE;
    for (; {
        Status = gST->ConIn->ReadKeyStroke (gST->ConIn, &key);
        if (Status == EFI_SUCCESS) {
            GotKeyStrokes = TRUE;
            continue;
        }
        break;
    }
    return GotKeyStrokes;*/
    return FALSE;
}

Clover does not encounter the touch keyboard issue and loads OSX successfully with no workarounds. I believe that something in this method triggers HP's UEFI to enter a type of debug mode and load the touch keyboard. Any ideas on how this method could be fixed to prevent this error?

Share this post


Link to post
Share on other sites

A typo from time ago

in clover bootmenu / options / PCI Devices

 

custom properies should be custom properties?

probably you mean this...

 

menu.c

NewEntry(&Entry, &SubScreen, ActionEnter, SCREEN_DEVICES, "Custom properies->");
and yes is a typo... should be "Custom properties->"

 

ErmaC

Share this post


Link to post
Share on other sites

Dear devs,

 

I just realized that I need to use "-DANDX86" everytime on buildclover script to make PhoenixOS && RemixOS (Android-x86) detected by Clover bootloader.

 

If possible.. May I propose these flags to be true, so Clover detects Android-x86 based OSes by default? Thanks.

 

 

#!ifdef ANDX86
  DEFINE ANDX86_FLAG = -DANDX86
#!endif 

 

 

Share this post


Link to post
Share on other sites

Dear devs,

 

I just realized that I need to use "-DANDX86" everytime on buildclover script to make PhoenixOS && RemixOS (Android-x86) detected by Clover bootloader.

 

If possible.. May I propose these flags to be true, so Clover detects Android-x86 based OSes by default? Thanks.

 

 

#!ifdef ANDX86
  DEFINE ANDX86_FLAG = -DANDX86
#!endif 

 

 

I think it is possible because I see no reason why not. 

It was added conditionally because no one need it.

Share this post


Link to post
Share on other sites
I hope this is the right place, a recommendation
 

Is possible change the position of letters?

They are hidden underneath and there is to scroll
 
Centered is much better visually. Thank.-

post-471348-0-36534600-1515777341_thumb.png

post-471348-0-46007700-1515777373_thumb.png

post-471348-0-33471800-1515777384_thumb.png

Share this post


Link to post
Share on other sites

I hope this is the right place, a recommendation

 

Is possible change the position of letters?

They are hidden underneath and there is to scroll

 

Centered is much better visually. Thank.-

Yes is a simple html with inline css, and the last one as you show is... conclusion.html

located here https://sourceforge.net/p/cloverefiboot/code/HEAD/tree/CloverPackage/package/Resources/templates/

 

and if I understand you correctly (align the copyright text on the right) will be:

from:

https://sourceforge.net/p/cloverefiboot/code/HEAD/tree/CloverPackage/package/Resources/templates/Conclusion.html#l14

to (changed line 14)

p.copyright{margin: 0px; font:13px 'Lucida Grande'; text-align: right}
ErmaC

Share this post


Link to post
Share on other sites

feature needed  : pass-by HP840g3 bios locked and being able to boot with clover ;)

just kidding, but if you dev this i'll take it :)

Thanks U to all clover dev

best

Share this post


Link to post
Share on other sites

feature needed  : pass-by HP840g3 bios locked and being able to boot with clover ;)

just kidding, but if you dev this i'll take it :)

Thanks U to all clover dev

best

I have no HP840g3 and so I have no idea what about you tell.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Reel
      All work 10.10, 10.11, 10,12
      camera not work in 10.13, 10.14
      You need SwitchResX that the screen does not freeze
      Custom resolutions: Back porch - lines change to 2
      UEFI boot moded bios https://github.com/Thiblizz/l502x-modded-bios
       
      For 10.14 you need: HD3000 Fix for Mojave.zip
      Installed in S/L/E 
       
      SMBIOS: MacbookPro 8.3 or MacbookPro 9.1
       
       

       

       
       
    • By glasgood
      CLOVER DUAL BOOT MOJAVE & WINDOWS 10 GUIDE 
       

       
       
      INCLUDES  MBR / LEGACY BIOS  TO  GPT / EFI CONVERSION
      USING MBR2GPT TOOL
       
       
      PREREQUISITE: Two physical discs ( SSD’s or HDD’s )
       
       
       
       
       
      STEP 1 - Clover dual boot configuration 
       
      Open config.plist with Clover Configurator
       
      Boot
       Legacy = PBR Timeout = True ( will remove the Timeout countdown, from Clover boot menu)  

       
      GUI 
      Scan / Custom
       Entries = True  Tool = True  Legacy = False ( removes extra Windows 10 entries )  
      Hide Volume
      - Preboot ( macOS Preboot )
      - Recovery ( macOS Recovery )
       

       
      So at boot you will have two options: boot macOS Mojave or Windows 10 
       
       
       
       
       
       
       
      ————————————————————
       
       
      STEP 2 - Using a drive without Windows 10 installed
       
      Disconnect system drive that contains your macOS Mojave install from computer ( This is so that Windows does not overwrite existing macOS Mojave boot loader )
       
      Proceed with a Windows 10 UEFI install.  
      After installation reconnect macOS Mojave Drive, the Windows installation should now be detected and usable in Clover. 
      If Windows 10 is not detected or able to boot,  then verify you installed Windows 10 as UEFI and not MBR ---->  ( Read step 2 - For a drive with Windows 10 installed )
       
       
      OR
       
       
       
      STEP 2 - Using a drive with Windows 10 already installed
       
      Verify your Windows install is  GPT / UEFI or MBR / Legacy BIOS.   
      If Windows install is GPT UEFI then Windows 10 install is ready to use at Clover boot menu, you should be able to boot into Windows directly from Clover boot screen. 
       

       
       
      But if  Windows drive is detected at Clover boot screen, but when booting Windows you get a black screen with a cursor on the top left,
      then this is most likely because Windows drive is MBR ( Legacy BIOS ).  You can easily convert MBR to GPT using  Windows MBR2GPT tool ( this saves hours work having to reinstall Windows 10 and setting up all your applications again  ) 
       
      If Windows 10 install is MBR / Legacy BIOS  then simply convert to GPT / UEFI  following instructions below ( read video summary and view video )
       
       
      ** To use Windows 10  MBR2GPT tool  you must have Windows 10 version 1703 ( creators update  ) or later and less than 3 partitions on 
      the Windows 10 drive **
       
      Video summary:
       
      Confirm Windows 10 drive is MBR Legacy BIOS ( in Windows Disk Management ) Reboot into Windows PE ( Advanced Startup ) Convert from MBR Legacy BIOS to GPT UEFI ( using commands below ) mbr2gpt /validate mbr2gpt /convert Restart Verify Windows 10 drive has changed to GPT UEFI ( in Windows Disk Management )  
       
       
       
      After conversion Windows 10 is ready to use at the Clover boot menu 
       
       
    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
×