Jump to content
ErmaC

Clover problems report & features request

555 posts in this topic

Recommended Posts

6 hours ago, gujiangjiang said:

Today when i updated Clover to r4674 and it cant boot and show this.


Start
Start OSName

So does it needed to clean some drivers if it redundant or comfilict.

 

Thanks. 

 

3 hours ago, kylon said:

My keyboard is not working in clover 4674!
I can t boot any os.

Default drivers + emuVariable (efi drivers, no bios drivers)

Was working on 4658, i have an ami bios, laptop.

 

Try deleting problematic FV2 drivers (AppleKeyFeeder-64.efi, AppleKeyAggregator-64.efi) as mentioned in this post.  Unfortunately, these new drivers are selected by default by the standard Clover package installer...

Share this post


Link to post
Share on other sites
Advertisement

— Doctor, doctor, it hurts when I do like this, please help me.

— Alright, do not do it like this, and it will not hurt :)

 

Really, if you have some hidden love in FV2 drivers, it could be understood, but the only thing you do is taking devs' time trying to understand wtf your issue is. Do not use the drivers until you really need FV2. End of the story.

Share this post


Link to post
Share on other sites

@fusion71au

 

Thanks i ll try, but 4658 is working with these drivers.

[mention=1135927]vit9696[/mention]

Yeah, but clover should not add problematic drivers by default

 

The default should be needed things to boot on most pcs, you can always add more drivers if you need them...

 

Anyway we will know when i try again

 

 

Share this post


Link to post
Share on other sites
— Doctor, doctor, it hurts when I do like this, please help me.
— Alright, do not do it like this, and it will not hurt
 
Really, if you have some hidden love in FV2 drivers, it could be understood, but the only thing you do is taking devs' time trying to understand wtf your issue is. Do not use the drivers until you really need FV2. End of the story.


The Fv2 drivers are selected as default, even if they are not installed they are still checked to install on the next clover update. This is where the issue is. Maybe clover can be made to detect FV2 and check them or if no FV2 then uncheck them.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

in my case, for long time, there is no issue related in FV2 driver. but

since AppleKeyFeeder.efi was added as default in clover package, GUI lag started.

i have to remove this driver as manual

Edited by Sherlocks

Share this post


Link to post
Share on other sites

Can clover installer have a sub menu or a checkbox for FV driver options so at least we know the drivers in that selection are for filevault? the problem is that the clover project does not have proper documentation. so if the dev's do not explain there project or driver properly how are we as end users going to  know what they do. only recently did we get some info of the drivers with the last rewrite of the installer.

13 hours ago, vit9696 said:

— Doctor, doctor, it hurts when I do like this, please help me.

— Alright, do not do it like this, and it will not hurt :)

 

Really, if you have some hidden love in FV2 drivers, it could be understood, but the only thing you do is taking devs' time trying to understand wtf your issue is. Do not use the drivers until you really need FV2. End of the story.

i understand your frustration but you as a dev might know what is what. clover is also used by non devs. but how can we help useres in the community when sometimes the dev's do not even know whats going on. like the issue sherlocks is having and he is a contributing dev.

 this is not a bash on you in any way or on anyone. it is just the gorilla in the room that no one likes to bring up. (problem no one wants to address)

 

i am the guy that has to help the end user use your projects just in case you where wondering.

Edited by bronxteck

Share this post


Link to post
Share on other sites

This is open source software

Quote

 * This software is provided 'as-is', without any express or implied
 * warranty.  In no event will the authors be held liable for any damages
 * arising from the use of this software.
 *

 

Share this post


Link to post
Share on other sites
On 9/20/2018 at 12:26 AM, kylon said:

My keyboard is not working in clover 4674!
I can t boot any os.

Default drivers + emuVariable (efi drivers, no bios drivers)

Was working on 4658, i have an ami bios, laptop.

 

Replace

/EFI/boot

with the one from r4658 (source).

Share this post


Link to post
Share on other sites

So, 4674 is broken

I removed every fv2 driver and the keyboard is still not working
@k0nrad
Not working

I need to install clover 4658 on top to make my keyboard working again

Share this post


Link to post
Share on other sites
5 minutes ago, kylon said:

So, 4674 is broken

I removed every fv2 driver and the keyboard is still not working
@k0nrad
Not working

I need to install clover 4658 on top to make my keyboard working again

 

Hi

Can you give a list of the drivers you are using with Clover and the deleted FV2 drivers.

Share this post


Link to post
Share on other sites

You can build clover Package without mandatory FileVault Drivers

Take look here ➜  Build-FileVault-Clover

that's work for UDK2018 and UDK2

I hope some Dev integrate my change in the Clover repos

 

 

1730396448_Capturedcranle2018-09-2112_32_58.png.f85a76152bd632cb70dd1b03b77b2f8e.png

Edited by chris1111

Share this post


Link to post
Share on other sites
38 minutes ago, chris1111 said:

You can build clover Package without mandatory FileVault Drivers

Take look here ➜  Build-FileVault-Clover

that's work for UDK2018 and UDK2

I hope some Dev integrate my change in the Clover repos

 

 

1730396448_Capturedcranle2018-09-2112_32_58.png.f85a76152bd632cb70dd1b03b77b2f8e.png

 

Great Job :) These file modifications are very interesting. For beginners, I think it would be easier if FV2 files are not checked by default, in my opinion.

Share this post


Link to post
Share on other sites
51 minutes ago, chris1111 said:

You can build clover Package without mandatory FileVault Drivers

Take look here ➜  Build-FileVault-Clover

that's work for UDK2018 and UDK2

I hope some Dev integrate my change in the Clover repos

 

 

1730396448_Capturedcranle2018-09-2112_32_58.png.f85a76152bd632cb70dd1b03b77b2f8e.png

Thank you for being part of the solution chris. this is what most users where asking for. a clear separation of what what is what. at least now the end user knows that those drivers are different to the general ones. as for EULA we know it is open source slice. its just small contributions like this that make the project better. that is what open source is.

Share this post


Link to post
Share on other sites
 

Hi

Can you give a list of the drivers you are using with Clover and the deleted FV2 drivers.

My drivers now

 

DataHubdxe

Emuvariable

FsInject

Smchelper

VboxHfs

 

Clover 4658 (it works with fv2 drivers)

 

I don t remember, i disabled every driver that said "for filevault 2" in the installer

 

I don t think the issue is fv2 here

Share this post


Link to post
Share on other sites
11 hours ago, kylon said:

My drivers now

 

DataHubdxe

Emuvariable

FsInject

Smchelper

VboxHfs

 

Clover 4658 (it works with fv2 drivers)

 

I don t remember, i disabled every driver that said "for filevault 2" in the installer

 

I don t think the issue is fv2 here

 

You don't use any Aptiodriver such like OSXAptio or AptioMemoryFix...? On my system Asus mobo, I have aptionmemoryFix for UEFI. Clover commit r4673 works fine

Share this post


Link to post
Share on other sites
18 hours ago, bronxteck said:

Thank you for being part of the solution chris. this is what most users where asking for. a clear separation of what what is what. at least now the end user knows that those drivers are different to the general ones. as for EULA we know it is open source slice. its just small contributions like this that make the project better. that is what open source is.

Thank you 

I did this exactly to help the community 

18 hours ago, Matgen84 said:

 

Great Job :) These file modifications are very interesting. For beginners, I think it would be easier if FV2 files are not checked by default, in my opinion.

Thanks 

Share this post


Link to post
Share on other sites
2 hours ago, chris1111 said:

Thanks 

 

I try your modified files: works fine of course. Why two directory for FileVault drivers? It's the same for x64 and x64UEFI. Also I make only one folder  for my personal use.

Share this post


Link to post
Share on other sites
2 hours ago, Matgen84 said:

 

I try your modified files: works fine of course. Why two directory for FileVault drivers? It's the same for x64 and x64UEFI. Also I make only one folder  for my personal use.

I you select UEFI Only drivers FileVault2 for Legacy(x64) not appears on choice

Of course If you are deselect UEFI Only the Drivers x64 filevault2 is selectable

Edited by chris1111

Share this post


Link to post
Share on other sites
18 minutes ago, chris1111 said:

I you select UEFI Only drivers FileVault2 for Legacy(x64) not appears on choice

Of course If you are deselect UEFI Only the Drivers x64 filevault2 is selectable

Alright I understand :)

Share this post


Link to post
Share on other sites

4674 bricks my X58 system.I just get a cursor, tried verbose still nothing that I can see besides a cursor.I should note that I always delete the EFI/Boot folder and leave the EFI/Clover as outlined HERE.Back to 4658 and all is well.Bless

Share this post


Link to post
Share on other sites

Would it be possible to hide a Volume (Trying to hide the Preboot Entires) in the Config.plist and not have F3 show it in the Clover GUI, I thought there was a way but it doesn't seem to work for me?

Share this post


Link to post
Share on other sites

@Slice I believe boot.efi cause I replaced 4678 EFI/boot with the one from 4658 EFI/boot and it worked as normal.i did not mess with CloverX64.efi.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By Slice
      Since rev 4844 Vector Themes are supported and there are ready-to-use Clovy by Clovy, cesium by Slice and BGM_SVG by Blackosx.
      You may see it's structure to create own theme
      -------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
      Pictures from Badruzeus
      https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=301597
    • By PixelLover
      I'm in the middle of my first hackintosh (High Sierra) on my ZenBook Pro UX501VW-US71 laptop using the Vanilla Install. I've tried using different config.plst files and I've gotten the furthest with RehabMan's own (linked here). It hangs at error message IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0.   Can anyone help me figure out what changes to make to the config.plst file for my specific laptop (which is where I assume the problem lies)   System Specs: Intel Skylake Core i7­-6700HQ 2.6 GHz Quad­core
      Intel® HD Graphics 530 Nvidia GTX 960M 2G 15.6" Touch IPS 4K Ultra­-HD display, 3840 x 2160 resolution   Kexts: AppleALC.kext FakeSMC.kext Lilu.kext USBInjectAll.kext WhateverGreen.kext  
×