Jump to content
ErmaC

Clover problems report & features request

947 posts in this topic

Recommended Posts

37 minutes ago, Slice said:

Clover uses order of patches exactly as they written in config.plist.

But some program you used may change the order in their way. Don't use Clover configurator I take no responsibility how it can change config.plist.

 

I have tried Clover Configurator and Plist Editor but both of them are still sort by A-Z.

 

I have an ideal about this feature.

Here are the Rename function now:

<dict>
	<key>ACPI</key>
	<dict>
		<key>RenameDevices</key>
		<dict>
			<key>GFX0</key>
			<string>IGPU</string>
		</dict>
	</dict>
</dict>

I hope to change it to this way and it can avoid the default order of the Rename Devices Patch.

<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>RenameDevices</key>
			<array>
				<dict>
					<key>Comment</key>
					<string>Rename GFX0 to IGPU</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<string>GFX0</string>
					<key>Rename</key>
					<string>IGPU</string>
				</dict>
			</array>
		</dict>
	</dict>
</dict>

And i also find some rename operation not only exist in Devices but also exist in Methods and Notify so if it possible to make Devices and Methods and Notify rename so we can easily rename Devices Methods and Notify and don't need to find HEX value.

<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Rename</key>
			<array>
				<dict>
					<key>Comment</key>
					<string>Rename GFX0 to IGPU</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<string>GFX0</string>
					<key>Rename</key>
					<string>IGPU</string>
					<key>Type</key>
					<string>Device</string>
				</dict>
				<dict>
					<key>Comment</key>
					<string>Rename BRT6 to BRTX</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<string>BRT6</string>
					<key>Rename</key>
					<string>BRTX</string>
					<key>Type</key>
					<string>Method</string>
				</dict>
				<dict>
					<key>Comment</key>
					<string>Rename BAT0 to BATC</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<string>BAT0</string>
					<key>Rename</key>
					<string>BATC</string>
					<key>Type</key>
					<string>Notify</string>
				</dict>
			</array>
		</dict>
	</dict>
</dict>

Thanks.

Edited by gujiangjiang

Share this post


Link to post
Share on other sites
Advertisement
On 9/10/2018 at 8:13 AM, fusion71au said:

 

Unfortunately, boot still hangs with problematic FV drivers, even if I use CLOVERX64.efi/BOOTX64.efi from the above post (UEFI booting into my non FV macOS volumes (10.13.6 hfs and 10.14beta10 apfs) on my NUC6i5SYH).

 

2 problematic r4667 drivers:  

AppleKeyFeeder-64.efi ---> freeze/unresponsive Clover Main Menu GUI

AppleKeyAggregator-64.efi ---> boot hang after launching macOS as shown below...

 

 

  Reveal hidden contents

IMG_2622.thumb.JPG.37c23d84c737279ee7c567701ad7f9cb.JPG

 

 

Deleting both drivers from /EFI/CLOVER/drivers64UEFI ---> I can boot again normally with CLOVERX64.efi r4667.

 

I vote for Clover package installer not selecting these problematic FV drivers by default...

 

+1 in GUI, movement is slow r4668. i have AppleKeyFeeder-64.efi and AppleKeyAggregator-64.efi. i don't have AptioFixInput and don't use FV2.

Share this post


Link to post
Share on other sites
10 minutes ago, Sherlocks said:

 

+1 in GUI, movement is slow r4668. i have AppleKeyFeeder-64.efi and AppleKeyAggregator-64.efi. i don't have AptioFixInput and don't use FV2.

Sorry I am not clear what is slow?

Share this post


Link to post
Share on other sites
Sorry I am not clear what is slow?
hi Slice. if press right button on keyboard in GUI, cursor moved line to down. this movement is slower than before. i don't have this problem before.

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
17 hours ago, Sherlocks said:

 

+1 in GUI, movement is slow r4668. i have AppleKeyFeeder-64.efi and AppleKeyAggregator-64.efi. i don't have AptioFixInput and don't use FV2.

 

17 hours ago, Sherlocks said:

hi Slice. if press right button on keyboard in GUI, cursor moved line to down. this movement is slower than before. i don't have this problem before.

나의 LG-F800S 의 Tapatalk에서 보냄
 

As you don't use FV2 then you can safely remove all AppleKey***.

 

 

Share this post


Link to post
Share on other sites

With the latest AppleSupportPkg compiled from GitHub master branch I get a black background in the EFI login screen (I am using FileVault 2). The users and password box are drawn OK, just the background image is missing. Does anyone else have this issue?

Share this post


Link to post
Share on other sites
1 hour ago, dgsga said:

With the latest AppleSupportPkg compiled from GitHub master branch I get a black background in the EFI login screen (I am using FileVault 2). The users and password box are drawn OK, just the background image is missing. Does anyone else have this issue?

Interesting finding, I'll check it 

Did u use 10.14 beta 11?

Edited by savvamitrofanov

Share this post


Link to post
Share on other sites
1 hour ago, savvamitrofanov said:

Interesting finding, I'll check it 

Did u use 10.14 beta 11?

I did indeed!

Share this post


Link to post
Share on other sites

I have the problem on the latest Mojave build (18A389) using Xcode 10 to compile. If I revert to the last Release build of AppleSupportPkg all works fine.

Edited by dgsga

Share this post


Link to post
Share on other sites

Hi,

 

Have current clover 4658. When I try to use DumpUefiCalls.efi it does not work together with ApfsDriverLoader.efi - clover boot menu is empty, no bootable partitions shown. Is it supposed to be so?

 

10x

Share this post


Link to post
Share on other sites
On 9/16/2018 at 11:10 AM, Sherlocks said:

hi savv. still develop AppleImageLoader for replacement of osxfatbinary?

나의 LG-F800S 의 Tapatalk에서 보냄
 

oh, so i must delete osxfatbinary if i use AppleImageLoader?

Share this post


Link to post
Share on other sites

Today when i updated Clover to r4674 and it cant boot and show this.

Start
Start OSName

IMG_9537.thumb.jpg.7fe275641d092d3ce59d3838f78f9a61.jpg

 

After many times test i found it related with UsbKbDxe-64.efi.

 

If i delete the UsbKbDxe-64 efi then can boot normally and when i put UsbKbDxe-64.efi into Driver64UEFI and it show above error log again.

 

So i want to know does this driver not ompitable for the new os or it has conflict when the other drivers.

 

I use all the Clover Driver64UEFI excpt these below:

OsxAptioFix2Drv-64
CsmVideoDxe-64
OsxLowMemFixDrv-64
OsxAptioFix3Drv-64
SMCHelper-64
OsxAptioFixDrv-64
EmuVariableUefi-64

And i found 3 groups similar drivers related with input.

AppleKeyAggregator-64.efi
AppleKeyFeeder-64.efi
AptioInputFix-64.efi
Ps2MouseDxe-64.efi
UsbKbDxe-64.efi
UsbMouseDxe-64.efi

And the UsbKbDxe-64.efi cause my problem.

 

So does it needed to clean some drivers if it redundant or comfilict.

 

Thanks. 

Edited by gujiangjiang

Share this post


Link to post
Share on other sites

My keyboard is not working in clover 4674!
I can t boot any os.

Default drivers + emuVariable (efi drivers, no bios drivers)

Was working on 4658, i have an ami bios, laptop.

Share this post


Link to post
Share on other sites
6 hours ago, gujiangjiang said:

Today when i updated Clover to r4674 and it cant boot and show this.


Start
Start OSName

So does it needed to clean some drivers if it redundant or comfilict.

 

Thanks. 

 

3 hours ago, kylon said:

My keyboard is not working in clover 4674!
I can t boot any os.

Default drivers + emuVariable (efi drivers, no bios drivers)

Was working on 4658, i have an ami bios, laptop.

 

Try deleting problematic FV2 drivers (AppleKeyFeeder-64.efi, AppleKeyAggregator-64.efi) as mentioned in this post.  Unfortunately, these new drivers are selected by default by the standard Clover package installer...

Share this post


Link to post
Share on other sites

— Doctor, doctor, it hurts when I do like this, please help me.

— Alright, do not do it like this, and it will not hurt :)

 

Really, if you have some hidden love in FV2 drivers, it could be understood, but the only thing you do is taking devs' time trying to understand wtf your issue is. Do not use the drivers until you really need FV2. End of the story.

Share this post


Link to post
Share on other sites

@fusion71au

 

Thanks i ll try, but 4658 is working with these drivers.

[mention=1135927]vit9696[/mention]

Yeah, but clover should not add problematic drivers by default

 

The default should be needed things to boot on most pcs, you can always add more drivers if you need them...

 

Anyway we will know when i try again

 

 

Share this post


Link to post
Share on other sites
— Doctor, doctor, it hurts when I do like this, please help me.
— Alright, do not do it like this, and it will not hurt
 
Really, if you have some hidden love in FV2 drivers, it could be understood, but the only thing you do is taking devs' time trying to understand wtf your issue is. Do not use the drivers until you really need FV2. End of the story.


The Fv2 drivers are selected as default, even if they are not installed they are still checked to install on the next clover update. This is where the issue is. Maybe clover can be made to detect FV2 and check them or if no FV2 then uncheck them.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By STLVNUB
      *Put the script into its own folder as it will create other folders*
      What is BTB?
      Script file to clone and help build Clover or Opencore repos
      Script will create link to itself in /usr/local/bin/bob
      Script SHOULD fix up any stray bobs you may have.
      Then you only need to type bob. and a parameter
      "a" for ACID repo, official
      "d" for ACID repo DUET build
      "c" for CLOVER
      "e" to erase UDK Folder
      Easier typing bob than.....usual stuff
      YOU WILL NEED TO cmod+x THE SCRIPT
      Enjoy
       
    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By ALGhackintosh
      Hi @chris1111 i have a tenda w311ma usb wireless adapter , i wanted to make it work with my catalina hackintosh so i installed the driver from the official site , the Rt2870driver.kext file and your wireless panel utility but i have a problem : The software dosent always connect to the acess points and when it does , and everything seems to be ok (even in network section of the system preferences ) when i go to safari for example it tells me that im not connected . I tried to connect the pc to my phone using hotspot , same problem in the pc it shows connected to network but in the phone the pc doesnt appear in the list of the connected devices . What to do ? Please help me !
       
×