Jump to content
About Just Joined group Read more... ×
ErmaC

Clover problems report & features request

963 posts in this topic

Recommended Posts

this is from latest clover
 
screenshot13.thumb.png.bfb963abc5525ea0f432769f8b6f4268.png
 
this is from your file
 
I notice no difference  looks ok for me
 
screenshot14.thumb.png.4d852f562d6b72c2d2dcbddb065c1591.png
you can see APFS letter on icon and HFS.
what is your sierra partition type? HFS+? your partition shown APFS icon.

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
Advertisement
5 minutes ago, Sherlocks said:

you can see APFS letter on icon and HFS.
what is your sierra partition type? HFS+? your partition shown APFS icon.

나의 LG-F800S 의 Tapatalk에서 보냄
 

Sierra is HFS+J  with another partition APFS Mojave=HD

but I am boot from High Sierra and is on APFS Volume

 

 

1711342414_Sanstitre.png.e275fe159274860a120185ab54103886.png

Edited by chris1111

Share this post


Link to post
Share on other sites
38 minutes ago, chris1111 said:

Sierra is HFS+J  with another partition APFS Mojave=HD

but I am boot from High Sierra and is on APFS Volume

 

 

1711342414_Sanstitre.png.e275fe159274860a120185ab54103886.png

 

thanks. i checked it by myself. yes. still there is problem.

need to think more cases. i will debug it. 

Share this post


Link to post
Share on other sites

With r4652 test, FlatCamp theme uses vol_internal_ext3 instead of vol_recovery for my HFS+ RecoveryHD volumes (10.11.6, 10.13.5, 10.14 b7)

Share this post


Link to post
Share on other sites
With r4652 test, FlatCamp theme uses vol_internal_ext3 instead of vol_recovery for my HFS+ RecoveryHD volumes (10.11.6, 10.13.5, 10.14 b7)
test.zip or test1.zip?

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
35 minutes ago, Sherlocks said:

test.zip or test1.zip?

 

Was test.zip, now it shown properly with "test1.zip" for "Recovery HD". Thanks.

Spoiler

W1SytjR.png

 

Edited by Badruzeus

Share this post


Link to post
Share on other sites
9 hours ago, Sherlocks said:

 

thanks. i checked it by myself. yes. still there is problem.

need to think more cases. i will debug it. 

 

8 hours ago, Badruzeus said:

 

Was test.zip, now it shown properly with "test1.zip" for "Recovery HD". Thanks.

  Reveal hidden contents

W1SytjR.png

 

 

@Badruzeus

@chris1111

@blackosx

alright. all was fixed.

screenshot4.thumb.png.de174e66cb28a24dcf44ee4d2f0cceb1.png

screenshot5.thumb.png.ee5bf005fa0a4f3cd1b217e30c1a3460.png

 

please test test2.zip

test2.zip

Share this post


Link to post
Share on other sites

I just ad new Icons in my theme Dell-HD and its work :D

Thanks lol

screenshot17.thumb.png.8b5dfdfee17cf85b2d2a022d97c12f6b.png

 

screenshot18.thumb.png.b005cd3c8cd0fa8d255566c8eae64fe4.png

screenshot19.thumb.png.3bf79c6f97a266b31dad7aa95064255c.png

Edited by chris1111

Share this post


Link to post
Share on other sites
8 minutes ago, Sherlocks said:

thank you for test. :)

i will commit it.

It definitely, needs "vol_internal_apfs.icns" to works? However, only my themes on repo have this icons already. -_-

Share this post


Link to post
Share on other sites

Great now I have made all icons and its perfect, I will commit lots of my theme tonight :thumbsup_anim:

 

screenshot21.thumb.png.ba6849384535704fce6f08c63ac1a1c8.png

Symplicity looks good :D

screenshot22.thumb.png.2e5aa92107bd0f4d0cc0801741f86d8d.png

Edited by chris1111

Share this post


Link to post
Share on other sites
It definitely, needs "vol_internal_apfs.icns" to works? However, only my themes on repo have this icons already. 
apfs.icns works now. i don't exactly know your theme.
i just tested your flatcamp. in your other themes, seems to disable badge for apfs and hfs? if its correct, i think that you enable badge in your theme like flatcamp

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
2 minutes ago, Sherlocks said:

apfs.icns works now. i don't exactly know your theme.
i just tested your flatcamp. in your other themes, seems to disable badge for apfs and hfs? if its correct, i think that you enable badge in your theme like flatcamp

Yes, exactly.. previously bcoz this issue with vol_internal_apfs, glad to know if it works right now. Thank you so much! :thumbsup_anim:

Share this post


Link to post
Share on other sites
17 minutes ago, chris1111 said:

Ok Icons is correct here I will change the themes tonight 

Thanks Sherlocks :wink_anim:

 

screenshot24.thumb.png.499e58df767d237836964f88b14dfda3.png

 

good.

is there any bug for theme too? if there is other bug or improvement, tell me later

Edited by Sherlocks

Share this post


Link to post
Share on other sites
13 minutes ago, droples said:

Hi! When I using FV2Apfs I have some problems with the correct name of the boot partition.

preboot.thumb.jpg.a8a988c01308bfb72771938ae792c7ab.jpg

 

For FV2HFS+ has been fixed here https://www.insanelymac.com/forum/topic/317290-filevault-2/?page=14,
how would this be done for fv2apfs the same.

 

please upload each clover bootlog

1. no using filevault2

2. using filevault2

 

you try to get each log by press f2 in GUI.

then upload here

Share this post


Link to post
Share on other sites
On 8/20/2018 at 7:57 PM, Sherlocks said:

 

please upload each clover bootlog

1. no using filevault2

2. using filevault2

 

you try to get each log by press f2 in GUI.

then upload here

All you want ..

Spoiler

FV2APFS.thumb.jpg.65b02bc5e6dfe2f80523c4f92b062e88.jpg

 

 

APFS.zip

FV2APFS..zip

Edited by droples

Share this post


Link to post
Share on other sites
3 hours ago, droples said:

All you want ..

  Reveal hidden contents

FV2APFS.thumb.jpg.65b02bc5e6dfe2f80523c4f92b062e88.jpg

 

 

APFS.zip

FV2APFS..zip

 

when using FV2APFS, you removed "Preboot" on hidden entry option.

your main partition is "SSDa"

 

after FV2, no more activated "SSDa" as main boot. "SSDa" has disappeared in GUI. then Preboot activated as role of "SSDa".
analyze finished. i will make test file.

 

in future, we have to consider bless part that download-fritz mentioned.

 

EDIT1.

if use FV2APFS, how do you update new update? could you see new entry in GUI when update?

 

EDIT2.

i wonder role of this "FileVault Prebooter" and ""macOS Install Prebooter".

case1. NO FV2

are "FileVault Prebooter" and "macOS Install Prebooter" useless? - in my memory, i get black screen when enther "FileVault Prebooter" in GUI.

 

case2. FV2

are "FileVault Prebooter" and "macOS Install Prebooter" use for booting?

 

as result, "FileVault Prebooter" and "macOS Install Prebooter" for only FV2? most of people uses "Preboot" hidden option to remove entry. i also use it.

 

EDIT3.

please give me info for only FV2

follow this process in terminal

type "diskutil apfs list"

you can see 

    +-> Volume disk1s1 7E63AFBA-1EFF-4DA9-B0D2-24861EE24844

    |   ---------------------------------------------------

    |   APFS Volume Disk (Role):   disk1s1 (No specific role)

    |   Name:                      Macintosh HD (Case-insensitive)

    |   Mount Point:               /

    |   Capacity Consumed:         30542188544 B (30.5 GB)

    |   FileVault:                 No

    |

    +-> Volume disk1s2 096483B1-B9C7-46F2-B64A-DEF85B188DC2

    |   ---------------------------------------------------

    |   APFS Volume Disk (Role):   disk1s2 (Preboot)

    |   Name:                      Preboot (Case-insensitive)

    |   Mount Point:               Not Mounted

    |   Capacity Consumed:         46395392 B (46.4 MB)

    |   FileVault:                 No

 

then

make "untitle" folder in your main "SSDa" parition root

and

type "sudo mount_apfs /dev/disk1s2 /Volumes/SSDa/untitle"  <- red color have to match your parition result

 

i want to know files list in Proboot partition.

 

 

EDIT4.

now, in clover, whole process are no problem. you just want defined name of entry in GUI. probably we need to consider Preboot partition when using only FV2

 

Edited by Sherlocks

Share this post


Link to post
Share on other sites
21 hours ago, Sherlocks said:

 

when using FV2APFS, you removed "Preboot" on hidden entry option.

your main partition is "SSDa"

 

after FV2, no more activated "SSDa" as main boot. "SSDa" has disappeared in GUI. then Preboot activated as role of "SSDa".
analyze finished. i will make test file.

 

in future, we have to consider bless part that download-fritz mentioned.

 

EDIT1.

if use FV2APFS, how do you update new update? could you see new entry in GUI when update?

 

EDIT2.

i wonder role of this "FileVault Prebooter" and ""macOS Install Prebooter".

case1. NO FV2

are "FileVault Prebooter" and "macOS Install Prebooter" useless? - in my memory, i get black screen when enther "FileVault Prebooter" in GUI.

 

case2. FV2

are "FileVault Prebooter" and "macOS Install Prebooter" use for booting?

 

as result, "FileVault Prebooter" and "macOS Install Prebooter" for only FV2? most of people uses "Preboot" hidden option to remove entry. i also use it.

 

EDIT3.

please give me info for only FV2

follow this process in terminal

type "diskutil apfs list"

you can see 

    +-> Volume disk1s1 7E63AFBA-1EFF-4DA9-B0D2-24861EE24844

    |   ---------------------------------------------------

    |   APFS Volume Disk (Role):   disk1s1 (No specific role)

    |   Name:                      Macintosh HD (Case-insensitive)

    |   Mount Point:               /

    |   Capacity Consumed:         30542188544 B (30.5 GB)

    |   FileVault:                 No

    |

    +-> Volume disk1s2 096483B1-B9C7-46F2-B64A-DEF85B188DC2

    |   ---------------------------------------------------

    |   APFS Volume Disk (Role):   disk1s2 (Preboot)

    |   Name:                      Preboot (Case-insensitive)

    |   Mount Point:               Not Mounted

    |   Capacity Consumed:         46395392 B (46.4 MB)

    |   FileVault:                 No

 

then

make "untitle" folder in your main "SSDa" parition root

and

type "sudo mount_apfs /dev/disk1s2 /Volumes/SSDa/untitle"  <- red color have to match your parition result

 

i want to know files list in Proboot partition.

 

 

EDIT4.

now, in clover, whole process are no problem. you just want defined name of entry in GUI. probably we need to consider Preboot partition when using only FV2

 

 

List of files in the Preboot.

Spoiler

Preboot_list.jpg.fafee4650af6d29cf8c1da8f6f55dda6.jpg

 

Share this post


Link to post
Share on other sites

Thank you! Finaly I can see my icons correctly and no with lines black&yellow using a nvme drive. Regards.-

Share this post


Link to post
Share on other sites

When using Filevault2 and clover does anyone know how to achieve UIScaling in the EFI unlock screen? At the moment both mouse cursor, user image and the password box appear unscaled and so very small (the Apple logo is also unscaled before EFI unlock screen appears). Thanks. I have EfiLoginHiDpi set to 1 and UIScale set to 2 in config.plist

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/yxsw7d3t
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/yxsw7d3t
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
       
      Use these kexts, enable XHCI port limit patch
       
      USB INTEL SERIE 400.zip
       
      and follow this tutorial for remap USB ports
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By Nomade
      Hello All,
       
      It's been a while that I am trying to update my system to 10.15.16.
      The install seem to start, then at reboot time I only see the Normal boot and the Recovery option from the Clover boot menu.
      None of those 2 allow to complete the update.
       
      Is there any ways to force it to install and/or show the "Update" option on the Clover boot screen?
       
      PS: I'm using Z97-Gaming-3
    • By Damx
      The specs CPU: Intel® Core™ i3 Processor 8130U, 2.20 GHz (Kaby Lake Refresh) Chipset: Intel® 300 Series Graphics: Intel® UHD Graphics 620 Display: 21.5'' 1920x1200 RAM: DDR4 PC2400 4GB SSD1: M.2 PLEXTOR (with original Windows 10) SSD2: SATA SAMSUNG 850 EVO (for macOS) Sound: Realtek ALC269 WiFi / BT: Intel 3168 NGW Realtek Card-reader  
       
      Not working
      WiFi: Intel 3168 NGW Realtek Card-reader  
       
      Pre-Installation
       
      I will not go through the basics since it is explained in details here on this site. Briefly, the process is to:
      Get Clover Get Catalina macOS installer Create USB with 2 MBR partitions (FAT32 for Clover and HFS+J for the installer)  
       
      Required kexts
      AppleALC.kext Lilu.kext RealtekRTL8111.kext VirtualSMC.kext WhateverGreen.kext  
       
      Config.plist
      I used the one provided by RehabMan called config_HD615_620_630_640_650.plist. Download it from GitHub. It has almost everything you will need with only few edits for audio.
      Edits:
      [CPU] Make sure there is lilcpu=9 setting in boot arguments needed for Kaby Lake R CPU to be recognised correctly. [GPU] Make sure there is a patch GFX0 to IGPU under ACPI->DSDT [GPU] Under Devices->Properties->PciRoot(0)/Pci(0x02,0) make sure that the AAPL,ig-platform-id value is 00001B59, and the device-id value is 16590000 [AUDIO] Under Devices->Properties->PciRoot(0)/Pci(0x1f,3) set the layout-id to 40 and the device-id to 70A10000 [SMBIOS] Set Mac model ID is iMac19,2  

       

       
      Notes
      For some reason with latest version of Clover the install partition was not visible. If you run into the same issue you can downgrade Clover to r5103, which worked perfectly. WiFi / BT Intel 3168 NGW needs to be replaced if one needs WiFi. Someone mentioned that to get HDMI work properly you may need to change AAPL,ig-platform-id value to 00001659 for PciRoot(0)/Pci(0x02,0) - not my case but may be considered if you get this issue. Don't forget to generate your serial and other SMBUS values before signing in with iCloud services.  
       
    • By MaLd0n
      A very custom DSDT for best experience under macOS. Removed all unused devices, injected all Apple devices, essentials, cosmetics, real improvements. 
       
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
          -Original DSDT have 167,880 lines and 762kb
       
      DSDT ORIGINAL.aml.zip138.01 kB · 8 downloads
       
      -Patched DSDT have 30,912 lines and 111kb
       
      DSDT PATCHED.aml.zip27.01 kB · 17 downloads
       
      --Hardware--
      Asus ROG RAMPAGE VI EXTREME OMEGA

      Processor  Intel i9-10980XE

      GPU Radeon RX 5700 XT

      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -XSPI -EC -PNLF -ARPT -GFX0 -NVME  
      --Screenshots-



















       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
          -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145 Model with Intel Core i5-1035G1 IceLake / Intel HD Graphics ICL
      -Update bios/uefi to last version 
       
      *For now we have 2 problems. Wake from sleep and some bugs in trackpad*
       
      --Bios/UEFI config--
      Go to Security tab and disable Secure boot
       
      -IceLake Premade installation Folder (easy way installation)
      https://tinyurl.com/y3tl6xlx
       
      --Clover and OpenCore Folders--
      Just paste EFI folder inside EFI partition
      -OpenCore
      https://tinyurl.com/y3c4rjkr
      -Clover
      https://tinyurl.com/y4496nq8
       
      --Enable Trackpad Dragging Option--
      Go to System Preferences/Accessibility/PointerControl/Trackpad Options and "Enable dragging"

      -Bluetooth Broadcom
       
      BrcmBluetoothInjector.zip2.46 MB · 4 downloads
       
      -OcQuirks.efi for Clover (Just replace Drivers folder)
       
      drivers.zip74.57 kB · 4 downloads
       
      --DSDT Patches--

      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 12 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -FULL RENAMED DEVICES   --IGPU Patch-- (All credits to Austere.J) Discussion about that HERE
       
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key>             <dict>                 <key>AAPL,ig-platform-id</key>                 <data>AABSig==</data>                 <key>device-id</key>                 <data>UooAAA==</data>                 <key>framebuffer-fbmem</key>                 <data>AACQAA==</data>                 <key>framebuffer-patch-enable</key>                 <data>AQAAAA==</data>                 <key>framebuffer-stolenmem</key>                 <data>AAAwAQ==</data>                 <key>framebuffer-unifiedmem</key>                 <data>AAAAgA==</data>                 <key>hda-gfx</key>                 <string>onboard-1</string>                 <key>igfxfw</key>                 <data>AgAAAA==</data>             </dict>  
      --USB Fix-- https://tinyurl.com/y4mqfahz
       
      -ScreenShots

       


























      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Acidanthera Team, Olarila Facebook Community, Hackintosh Facebook Community and many others!     We're all here to have fun and learn from each other!
×