Jump to content
Dan ZG

BIOS sees 16GB, but OSX only 12GB (RAM)

11 posts in this topic

Recommended Posts

Anyone have any idea why I can see my my full 16GB RAM (4x4) in BIOS but OSX only shows 12?

And 16 TB "wired" .. ha ..


Mobo = Gigabyte X58A-UD3R (FH)




Share this post

Link to post
Share on other sites

It's not set at all in config.plist 


And by UEFIBIOS you mean in my BIOS settings? I would have to check.


Should they both be enabled?



Share this post

Link to post
Share on other sites



Opening the box led me to RTFM of the mobo ... and I discovered I had the 4 chips inserted wrongly. (It's a triple channel 6-slot board, and I was using the wrong slots.)

I re-arranged them properly, and now I can see all 4x4.


Thanks for all your help!

Share this post

Link to post
Share on other sites

Thanks! Yeah, I'm on amazon now...


But I'm wondering ... can I add 2x8GB?


I've seen different reports about this mobo having or not having a maximum of 6x4GB. Some people report success with 6x8GB.


Could I do 4x4GB + 2x8GB?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ishraqiyun77
      Hi, first post here and pretty new to Hackintoshing.
      Lenovo ThinkPad X1 Extreme (laptop) i7-8850H (Coffee Lake) Intel UHD630 GTX 1050 Ti with Max-q 4K Touchscreen 2x 2TB EVO 970 SSD (one for Windows and one for macOS) 2x 32GB DATARAM 2666Mhz DDR4 RAM (max for laptop, works in Windows and Ubuntu) Haven't replaced the Wifi card yet for macOS compatible, just using Ethernet for now Everything else is stock macOS Mojave 10.14.4  
      Was stuck several days just trying to get passed End RandomSeed. What finally worked was the following:
      Clover 4910 (instead of using RehabMan's versions) The attached EFI zip Leaving only one RAM module (1x 32GB) in the first slot on the mobo (the right slot if the laptop is upside down and the back is facing you)  
      Was able to install macOS to the SSD. Well, I am at the phase where I need to get macOS to boot from the SSD  without the USB. Struggling with that, but will make a different thread regarding it.
      Thought I'd give it a go again with both RAM modules installed since I read somewhere once macOS is installed, you can change the RAM freely. Again, with both modules installed it just hangs at End RandomSeed.
      What I have tried:
      AptioMemoryFix-64 or OsxAptioFix3Drv-64 or OsxAptioFixDrv-64 or OsxAptioFix2Drv-free2000
      AptioMemoryFix-64 plus OsxAptioFix3Drv-64 or OsxAptioFixDrv-64 or OsxAptioFix2Drv-free2000 (read somewhere that having a combination of AptioMemoryFix plus one of the others worked for some people)
      Adding RAM entries in SMBIOS (see attached)
      Unfortunately, none have seem to have had an effect. 
      Any suggestions?
      Thank you in advance for the help!

    • By TimNeumann
      MB: Asus X99 A-II
      RAM: G.Skill Ripjaws V F4-3200C16D-32GVK (3200MHz, 4x 16GB DIMMs, so Total 64GB) in quad-channel configuration.
      CPU: i7 6800k @4.0Ghz
      GPUs: GTX 1080 Ti and GTX 1060 3GB
      (each one a monitor, because I can't get DVI to run parallel with DP on the 1080Ti, and my second monitor only has DVI/VGA)
      OS: High Sierra 10.13.2 (17C88) / Clover revision: 4392
      Hello everybody,
      I occasionally have system crashes and suspect that it is related to RAM. However, this RAM is completely new, and a run with MemTest86+ from the USB stick showed no errors. However, if I use Memtest on MacOS, I get a bunch of error messages, but sometimes none (I restart the computer between tests).  
      As I just discovered, my RAM is not on the recommended vendor list of my motherboard, nor is it on the manufacturer side of the RAM. I have read several times that the RAM may not have been tested by the manufacturer on this platform. Not a single X99 motherboard is listed for this RAM.
      So I also suspect that my RAM is not compatible.
      But if that were the case, how could it sometimes work completely error-free?
      During RAM tests in summer 2017 (a slightly different setup, 4x8GB but still G.Skill Ripjaws V) I had no errors at Memtest under MacOS, if I remember correctly. At that time it ran under Sierra 10.12.6. AptioMemoryFix.efi could also cause problems.
      I am appreciative for any help!
      Here is an excerpt from a faulty test.
      It is noticeable that it is always the same address during the test, but a different one after each test.
      Memtest version 4.22 (64-bit) Copyright (C) 2004 Charles Cazabon Copyright (C) 2004-2008 Tony Scaminaci (Macintosh port) Licensed under the GNU General Public License version 2 only Mac OS X 10.13.2 (17C88) running in multiuser mode Memory Page Size: 4096 System has 12 Intel core(s) with SSE Requested memory: 57232MB (60012990464 bytes) Available memory: 57232MB (60012990464 bytes) Allocated memory: 57232MB (60012990464 bytes) at local address 0x00000001033e1000 Attempting memory lock... locked successfully Partitioning memory into 2 comparison buffers... Buffer A: 28616MB (30006495232 bytes) starts at local address 0x00000001033e1000 Buffer B: 28616MB (30006495232 bytes) starts at local address 0x00000007ffc4d800 Running 1 test sequence... (CTRL-C to quit) Test sequence 1 of 1: Running tests on full 57232MB region... Stuck Address : ok Linear PRN : testing 7 of 16 FAILURE! Data mismatch at local address 0x0000000e88133d30 Expected Data: 0xc4c340079ac9a645, Actual Data: 0xc4c3400788468846 Running comparison tests using 28616MB buffers... Random Value : ok Compare XOR : ok Compare SUB : ok Compare MUL : ok Compare DIV : ok Compare OR : ok Compare AND : ok Sequential Increment: ok Solid Bits : ok Block Sequential : testing 80 of 256 FAILURE! Data mismatch at local BUFA address 0x000000078b8c7530, BUFB address 0x0000000e88133d30 BUFA Data: 0x4f4f4f4f4f4f4f4f, BUFB Data: 0x4f4f4f4f88468846 Checkerboard : testing 3 of 64 FAILURE! Data mismatch at local BUFA address 0x000000078b8c7530, BUFB address 0x0000000e88133d30 BUFA Data: 0x5555555555555555, BUFB Data: 0x5555555588468846 Bit Spread : testing 1 of 128 FAILURE! Data mismatch at local BUFA address 0x000000078b8c7530, BUFB address 0x0000000e88133d30 BUFA Data: 0x0000000000000005, BUFB Data: 0x0000000088468846 Bit Flip : testing 74 of 512 FAILURE! Data mismatch at local BUFA address 0x000000078b8c7530, BUFB address 0x0000000e88133d30 BUFA Data: 0x0000000000000200, BUFB Data: 0x0000000088468846 Walking Ones : testing 40 of 128 Clover Files attached
    • By deejaystage
      Hola chicos!
      Mi sistema sólo muestra 7 mb de vram y no tengo aceleración en mi gráfica. He probado infinidad de remedios pero no he encontrado la solución.
      ¿Alguien podría ayudarme?
      Gracias por adelantado
    • By animani
      Hi guys,

      I've tried adding the ram slots in Clover and I get 48GB but using 40% of the ram without doing anything in my computer. It reports as "wired" mostly. 

      If I remove them from config.plist and add trust it detects 32GB and no ram usage after restarting.

      Any help would be appreciated.
      Bios update to the latest version solved my problem.
    • By heirapparent
      Long story short: a couple of weeks ago I built a custom pc (see signature), installed 10.11.2, fixed a couple of this that weren't working and then updated to 10.11.3. 
      It all went quite smooth (the last hackintosh I built was 6 years ago with iAkintosh or something on a netbook, and things were.. complicated). The system was running all nice and fast without any problem at all, until.. Random reboots started appearing. I didn't installed/change any kext after the usual post-install. 
      It is really all working: iMessage, WiFi, Bluetooth, Nvidia, Sleep/Wake, USB 3, etc. I only get random reboots pretty much everyday (and when it happens, multiple times a day).
      I investigated the following cases/issues:
      Bad RAM: maybe.. Maybe yes: memtest always reports different amounts of RAM (rebooted in two occasions), "About this Mac" randomly displays correct memory frequency, sometimes before a kernel panic occurs apps start to crash and can't be reopen (then the system restarts); Maybe no: under heavy memory load the system doesn't reboot, and I game on Windows under heavy load without any problem; Bad power management: maybe too..? ​Maybe yes: Intel power gadget can't recognize CPU (CPU not supported), original DSDT (F4 on clover boot) have an error I can't resolve; Maybe no: the reboots are random, sleep/wake doesn't increase or decrease them, and I put OS X under heavy load too; Wrong kext/driver: really don't know, didn't installed anything kext-related after the first installation but never say never.  
      I know Skylake is not fully supported but hey, everything was working fine. 
      Also, I can not update clover.. Connection is there but when I click "check now" nothing happens (updated fine before). 
      I tried fixing permissions and rebuild kext cache, nope, keeps rebooting.
      I made an SSDT with SSDTPRgen and put in clover patched folder, keeps rebooting.
      At this point I don't have any clue on where to look/patch, so I'm posting here the last 7 panic reports with the hope that someone, somehow will be able to help me, thank you very much,
      panic 1.rtf
      panic 2.rtf
      panic 3.rtf
      panic 4.rtf
      panic 5.rtf
      panic 6.rtf
      panic 7.rtf