Jump to content

379 posts in this topic

Recommended Posts

you can try with his new work around.

Saw it and compiled it already, but indeed still gives me a KP

Share this post


Link to post
Share on other sites
Advertisement

I used @vandroy kernel to patches method, then also tried again with "keepsyms=1", both didn't work on my case.. with Lilu v1.2.1 (after @vit9696 has given workarround though). So, my temporary solution with 10.13.2 Beta for now, is by disabling Lilu.kext. Thanks anyway.

Share this post


Link to post
Share on other sites

I used @vandroy kernel to patches method, then also tried again with "keepsyms=1", both didn't work on my case.. with Lilu v1.2.1 (after @vit9696 has given workarround though). So, my temporary solution with 10.13.2 Beta for now, is by disabling Lilu.kext. Thanks anyway.

It isn't a fix for Lilu, but that way the KP is actually readable  :P

 

E.g. ^ his picture and mine:

 

 

tszz4m9.jpg

 

Share this post


Link to post
Share on other sites

It isn't a fix for Lilu, but that way the KP is actually readable :P

 

E.g. ^ his picture and mine:

 

 

tszz4m9.jpg

 

Ooh, OK. Thanks for confirming, on my case it gets instant reboot hmmb..

Share this post


Link to post
Share on other sites

Ooh, OK. Thank for confirming, on my case it gets instant reboot hmmb..

debug=0x100 or spacebar on OS selection->Do not reboot on panic

Share this post


Link to post
Share on other sites

It isn't a fix for Lilu, but that way the KP is actually readable  :P

 

E.g. ^ his picture and mine:

 

 

tszz4m9.jpg

 

 

Anybody try removing the "immutable kernel" in S/L/PrelinkedKernels folder?    For AMD Ryzen I've been able to remove it without issues.

Share this post


Link to post
Share on other sites

Just compiled it and it workes  :D

Just give it a try: attachicon.gifLilu.kext.zip

 

Thanks to VIT and all People involved to fix it that fast couldn't be more thankful. Nice Job done once again.

Bootflag '-lilubeta' required?

 

Trying to get Lilu working on macOS 17B46a before I embark on updating to 17C60c, but I'm still getting KP reboot loops with the latest Lilu build.

Share this post


Link to post
Share on other sites

The good news is that on 10.13.1 I had issues with my nvidia card and dual monitor setup. NightShift wouldn't work on both monitors and mirroring displays resulted in a black screen. This seems to be fixed in 10.13.2 dp 1.

 

 

Optiplex 790:

 

 

 

Probook 6470b:

 

 

Everything work on your pro book? I just received a similar model

Share this post


Link to post
Share on other sites

 I was just wondering about the kernel panic too! I removed lilu, I could update from 10.13.1 and the installer completed, then it would panic on startup ... trying the new updated one now ... 

Share this post


Link to post
Share on other sites

I was just wondering about the kernel panic too! I removed lilu, I could update from 10.13.1 and the installer completed, then it would panic on startup ... trying the new updated one now ...

Please share your results.

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Bootflag '-lilubeta' required?

 

Trying to get Lilu working on macOS 17B46a before I embark on updating to 17C60c, but I'm still getting KP reboot loops with the latest Lilu build.

Turns out culprit is AppleALC, not Lilu.

Share this post


Link to post
Share on other sites

How did you come to this conclusion? Where you able to pass the KP?

Disabled AppleALC and it boots fine w/ latest Lilu 1.2.1.

 

I'll try a few other things. Just annoying to reboot as it takes ~5mins (via NVMe PCIe drive), because APFS is buggy garbage apparently.

Share this post


Link to post
Share on other sites

Disabled AppleALC and it boots fine w/ latest Lilu 1.2.1.

 

I'll try a few other things. Just annoying to reboot as it takes ~5mins (via NVMe PCIe drive), because APFS is buggy garbage apparently.

lol is nvme pcie worth it???? im considering upgrading 

Share this post


Link to post
Share on other sites

lol is nvme pcie worth it???? im considering upgrading

I like it. Big improvement in system responsiveness over already fast SATA SSD I had before.

 

Got this one for $250 though—not worth the $300+ they usually cost IMO.

 

Just a shame 10.13 won't boot it faster.

Share this post


Link to post
Share on other sites

I like it. Big improvement in system responsiveness over already fast SATA SSD I had before.

 

Got this one for $250 though—not worth the $300+ they usually cost IMO.

 

Just a shame 10.13 won't boot it faster.

Which one did you buy?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×