Jump to content
Taruga

AppleHDA Solution - Work in progress

4,109 posts in this topic

Recommended Posts

Could anyone say if the patcher works for AD1984 cards? I am trying to make my ThinkPad sing without any luck for over a week now... :o

Share this post


Link to post
Share on other sites
Advertisement

Hi Everybody,

First of all, thanks for your efforts helping us. It's greatly appreciated.

I have a Asus P5E WS Mainboard, with Kalyway 10.5.1 OS.

Mainboard has ALC888 sound chipset with ICH9R Southbridge.

I've installed AppleHDAPatcher 1.20 with a ALC888 dumb, sound works only on 2 channels, microphone and digital output.

I'd like to know if someone has the front panel headset and microphone plugs working. I've set ports as HD Audio but I could set them as Legacy AC'97 by Bios.

Thanks a lot

Antonio

Share this post


Link to post
Share on other sites

Hi, is there any solution for P5B Deluxe, AD1988b? At least 2ch?

 

Thank you.

Share this post


Link to post
Share on other sites

Realtek ALC268 working!

 

THANK YOU Diego and Taruga!!

 

Using Diego´s v0.2 and Taruga´s ALC268Test installer.

 

Got the white noise problem, but easily fixed by turning mic volume all way down.

 

Internal speakers: Excellent (No mute)

Internal mic: Not working?

Headphones out: Excellent (No mute)

Mic in: Working (with noise)

Line In: Not tested

 

post-148178-1199820345_thumb.pngpost-148178-1199820359_thumb.png

Share this post


Link to post
Share on other sites

Hi Taruga

 

I testing ALC861_0x10ec861 is working for my Toshiba notebook. The step is :

 

1. download alc861_0x10ec861.zip

2. Open your Extensions folder: /System/Library/Extensions/

3. On that folder erase AppleAzalia.kext, AppleHDA.kext and ALCinject.kext

4. run alc861_0x10ec861.zip

 

Computer : Toshiba A105-4384 (notebook)

 

Display : intel GMA945

 

Audio : ALC861

Vendor Id: 0x10ec0861

Subsystem Id: 0x11791205

Revision Id: 0x100300

Wifi card : Intel 3945 change AR5424 (AR5424 order from ebay USD25.00)

Network : Intel Pro10/100V

 

OS: Leopard 10.5.0 (ToH and Brazil Patch)

Share this post


Link to post
Share on other sites

hi,

 

is there a progress for the STAC9274D driver? Sigmatel on Badaxe2 Motherboard. Had until now no success with codec dumps...

 

apoo

Share this post


Link to post
Share on other sites
hi,

 

is there a progress for the STAC9274D driver? Sigmatel on Badaxe2 Motherboard. Had until now no success with codec dumps...

 

apoo

 

Ditto, I only have stereo output - no Mute, no Mic, etc.

 

I'd be happy to help out with whatever I can - linux dumps, whatever.

Share this post


Link to post
Share on other sites

There is some discussion at netkas forum about adding sound with EFI

 

has anyone tried it?

 

Today, i found that a device-properties string can succesfully replace ALCinject. Just create a plist like that:

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>02010c00d041030a0100000001010600001b7fff0400</key>

<dict>

<key>PinConfigurations</key>

<data>

</data>

<key>built-in</key>

<string>0x00</string>

<key>layout-id</key>

<string>0x0000000c</string>

</dict>

</dict>

</plist>

 

change the DevicePath to correct one for your system and convert it to a binary plist with gfxutil.

Share this post


Link to post
Share on other sites

Have'nt tried it but it's just a method so we won't use ALCInject anymore and this won't even help if you don't have sound at all.

 

it's the same method of putting a GFX string on com.apple.Boot.plist so that Natit,NVInject etc won't be needed anymore.

Share this post


Link to post
Share on other sites
conexant!!! why did HP pick this one; ; page after page of reading and i can't figure out how to get headphones to work..

 

 

All users of Conexant audio chipsets hope, that next release fix this issues=))

Feauture thx to developers :)

Share this post


Link to post
Share on other sites

hi,

i am also a dell 9400/e1705 user, now, I have no knowledge or experience with osx. i am running 10.5.1 installed from iAtkos DVD. Can someone please give me a bit of detail on how to get the ST9200 working, and please note that i have no knowledge of how to do anything on osx, though i learn quickly.

Share this post


Link to post
Share on other sites

hi ppl!

imm new to the OS X!

today i instalet it on the LENOVO N100, C2D T5500 1.66

everething works smooth! and without problems!

but! AUDIO dosent working! intel High Definition Audio (AD1986A)!

but ist not the only problem!  the wifi is not working and the integrated web cam!

maby somebpdy know what to do? please!

iv tried to install the ad1986a thru the patcher but the system is crashing!

what is kernel?

Share this post


Link to post
Share on other sites

Hi to all, I did a search in all this topic but I'm unable to find the name of a motherboard that has the 5.1 audio analog output support with leopard.....is there someone who can help me?

Bye!

Share this post


Link to post
Share on other sites

What about AppleHDA Patcher v2.0? No words on it since a while!

 

Anyways, thanks Taruga for your hard work :)

Share this post


Link to post
Share on other sites

Tested "stac9271D 0x83847627" on my Dell XPS M1210, doesn't work.My audio is STAC92XXX, and I used Kext Helper b7 to install the two .kext files from the zip downloaded here. nothing happened. :(anyone can help?? thanks man. you are helping a lot of people here.forgot to say, I am running Kalyway-leopard. :D

Share this post


Link to post
Share on other sites

ufter instaling the ad1986 (AD1986 0x11d41986 for testing)

and this what i geting! still no sound! but until now there wasent even that!

 

i have ad1986a

 

ok! i have sound! from the headphones only!

and the sound quallty is horreble!

no sound from speachkers and in mic.

post-171189-1199985957_thumb.jpg

post-171189-1199985976_thumb.jpg

Edited by Taruga
Posty an ioreg dump with the following command: ioreg -lw0 > /ad1986ioreg.txt

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×