Jump to content
Sign in to follow this  
Followers 0
Meowthra

Intel HD Graphics Haswell GT1 QE/CI 10.8-10.11

6 posts in this topic

Recommended Posts

Haswell-UTL GT1 0x0a06
OS Version: 10.8.5、10.9.5、10.10.5、10.11.6

 

Clover:
rename GFX0 to IGPU

    <key>ACPI</key>
    <dict>
        <key>DSDT</key>
        <dict>
            <key>Patches</key>
            <array>
                <dict>
                    <key>Comment</key>
                    <string>Rename GFX0 to IGPU</string>
                    <key>Find</key>
                    <data>R0ZYMA==</data>
                    <key>Replace</key>
                    <data>SUdQVQ==</data>
                </dict>
            </array>
        </dict>
    </dict>

 

    <key>Graphics</key>
    <dict>
        <key>ig-platform-id</key>
        <string>0x0A160000</string>
        <key>EDID</key>
        <dict>
            <key>Inject</key>
            <true/>
        </dict>
    </dict>

AGPM:

https://www.insanelymac.com/forum/topic/337145-agpm-patch/

 

QE/CI Patch:

curl -O https://raw.githubusercontent.com/kalifans/Darwin/Driver/Intel-HD-Graphics-Haswell-Patch.tar.gz
tar zxvf Intel-HD-Graphics-Haswell-Patch.tar.gz
cd Intel-HD-Graphics-Haswell-Patch
./qeci-patch.sh

 

Reboot Computer


 ud5xsFc.png

 

Edited by Meowthra

Share this post


Link to post
Share on other sites
Advertisement

are your 10.12.x kexts compatible with macos 10.13.x ? if not, any plans in releasing supported kexts? 

Share this post


Link to post
Share on other sites

any chance to get qe/ci on intel hd graphics haswell GT1 (pentium 3556u) working on 10.12/13?

Share this post


Link to post
Share on other sites

just tried the 10.12.6 patch in my hackintosh running 10.13.4 with no success...my config is a gigabyte mobo GA-H87-D3H with g3258 pentium processor. Still my intel HD graphics unstable with glitches and many web pages unreadable...So please for when the 10.13 patch ? 

Share this post


Link to post
Share on other sites

OS X 10.12 or later Pentium and Celeron Unable Support
Because OS X 10.12 and later Haswell OpenGL Driver Requires AVX Instructions
So the Processor Must Support the AVX Instruction Set.
Unless there is a Source code that can be Recompiled.
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×