Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By DiddyKong
      Fully optimizing DSDT & SSDT for OS X Sierra POST INSTALL on a Dell345MT with a i7 - 920(first gen) 
       
      I know how this forum feels about 3rd party software, but that was just a crutch, I'm 100% vanilla now which is why I'm now posting for help because I eliminated the possibility having to do with 3rd party. Anyways, with that said I just have a couple things I want to be sure of.
       
      I used a n---bistro to get a App Store copy of Sierra, as I didn't know there were other ways of getting it now from a windows10 machine. anyways, I was able to build a vanilla usb. I couldn't figure the EFI out on my vanilla Sierra-usb, but the EFI on the usb-ni---bistro I had would boot my pre-install and post-install. so I was able to install Sierra. After a few days of figuring out how to remake a EFI and config, I broke my EFI.
      So back to my windows10 SSD and I found BootDiskUtility, and that made a EFI usb with the newest version of clover(r4895). So then swapped SSDs back to my OS X, plugged in the BDU-usb, after trial and error I got back into my Sierra. Now with the newest version of clover and no traces of ni---bistro anymore. Then copied the BDU-usb to my SSD EFI and was able to boot without a usb again!! YAY.
       
      Then starting working on fixing my web drivers for my gtx 1050 2gb. Installed the os update so i'm at 10.12.6, pulled my hair out figuring out the web drivers, eventually got them installed and the cuda fixed.
       
      Now all 3 of my screens work, yet windows can't sit 'between' screens, I just simply haven't looked for that fix yet as I want the sys itself running like a top first.
      My screen saver works, I don't get stuck in screensaver, I did once before, I believe lilu.kext and whatevergreen.kext fixed that.
      Now with all that I felt it was time to give my config.plist a diet cos it was bloated, I generated a config copied the clover settings check for check instead of coping text cos I'm trying to shrink it.
      Config.plist boots my system with DSDT-1FE7B5D7
       
      So after the above, This is now where I'm stuck
       a 100% correct DSDT and SSDT, from my understanding with a patched DSDT I wouldn't need any options selected in clover on the ACPI page?
       
      So with the patching part that I think I understand how to do it now, but when I extract with F4 every file has RSDT in front of it, I have one that says RSDP.aml and RSDT.aml
      so would I just erase the RSDT from the beginning of each file then go from their, which would then leave me with a DSDT.aml and 17 SSDTs?
      I know I have to decompile and patch them, but with my file names[DSDT table extract] not matching tutorials online I'm having a difficult time understanding which files I need.
      IS the RDST-DSDT.aml my DSDT? it is the biggest file.
      which ones that have SSDT in the filename is the SSDT(s) I need to patch?
       
      also how do I know if everything is patched correctly? like if my CPU is fully working and not just sorta working that way when I start running software like photoshop, unity, 10 chrome tabs, my hackintosh doesn't crash
       
      System details
      i7 920 (first gen) very similar to nehelam
      GeForce 1050 2Gb (3 monitors connected all work, one acer on HD connection, two HP s2031 on HD, using adapters to change all ports on GPU card to HD for screens)
          display port, HDMI, and HD
      4x 1Gg + 2x 8Gb RAM running at 1066 after injecting smbios with ram info macOS sees all my ram correctly
      Samsung SSD 860 EVO 500Gb
       
      Thanks to anyone that can help me out, I've been working on my system for about two weeks and this is basically the wall I finally can't seem to figure out how to pass
      I can post another info also if it helps
       
      Boot.log
      DSDTdump.Log

    • By gk12345
      hello to everyone, i managed to install mojave on my asus ux303ub with i5 cpu and now sleep does not work when i press sleep display turns black and pc stays on and then i have to force shut down by holding power button in order to restart pc ,by the way i used the clover folder from a guide on the internet, any help would be appreciated, thanks
    • By mikmavros
      Thanks for accepting
      I recently installed Sierra  and I encounter the following problem ... When I restart or I start up my machine return to BIOS. If anyone knows and can any help be valuable Thank you very much. (When I boot from a Capitan disk in the same machine all  is running well.) Both discs with Clover in Legacy mode.
      gigabyte z68x-ud5-b3 F8
      I7 2600K
      GT 620 ( την βλέπει κανονικά χωρίς Web drivers)
      16 GB ddr3 1600 


    • By vin047
      I have a Kingston HyperX Predator PCIE-SSD (model: SHPM2280P2H) matched with an X58 motherboard (legacy bios). The card has a Marvell 88SS9293 controller with an Option ROM which allows it to be detected on my motherboard as a bootable drive - listed as "IDE: Kingston SHPM". As my BIOS is non-UEFI, I assume the Option ROM presents it in IDE mode instead of AHCI.
       
      I use Clover legacy with BiosBlockIO to get around this, and it works well - Clover detects my drive and allows me to install macOS onto it and use it as a boot drive. macOS detects the drive correctly as a SATA AHCI drive. I guess Clover correctly detects (configures?) the Option ROM into AHCI mode and presents it as such to macOS - getting full speed read Read/Write performance. All is well.
       
      Except waking from sleep. When waking from sleep, depending on clover config options + dsdt, I either get an immediate reboot or hang on black screen that requires hard reset. I eventually realised that nothing after entering sleep mode is recorded in the logs, its completely empty until next boot up. This makes me think that on resume from sleep, macOS isn't seeing the drive anymore (hence can't even write to logs). My assumption here is that the Option ROM is presenting/configuring the card in IDE mode, which is not what macOS is expecting.
       
      This post describes the problem: 
       
      and also has a solution: in dsdt, simply write the correct values to 0x40, 0x41, 0x42 (which must be the BAR0 register?) to configure Option ROM to use AHCI mode. But I have no idea what address BAR0 is on the Marvell 88SS9293 - there appears to be no documentation whatsoever on this controller available online!
       
      I managed to dump the ROM using Linux sysfs, but don't have the skills to disassemble/decipher the binary to find the correct addresses. Anyone with such experience able to help?? I've attached the ROM dump and lspci output.
       
      Thanks in advance!
      rom.bin
      lspci_output.txt
    • By vin047
      Hi, have an old Asrock X58 Deluxe motherboard with an i7-920 Nehalem CPU (yes old board ) + AMD RX460 . As per the title, i've managed to get Mojave installed and running with Speed Step working too!
       
      Final issue i'm having is with sleep - it sleeps fine and even responds to keyboard/mouse event, but instead of waking up to the desktop it restarts and loads from BIOS boot screen. When finally booted into macos, it restores as if restored from unexpected shutdown (though no error is shown).
       
      I've tried for days to get it working, sometimes depending on clover config changes, I can get it to wake up without reboot, but it just remains at a black screen and is unresponsive. 
       
      I have no custom DSDT, i've tried writing one but don't know really know what i'm looking for? Currently relying on clover patches. I've uploaded my original DSDT (dumped from Clover, F4 option) + current config. Anyone have any ideas?
      dsdt original.zip
      config.plist.zip
×